By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,304 Members | 1,242 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,304 IT Pros & Developers. It's quick & easy.

Fatal error: Call to undefined function MYSQL_CONNECT()

P: n/a
I know this is a common error, and that there are lots of posts all
over the place as to why it happens, but I cannot for the life of me
figure out what I'm doing wrong. Here's the scoop:

My path includes: c:\program files\php\; c:\program files\php
\extensions;

php.ini includes:

extension=php_mysql.dll
extension=php_mysqli.dll

I'm using Windows XP Professional with SP2, php 5.2.5 and mysql
5.0.51a

The libmySQL.dll was copied from the C:\Program Files\MySQL\MySQL
Server 5.0\bin folder into the c:\program files\php\ folder.

I have disabled Norton internet worm protection, rebooted,
systematically examined all of the above, and nothing has worked.
Mysql is not found in the phpinfo()

Can anybody point me in the right direction?

MrsBean
Feb 27 '08 #1
Share this Question
Share on Google+
3 Replies


P: n/a
On Feb 27, 11:29 am, MrsBean <li...@phoenixpromotions.comwrote:
I know this is a common error, and that there are lots of posts all
over the place as to why it happens, but I cannot for the life of me
figure out what I'm doing wrong. Here's the scoop:

My path includes: c:\program files\php\; c:\program files\php
\extensions;

php.ini includes:

extension=php_mysql.dll
extension=php_mysqli.dll

I'm using Windows XP Professional with SP2, php 5.2.5 and mysql
5.0.51a

The libmySQL.dll was copied from the C:\Program Files\MySQL\MySQL
Server 5.0\bin folder into the c:\program files\php\ folder.

I have disabled Norton internet worm protection, rebooted,
systematically examined all of the above, and nothing has worked.
Mysql is not found in the phpinfo()

Can anybody point me in the right direction?

MrsBean
Are you sure you've edited the correct php.ini? phpinfo() will tell
you which one is actually being used.
Feb 27 '08 #2

P: n/a
On Wed, 27 Feb 2008 17:31:09 +0100, ZeldorBlat <ze********@gmail.com
wrote:
On Feb 27, 11:29 am, MrsBean <li...@phoenixpromotions.comwrote:
>I know this is a common error, and that there are lots of posts all
over the place as to why it happens, but I cannot for the life of me
figure out what I'm doing wrong. Here's the scoop:

My path includes: c:\program files\php\; c:\program files\php
\extensions;

php.ini includes:

extension=php_mysql.dll
extension=php_mysqli.dll

I'm using Windows XP Professional with SP2, php 5.2.5 and mysql
5.0.51a

The libmySQL.dll was copied from the C:\Program Files\MySQL\MySQL
Server 5.0\bin folder into the c:\program files\php\ folder.
Is c:\program files\php\ in your path?
--
Rik Wasmus
Feb 27 '08 #3

P: n/a
Yes. The php.ini file that is displayed in phpinfo() is c:\program
files\php\php.ini, and that is the one I have edited.

MrsBean

On Feb 27, 11:31*am, ZeldorBlat <zeldorb...@gmail.comwrote:
On Feb 27, 11:29 am, MrsBean <li...@phoenixpromotions.comwrote:


I know this is a common error, and that there are lots of posts all
over the place as to why it happens, but I cannot for the life of me
figure out what I'm doing wrong. *Here's the scoop:
My path includes: c:\program files\php\; c:\program files\php
\extensions;
php.ini includes:
extension=php_mysql.dll
extension=php_mysqli.dll
I'm using Windows XP Professional with SP2, php 5.2.5 and mysql
5.0.51a
The libmySQL.dll was copied from the C:\Program Files\MySQL\MySQL
Server 5.0\bin folder into the c:\program files\php\ folder.
I have disabled Norton internet worm protection, rebooted,
systematically examined all of the above, and nothing has worked.
Mysql is not found in the phpinfo()
Can anybody point me in the right direction?
MrsBean

Are you sure you've edited the correct php.ini? *phpinfo() will tell
you which one is actually being used.- Hide quoted text -

- Show quoted text -
Feb 27 '08 #4

This discussion thread is closed

Replies have been disabled for this discussion.