By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,751 Members | 1,175 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,751 IT Pros & Developers. It's quick & easy.

php files downloading

P: n/a
Hi,
Can anyone suggest me why some .php files are downloading and some are
executing. Ive got php 5.2.0 and apache 2.0.54. Apache came as an rpm
along with Fedora 4. I downloaded php from the site and built it
Thanks
Danish

Feb 16 '07 #1
Share this Question
Share on Google+
8 Replies


P: n/a
On 16 Feb, 10:32, "danish" <me.linuxad...@gmail.comwrote:
Hi,
Can anyone suggest me why some .php files are downloading and some are
executing. Ive got php 5.2.0 and apache 2.0.54. Apache came as an rpm
along with Fedora 4. I downloaded php from the site and built it

Thanks
Danish
short tags?

<? instead of <?php

Feb 16 '07 #2

P: n/a
On Feb 16, 3:53 pm, "shimmyshack" <matt.fa...@gmail.comwrote:
On 16 Feb, 10:32, "danish" <me.linuxad...@gmail.comwrote:
Hi,
Can anyone suggest me why some .php files are downloading and some are
executing. Ive got php 5.2.0 and apache 2.0.54. Apache came as an rpm
along with Fedora 4. I downloaded php from the site and built it
Thanks
Danish

short tags?

<? instead of <?php
Its not making any difference. I changed it bothways

Danish

Feb 16 '07 #3

P: n/a
On Feb 16, 4:15 pm, "danish" <me.linuxad...@gmail.comwrote:
On Feb 16, 3:53 pm, "shimmyshack" <matt.fa...@gmail.comwrote:
On 16 Feb, 10:32, "danish" <me.linuxad...@gmail.comwrote:
Hi,
Can anyone suggest me why some .php files are downloading and some are
executing. Ive got php 5.2.0 and apache 2.0.54. Apache came as an rpm
along with Fedora 4. I downloaded php from the site and built it
Thanks
Danish
short tags?
<? instead of <?php

Its not making any difference. I changed it bothways

Danish
Hi...I found out that this downloading option only comes when the
index.php file is accesses by giving the full url...

eg...http://192.168.1.1/inventory/index.php

Feb 16 '07 #4

P: n/a
On Feb 16, 1:50 pm, "danish" <me.linuxad...@gmail.comwrote:
On Feb 16, 4:15 pm, "danish" <me.linuxad...@gmail.comwrote:
On Feb 16, 3:53 pm, "shimmyshack" <matt.fa...@gmail.comwrote:
On 16 Feb, 10:32, "danish" <me.linuxad...@gmail.comwrote:
Hi,
Can anyone suggest me why some .php files are downloading and some are
executing. Ive got php 5.2.0 and apache 2.0.54. Apache came as an rpm
along with Fedora 4. I downloaded php from the site and built it
Thanks
Danish
short tags?
<? instead of <?php
Its not making any difference. I changed it bothways
Danish

Hi...I found out that this downloading option only comes when the
index.php file is accesses by giving the full url...

eg...http://192.168.1.1/inventory/index.php
Check the httpd.conf Content-type settings for lines related to PHP5.
If you have module-based PHP installation, there should be line like
that:

LoadModule php5_module "path-to-your-php-module"

Also,check the mime.types file. There should be lines

application/x-httpd-php php
application/x-httpd-php-source phps

Feb 16 '07 #5

P: n/a
danish wrote:
On Feb 16, 4:15 pm, "danish" <me.linuxad...@gmail.comwrote:
>On Feb 16, 3:53 pm, "shimmyshack" <matt.fa...@gmail.comwrote:
>>On 16 Feb, 10:32, "danish" <me.linuxad...@gmail.comwrote:
Hi,
Can anyone suggest me why some .php files are downloading and some are
executing. Ive got php 5.2.0 and apache 2.0.54. Apache came as an rpm
along with Fedora 4. I downloaded php from the site and built it
Thanks
Danish
short tags?
<? instead of <?php
Its not making any difference. I changed it bothways

Danish

Hi...I found out that this downloading option only comes when the
index.php file is accesses by giving the full url...

eg...http://192.168.1.1/inventory/index.php
This would be an Apache configuration problem, not PHP. I'd recommend
you check in alt.apache.configuration. They'll want to know what's in
your httpd.conf file.

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
js*******@attglobal.net
==================
Feb 16 '07 #6

P: n/a
Jerry Stuckle wrote:
danish wrote:
>On Feb 16, 4:15 pm, "danish" <me.linuxad...@gmail.comwrote:
>>On Feb 16, 3:53 pm, "shimmyshack" <matt.fa...@gmail.comwrote:

On 16 Feb, 10:32, "danish" <me.linuxad...@gmail.comwrote:
Hi,
Can anyone suggest me why some .php files are downloading and some are
executing. Ive got php 5.2.0 and apache 2.0.54. Apache came as an rpm
along with Fedora 4. I downloaded php from the site and built it
Thanks
Danish
short tags?
<? instead of <?php
Its not making any difference. I changed it bothways

Danish

Hi...I found out that this downloading option only comes when the
index.php file is accesses by giving the full url...

eg...http://192.168.1.1/inventory/index.php

This would be an Apache configuration problem, not PHP. I'd recommend
you check in alt.apache.configuration. They'll want to know what's in
your httpd.conf file.
In the Apache config make sure you added index.php to DirectoryIndex.

Example:

DirectoryIndex index.html index.html.var index.php
--
Thanks in Advance... http://weconsultants.prophp.org
IchBin, Pocono Lake, Pa, USA http://ichbinquotations.awardspace.com
__________________________________________________ ____________________
'If there is one, Knowledge is the "Fountain of Youth"'
-William E. Taylor, Regular Guy (1952-)
Feb 16 '07 #7

P: n/a
On Feb 16, 7:48 pm, "Mityok" <mit...@gmail.comwrote:
On Feb 16, 1:50 pm, "danish" <me.linuxad...@gmail.comwrote:
On Feb 16, 4:15 pm, "danish" <me.linuxad...@gmail.comwrote:
On Feb 16, 3:53 pm, "shimmyshack" <matt.fa...@gmail.comwrote:
On 16 Feb, 10:32, "danish" <me.linuxad...@gmail.comwrote:
Hi,
Can anyone suggest me why some .php files are downloading and some are
executing. Ive got php 5.2.0 and apache 2.0.54. Apache came as an rpm
along with Fedora 4. I downloaded php from the site and built it
Thanks
Danish
short tags?
<? instead of <?php
Its not making any difference. I changed it bothways
Danish
Hi...I found out that this downloading option only comes when the
index.php file is accesses by giving the full url...
eg...http://192.168.1.1/inventory/index.php

Check the httpd.conf Content-type settings for lines related to PHP5.
If you have module-based PHP installation, there should be line like
that:

LoadModule php5_module "path-to-your-php-module"

Also,check the mime.types file. There should be lines

application/x-httpd-php php
application/x-httpd-php-source phps
application/x-httpd-php php
application/x-httpd-php-source phps
These lines are not present in mime.types file but in httpd.conf
file. The LoadModule directive is also present in the httpd.conf file
Feb 16 '07 #8

P: n/a
On Feb 16, 9:40 pm, IchBin <wecon...@ptd.netwrote:
Jerry Stuckle wrote:
danish wrote:
On Feb 16, 4:15 pm, "danish" <me.linuxad...@gmail.comwrote:
On Feb 16, 3:53 pm, "shimmyshack" <matt.fa...@gmail.comwrote:
>>On 16 Feb, 10:32, "danish" <me.linuxad...@gmail.comwrote:
Hi,
Can anyone suggest me why some .php files are downloading and some are
executing. Ive got php 5.2.0 and apache 2.0.54. Apache came as an rpm
along with Fedora 4. I downloaded php from the site and built it
Thanks
Danish
short tags?
<? instead of <?php
Its not making any difference. I changed it bothways
>Danish
Hi...I found out that this downloading option only comes when the
index.php file is accesses by giving the full url...
eg...http://192.168.1.1/inventory/index.php
This would be an Apache configuration problem, not PHP. I'd recommend
you check in alt.apache.configuration. They'll want to know what's in
your httpd.conf file.

In the Apache config make sure you added index.php to DirectoryIndex.

Example:

DirectoryIndex index.html index.html.var index.php
--
Thanks in Advance... http://weconsultants.prophp.org
IchBin, Pocono Lake, Pa, USA http://ichbinquotations.awardspace.com
__________________________________________________ ____________________
'If there is one, Knowledge is the "Fountain of Youth"'
-William E. Taylor, Regular Guy (1952-)

Thanks for the help Jerry. Ill be posting in the
alt.apache.configuration group.

Ichbin..

I do have index.php in the DirectoryIndex directive

Danish
Feb 16 '07 #9

This discussion thread is closed

Replies have been disabled for this discussion.