By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,730 Members | 1,399 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,730 IT Pros & Developers. It's quick & easy.

CSS file size limit?

P: n/a
Yesterday my site unexpectedly stopped loading. I tracked it down to
the CSS file for the site. When I commented it out, the site was okay.
When I put it back in, it was not. I tried connecting to the server
via Dreamweaver and it could not dowload the file. Very bizarre,
however I noticed that it was getting to 14.6K / 15.2K before pausing.
So I went in via the command line and deleted from the end of the file
until it was smaller than 14.6K. The site now works like a charm,
minus my missing style elements.

Next I tried creating a second style sheet (styles2.css), appending
the ~50 lines I had deleted, and linking to it. Again, the site
stopped responding. I started cutting out style elements and once I
got beneath a certain threshold, the site would start loading. It
didn't matter which elements I cut, just as long as I didn't have too
many.

Any insight into what is going on here? Is there some kind of size
limit of CSS files?
Thank you,
Kevin

Feb 7 '07 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Kevin Audleman wrote:
Yesterday my site unexpectedly stopped loading. I tracked it down to
the CSS file for the site. When I commented it out, the site was okay.
When I put it back in, it was not. I tried connecting to the server
via Dreamweaver and it could not dowload the file. Very bizarre,
however I noticed that it was getting to 14.6K / 15.2K before pausing.
So I went in via the command line and deleted from the end of the file
until it was smaller than 14.6K. The site now works like a charm,
minus my missing style elements.

Next I tried creating a second style sheet (styles2.css), appending
the ~50 lines I had deleted, and linking to it. Again, the site
stopped responding. I started cutting out style elements and once I
got beneath a certain threshold, the site would start loading. It
didn't matter which elements I cut, just as long as I didn't have too
many.

Any insight into what is going on here? Is there some kind of size
limit of CSS files?
Thank you,
Kevin
Who knows? Probably not in a PHP newsgroup.

You might try asking an an appropriate newsgroup such as alt.html.css or
alt.html.

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
js*******@attglobal.net
==================
Feb 7 '07 #2

P: n/a
On Feb 6, 5:12 pm, Jerry Stuckle <jstuck...@attglobal.netwrote:
Kevin Audleman wrote:
Yesterday my site unexpectedly stopped loading. I tracked it down to
the CSS file for the site. When I commented it out, the site was okay.
When I put it back in, it was not. I tried connecting to the server
via Dreamweaver and it could not dowload the file. Very bizarre,
however I noticed that it was getting to 14.6K / 15.2K before pausing.
So I went in via the command line and deleted from the end of the file
until it was smaller than 14.6K. The site now works like a charm,
minus my missing style elements.
Next I tried creating a second style sheet (styles2.css), appending
the ~50 lines I had deleted, and linking to it. Again, the site
stopped responding. I started cutting out style elements and once I
got beneath a certain threshold, the site would start loading. It
didn't matter which elements I cut, just as long as I didn't have too
many.
Any insight into what is going on here? Is there some kind of size
limit of CSS files?
Thank you,
Kevin

Who knows? Probably not in a PHP newsgroup.

You might try asking an an appropriate newsgroup such as alt.html.css or
alt.html.

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
jstuck...@attglobal.net
==================
Great idea Jerry. I'm not sure what I was thinking posting here.
Thanks.

Kevin

Feb 7 '07 #3

P: n/a
On Feb 7, 5:41 am, "Kevin Audleman" <kevin.audle...@gmail.comwrote:
Yesterday my site unexpectedly stopped loading.
<snip>

FWIW, I had posted similar issue about 2 years back and later I
found there is an issue with Apache on Windows. Couldn't give you any
links; but I'm sure there was some issue in Apache on Windows; it was
even mentioned in FAQ or readme, IIRC

--
<?php echo 'Just another PHP saint'; ?>
Email: rrjanbiah-at-Y!com Blog: http://rajeshanbiah.blogspot.com/

Feb 7 '07 #4

This discussion thread is closed

Replies have been disabled for this discussion.