By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,091 Members | 1,546 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,091 IT Pros & Developers. It's quick & easy.

You must specify the PHP executable used for the debug session

P: n/a
Hi,

I'm new to perl and have run into some roadblocks while trying to run
tutorials.

I have installed Apache v2.2.3
I have installed ActivePerl v6.6.1.638
I have installed php v5.2.0
I am running Komodo professional, version 3.5.3

and running through the guestbook.php tutorial which came with Komodo.

Following Komodo's instructions, I click on Debug
then 'Run without debugging' (They say to click 'start', but start is not an
option I am presented with)
I am then given a debugging window where I can enter environment variables,
select CGI envronment, etc.
I enter the data as the tutorial specifies, but when I click 'OK', I get the
error message "You must specify the PHP executable used for the debug
session"

How do I do this?

I've tried Preperences, Languages, Perl and PHP as per searches on the WEB
but to no avail. Has anyone seen this error? Can anyone guide me to
resolving it? Any help would be appreciated. Thanks. Ian

Jan 20 '07 #1
Share this Question
Share on Google+
6 Replies


P: n/a
Scubadude wrote:
Hi,

I'm new to perl and have run into some roadblocks while trying to run
tutorials.

I have installed Apache v2.2.3
I have installed ActivePerl v6.6.1.638
I have installed php v5.2.0
I am running Komodo professional, version 3.5.3

and running through the guestbook.php tutorial which came with Komodo.

Following Komodo's instructions, I click on Debug
then 'Run without debugging' (They say to click 'start', but start is not an
option I am presented with)
I am then given a debugging window where I can enter environment variables,
select CGI envronment, etc.
I enter the data as the tutorial specifies, but when I click 'OK', I get the
error message "You must specify the PHP executable used for the debug
session"

How do I do this?

I've tried Preperences, Languages, Perl and PHP as per searches on the WEB
but to no avail. Has anyone seen this error? Can anyone guide me to
resolving it? Any help would be appreciated. Thanks. Ian

You've must have missed it. It's there....
Edit Prefrences
Goto Languages PHP
See Debugger Configuration

Hendri Kurniawan
Jan 20 '07 #2

P: n/a
Hi Hendri,

Under Edit>Preferences>Languages>PHP I have entered:

Use this interpreter --E:\Program Files\perl\PHP\php.exe
Directory containing php.ini --E:\Program Files\perl\PHP\

Under Debugger information, I get the following message:

WARNING! PHP is not configured for debugging. You can use the
configuration wizzard to configure PHP for debugging.

I have tried running the wizzard and it says it has done its thing, but I
keep getting the same error.

Any other thoughts? Thanks. Ian
----------------
"Hendri Kurniawan" <as****@email.comwrote in message
news:12*************@corp.supernews.com...
Scubadude wrote:
Hi,

I'm new to perl and have run into some roadblocks while trying to run
tutorials.

I have installed Apache v2.2.3
I have installed ActivePerl v6.6.1.638
I have installed php v5.2.0
I am running Komodo professional, version 3.5.3

and running through the guestbook.php tutorial which came with Komodo.

Following Komodo's instructions, I click on Debug
then 'Run without debugging' (They say to click 'start', but start is
not an
option I am presented with)
I am then given a debugging window where I can enter environment
variables,
select CGI envronment, etc.
I enter the data as the tutorial specifies, but when I click 'OK', I get
the
error message "You must specify the PHP executable used for the debug
session"

How do I do this?

I've tried Preperences, Languages, Perl and PHP as per searches on the
WEB
but to no avail. Has anyone seen this error? Can anyone guide me to
resolving it? Any help would be appreciated. Thanks. Ian



You've must have missed it. It's there....
Edit Prefrences
Goto Languages PHP
See Debugger Configuration

Hendri Kurniawan

Jan 20 '07 #3

P: n/a
Scubadude wrote:
Hi Hendri,

Under Edit>Preferences>Languages>PHP I have entered:

Use this interpreter --E:\Program Files\perl\PHP\php.exe
Directory containing php.ini --E:\Program Files\perl\PHP\

Under Debugger information, I get the following message:

WARNING! PHP is not configured for debugging. You can use the
configuration wizzard to configure PHP for debugging.

I have tried running the wizzard and it says it has done its thing, but I
keep getting the same error.

Any other thoughts? Thanks. Ian
----------------
"Hendri Kurniawan" <as****@email.comwrote in message
news:12*************@corp.supernews.com...
>Scubadude wrote:
>>Hi,

I'm new to perl and have run into some roadblocks while trying to run
tutorials.

I have installed Apache v2.2.3
I have installed ActivePerl v6.6.1.638
I have installed php v5.2.0
I am running Komodo professional, version 3.5.3

and running through the guestbook.php tutorial which came with Komodo.

Following Komodo's instructions, I click on Debug
then 'Run without debugging' (They say to click 'start', but start is
not an
>>option I am presented with)
I am then given a debugging window where I can enter environment
variables,
>>select CGI envronment, etc.
I enter the data as the tutorial specifies, but when I click 'OK', I get
the
>>error message "You must specify the PHP executable used for the debug
session"

How do I do this?

I've tried Preperences, Languages, Perl and PHP as per searches on the
WEB
>>but to no avail. Has anyone seen this error? Can anyone guide me to
resolving it? Any help would be appreciated. Thanks. Ian

You've must have missed it. It's there....
Edit Prefrences
Goto Languages PHP
See Debugger Configuration

Hendri Kurniawan


Did Komodo modified the INI file and put it in a "Debug" directory?
If it did, it will be something like (at the beginning of the modified
INI) (Different path of course):
; xdebug config added by Komodo
zend_extension_ts=c:\dev\php\ext\php_xdebug.dll
xdebug.remote_enable=1
xdebug.remote_handler=dbgp
xdebug.remote_mode=req
xdebug.remote_port=9000

Do you use firewall? Try allowing komodo to access the network (ie.
which is just listening and sending)
to your own local machine.

If everything is as it is, I don't know what else is wrong.
Keep posting for the result tho.

BTW, there is no start on the "Debug" menu.... The tutorial is wrong,
I've got thrown off too once.
I mainly just use the toolbar with the play ( ie. ) or pressing F5

Hendri Kurniawan
Jan 20 '07 #4

P: n/a
Great information Hendri,

I did some research. The php.ini file has not been modified and there are
no other php.ini files on my system, so that would account for the error.

I ran the wizzard again. I'll include the prompts and my input. It is
giving me an error but I didn't realize it because I just clicked 'finished'
at the end.

Select Installation to configure
- Installations found on your system : E:\Program Files\perl\PHP\php.exe
- Setup this installation : E:\Program
Files\perl\PHP\php.exe
NEXT >

ini file to be copied
E:\Program Files\perl\PHP\php.ini
Put debug version of ini at
E:\Program Files\perl\PHP\ (It will not change the
file if I do this, so I altered the destination to E:\Program
Files\perl\PHP\dev\ and it created a new ini file)
NEXT >

currently configured extensions directory
E:\Program Files\perl\PHP\extensions (If I use the debug directory
of ..\php\ then this directory is not created)
NEXT >

The results.....

Using the directory ..\php\ above, I get the following message:
Sorry, PHP Debugging configuration failed. Unable to copy [E:\Program
Files\perl\PHP\php.ini] to [E:\Program Files\perl\PHP] Please consult the
help file
for more information on configuring PHP. If you continue to have problems,
contact yadda yadda yadda

Using the directory ..\php\dev\ above, I get the following message:
Sorry, PHP Debugging configuration failed. PHP is configured but was unable
to load
the debugger extension. Please consult the help file yadda yadda yadda

After doing this, and creating a new .ini file, I tried copying it into the
...\php\ directory but still was unable to run the debugger.

Hendri, you have been a great help in helping me to understand the workings
of the system. Knowing what I should be seeing is great. I now know what
direction I am facing. Can you shed a little more light on the subject?
And yes, when it did create the new .ini file, it had all that xdebug stuff
in it. Ian
--------
"Hendri Kurniawan" <as****@email.comwrote in message
news:12*************@corp.supernews.com...
Scubadude wrote:
Hi Hendri,

Under Edit>Preferences>Languages>PHP I have entered:

Use this interpreter --E:\Program Files\perl\PHP\php.exe
Directory containing php.ini --E:\Program Files\perl\PHP\

Under Debugger information, I get the following message:

WARNING! PHP is not configured for debugging. You can use the
configuration wizzard to configure PHP for debugging.

I have tried running the wizzard and it says it has done its thing, but
I
keep getting the same error.

Any other thoughts? Thanks. Ian
----------------
"Hendri Kurniawan" <as****@email.comwrote in message
news:12*************@corp.supernews.com...
Scubadude wrote:
Hi,

I'm new to perl and have run into some roadblocks while trying to run
tutorials.

I have installed Apache v2.2.3
I have installed ActivePerl v6.6.1.638
I have installed php v5.2.0
I am running Komodo professional, version 3.5.3

and running through the guestbook.php tutorial which came with Komodo.

Following Komodo's instructions, I click on Debug
then 'Run without debugging' (They say to click 'start', but start is
not an
>option I am presented with)
I am then given a debugging window where I can enter environment
variables,
>select CGI envronment, etc.
I enter the data as the tutorial specifies, but when I click 'OK', I
get
the
>error message "You must specify the PHP executable used for the debug
session"

How do I do this?

I've tried Preperences, Languages, Perl and PHP as per searches on the
WEB
>but to no avail. Has anyone seen this error? Can anyone guide me to
resolving it? Any help would be appreciated. Thanks. Ian


You've must have missed it. It's there....
Edit Prefrences
Goto Languages PHP
See Debugger Configuration

Hendri Kurniawan


Did Komodo modified the INI file and put it in a "Debug" directory?
If it did, it will be something like (at the beginning of the modified
INI) (Different path of course):
; xdebug config added by Komodo
zend_extension_ts=c:\dev\php\ext\php_xdebug.dll
xdebug.remote_enable=1
xdebug.remote_handler=dbgp
xdebug.remote_mode=req
xdebug.remote_port=9000

Do you use firewall? Try allowing komodo to access the network (ie.
which is just listening and sending)
to your own local machine.

If everything is as it is, I don't know what else is wrong.
Keep posting for the result tho.

BTW, there is no start on the "Debug" menu.... The tutorial is wrong,
I've got thrown off too once.
I mainly just use the toolbar with the play ( ie. ) or pressing F5

Hendri Kurniawan

Jan 21 '07 #5

P: n/a
Scubadude wrote:
Great information Hendri,

I did some research. The php.ini file has not been modified and there are
no other php.ini files on my system, so that would account for the error.

I ran the wizzard again. I'll include the prompts and my input. It is
giving me an error but I didn't realize it because I just clicked 'finished'
at the end.

Select Installation to configure
- Installations found on your system : E:\Program Files\perl\PHP\php.exe
- Setup this installation : E:\Program
Files\perl\PHP\php.exe
NEXT >

ini file to be copied
E:\Program Files\perl\PHP\php.ini
Put debug version of ini at
E:\Program Files\perl\PHP\ (It will not change the
file if I do this, so I altered the destination to E:\Program
Files\perl\PHP\dev\ and it created a new ini file)
NEXT >

currently configured extensions directory
E:\Program Files\perl\PHP\extensions (If I use the debug directory
of ..\php\ then this directory is not created)
NEXT >

The results.....

Using the directory ..\php\ above, I get the following message:
Sorry, PHP Debugging configuration failed. Unable to copy [E:\Program
Files\perl\PHP\php.ini] to [E:\Program Files\perl\PHP] Please consult the
help file
for more information on configuring PHP. If you continue to have problems,
contact yadda yadda yadda

Using the directory ..\php\dev\ above, I get the following message:
Sorry, PHP Debugging configuration failed. PHP is configured but was unable
to load
the debugger extension. Please consult the help file yadda yadda yadda

After doing this, and creating a new .ini file, I tried copying it into the
...\php\ directory but still was unable to run the debugger.

Hendri, you have been a great help in helping me to understand the workings
of the system. Knowing what I should be seeing is great. I now know what
direction I am facing. Can you shed a little more light on the subject?
And yes, when it did create the new .ini file, it had all that xdebug stuff
in it. Ian


Hi Ian,

The problem now lies within the debugger itself. It's not compatible
with php5.2
That you need to do is download a new debugger for the new version.

You are ovbviously running windows..., so download this:
http://pecl4win.php.net/download.php...php_xdebug.dll
And replace the dll on your php/ext directory (ie. the file that is
pointed at on your php.ini)

I don't know whether it will work or not, I haven't tried it myself.
Hope it does tho

Hendri Kurniawan
Jan 21 '07 #6

P: n/a
Hi Hendri,

Thanks for all your help. I have now resolved this issue. The problem was
the configuration of the php.ini file. I had used the windows installer to
install PHP for me and it was leaving something vital out. After removing
everything, I performed a manual installation and the error is gone... Of
course I now have a new one telling me "No input file specified." but I'll
muddle with that for a bit before asking for help.

Thanks again. Ian
----------
"Hendri Kurniawan" <as****@email.comwrote in message
news:12*************@corp.supernews.com...
Scubadude wrote:
Great information Hendri,

I did some research. The php.ini file has not been modified and there
are
no other php.ini files on my system, so that would account for the
error.

I ran the wizzard again. I'll include the prompts and my input. It is
giving me an error but I didn't realize it because I just clicked
'finished'
at the end.

Select Installation to configure
- Installations found on your system : E:\Program
Files\perl\PHP\php.exe
- Setup this installation : E:\Program
Files\perl\PHP\php.exe
NEXT >

ini file to be copied
E:\Program Files\perl\PHP\php.ini
Put debug version of ini at
E:\Program Files\perl\PHP\ (It will not change
the
file if I do this, so I altered the destination to E:\Program
Files\perl\PHP\dev\ and it created a new ini file)
NEXT >

currently configured extensions directory
E:\Program Files\perl\PHP\extensions (If I use the debug
directory
of ..\php\ then this directory is not created)
NEXT >

The results.....

Using the directory ..\php\ above, I get the following message:
Sorry, PHP Debugging configuration failed. Unable to copy [E:\Program
Files\perl\PHP\php.ini] to [E:\Program Files\perl\PHP] Please consult
the
help file
for more information on configuring PHP. If you continue to have
problems,
contact yadda yadda yadda

Using the directory ..\php\dev\ above, I get the following message:
Sorry, PHP Debugging configuration failed. PHP is configured but was
unable
to load
the debugger extension. Please consult the help file yadda yadda yadda

After doing this, and creating a new .ini file, I tried copying it into
the
...\php\ directory but still was unable to run the debugger.

Hendri, you have been a great help in helping me to understand the
workings
of the system. Knowing what I should be seeing is great. I now know
what
direction I am facing. Can you shed a little more light on the subject?
And yes, when it did create the new .ini file, it had all that xdebug
stuff
in it. Ian


Hi Ian,

The problem now lies within the debugger itself. It's not compatible
with php5.2
That you need to do is download a new debugger for the new version.

You are ovbviously running windows..., so download this:
http://pecl4win.php.net/download.php...php_xdebug.dll
And replace the dll on your php/ext directory (ie. the file that is
pointed at on your php.ini)

I don't know whether it will work or not, I haven't tried it myself.
Hope it does tho

Hendri Kurniawan

Jan 25 '07 #7

This discussion thread is closed

Replies have been disabled for this discussion.