By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,391 Members | 1,387 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,391 IT Pros & Developers. It's quick & easy.

Bizarre Apache/PHP startup error

P: n/a
I've been trying to bring up an IMP webmail server for...oh, several
days now. I've never had so much trouble bringing up any machine, and
I've beaten my forehead flat against it. Either I've been at it too
long, or I've been at it too long and there's a bug here somewhere.

Basically, I had a working machine up until yesterday, with gd.so,
imap.so, ldap.so, mbstring.so, mcrypt.so, and pgsql.so all up and
running nicely. At that point I wanted to install fileinfo, so I first
installed Christos Zoulas' File 4.17 from astron.com. I then did a
"pear install fileinfo", which I *think* relies on File 4.17 and/or its
magic.h header as a prerequisite, although it's possible that this idea
crept into my head along the way and has no basis in reality. After
"pear install fileinfo", pear exits with "Warning:
opendir(/var/tmp/pear-build-davek/install-Fileinfo-1.0.3//var/www/pear):
failed to open dir: No such file or directory in Builder.php on line
162", so I popped into pear's download directory under /tmp and ran
configure, make and make install, without any error messages. After
running "phpxs -a fileinfo" I should be done.

Except that now Apache 1.3.29 will no longer start:

/var/www/conf # httpd
Syntax error on line 267 of /var/www/conf/httpd.conf:
Cannot load /usr/lib/apache/modules/libphp5.so into server: Cannot load
specified object
/var/www/conf # httpd -u
Syntax error on line 267 of /var/www/conf/httpd.conf:
Cannot load /usr/lib/apache/modules/libphp5.so into server: Cannot load
specified object

Line 267 of httpd.conf looks as follows:

LoadModule php5_module /usr/lib/apache/modules/libphp5.so

A quick check verifies that libphp5.so is present in
/usr/lib/apache/modules. It hasn't been touched for the past several
days in between the time it loaded up just fine and the time it didn't.
Neither has httpd.conf, which was syntactically correct last week but
not this week even though it also is unchanged. If I comment out the
offending PHP5 startup line, Apache starts.

There isn't anything in either Apache's or PHP's error log. I've tried
copying the straight "php.ini-recommended" over with no luck.

I've tried running a commandline php test using fileinfo object file,
and it seems
to work great, so I don't think the problem is with fileinfo. But I'm
not positive. All I really know is that I was working on the machine
and it suddenly stopped working. I need some better ways to diagnose
the problem than what Apache and PHP provide.

So what am I missing?

Thanks in advance for any advice!
Dave Klingler

The OS is OpenBSD snapshot (3.9), although I've had the same problem
trying this in OpenBSD 3.8.

Apr 11 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.