By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,986 Members | 2,030 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,986 IT Pros & Developers. It's quick & easy.

pxeboot problem

P: n/a
GH
Hi

I have spend a week-tough-fight with booting FreeBSD on diskless machine.
I don't know if I have configured everything OK, because I have a problem
with basic things.

I have FreeBSD 5.0, and normally to compile pxeboot file I should go to
/usr/src/sys/boot, execute: make clean, make depend and make.
So I did. After this I got "pxeboot" file that I copy to my remote boot
directory. I think I have correctly configured dhcp, inetd etc.

The effect is that my diskless workstation gets IP address from DHCP, gets
right path to remote booting, and reads the "pxeboot" file.
But the problem is that it is booting for hours - I have to wait for 30
minutes or longer to something happend.
If I switch "pxeboot" file to another one found on the internet (for linux)
it boots normally (of course not whole kernel loads, but I mean the speed of
boot).

Another thing is that firstly I have tried compile pxe boot on FreeBSD 4.8
release, and in the beginning it was the same slow loading problem.
But after adding to make.conf "LOADER_TFTP_SUPPORT=YES" and compiling
"pxeboot" file it works normally.
With my FreeBSD 5.0 that I am using now adding this command to make.conf, or
trying to execute command make -D LOADER_TFTP_SUPPORT while compliling
pxeboot file is not solving this problem.

Please help.

Domin
domin(at)zyx.pl
Jul 17 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
GH

I'm sorry.

Wrong newsgroup
Jul 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.