By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,662 Members | 1,052 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,662 IT Pros & Developers. It's quick & easy.

include_path error, dbg with Zend Studio

P: n/a
I'm a little confused, I have test apps, using Pear DB.php but in my
application, and debugging through Zend studio, I have some Database
updates obviously working and then I get a Fatal Error.
Apparently, it cannot find DB.php and shows include_path as:
".;C:\PHP5"

On my Windows XP system, I've got php installed at C:\php
and any php.ini or apache conf files reflect this accurately.
My phpinfo() also correctly shows include_path as:
".;C:\PHP\pear"

Even stranger, is why I'd get some updates to work initially, then it
hiccups.

ideas ?

Aug 23 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
This problem seems directly related to Zend Studio 4.0. I can run
error-free without it. It seems to have assigned a new value to my
include_path.

Anyone else have a similar experience ?

I've checked many settings: (env and registry), php.ini, Apache's conf
and found no instance of C:\PHP5 I have to assume its a Zend Studio
problem.

When I manually set the "include_path" right above, an Fatal Error
occurs; it can't find the mysql extension: 'DB Error: extension not
found'.

Suggestions most welcome.
i_dvlp at hotmail.com

Aug 25 '05 #2

P: n/a
On 2005-08-25, webguynow <in*****@rcn.com> wrote:
This problem seems directly related to Zend Studio 4.0. I can run
error-free without it. It seems to have assigned a new value to my
include_path.

Anyone else have a similar experience ?

I've checked many settings: (env and registry), php.ini, Apache's conf
and found no instance of C:\PHP5 I have to assume its a Zend Studio
problem.

When I manually set the "include_path" right above, an Fatal Error
occurs; it can't find the mysql extension: 'DB Error: extension not
found'.


Or you sure the php.ini in use is the one you think it is? With
phpinfo() you can see which ini file is used.

To me it sounds like you're missing a extension=php_mysql.dll

--
Met vriendelijke groeten,
Tim Van Wassenhove <http://timvw.madoka.be>
Aug 25 '05 #3

P: n/a
As I mentioned - I'm running error free when I don't use the Z.Studio.

Aug 26 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.