By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,992 Members | 934 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,992 IT Pros & Developers. It's quick & easy.

Turn on $_SERVER["PHP_AUTH_USER"] locally?

P: n/a
Hello,

I am finding that on a new server where I am developing

$_SERVER["PHP_AUTH_USER"] and
$_SERVER["PHP_AUTH_PW"]

Do not show up in $_SERVER when I when they should be defined I test
using
print_r($_SERVER) or this

<?php
if (!isset($_SERVER['PHP_AUTH_USER'])) {
header('WWW-Authenticate: Basic realm="My Realm"');
header('HTTP/1.0 401 Unauthorized');
echo 'Text to send if user hits Cancel button';
exit;
} else {
echo "<p>Hello {$_SERVER['PHP_AUTH_USER']}.</p>";
echo "<p>You entered {$_SERVER['PHP_AUTH_PW']} as your
password.</p>";
}
?>

Is there a setting that is keeping PHP from accessing this
information? Can I set this locally?

$_SERVER["REMOTE_USER"] also stays empty.

TIA for any advice!

jg
Jul 17 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
I should add that if I add an .htaccess to a folder requiring username "dm"
and password "whatever" and then

do this

<?php
echo 'PHP_AUTH_USER =' . $_SERVER['PHP_AUTH_USER'] . '<br>';
echo 'PHP_AUTH_PW =' . $_SERVER['PHP_AUTH_PW'] . '<br>';
echo 'REMOTE_USER =' . $_SERVER['REMOTE_USER'] . '<br>';
?>
I get this:

PHP_AUTH_USER =
PHP_AUTH_PW =
REMOTE_USER =dm

so REMOTE_USER is defined but no :password.

jg
Jul 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.