By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,729 Members | 1,363 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,729 IT Pros & Developers. It's quick & easy.

"XSLTProcessor class not found"

P: n/a
On WinXP, IIS 5.1, PHP 5.04 manually installed from php504 win32.zip

I cannot get xslt and xml functions to run.
Most advice from dredging the net suggests enabling "php_xslt" and "php_xml"
exts, but these do not exist in 5.04.
In "ext" folder are folders "libxml" and "libxslt" both of which contain
subfolders, including "bin" folder in each, containing "libxml2.dll" and
"libxslt.dll".
Some advice recommends moving these two dlls to the main folder but this too
does not work.

Any help would save whats left of my hair :^(

--
Tony Bishop
www.bishfish.co.nz
New Zealand
Jul 17 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Download the complete php zip package and copy the xsl dll from the zip
to php
directory.
Check this link for zip download

http://us4.php.net/get/php-5.0.3-Win.../from/a/mirror

Bishfish wrote:
On WinXP, IIS 5.1, PHP 5.04 manually installed from php504 win32.zip

I cannot get xslt and xml functions to run.
Most advice from dredging the net suggests enabling "php_xslt" and "php_xml" exts, but these do not exist in 5.04.
In "ext" folder are folders "libxml" and "libxslt" both of which contain subfolders, including "bin" folder in each, containing "libxml2.dll" and "libxslt.dll".
Some advice recommends moving these two dlls to the main folder but this too does not work.

Any help would save whats left of my hair :^(

--
Tony Bishop
www.bishfish.co.nz
New Zealand


Jul 17 '05 #2

P: n/a
Thanks Mathew, using your info and some more I discovered;

move libxslt.dll, libxml2.dll, from the ext\libxml and ext\libxslt bin
folders to the php directory.

Here is the kicker for novices like me, check using phpinfo.php that the IIS
sever configuration pionts to php.ini in the php directory if that is where
it actually is (as recommended)! - by default it pionts to C:\windows - you
can change this after installation by adding variable "PHPRC" with a value
"C:\php" in your environment variables.

Seems to be working for me.
Jul 17 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.