By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,502 Members | 1,878 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,502 IT Pros & Developers. It's quick & easy.

Problem with Cross database join

P: n/a
I hope someone can offer me some advice or additional areas to search
for the answer.
I'm trying to do a cross database join on a single server. My searches
indicate that the way to do this is a database link.
Seemed simple enough, however, no matter what I try I get "database
link is not active". My understanding of this error indicates that I
either have the wrong username and password or I have specified a
database that doesn't exist. I finally ended up expanding the query to
create the link to the maximum number of parameters. The statement I
execute is as follows:

CREATE SHARED PUBLIC DATABASE LINK RLINK
CONNECT TO system IDENTIFIED BY manager
AUTHENTICATED BY system IDENTIFIED BY manager
USING '(description=(address=(protocol=tcp)(host=<RETIRE .PROVIDERTECHNOLOGIES.COM>)
(Port = 1521) ) (connect_data= (sid=<retire>)))';

Depending on how I change the variables above I get different errors
when I try to execute against the link.

select * from employer@RLINK;

returns any number of errors ranging from "Authentication" errors to
"TNSListener" errors. I have verified the service names as well as the
listener parameters and I can use these parameters via ODBC. In DBA
studio however the error is consistently "database link is not
active".

What am I missing? Where else should I look for the solution? Is there
some sort of permission that needs to be turned on in order to create
and use database links?
DBA studio makes this seem simple. The dialogs only ask for a few
number of parameters and I have double-checked and triple-checked to
make sure I am entering the right information and I believe I am but
it still won't work.

Thanks,

Eric
Jul 19 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.