471,045 Members | 1,004 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,045 software developers and data experts.

Assembly missing in GAC after Publish?

Hi,

We're using ClickOnce alreaddy more than a year for a given applicaiton,
doing more than 50 publishes without any problem.

Yesterday we made a minor change to one of our components (let's say with
the name MyAssembly), and incremented it's version (AssemblyVersion: from
0.1.7.0 to 0.1.7.1). We did the Publish with ClickOnce, but when the users
know want to run the application they get this error:
"Unable to install or run the application. The application requires that
assembly MyAssembly Version 0.1.7.0
be installed in the Global Assembly Cache (GAC) first."
This is so weird, especially when knowing we had alreaddy inremented this
version number without any problems in the past.

Anybody has any idea? Your help will be really appreciated!
Thanks a lot in advance,
Pieter
Jun 27 '08 #1
2 1527
Aaargh never mind, I've found it:
What was actually happening was soem type of dll hell :-)
Another component in the project was referencing the same assembly, but did
it with a compiled version, not the source of the project. so when doing the
publish there was some conflict between the old one and the new one...

This conflict should be more visible in the output window when doing a build
:-)

"Pieter" <pi****************@hotmail.comwrote in message
news:%2******************@TK2MSFTNGP04.phx.gbl...
Hi,

We're using ClickOnce alreaddy more than a year for a given applicaiton,
doing more than 50 publishes without any problem.

Yesterday we made a minor change to one of our components (let's say with
the name MyAssembly), and incremented it's version (AssemblyVersion: from
0.1.7.0 to 0.1.7.1). We did the Publish with ClickOnce, but when the users
know want to run the application they get this error:
"Unable to install or run the application. The application requires that
assembly MyAssembly Version 0.1.7.0
be installed in the Global Assembly Cache (GAC) first."
This is so weird, especially when knowing we had alreaddy inremented this
version number without any problems in the past.

Anybody has any idea? Your help will be really appreciated!
Thanks a lot in advance,
Pieter


Jun 27 '08 #2
On Jun 17, 12:15*pm, "Pieter" <pieterNOSPAMcou...@hotmail.comwrote:
Aaargh never mind, I've found it:
What was actually happening was soem type of dll hell :-)
Another component in the project was referencing the same assembly, but did
it with a compiled version, not the source of the project. so when doing the
publish there was some conflict between the old one and the new one...

This conflict should be more visible in the output window when doing a build
:-)

"Pieter" <pieterNOSPAMcou...@hotmail.comwrote in message

news:%2******************@TK2MSFTNGP04.phx.gbl...
Hi,
We're using ClickOnce alreaddy more than a year for a given applicaiton,
doing more than 50 publishes without any problem.
Yesterday we made a minor change to one of our components (let's say with
the name MyAssembly), and incremented it's version (AssemblyVersion: from
0.1.7.0 to 0.1.7.1). We did the Publish with ClickOnce, but when the users
know want to run the application they get this error:
"Unable to install or run the application. The application requires that
assembly MyAssembly Version 0.1.7.0
be installed in the Global Assembly Cache (GAC) first."
This is so weird, especially when knowing we had alreaddy inremented this
version number without any problems in the past.
Anybody has any idea? Your help will be really appreciated!
Thanks a lot in advance,
Pieter- Hide quoted text -

- Show quoted text -
Hi,
If you need to play with GAC manually, you can also refer to this
article:
http://support.microsoft.com/kb/315682

Thanks,

Onur Güzel
Jun 27 '08 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by EAI | last post: by
6 posts views Thread by ewolfman | last post: by
10 posts views Thread by MarkAurit | last post: by
1 post views Thread by Andrew | last post: by
2 posts views Thread by Pieter | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.