By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,952 Members | 897 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,952 IT Pros & Developers. It's quick & easy.

Problems with ActiveX usage in C# usercontrol

P: n/a
OS: XP

..Net= framework = 1.0.3705

VS.Net IDE = 7.0.9466

1. I used an ActiveX control in C# client Application[has dll]. After
executing Aximp of ActiveX control. I derived a class [DerivedGrid] from the
AxHost[wrapper for ActiveX].

This DerivedGrid class is hosted on a usercontrol[Tv class] which is inturn
hosted on another UserControl[Idc]. In turn this Idc is hosted on a Form.

Now the problem is: If the DerivedGrid class object is created and the Idc
is hidden[Visiblity=false], then the WM_VISIBLE style of ActiveX control
gets removed internally

[when? no idea]. Can anybody help me out why this happens.

2. I used a work around for the above problem by resetting WM_VISIBLE style
in ActiveX control[temporarly]. This has resulted into another problem. Now
the other problem is when I create 'n' numbers of DerivedGrid object and
place them sequentially cross the viewing area and also I enable the
AutoScroll on Tv class for viewing all the grids. Then Scroll few pixels in
both horizontal and vertical direction and Click one of the DerivedGrid
object , the DerivedGrid object gets clipped. This is a strange behaviour.
Jul 19 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.