469,304 Members | 2,018 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,304 developers. It's quick & easy.

Compile Error: Null Device is Missing

I am having a "Null Device is Missing" compile error when compiling a c++
project.

The documentation from MSDN said it could be caused by low system resource
or the user account does not have the prillivage.
But I am plenty of system resources and I logged in as Admin.

Anyone know how to solve this?

Thanks in advance
Tony
Nov 16 '05 #1
8 12397
Hi Tony,

As I understand, you get the following error when you try to build a
default Visual C++ .NET application.

"Null Device is Missing"

Based on my research and experience, please try the following steps on your
side: (I am using Windows XP Professional)

1. Go to the Start menu and select control Panel.

2. Select Administrative Tools.

3. Select Computer Management.

4. Select Device Manager.

5. Select the View Menu and the option for Show Hidden Devices

6. Expand the Non Plug and Play Drivers (Tree)

7. Scroll to the Null selection, right click, and select properties.

8. Make sure it is enabled and started.

Please try it and tell me the result.

Best regards,
Jacob Yang
Microsoft Online Partner Support
Get Secure! 每 www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

Nov 16 '05 #2
I followed your steps, and I can locate the null device from the Device
View, however, I can't start or stop the driver like the others devices as
the controls in the Driver property page for the null device are disabled.

Any ideas?

Tony

"Jacob Yang [MSFT]" <ji***@online.microsoft.com> wrote in message
news:G5**************@cpmsftngxa06.phx.gbl...
Hi Tony,

As I understand, you get the following error when you try to build a
default Visual C++ .NET application.

"Null Device is Missing"

Based on my research and experience, please try the following steps on your side: (I am using Windows XP Professional)

1. Go to the Start menu and select control Panel.

2. Select Administrative Tools.

3. Select Computer Management.

4. Select Device Manager.

5. Select the View Menu and the option for Show Hidden Devices

6. Expand the Non Plug and Play Drivers (Tree)

7. Scroll to the Null selection, right click, and select properties.

8. Make sure it is enabled and started.

Please try it and tell me the result.

Best regards,
Jacob Yang
Microsoft Online Partner Support
Get Secure! 每 www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

Nov 16 '05 #3
Hi Tony,

Thank you for your update.

Please perform the following step on your side after the step 7 on my
previous post.

Under Device Usage select "Use this device (enable)" and then Click OK.
I hope it helps.

Best regards,

Jacob Yang
Microsoft Online Partner Support
Get Secure! 每 www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

Nov 16 '05 #4
I do have the device enabled in the first place.
"Jacob Yang [MSFT]" <ji***@online.microsoft.com> wrote in message
news:94**************@cpmsftngxa06.phx.gbl...
Hi Tony,

Thank you for your update.

Please perform the following step on your side after the step 7 on my
previous post.

Under Device Usage select "Use this device (enable)" and then Click OK.
I hope it helps.

Best regards,

Jacob Yang
Microsoft Online Partner Support
Get Secure! 每 www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

Nov 16 '05 #5
Hi Tony,

I am sorry if there is any misunderstanding.

Based on the information you provided, the Null device is not configured
successfully on the system. Please make the followings on your side.

1. Please tell me which Operating System you are using. I am using Windows
XP professional

2. When you right click the "Null" device, what options can you see in the
pop menu? I can find the following options:

Disable
Uninstall
-------------
Scan for hardware changes
-------------
Properties

3. When you select Properties, there are two tabs - General and Driver.

4. In the General Tab, please make sure the following settings:

1) Device Status

"This device is working properly.

If you are having problems with this device, click Troubleshoot to start
the troubleshooter."

2) Device usage

"Use this device (enable)"

5. In the Driver Tab, please make sure the following settings:

1) Current Status

Status: Started

2) Type

System

I am looking forward to your result.

Best regards,

Jacob Yang
Microsoft Online Partner Support
Get Secure! 每 www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

Nov 16 '05 #6
I have Windows XP Pro with the lastest patch. When I located the null
device in the by following your steps, I right click on it and the popup
menu is the same as yours. When I select Properties, I also got two tabs.

In the General Tab, I have the status text as "The device is working
properly." and under Device Usage, I have "Use this device (enable)".
In the Driver Tab, the current status is "Unknown", and the Start and Stop
buttons, and Startup Type combo box are disabled.
The only button enabled is the "Driver Details" button so I clicked on it,
the driver files shows "c:\Windows\System32\drivers\Null.sys".
I did tried disabling the null device, restart the computer, and then enable
the null device again, just hoping to "restart" the device, but this does
not solve the problem.

Is this device depending on some kind of Windows Services? I do have some
Window services that I dont use disabled.

"Jacob Yang [MSFT]" <ji***@online.microsoft.com> wrote in message
news:uQ**************@cpmsftngxa06.phx.gbl...
Hi Tony,

I am sorry if there is any misunderstanding.

Based on the information you provided, the Null device is not configured
successfully on the system. Please make the followings on your side.

1. Please tell me which Operating System you are using. I am using Windows
XP professional

2. When you right click the "Null" device, what options can you see in the
pop menu? I can find the following options:

Disable
Uninstall
-------------
Scan for hardware changes
-------------
Properties

3. When you select Properties, there are two tabs - General and Driver.

4. In the General Tab, please make sure the following settings:

1) Device Status

"This device is working properly.

If you are having problems with this device, click Troubleshoot to start
the troubleshooter."

2) Device usage

"Use this device (enable)"

5. In the Driver Tab, please make sure the following settings:

1) Current Status

Status: Started

2) Type

System

I am looking forward to your result.

Best regards,

Jacob Yang
Microsoft Online Partner Support
Get Secure! 每 www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

Nov 16 '05 #7
Hi Tony,

Thank you for your update.

Please check the following registry key on your machine.

HKEY_LOCAL_MACHINE->SYSTEM->CurrentControlSet->Services->Null

The values of "Start" and "Type" should be "1" (Hex). If you want it, I can
a screen shot for your reference.

Note:
Before you modify the registry, make sure to back it up and make sure that
you understand how to restore the registry if a problem occurs. For
information about how to back up, restore, and edit the registry, please
check the following article.

Description of the Microsoft Windows Registry
http://support.microsoft.com/default...b;EN-US;256986

I hope it helps.

Best regards,

Jacob Yang
Microsoft Online Partner Support
Get Secure! 每 www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

Nov 16 '05 #8
Thanks you VERY much! This solve the problem.
Actually, my problem is that I don't even have a "Start" value, however,
after I added the "Start" value and specifies 1 as the value data, it works.

Thanks.
Tony
"Jacob Yang [MSFT]" <ji***@online.microsoft.com> wrote in message
news:eE*************@cpmsftngxa06.phx.gbl...
Hi Tony,

Thank you for your update.

Please check the following registry key on your machine.

HKEY_LOCAL_MACHINE->SYSTEM->CurrentControlSet->Services->Null

The values of "Start" and "Type" should be "1" (Hex). If you want it, I can a screen shot for your reference.

Note:
Before you modify the registry, make sure to back it up and make sure that
you understand how to restore the registry if a problem occurs. For
information about how to back up, restore, and edit the registry, please
check the following article.

Description of the Microsoft Windows Registry
http://support.microsoft.com/default...b;EN-US;256986

I hope it helps.

Best regards,

Jacob Yang
Microsoft Online Partner Support
Get Secure! 每 www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

Nov 16 '05 #9

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

10 posts views Thread by Bart Goeman | last post: by
1 post views Thread by electrixnow | last post: by
4 posts views Thread by Susan Rice | last post: by
11 posts views Thread by Bryan Crouse | last post: by
2 posts views Thread by BruceWho | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by harlem98 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.