By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,505 Members | 1,165 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,505 IT Pros & Developers. It's quick & easy.

Update Command Not Working Within Nested Datagrid

P: n/a
Hi,

I almost have my nested datagrid working properly. I created a datagrid on a
user control and dropped that onto another datagrid. At first, I noticed when
I was stepping through the code, that the update linkbutton actually goes to
the edit command instead of the update command (which I'm pretty sure would
be a bug). Anyway, I took out the editcommmand column and replaced it with a
regular template column. Within the editItemTemplate, I placed a button which
calls the update command, which actually works. The update statement also
works properly (I tested in SQL while debudding and the database updates),
but when I send the editItemIndex back to -1, you cannot see the change. I do
bind the data as well.

This whole process works when I test the user control datagrid on a webform
by itself. But as soon as I nest it within another datagrid, it doesn't work.

Another weird thing is that if I hit edit and then update again, you can see
that the change took place. Also, if I just do a refresh on the page, you can
see those changes as well.

Any help would be very much appreciated...I have wasted many, many hours on
this!
Jul 21 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.