By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,610 Members | 1,957 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,610 IT Pros & Developers. It's quick & easy.

Remote Debugging-No Suitable Logon Session

P: n/a
I am trying to setup remote debugging on my first client-server setup, so
hopefully this problem is just stupidity on my part. The client machine is
running Windows XP Pro/SP2 with Visual Studio .NET 2002 and the server is
Windows Server 2003 with the Server Components installed from VS. Both
machines are in the domain, and the user is an administrator of both machines
and has been added to the VS Developers group & the Debugger Users group on
both machines (just to be sure). Frontpage Server Extensions are installed &
the user has been added to the admin role. DCOM settings are allowing
Administrators & the user full access to MDM. The web application site does
not allow anonymous users and is Windows integrated for security. The web
application is on the server and is not using the default port. File level
permissions are Ok.

There is a minor problem with project access (that I'm not sure is a
problem), the file share used by the project maps to the web application, but
VS reports that it does not, however, the site's home directory is a local
folder. I am not worried about that, as using the FrontPage web access
setting works fine.

The problem that is annoying me occurs when I try to debug, everything else
works fine. When I try to initiate the debugger (F5) I get the following
message:

Error while trying to run project: Unable to start debugging on the web
server. There appears to be no suitable logon session on the server. Please
verify that you are logged on to the server through Terminal Services or that
you are logged onto the server locally. Would you like to disable future
attempts to debug ASP.NET pages for this project?

If I understand correctly it is asking me to have everything installed on
the server and login locally, or remotly login to the local account via
terminal services (remote desktop?), which seems a bit silly for remote
debugging.

Can someone please help me understand what it is I'm doing wrong? (BTW: I
appologize if I have posted this in the wrong area and if I have then where
should I put it?) Thanks
Jul 21 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
I am having the same problem and I was wondering if you ever got your problem resolved.
I know it is a setting on the server, but which one?
I am trying to setup remote debugging on my first client-server setup, so
hopefully this problem is just stupidity on my part. The client machine is
running Windows XP Pro/SP2 with Visual Studio .NET 2002 and the server is
Windows Server 2003 with the Server Components installed from VS. Both
machines are in the domain, and the user is an administrator of both machines
and has been added to the VS Developers group & the Debugger Users group on
both machines (just to be sure). Frontpage Server Extensions are installed &
the user has been added to the admin role. DCOM settings are allowing
Administrators & the user full access to MDM. The web application site does
not allow anonymous users and is Windows integrated for security. The web
application is on the server and is not using the default port. File level
permissions are Ok.

There is a minor problem with project access (that I'm not sure is a
problem), the file share used by the project maps to the web application, but
VS reports that it does not, however, the site's home directory is a local
folder. I am not worried about that, as using the FrontPage web access
setting works fine.

The problem that is annoying me occurs when I try to debug, everything else
works fine. When I try to initiate the debugger (F5) I get the following
message:

Error while trying to run project: Unable to start debugging on the web
server. There appears to be no suitable logon session on the server. Please
verify that you are logged on to the server through Terminal Services or that
you are logged onto the server locally. Would you like to disable future
attempts to debug ASP.NET pages for this project?

If I understand correctly it is asking me to have everything installed on
the server and login locally, or remotly login to the local account via
terminal services (remote desktop?), which seems a bit silly for remote
debugging.

Can someone please help me understand what it is I'm doing wrong? (BTW: I
appologize if I have posted this in the wrong area and if I have then where
should I put it?) Thanks


User submitted from AEWNET (http://www.aewnet.com/)
Jul 21 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.