By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,221 Members | 1,295 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,221 IT Pros & Developers. It's quick & easy.

Access Violation error, SP1 does not work

P: n/a
AA
This mail is regarding a trouble I'm facing with SQL Server 2000. I'm
working with ASP .NET V 1.1 and SQL Server 2000. I have a reporting module
that generates XML reports from the SQL Server 2000 database. Things are
fine and running, but at times I get a fatal SQL Server Exception when I
access reports continuously. That is, this error occurs after I generate a
report and immediately invoke another report. But the same process works
without any problem some other time!
The exception says" Process 55 generated fatal exception c0000005
EXCEPTION_ACCESS_VIOLATION. SQL Server is terminating this process."?

Searching the cause of this bug, I learnt that the fix for this SQL bug is
in SQL Server 2000 Service Pack 1. I installed it, but the error is still
there. I tried service pack 3 also, but of no use. I also tried connecting
to the database by setting "pooling=false" in the connection string so that
every time I go to the database with a new connection. I did this thinking
that it might be a corrupted connection in the pool which is creating the
error, but of no effect.

From the error, I can assess that it's an unmanaged memory violation
exception that is occurring at the server. I also doubt whether it's any
deadlock occurring at the server when the current connection tries to access
the resource occupied by a previously unclosed connection in the database.

I also got one more misleading error in the same context, which says
"General Network Error. Please check your network documentation". I wonder
whether this error is related to the previous bug.
Jul 21 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.