By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,600 Members | 1,214 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,600 IT Pros & Developers. It's quick & easy.

MYSQL max_allowed_packet won't change, can't restore..

P: 1
Hi all,
Could someone please give some insight on the following please?

Screnario: would like to restore a medium database (846MB), what has a lot of BLOB attachments.

During restore, i get the error message that one of this attachments are larger then max_allowed_packet.
The attachment is 10124159 bytes~10Mb.

(i use
Expand|Select|Wrap|Line Numbers
  1. mysql -u root -p -v --max_allowed_packet=1024M -h mydbserver db1 < db1_bak.sql
  2.  
locally in terminal)

My my.cnf is set up with
max_allowed_packet=16M

i tried a couple of things like putting
--max_allowed_packet=1024M into the restore command, set it by set global in mysql prompt, but nothing seems to help.

Restarted the server several times..

One thing i noticed, that after setting the global in mysql prompt the show variables still shows the 16M size.. but it's accepting the set... I don't get it.. i'm in with DBA root, useing the local root user & even sudo...

Can someone help me please?
I'm on MySQL 5.1.37 on a virtualized XUbuntu 9.10 (2 cores AMD 2GB dedicated RAM for the VM, full 16GB on the VM Host)

Thank you, regards.
Daniel
Jun 10 '11 #1
Share this Question
Share on Google+
1 Reply


mwasif
Expert 100+
P: 801
Is max_allowed_packet=16M written under [mysqld] in my.cnf?

Run the following command on mysql prompt and post the out put here
Expand|Select|Wrap|Line Numbers
  1. SHOW VARIABLES LIKE 'max_allowed_packet';
Jun 12 '11 #2

Post your reply

Sign in to post your reply or Sign up for a free account.