By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,257 Members | 928 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,257 IT Pros & Developers. It's quick & easy.

[users@httpd] apache/mysql errors....

P: n/a
Hi...

Update....

We have the following setup in our httpd.conf file. We've tried to give
what's related to the issue. We're trying to set up a virtual host for a
test project. The behavior that we're seeing is that we can type:

http://foo.com but the url that gets displayed is

http://12.x.x.x where 12.x.x.x is the address of the external router

(foo.com is the internal IP of the Internal machine. The machine is behind a
linksys router.)

We're not sure why we're getting the 12.x.x.x from the server/app....
We'd like to have the app display the

The following information is from the httpd.conf file:

Listen 80
..
..
..
ServerName 192.168.1.52
..
..
..
UseCanonicalName on
..
..
..
#
# added the namevirtualhost (b douglas)
#
NameVirtualHost 192.168.1.52
#NameVirtualHost 12.x.x.x:80
# Virtual hosts
#
#bdouglas this was commented out...
# uncomment to test..
<VirtualHost 192.168.1.52>
### ServerAdmin fo*@earthlink.net
DocumentRoot "/var/www/gforge-3.0/www"
# ServerName 192.168.1.52
ServerName gforge.mesa.com
<Directory "/var/www/gforge-3.0/www">
Options Indexes FollowSymLinks
#AllowOverride All Order allow,deny
AllowOverride All
Allow from all
ErrorDocument 404 /404.php
Order allow,deny
DirectoryIndex index.php index.html index.htm index.shtml
</Directory>
</VirtualHost>

Any help/assistance/pointers would be greatly appreciated....

Thanks

Bruce
be*******@earthlink.net


Hi...

A mysql/Apache issue:

I get the following when I'm trying to run a test web site on an Apache
2.0/RH8.0 setup.

--------------------------------
Warning: Access denied for user: 'apache@localhost' (Using password: YES) in
/var/www/html/dbid/mysql/database.php on line 17

Warning: MySQL Connection Failed: Access denied for user: 'apache@localhost'
(Using password: YES) in /var/www/html/dbid/mysql/database.php on line 17
Could not connect: Access denied for user: 'apache@localhost' (Using
password: YES)
---------------------------------

I have added the mysql user/password to the php file. I can access mysql
using the user/password from the linux command line.

However, when I check mysql, I don't have an Apache user defined in the user
table. Do I need to have one defined, or should the php app utilize the
user/passwd/dbname that I provide in the db_connect function?

I can access the phpMyAdmin application with no apparent issues/problems...

A check of google indicates that the issue seems to be related to not having
mysql setup for an Apache user....

As an additional question, if I have a web app that has a mysql db, do I
need to allow Apache to have access to each table that the app uses...?????

Any help/assitance/pointers to resolve this would be greatle appreciated...

Regards,

Bruce
be*******@earthlink.net
(925) 866-2790


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: us***************@httpd.apache.org
" from the digest: us**********************@httpd.apache.org
For additional commands, e-mail: us********@httpd.apache.org
--
MySQL General Mailing List
For list archives: http://lists.mysql.com/mysql
To unsubscribe: http://lists.mysql.com/my***********...ie.nctu.edu.tw

Jul 19 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.