By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,213 Members | 2,172 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,213 IT Pros & Developers. It's quick & easy.

Fw: mysql 4.0.14 + replication + windows XP PROF

P: n/a

No one has replied to my post.

----- Original Message -----
From: "I.P." <ja***********@wp.pl>
To: <my***@lists.mysql.com>
Sent: Monday, August 18, 2003 1:01 PM
Subject: mysql 4.0.14 + replication + windows XP PROF
Hi, it's my story.
I have two 4.0.14 mysql server on one machine with win XP Professional
polish version.

First acts as master: on port 3300
Second acts as slave: on port 3301

below my configuration:

####### FOR MASTER #################
# This will be passed to all mysql clients
[client]
#password=my_password
port=3300
#socket=MySQL

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# The MySQL server
[mysqld]
basedir = c:/mysql4/
datadir = c:/mysql4/data/
port=3300
language=polish
default-character-set=latin2
log-bin
server-id=1
log-warnings

set-variable = key_buffer=16K
set-variable = max_allowed_packet=1M
set-variable = thread_stack=64K
set-variable = table_cache=4
set-variable = sort_buffer=64K
set-variable = net_buffer_length=2K
query_cache_size = 1024K
# Uncomment the following if you are using Innobase tables
innodb_data_file_path = ibdata1:50M
innodb_data_home_dir = d:\\innodb\\mysql4\\master\\ibdata
innodb_log_group_home_dir = d:\\innodb\\mysql4\\master\\iblogs
innodb_log_arch_dir = d:\\innodb\\mysql4\\master\\iblogs

set-variable = innodb_mirrored_log_groups=1
set-variable = innodb_log_files_in_group=3
set-variable = innodb_log_file_size=5M
set-variable = innodb_log_buffer_size=8M
innodb_flush_log_at_trx_commit=1
innodb_log_archive=0
set-variable = innodb_buffer_pool_size=16M
set-variable = innodb_additional_mem_pool_size=2M
set-variable = innodb_file_io_threads=4
set-variable = innodb_lock_wait_timeout=50
[mysqldump]
quick
set-variable = max_allowed_packet=16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
set-variable = key_buffer=8M
set-variable = sort_buffer=8M

[myisamchk]
set-variable = key_buffer=8M
set-variable = sort_buffer=8M

[mysqlhotcopy]
interactive-timeout
###########################
### FOR SLAVE #########
# This will be passed to all mysql clients
[client]
#password=my_password
port=3301
#socket=MySQL

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# The MySQL server
[mysqld]
basedir = c:/mysql4_slave/
datadir = c:/mysql4_slave/data/
port=3301
language=polish
default-character-set=latin2
server-id=2
# log-bin
# log-slave-updates
master-host=127.0.0.1
master-user=irek
master-password=XXXXXXXXXX
master-port=3300
master-connect-retry=30
# log-update=log_updates.log
log-warnings

set-variable = key_buffer=16K
set-variable = max_allowed_packet=1M
set-variable = thread_stack=64K
set-variable = table_cache=4
set-variable = sort_buffer=64K
set-variable = net_buffer_length=2K
query_cache_size = 1024K
# Uncomment the following if you are using Innobase tables

innodb_data_file_path = ibdata1:50M
innodb_data_home_dir = d:\\innodb\\mysql4\\slave\\ibdata
innodb_log_group_home_dir = d:\\innodb\\mysql4\\slave\\iblogs
innodb_log_arch_dir = d:\\innodb\\mysql4\\slave\\iblogs

set-variable = innodb_mirrored_log_groups=1
set-variable = innodb_log_files_in_group=3
set-variable = innodb_log_file_size=5M
set-variable = innodb_log_buffer_size=8M
innodb_flush_log_at_trx_commit=1
innodb_log_archive=0
set-variable = innodb_buffer_pool_size=16M
set-variable = innodb_additional_mem_pool_size=2M
set-variable = innodb_file_io_threads=4
set-variable = innodb_lock_wait_timeout=50
[mysqldump]
quick
set-variable = max_allowed_packet=16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
set-variable = key_buffer=8M
set-variable = sort_buffer=8M

[myisamchk]
set-variable = key_buffer=8M
set-variable = sort_buffer=8M

## END configuration
So i have noticed this things.

I start replication with master and slave:
1)
Master is running ...

---------------------------------------------------
Slave is running ... and at console can i see:

030804 22:55:36 InnoDB: Started
030804 22:55:36 Slave I/O thread: connected to master
'i***@127.0.0.1:3300', r
eplication started in log 'FIRST' at position 4
030804 22:55:36 Slave SQL thread initialized, starting replication in log 'FIRS
T' at position 0, relay log '.\hq-relay-bin.001' position: 4
mysqld-max-nt: ready for connections.
Version: '4.0.14-max-nt' socket: '' port: 3301
---------------------------------------------------

That is ok.

3) checked master data dir:
hq-bin.001
hq-bin.index

4) checked slave data dir:
hq-relay-bin.001
hq-relay-bin.index
master.info
relay-log.info

5) I stopped slave - shutdown nicely.

6) I stopped and started master 3 times.

7) I checked master data dir and i can see:
hq-bin.001
hq-bin.002
hq-bin.003
hq-bin.004
hq-bin.index

8) I started master.

9) master data dir:
hq-bin.001
hq-bin.002
hq-bin.003
hq-bin.004
hq-bin.005
hq-bin.index

10) I started a slave:
030804 23:07:36 InnoDB: Started
030804 23:07:36 Slave I/O thread: connected to master
'i***@127.0.0.1:3300', r
eplication started in log 'hq-bin.001' at position 79
030804 23:07:36 Slave SQL thread initialized, starting replication in log 'hq-b
in.001' at position 79, relay log '.\hq-relay-bin.001' position: 116
mysqld-max-nt: ready for connections.
Version: '4.0.14-max-nt' socket: '' port: 3301
11) I stopped slave (master is still runing):

12) I started slave again:
030804 23:09:17 InnoDB: Started
030804 23:09:17 Slave I/O thread: connected to master
'i***@127.0.0.1:3300', r
eplication started in log 'hq-bin.005' at position 79
030804 23:09:17 Slave SQL thread initialized, starting replication in log 'hq-b
in.005' at position 79, relay log '.\hq-relay-bin.002' position: 489
030804 23:09:17 next log error: -1 offset: 19 log:

030804 23:09:17 Error reading relay log event: Error purging processed

log
030804 23:09:17 Could not parse relay log event entry. The possible

reasons
are
: the master's binary log is corrupted (you can check this by running
'mysqlbinl
og' on the binary log), the slave's relay log is corrupted (you can check this b
y running 'mysqlbinlog' on the relay log), a network problem, or a bug in the ma
ster's or slave's MySQL code. If you want to check the master's binary log or sl
ave's relay log, you will be able to know their names by issuing 'SHOW

SLAVE
STA
TUS' on this slave.
030804 23:09:17 Error running query, slave SQL thread aborted. Fix the
problem,
and restart the slave SQL thread with "SLAVE START". We stopped at log
'hq-bin.
005' position 79
mysqld-max-nt: ready for connections.
Version: '4.0.14-max-nt' socket: '' port: 3301
13) In slave data dir:

hq-relay-bin.003
hq-relay-bin.index
master.info
relay-log.info
THIS IS BUG ???
Now my slave is runnung, but does'nt do a replication.

14) stop slave and running it again.
030804 23:12:00 InnoDB: Started
030804 23:12:00 Failed to open the relay log
(relay_log_name='.\hq-relay-bin.00
2', relay_log_pos=489
030804 23:12:00 Could not find first log during relay log initialization 030804 23:12:00 Failed to initialize the master info structure
mysqld-max-nt: ready for connections.
Version: '4.0.14-max-nt' socket: '' port: 3301

Right, in slave data dir isn't that file, it is deleted by mysql server

wich
is running as slave, WHY ??

IS that BUG, what should i do ?

LOAD DATA FROM MASTER ?? or sync again slave tables with master tables ??

Best regards, irek
--
MySQL General Mailing List
For list archives: http://lists.mysql.com/mysql
To unsubscribe: http://lists.mysql.com/mysql?unsub=ja***********@wp.pl

--
MySQL General Mailing List
For list archives: http://lists.mysql.com/mysql
To unsubscribe: http://lists.mysql.com/my***********...ie.nctu.edu.tw

Jul 19 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.