By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,199 Members | 1,551 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,199 IT Pros & Developers. It's quick & easy.

AW: I Specify explicitly TYPE = InnoDB But My SQL gives me TYPE=MyISAM ?

P: n/a
Dear Fred,

according to what I experience,=20
I do definitely run the default binaries, perhaps the daemon mysqld
has to be started with an option in order to support InnoDB ?

How can this be investigated ?

C:\mysql\bin>mysqld -v
mysqld Ver 3.23.55-max-debug for Win95/Win98 on i32

C:\mysql\bin>mysql -v
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 264 to server version: 3.23.55-nt

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql>=20

C:\mysql\bin>ver

Microsoft Windows 2000 [Version 5.00.2195]
This seems fine to me, I believe I have the default binaries.=20

If InnoDB is not supported in MySQL, then I would have expected a
warning,
Or an error message.

As we all can see, no warning or error is issued, =20
perhaps another error level can give me more feedback ?
Yours Sincerely

Morten Gulbrandsen
-----Urspr=FCngliche Nachricht-----
Von: Fred van Engen [mailto:fr************@xbn.nl]=20
TYPE =3D InnoDB only works if MySQL is compiled with InnoDB support,
which is the default in binaries from MySQL. If you compile it yourself
you need to configure --with-innodb .

Regards,

Fred.

--=20
Fred van Engen XB Networks B.V.
email: fr************@xbn.nl Televisieweg 2
tel: +31 36 5462400 1322 AC Almere
fax: +31 36 5462424 The Netherlands

--=20
MySQL General Mailing List
For list archives: http://lists.mysql.com/mysql
To unsubscribe: =
http://lists.mysql.com/my***************@owi-aachen.de
--
MySQL General Mailing List
For list archives: http://lists.mysql.com/mysql
To unsubscribe: http://lists.mysql.com/my***********...ie.nctu.edu.tw

Jul 19 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.