468,290 Members | 1,954 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,290 developers. It's quick & easy.

MySQL client crashes with segmentation fault on Red Hat Linux Enterprise IA64

Hi all,

I don't know what I'm missing here, but if anyone could help me out I'd
really appreciate it. Basically, everything is fine, compiles,
installs, server runs, but the interactive mysql client breaks.

I have an IA64 Red Hat Linux Enterprise Edition system and I tried to
install the binaries recommended on MySQL. However, when I run the
mysql client, I get simply:

Segmentation fault.

So I tried to do a basic source compile, which went fine, but when I
run mysql client, I get this:

Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 2 to server version: 4.1.12

Segmentation fault

When I try the flags recommended by MySQL
(--with-extra-charsets=complex among others), the make test fails on
ucs_binlog - something to do with charsets I believe?

The mysql user, group etc. are all set up. Strangely, the mysql client
works in batch mode so if you make a file that reads:
SHOW DATABASES;

Then type:
mysql < commandfile

It'll display
Database
mysql
test

Without any faults....

Anyone any ideas or suggestions?

Thanks very much,
John

Aug 6 '05 #1
0 1342

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by sivignon | last post: by
1 post views Thread by marko | last post: by
reply views Thread by Robert Mazur | last post: by
6 posts views Thread by songfire | last post: by
reply views Thread by nickyxu | last post: by
reply views Thread by NPC403 | last post: by
2 posts views Thread by MrBee | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.