469,935 Members | 2,232 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,935 developers. It's quick & easy.

error with javascript - please help

For some reason I am unable to access documents in Javascript.

eg - tried to register on a site, and when clicked on register, blank
screen came up with this address:

"javascript:submit_form('toregister_form')"

and "done" in bottom left hand corner.

Not being very technical minded - anybody know what I have done wrong,
or is there someting I need to download.

Many thanks,

Pat Mahoney
Jul 20 '05 #1
8 1329
In article <2e*************************@posting.google.com> ,
pa********@btinternet.com enlightened us with...
For some reason I am unable to access documents in Javascript.

eg - tried to register on a site, and when clicked on register, blank
screen came up with this address:

"javascript:submit_form('toregister_form')"

and "done" in bottom left hand corner.

Not being very technical minded - anybody know what I have done wrong,
or is there someting I need to download.


What browser?

--
--
~kaeli~
Jesus saves, Allah protects, and Cthulhu thinks you'd make
a nice sandwich.
http://www.ipwebdesign.net/wildAtHeart
http://www.ipwebdesign.net/kaelisSpace

Jul 20 '05 #2
microsoft internet explorer is my browser

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 20 '05 #3
In article <40***********************@news.frii.net>,
oa********@btinternet.com enlightened us with...
microsoft internet explorer is my browser


What version? Service Pack?
Help->About Internet Explorer
I use 6.0.28 SP1

If you're using anything under 5.5, upgrade if possible.

Check for errors in the site's script by looking at the lower left hand
corner of the window for a little yellow exclamation point. If you see
that, it's the site that has the problem, not your browser. Click on the
exclamation point for a detailed error message.
By default, IE will NOT show errors, IIRC. It just stops processing and
shows the yellow bang.

If no error exists in the page's code, save the following as test.html
somewhere in my documents or something.

----------
<html>
<head>
<title> New Document </title>
</head>

<body>
<a href="javascript:alert('hi'); return false;">say hi</a>
</body>
</html>
------------

Open that in IE with File->Open and click on the link.
Did it work?
If it doesn't alert a 'hi', you might have script disabled. If it does,
you might have your security settings too high and other sites can't run
script.

We'd have to further debug from there.

--
--
~kaeli~
Those who jump off a bridge in Paris... are in Seine.
http://www.ipwebdesign.net/wildAtHeart
http://www.ipwebdesign.net/kaelisSpace

Jul 20 '05 #4
Thanks for help so far - I copied your message and saved it as
test.html - tried to open it in Internet Explorer, but could not find
the link.

Pat

kaeli <ti******@NOSPAM.comcast.net> wrote in message news:<MP************************@nntp.lucent.com>. ..
In article <40***********************@news.frii.net>,
oa********@btinternet.com enlightened us with...
microsoft internet explorer is my browser


What version? Service Pack?
Help->About Internet Explorer
I use 6.0.28 SP1

If you're using anything under 5.5, upgrade if possible.

Check for errors in the site's script by looking at the lower left hand
corner of the window for a little yellow exclamation point. If you see
that, it's the site that has the problem, not your browser. Click on the
exclamation point for a detailed error message.
By default, IE will NOT show errors, IIRC. It just stops processing and
shows the yellow bang.

If no error exists in the page's code, save the following as test.html
somewhere in my documents or something.

----------
<html>
<head>
<title> New Document </title>
</head>

<body>
<a href="javascript:alert('hi'); return false;">say hi</a>
</body>
</html>
------------

Open that in IE with File->Open and click on the link.
Did it work?
If it doesn't alert a 'hi', you might have script disabled. If it does,
you might have your security settings too high and other sites can't run
script.

We'd have to further debug from there.

--

Jul 20 '05 #5
In article <2e**************************@posting.google.com >,
pa********@btinternet.com enlightened us with...
Thanks for help so far - I copied your message and saved it as
test.html - tried to open it in Internet Explorer, but could not find
the link.


I'm an idiot. :)

One more try.

<html>
<head>
<title> New Document </title>
</head>
<body bgcolor="white">
<p>
<font color="black">
<font size="3">
<a href="javascript:alert('hi');">say hi</a>
</font>
</font>
</p>
</body>
</html>

(oh, if your browser were set to show errors, you'd have seen my error
immediately at the return statement)

--
--
~kaeli~
Dijon vu - the same mustard as before.
http://www.ipwebdesign.net/wildAtHeart
http://www.ipwebdesign.net/kaelisSpace

Jul 20 '05 #6
Still no luc - openedd link and it just opened as a web page.

Any suggestions??

Pat

kaeli <ti******@NOSPAM.comcast.net> wrote in message news:<MP************************@nntp.lucent.com>. ..
In article <2e**************************@posting.google.com >,
pa********@btinternet.com enlightened us with...
Thanks for help so far - I copied your message and saved it as
test.html - tried to open it in Internet Explorer, but could not find
the link.


I'm an idiot. :)

One more try.

<html>
<head>
<title> New Document </title>
</head>
<body bgcolor="white">
<p>
<font color="black">
<font size="3">
<a href="javascript:alert('hi');">say hi</a>
</font>
</font>
</p>
</body>
</html>

(oh, if your browser were set to show errors, you'd have seen my error
immediately at the return statement)

--

Jul 20 '05 #7
In article <2e**************************@posting.google.com >,
pa********@btinternet.com enlightened us with...
Still no luc - openedd link and it just opened as a web page.

Any suggestions??


Well, we now know it is your browser having issues and not that site.
So, next thing is to check your settings.

I use IE6, and the settings are in a different spot for some stuff than
5, so let me know if you can't find this.
Anyways, go to Tools->Internet Options and click on the Security Tab.
If Internet (the little globe) isn't highlighted, click on it to
highlight it.
Check to be sure the setting is NOT at high.
If the setting is on Custom, click the custom button to show the
settings.
Scroll down to Scripting
Make sure Active Scripting is enabled.

Let me know if that fixes it.

Also, you're not using Windows 98 or below with IE6, are you? They
aren't compatible.

If you have IE5/6 with Win2000 or XP:
Did you try repairing IE?
Open the Control Panel's Add/Remove Programs, click MS Internet
Explorer to highlight, click the Add/Remove button, select Repair IE.

Another suggestion for Win2K/XP: reinstall WScriptHost.
http://members.aol.com/pattyoh105/vb_wsh_a.htm
--
--
~kaeli~
Press any key...NO, NO, NO, NOT THAT ONE!!!!!!
http://www.ipwebdesign.net/wildAtHeart
http://www.ipwebdesign.net/kaelisSpace

Jul 20 '05 #8
Thanks for your help so far, but I am afraid not having any luck!

"Active scripting" is enabled but not making any difference!

Anything else I can do??

Pat

kaeli <ti******@NOSPAM.comcast.net> wrote in message news:<MP************************@nntp.lucent.com>. ..
In article <2e**************************@posting.google.com >,
pa********@btinternet.com enlightened us with...
Still no luc - openedd link and it just opened as a web page.

Any suggestions??


Well, we now know it is your browser having issues and not that site.
So, next thing is to check your settings.

I use IE6, and the settings are in a different spot for some stuff than
5, so let me know if you can't find this.
Anyways, go to Tools->Internet Options and click on the Security Tab.
If Internet (the little globe) isn't highlighted, click on it to
highlight it.
Check to be sure the setting is NOT at high.
If the setting is on Custom, click the custom button to show the
settings.
Scroll down to Scripting
Make sure Active Scripting is enabled.

Let me know if that fixes it.

Also, you're not using Windows 98 or below with IE6, are you? They
aren't compatible.

If you have IE5/6 with Win2000 or XP:
Did you try repairing IE?
Open the Control Panel's Add/Remove Programs, click MS Internet
Explorer to highlight, click the Add/Remove button, select Repair IE.

Another suggestion for Win2K/XP: reinstall WScriptHost.
http://members.aol.com/pattyoh105/vb_wsh_a.htm
--

Jul 20 '05 #9

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by TeknoCat | last post: by
2 posts views Thread by New guy.. please help | last post: by
9 posts views Thread by VancouverMike | last post: by
1 post views Thread by JumpingOffPlace | last post: by
6 posts views Thread by shror | last post: by
8 posts views Thread by =?Utf-8?B?Q2hyaXMgSGFsY3Jvdw==?= | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.