By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,818 Members | 2,089 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,818 IT Pros & Developers. It's quick & easy.

Include virtual

P: n/a
Hejsa,
Har "arvet" et website jeg skal have "oversat" til .NET

I øjeblikket er det "almindelige" .asp sider, som jeg ikke har prøvet før.

I c:\test\kims\www\eval\default.asp er følgende linier:
<!--#include file="Connections/Conneval.asp" -->
..
..
..
<!--#include virtual="eval\uTop.asp" -->
..
..

Den kommer så med;
Inkluderingsfilen 'eval\uTop.asp' blev ikke fundet.
/evaluator/eval/Default.asp, line 49

Der findes en fil der hedder
c:\test\kims\www\eval\uTop.asp
Har jeg oprettet min Virtuelle mappe forkert i IIS ?

mvh
/jim
Jul 20 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
<!--#include virtual="\eval\uTop.asp" -->

I think is your answer.

As it's virtual you need to put in \ (i.e from the root of the site).

Stu

"Jim Andersen" <jimVÆÆK@officeconsult.dk> wrote in message
news:bq**********@sunsite.dk...
Hejsa,
Har "arvet" et website jeg skal have "oversat" til .NET

I øjeblikket er det "almindelige" .asp sider, som jeg ikke har prøvet før.

I c:\test\kims\www\eval\default.asp er følgende linier:
<!--#include file="Connections/Conneval.asp" -->
.
.
.
<!--#include virtual="eval\uTop.asp" -->
.
.

Den kommer så med;
Inkluderingsfilen 'eval\uTop.asp' blev ikke fundet.
/evaluator/eval/Default.asp, line 49

Der findes en fil der hedder
c:\test\kims\www\eval\uTop.asp
Har jeg oprettet min Virtuelle mappe forkert i IIS ?

mvh
/jim

Jul 20 '05 #2

P: n/a
Oh Damn, did I write it in Danish ? :-)

I'll just translate.....

I have "inherited" a (to my knowledge) working application and am going to
convert it to .NET, as I have never written .asp applications.

But you are saying that this could never have worked, without the "\" in
front ?

The examples I've seen suggests you are right....

/jim
Stuart Palmer wrote:
<!--#include virtual="\eval\uTop.asp" -->

I think is your answer.

As it's virtual you need to put in \ (i.e from the root of the site).

Stu

"Jim Andersen" <jimVÆÆK@officeconsult.dk> wrote in message
news:bq**********@sunsite.dk...
Hejsa,
Har "arvet" et website jeg skal have "oversat" til .NET

I øjeblikket er det "almindelige" .asp sider, som jeg ikke har
prøvet før.

I c:\test\kims\www\eval\default.asp er følgende linier:
<!--#include file="Connections/Conneval.asp" -->
.
.
.
<!--#include virtual="eval\uTop.asp" -->
.
.

Den kommer så med;
Inkluderingsfilen 'eval\uTop.asp' blev ikke fundet.
/evaluator/eval/Default.asp, line 49

Der findes en fil der hedder
c:\test\kims\www\eval\uTop.asp
Har jeg oprettet min Virtuelle mappe forkert i IIS ?

mvh
/jim

Jul 20 '05 #3

P: n/a
Hello

Just to clear this up

#include file means you put in a relative path

#include virtual requires the path from the root of the application

e.g.
using

www.site.com/area/file.asp

To include a file which is in

www.site.com/area/includes/

either
<!--#include file="includes/incfile.asp"-->
or
<!--#include virtual="/area/includes/incfile.asp"-->
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 20 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.