471,872 Members | 1,466 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,872 software developers and data experts.

Script works without errors in FF, but not in IE7

HansHenrik
Hey.
I'm new to this forum, and a totally javascript n00b.

My "problem" is: when I run a script in Firefox everything is A OK, but when I run it in IE7.... it runs, but tells me there's an error. It's something with NULL or not an object.

I've borrowed the script from Dynamic Drive

I've copied the code and made it an external js file to this site:
CPH Locations

The javascript can be found here.

Why does IE give me an "Done, but with errors on page." when everything seems brilliant in the Firefox DOM inspector?
Mar 28 '07 #1
4 1122
acoder
16,027 Expert Mod 8TB
Welcome to TSDN.

You're calling imageblend.js more than once. If you look at the dynamic drive page, you put the first part in the header and the second part in the body, so you need to split up your code and do exactly as instructed on the DD site.
Mar 29 '07 #2
Thx for your response.

When saying I have to do exactly like DD's instructions, does that mean I can't make the script as an external script?
Mar 29 '07 #3
The reason I'm asking is because I'm currently doing some SEO service on the site, and I really do not want a massive script in the header.
Mar 29 '07 #4
Got it know - the solution was this

Thank you for your help.
Mar 30 '07 #5

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

14 posts views Thread by Mario | last post: by
28 posts views Thread by Randy Starkey | last post: by
3 posts views Thread by niconedz | last post: by
3 posts views Thread by comzy | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.