469,578 Members | 1,810 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,578 developers. It's quick & easy.

Permission Denied

Someone suggested I post this here. Nobody in the ASP forums had an answer

I'm getting this error while trying to rename a file on my webserver

Microsoft VBScript runtime error '800a0046'

Permission denied

/pictures/testy.asp, line 11

Now I've gone and checked the permissions on the folder through the limited web utility my hosting service provides me and I've given the folder all possible permissions.

I had a page that would upload a file and then rename it to the email address of the user that uploaded it (for uniqueness). It worked fine, then while working on a newer version of my site (setting up new folders) I get this error while trying to exercise anything requiring modify rights as an anonymous user (move, rename). Nothing on the original page changed, but once I reset all the permissions from the root even the original page errors out now. Just to double check I made a simple script so I could completely eliminate it as a problem.

Code: ( text )

1.
<%
2.

3.
dim fs
4.
set fs=Server.CreateObject("Scripting.FileSystemObject ")
5.

6.

7.

8.
path3 = Server.MapPath("sample3.txt")
9.
path4 = Server.MapPath("sample.txt")
10.

11.
fs.MoveFile path4,path3
12.

13.

14.

15.
set fs=nothing
16.

17.
%>



I'm using godaddy as my host and they keep insisting its not a permissions problem and that everything is set right. Have you guys ever had a similar problem and how did it get fixed?
Jan 9 '08 #1
2 3519
kenobewan
4,871 Expert 4TB
If the account permissions and folder permissions are ok, then it is usually that the file still being used by another process. However I believe there may be serious security implications of allowing anonymous user to do such an operation.

There can be a downside to third party, you often have to prove the problem is theirs. Maybe you should have one who has a better management console without risking their own security. Don't get me wrong I am a huge fan of third party hosting.

Which OS are you using? This article may help:
Could I get some help working with files using FileSystemObject?
Jan 10 '08 #2
Thanks for the reply. The problem ended up being with godaddy (of course). When they switched to the new UI apparently the "write" permission on the UI was supposed to give modify permissions also so it must of been screwed up for everyone. Totally lame, but at least it works now.
Jan 18 '08 #3

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

6 posts views Thread by Jon Montana | last post: by
1 post views Thread by Mark E. Hamilton | last post: by
2 posts views Thread by Taishi | last post: by
reply views Thread by private.anders | last post: by
reply views Thread by private.anders | last post: by
4 posts views Thread by xzzy | last post: by
4 posts views Thread by guiromero | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.