By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
458,125 Members | 1,524 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 458,125 IT Pros & Developers. It's quick & easy.

Permission denied error 2nd Post

P: n/a
New user of SQL
Everything is on the same machine
My error is close to the bottom
After reading it today, I can see there is a problem with 2 dbases
'PUBS' and 'Master'
There are also some comments from the group:
---microsoft.public.sqlserver.odbc-- subject: Permission Denied -- Thanks
for help guys

I was able to find a trial version of the Enterprise Manager.

It was suggested to make the post over in dotnet.framework. I am new to
SQL. I can see the following in the MSDE manager:

sql server(my machine name\??SDK)
after I right click on 'PUBS'
---Users/Roles/Public
---public
---machine_name\aspnet
---guest

guest is the only one with 5 check marks going across from left to right for
the following:
Create Table, Create View, Create SP, Create Default, Create Rule

the following 3 are blank:
Create Function, Backup DB, and Backup Log

public has just 1 check mark on
Create SP

machine_name\aspnet is blank from left to right.

CREATE DBASE right is not displayed.

How can I solve my Permission denied error problem?

Thanks for the help,
Taishi



---Comments---
Hi Tashi!

You can ue Enterprise manager to set the rights. Locate the table, and right
click. Select All Tasks, then Manage Permissions. Locate the user that you
are using in your connection object, and then grant the rights. I agree with
Greg that the web user should not normally have that level of permission.
One false move and your server and data could be toast. If you are really
trying to create a table, or attach a database, you should be doing that
through Enterprise Manager, and not the web interface.

Sloan

"Taishi" <ta********@hotmail.com> wrote in message
news:u5**************@TK2MSFTNGP12.phx.gbl...
How can I check the permissions/rights?

How can I grant the correct permissions/rights?

Thanks,
T

"Greg Obleshchuk" <gr***************@ag-s-o-f-t-w-a-r-e.com> wrote in
message news:ud**************@TK2MSFTNGP10.phx.gbl...
Hello,
What are you trying to do here? Can you post the commands

To create databases you need system administrator rights and dbcreator

Permissions (from BOL)
CREATE DATABASE permission defaults to members of the sysadmin and dbcreator
fixed server roles. Members of the sysadmin and securityadmin fixed server
roles can grant CREATE DATABASE permissions to other logins. Members of

the
sysadmin and dbcreator fixed server role can add other logins to the
dbcreator role. The CREATE DATABASE permission must be explicitly granted; it is not granted by the GRANT ALL statement.

CREATE DATABASE permission is usually limited to a few logins to maintain control over disk usage on an instance of SQL Server.

I wouldn't suggest granting the owner of a .NET IIS app either of these
rights
--
I hope this helps
regards
Greg O MCSD
http://www.ag-software.com/ags_scribe_index.aspx. SQL Scribe

Documentation
Builder, the quickest way to document your database
http://www.ag-software.com/ags_SSEPE_index.aspx. AGS SQL Server Extended Property Extended properties manager for SQL 2000
http://www.ag-software.com/IconExtractionProgram.aspx. Free icon

extraction
program
http://www.ag-software.com. Free programming tools


"Taishi" <ta********@hotmail.com> wrote in message
news:eJ*************@TK2MSFTNGP12.phx.gbl...
Windows Pro
VS.Net
.Net Framework
ASP.NET
My 1st time using Web Forms in .Net
1st time using SQL
I am receiving the following error:

System.Data.SqlClient.SqlException: CREATE DATABASE permission denied in database 'master'. Could not attach database 'pubs' to file 'D:\Program Files\Microsoft SQL Server\MSSQL$NETSDK\Data\pubs.mdf'.

I tried the following:

Reboot 4-5 times
Share the folder
Web share the folder

Here is some advanced help from another SQL forum.
sp_helpsrvrolemember 'sysadmin' ----> command is not on my box.
isql /usa/p/server\sdk -i\instpubs.sql ----> did not work. isql is

not a command found on my box.
Any ideas?

Thanks for your help,
T



Nov 18 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
You might want to investigate this open source solution:
"ASP Enterprise Manager is a web-based interface for Microsoft SQL Server
and MSDE written using ASP.Net, VB.Net and C#.Net. This project was
developed to allow many SQL Server and MSDE design and administration tasks
to be performed from any computer with a web browser. "

http://www.aspenterprisemanager.com/

http://sourceforge.net/projects/asp-ent-man/
"Taishi" <ta********@hotmail.com> wrote in message
news:ed**************@tk2msftngp13.phx.gbl...
New user of SQL
Everything is on the same machine
My error is close to the bottom
After reading it today, I can see there is a problem with 2 dbases
'PUBS' and 'Master'
There are also some comments from the group:
---microsoft.public.sqlserver.odbc-- subject: Permission Denied -- Thanks
for help guys

I was able to find a trial version of the Enterprise Manager.

It was suggested to make the post over in dotnet.framework. I am new to
SQL. I can see the following in the MSDE manager:

sql server(my machine name\??SDK)
after I right click on 'PUBS'
---Users/Roles/Public
---public
---machine_name\aspnet
---guest

guest is the only one with 5 check marks going across from left to right
for
the following:
Create Table, Create View, Create SP, Create Default, Create Rule

the following 3 are blank:
Create Function, Backup DB, and Backup Log

public has just 1 check mark on
Create SP

machine_name\aspnet is blank from left to right.

CREATE DBASE right is not displayed.

How can I solve my Permission denied error problem?

Thanks for the help,
Taishi



---Comments---
Hi Tashi!

You can ue Enterprise manager to set the rights. Locate the table, and
right
click. Select All Tasks, then Manage Permissions. Locate the user that you
are using in your connection object, and then grant the rights. I agree
with
Greg that the web user should not normally have that level of permission.
One false move and your server and data could be toast. If you are really
trying to create a table, or attach a database, you should be doing that
through Enterprise Manager, and not the web interface.

Sloan

"Taishi" <ta********@hotmail.com> wrote in message
news:u5**************@TK2MSFTNGP12.phx.gbl...
How can I check the permissions/rights?

How can I grant the correct permissions/rights?

Thanks,
T

"Greg Obleshchuk" <gr***************@ag-s-o-f-t-w-a-r-e.com> wrote in
message news:ud**************@TK2MSFTNGP10.phx.gbl...
> Hello,
> What are you trying to do here? Can you post the commands
>
> To create databases you need system administrator rights and dbcreator
>
> Permissions (from BOL)
> CREATE DATABASE permission defaults to members of the sysadmin and

dbcreator
> fixed server roles. Members of the sysadmin and securityadmin fixed server > roles can grant CREATE DATABASE permissions to other logins. Members of

the
> sysadmin and dbcreator fixed server role can add other logins to the
> dbcreator role. The CREATE DATABASE permission must be explicitly granted; > it is not granted by the GRANT ALL statement.
>
> CREATE DATABASE permission is usually limited to a few logins to maintain > control over disk usage on an instance of SQL Server.
>
> I wouldn't suggest granting the owner of a .NET IIS app either of these
> rights
>
>
> --
> I hope this helps
> regards
> Greg O MCSD
> http://www.ag-software.com/ags_scribe_index.aspx. SQL Scribe

Documentation
> Builder, the quickest way to document your database
> http://www.ag-software.com/ags_SSEPE_index.aspx. AGS SQL Server Extended > Property Extended properties manager for SQL 2000
> http://www.ag-software.com/IconExtractionProgram.aspx. Free icon

extraction
> program
> http://www.ag-software.com. Free programming tools
>
>
>
>
> "Taishi" <ta********@hotmail.com> wrote in message
> news:eJ*************@TK2MSFTNGP12.phx.gbl...
> > Windows Pro
> > VS.Net
> > .Net Framework
> > ASP.NET
> > My 1st time using Web Forms in .Net
> > 1st time using SQL
> > I am receiving the following error:
> >
> > System.Data.SqlClient.SqlException: CREATE DATABASE permission denied in > > database 'master'. Could not attach database 'pubs' to file 'D:\Program > > Files\Microsoft SQL Server\MSSQL$NETSDK\Data\pubs.mdf'.
> >
> > I tried the following:
> >
> > Reboot 4-5 times
> > Share the folder
> > Web share the folder
> >
> > Here is some advanced help from another SQL forum.
> > sp_helpsrvrolemember 'sysadmin' ----> command is not on my box.
> > isql /usa/p/server\sdk -i\instpubs.sql ----> did not work. isql is

not
a
> > command found on my box.
> >
> >
> > Any ideas?
> >
> > Thanks for your help,
> > T
> >
> >
>
>




Nov 18 '05 #2

P: n/a
Hello! Ken:

I posted that website on my other posting(Permission Denied). I will do
some more research and investigating but you told me that I had to install
it on a ASP.net web server???? I am a uninitiated, so I'm trying to grasp
the concept.

Hi Tashi!

You'll have to install it on a local ASP.net web server, and then use your
browser to go to the site.

Sloan

Taishi
"Ken Cox [Microsoft MVP]" <BA************@sympatico.ca> wrote in message
news:u2**************@TK2MSFTNGP11.phx.gbl...
You might want to investigate this open source solution:
"ASP Enterprise Manager is a web-based interface for Microsoft SQL Server
and MSDE written using ASP.Net, VB.Net and C#.Net. This project was
developed to allow many SQL Server and MSDE design and administration tasks to be performed from any computer with a web browser. "

http://www.aspenterprisemanager.com/

http://sourceforge.net/projects/asp-ent-man/
"Taishi" <ta********@hotmail.com> wrote in message
news:ed**************@tk2msftngp13.phx.gbl...
New user of SQL
Everything is on the same machine
My error is close to the bottom
After reading it today, I can see there is a problem with 2 dbases
'PUBS' and 'Master'
There are also some comments from the group:
---microsoft.public.sqlserver.odbc-- subject: Permission Denied -- Thanks for help guys

I was able to find a trial version of the Enterprise Manager.

It was suggested to make the post over in dotnet.framework. I am new to
SQL. I can see the following in the MSDE manager:

sql server(my machine name\??SDK)
after I right click on 'PUBS'
---Users/Roles/Public
---public
---machine_name\aspnet
---guest

guest is the only one with 5 check marks going across from left to right
for
the following:
Create Table, Create View, Create SP, Create Default, Create Rule

the following 3 are blank:
Create Function, Backup DB, and Backup Log

public has just 1 check mark on
Create SP

machine_name\aspnet is blank from left to right.

CREATE DBASE right is not displayed.

How can I solve my Permission denied error problem?

Thanks for the help,
Taishi



---Comments---
Hi Tashi!

You can ue Enterprise manager to set the rights. Locate the table, and
right
click. Select All Tasks, then Manage Permissions. Locate the user that you are using in your connection object, and then grant the rights. I agree
with
Greg that the web user should not normally have that level of permission. One false move and your server and data could be toast. If you are really trying to create a table, or attach a database, you should be doing that
through Enterprise Manager, and not the web interface.

Sloan

"Taishi" <ta********@hotmail.com> wrote in message
news:u5**************@TK2MSFTNGP12.phx.gbl...
How can I check the permissions/rights?

How can I grant the correct permissions/rights?

Thanks,
T

"Greg Obleshchuk" <gr***************@ag-s-o-f-t-w-a-r-e.com> wrote in
message news:ud**************@TK2MSFTNGP10.phx.gbl...
> Hello,
> What are you trying to do here? Can you post the commands
>
> To create databases you need system administrator rights and dbcreator >
> Permissions (from BOL)
> CREATE DATABASE permission defaults to members of the sysadmin and
dbcreator
> fixed server roles. Members of the sysadmin and securityadmin fixed

server
> roles can grant CREATE DATABASE permissions to other logins. Members of the
> sysadmin and dbcreator fixed server role can add other logins to the
> dbcreator role. The CREATE DATABASE permission must be explicitly

granted;
> it is not granted by the GRANT ALL statement.
>
> CREATE DATABASE permission is usually limited to a few logins to

maintain
> control over disk usage on an instance of SQL Server.
>
> I wouldn't suggest granting the owner of a .NET IIS app either of these > rights
>
>
> --
> I hope this helps
> regards
> Greg O MCSD
> http://www.ag-software.com/ags_scribe_index.aspx. SQL Scribe
Documentation
> Builder, the quickest way to document your database
> http://www.ag-software.com/ags_SSEPE_index.aspx. AGS SQL Server

Extended
> Property Extended properties manager for SQL 2000
> http://www.ag-software.com/IconExtractionProgram.aspx. Free icon
extraction
> program
> http://www.ag-software.com. Free programming tools
>
>
>
>
> "Taishi" <ta********@hotmail.com> wrote in message
> news:eJ*************@TK2MSFTNGP12.phx.gbl...
> > Windows Pro
> > VS.Net
> > .Net Framework
> > ASP.NET
> > My 1st time using Web Forms in .Net
> > 1st time using SQL
> > I am receiving the following error:
> >
> > System.Data.SqlClient.SqlException: CREATE DATABASE permission
denied in
> > database 'master'. Could not attach database 'pubs' to file

'D:\Program
> > Files\Microsoft SQL Server\MSSQL$NETSDK\Data\pubs.mdf'.
> >
> > I tried the following:
> >
> > Reboot 4-5 times
> > Share the folder
> > Web share the folder
> >
> > Here is some advanced help from another SQL forum.
> > sp_helpsrvrolemember 'sysadmin' ----> command is not on my box.
> > isql /usa/p/server\sdk -i\instpubs.sql ----> did not work. isql is

not
a
> > command found on my box.
> >
> >
> > Any ideas?
> >
> > Thanks for your help,
> > T
> >
> >
>
>


Nov 18 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.