473,888 Members | 1,434 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

valgrind error - "failed to start tool 'memcheck' for platform x86-linux" no such fil

365 Contributor
valgrind error - "failed to start tool 'memcheck' for platform x86-linux" no such file or dir

copied all lib and bin files which are generated after I compiled valgrind package, when I run my exe with valgrind, I am getting above error, any idea?

lib/
-rw-r--r-- 1 0 0 27934 default.supp
-rwxr-xr-x 1 0 0 4636305 cachegrind-x86-linux
-rwxr-xr-x 1 0 0 4891451 callgrind-x86-linux
-rwxr-xr-x 1 0 0 4857510 drd-x86-linux
-rwxr-xr-x 1 0 0 4519362 exp-bbv-x86-linux
-rwxr-xr-x 1 0 0 4729657 exp-ptrcheck-x86-linux
-rwxr-xr-x 1 0 0 4837460 helgrind-x86-linux
-rwxr-xr-x 1 0 0 4529944 lackey-x86-linux
-rwxr-xr-x 1 0 0 4568883 massif-x86-linux
-rwxr-xr-x 1 0 0 5040139 memcheck-x86-linux
-rwxr-xr-x 1 0 0 4509675 none-x86-linux
-rwxr-xr-x 1 0 0 72136 vgpreload_memch eck-x86-linux.so
-rwxr-xr-x 1 0 0 37223 vgpreload_massi f-x86-linux.so
-rwxr-xr-x 1 0 0 107935 vgpreload_helgr ind-x86-linux.so
-rwxr-xr-x 1 0 0 45354 vgpreload_exp-ptrcheck-x86-linux.so
-rwxr-xr-x 1 0 0 170657 vgpreload_drd-x86-linux.so
-rwxr-xr-x 1 0 0 6765 vgpreload_core-x86-linux.so
#

bin/
rwxr-xr-x 1 0 0 40959 callgrind_annot ate
-rwxr-xr-x 1 0 0 13662 callgrind_contr ol
-rwxr-xr-x 1 0 0 32064 cg_annotate
-rwxr-xr-x 1 0 0 42942 cg_merge
-rwxr-xr-x 1 0 0 24211 ms_print
-rwxr-xr-x 1 0 0 8531 no_op_client_fo r_valgrind
-rwxr-xr-x 1 0 0 30823 valgrind
-rwxr-xr-x 1 0 0 18887 valgrind-listener
Jan 15 '10 #1
2 9608
tvnaidu
365 Contributor
if I run the same executable on x86 LINUX machine, it works, my target also x86 based embedded board, there it cannot fine memcheck file, eventhough the file exists in same directory.
Jan 15 '10 #2
tvnaidu
365 Contributor
I tried to use ldd on my embedded target, I copied ldd, but it doesn't show anything.
Jan 15 '10 #3

Sign in to post your reply or Sign up for a free account.

Similar topics

1
2223
by: gcash | last post by:
I'm doing stuff using COM to automate IE, for some boring repetitive portal tasks I have to do. Anyway, every so often I'll make some sort of error and things will crash, and I'll have to do something like using task manager to kill Python and/or the IE instance. Then I'll reload pythonwin and get "LoadBarState failed due to win32 exception" and once I get this pythonwin will no longer work. It'll get all sorts of errors, the drop...
0
2033
by: Bill Davy | last post by:
I am building a C++ program (main.exe) with VC6 which expects to call the Python DLL. When I start it (under the debugger), I get: "This application has failed to start because python24_d.dll was not found. Re-installing the application may fix this problem." I built Python24_d.dll using VS.NET 2003 (which I bought specifically for that purpose but cannot use for our project, boo hoo). I am building a debug version of main.exe which...
0
2202
by: camaro77 majau via DotNetMonster.com | last post by:
Sorry by my english but i'm from spain. I have a problem and after search by the web i have know that is due by framework. The message is : setup error "failed to load ressouces from resource file please check your setup" It only appears when i'm using a p2p program called elephant,who needs framework to run.some month ago I instaled for first time elephant and framework,but i don't remember whar version of framework i had
2
14955
by: Steve M | last post by:
A few users today received the message "The trust relationship between this workstation and the primary domain failed" on their web browser while using an ASP.NET web app. The problem went away but has anyone seen this before on a error page? I think it occured when users were reporting general slow web performance. I've seen it while users try to log into an NT domain from their desktops but not while using a web browser. Users can log...
1
1916
by: Roy | last post by:
Hey all, I have a VB App which uses the bundled version of Crystal Reports for VS.NET 2003. It works fine in when I run it using VS *but* when I deploy it anywhere (including the development PC itself) it won't load a report and displays the cryptic "Load Report Failed" error. It's frustrating. Why would it work great on my machine using the VS "Start" option, but fail to work when I try to run it as an executable?
3
11764
by: Dean Slindee | last post by:
The code below is being used to launch WinWord.exe from a VB.NET program. Word launches, but displays this error message: "Word has experienced an error trying to open the file. Try these suggestions. 1) Check the file permissions for the document or drive. 2) Make sure there is sufficient free memory and disk space. 3) Open the file with the Text Recovery converter." The document that I want to display is on my PC and was created by...
1
2123
by: ikarlgut | last post by:
We get this error once in a while - every 10 page hits or so... Failed to start monitoring changes to 'bla bla bla'. (Note blah = unc path + file name) We have a file server (win2003) hosting the files, and 2 web servers (win2003) running with virtual directories pointing to that unc share. I am sure it's not security as we would not be able to browse the site
5
2642
by: Vijaya P Krishna | last post by:
Hi, I have a .NET Windows Forms application, written in VB.NET and C#. I am opening a URL from the application using Process.Start(). The URL points to a java servlet running on apache-tomcat. For some users the application shows an error dialog with following information. Another very interesting observation is that it's sending a lot of requests to the servlet within no time. Please note that this is not happening for all users.
5
4768
by: =?Utf-8?B?c25vd2JraWQx?= | last post by:
I have Visual C++ 2005 express edition, I downloaded it from the microsoft website. I am using it for school. I started an assignment in the lab at my school, and for the asssignment I had to create 3 projects under one solution. They were created no problem, each with just a few lines of extremely simple code in them (for learning purposes.) I zipped the file and brought it home so I could complete the assignment. I got all the files,...
0
2216
by: sa6113 | last post by:
I am using this code to connect to a windows machine using paramiko, I have installed sshd on the machine and it works properly: sock.connect((hostname, port)) t = paramiko.Transport(sock) event = threading.Event() t.start_client(event) event.wait() if not t.is_active(): print 'SSH negotiation failed.'
0
9800
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language synchronization. With a Microsoft account, language settings sync across devices. To prevent any complications,...
0
11182
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
0
10778
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that captivates audiences and drives business growth. The Art of Business Website Design Your website is...
0
10439
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
0
9597
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project—planning, coding, testing, and deployment—without human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then launch it, all on its own.... Now, this would greatly impact the work of software developers. The idea...
1
7990
isladogs
by: isladogs | last post by:
The next Access Europe User Group meeting will be on Wednesday 1 May 2024 starting at 18:00 UK time (6PM UTC+1) and finishing by 19:30 (7.30PM). In this session, we are pleased to welcome a new presenter, Adolph Dupré who will be discussing some powerful techniques for using class modules. He will explain when you may want to use classes instead of User Defined Types (UDT). For example, to manage the data in unbound forms. Adolph will...
0
7148
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert into image. Globals.ThisAddIn.Application.ActiveDocument.Select();...
0
6014
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?
2
4245
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.