By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,105 Members | 2,620 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,105 IT Pros & Developers. It's quick & easy.

Automation Error: :"Object reference not set to an instance of an

P: n/a
I'm doing a server side automation(I know it's bad but..) and its working
fine locally and when accessing it from a remote machine using web browser is
was giving me this error"Retrieving the COM class factory for component with
CLSID
{000209FF-0000-0000-C000-000000000046} failed due to the following error:
80070005". so I configured the server using dcomcnfg as described in this
link:
http://support.microsoft.com/kb/288368/
and know this error now is gone but I'm having this error:"Object reference
not set to an instance of an object." when it comes to the last line of this
code:

Word.Application wrdApp;
Word._Document wrdDoc;
wrdApp = new Word.Application();
wrdDoc = wrdApp.Documents.Add(ref oName, ref oFalse,
ref oMissing, ref oMissing);
wrdDoc.Select();

Apr 27 '07 #1
Share this Question
Share on Google+
2 Replies


P: n/a
It's suggesting that wrdDoc is null.

--
Browse http://connect.microsoft.com/VisualStudio/feedback/ and vote.
http://www.peterRitchie.com/blog/
Microsoft MVP, Visual Developer - Visual C#
"Badis" wrote:
I'm doing a server side automation(I know it's bad but..) and its working
fine locally and when accessing it from a remote machine using web browser is
was giving me this error"Retrieving the COM class factory for component with
CLSID
{000209FF-0000-0000-C000-000000000046} failed due to the following error:
80070005". so I configured the server using dcomcnfg as described in this
link:
http://support.microsoft.com/kb/288368/
and know this error now is gone but I'm having this error:"Object reference
not set to an instance of an object." when it comes to the last line of this
code:

Word.Application wrdApp;
Word._Document wrdDoc;
wrdApp = new Word.Application();
wrdDoc = wrdApp.Documents.Add(ref oName, ref oFalse,
ref oMissing, ref oMissing);
wrdDoc.Select();
Apr 27 '07 #2

P: n/a
So, why it's woking when I run it in local machine that contain the project,
the problem comes only when I run it from a remote machine!!!?

"Peter Ritchie [C# MVP]" wrote:
It's suggesting that wrdDoc is null.

--
Browse http://connect.microsoft.com/VisualStudio/feedback/ and vote.
http://www.peterRitchie.com/blog/
Microsoft MVP, Visual Developer - Visual C#
"Badis" wrote:
I'm doing a server side automation(I know it's bad but..) and its working
fine locally and when accessing it from a remote machine using web browser is
was giving me this error"Retrieving the COM class factory for component with
CLSID
{000209FF-0000-0000-C000-000000000046} failed due to the following error:
80070005". so I configured the server using dcomcnfg as described in this
link:
http://support.microsoft.com/kb/288368/
and know this error now is gone but I'm having this error:"Object reference
not set to an instance of an object." when it comes to the last line of this
code:

Word.Application wrdApp;
Word._Document wrdDoc;
wrdApp = new Word.Application();
wrdDoc = wrdApp.Documents.Add(ref oName, ref oFalse,
ref oMissing, ref oMissing);
wrdDoc.Select();

Apr 30 '07 #3

This discussion thread is closed

Replies have been disabled for this discussion.