By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
457,929 Members | 1,417 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 457,929 IT Pros & Developers. It's quick & easy.

how to enable fxcop

P: n/a
I VS 2005 beta 2 i have a solution with

- a number of classes
- a website
- a httphandler
- a http module

I want to run fxcop on my class files - but cant find out how to enable it.

I've looked at http://msdn2.microsoft.com/library/m...us,vs.80).aspx
- but is still lost.

The only thing i can do is "enable fxcop" on the website properties page.
But it doesn't do me no good

Nov 17 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
For website you can enable "FxCop" in the menu: "WebSite - Code Anlysis
Configuration". For other projects you can configure it in the solution
properties.
There is a problem in beta 2 with coda analysis however. You get an error if
no fxcop-warnings exists. A workaround is to disable fxcop in this case or to
leave one (minor) warning open.....

"Rasmus" wrote:
I VS 2005 beta 2 i have a solution with

- a number of classes
- a website
- a httphandler
- a http module

I want to run fxcop on my class files - but cant find out how to enable it.

I've looked at http://msdn2.microsoft.com/library/m...us,vs.80).aspx
- but is still lost.

The only thing i can do is "enable fxcop" on the website properties page.
But it doesn't do me no good

Nov 17 '05 #2

P: n/a
As i wrote I have enabled it on the website, but a can't se any fxcop error
and warnings anywhere

/rasmus
Nov 17 '05 #3

P: n/a
Hi Rasmus,

Did you tried to show all errors in the output window? Besides posting
here, I suggest you can try to post in the following forum, since it is
dedicated for VS.NET 2005.

http://forums.microsoft.com/msdn/Sho...spx?ForumID=18

Kevin Yu
=======
"This posting is provided "AS IS" with no warranties, and confers no
rights."

Nov 17 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.