468,135 Members | 1,410 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,135 developers. It's quick & easy.

Error with impersonation: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection.

We are using impersonation so that a user on our domain will login into our
SQL Server using their own domain login and/or associated domain groups. To
do this, we've added:

<authentication mode="Windows" />
<identity impersonate="true"/>

to our web.config file. In IIS, annonymous access is unchecked, digest
authentication is unchecked, basic authentication is unchecked, and
Integrated Windows Authentication is checked.

The problem: This works like a charm on my local pc running IIS and
connecting to SQL Server A, but the momemnt I load it up on our development
web site with the same web.config file and same IIS settings, the connection
to SQL Server A bombs with the error message:
"Login failed for user '(null)'. Reason: Not associated with a trusted SQL
Server connection." Note that the rest of the site that does not use a
connection to SQL Server works just fine.

Any ideas?? Thanks in advance for your help! We appreciate it.

Mark
fi******@umn.edu

Nov 15 '05 #1
1 2457

Hello, Mark!
We are using impersonation so that a user on our domain will login into our SQL Server using their own domain login and/or associated domain groups. To do this, we've added:

<authentication mode="Windows" />
<identity impersonate="true"/>

to our web.config file. In IIS, annonymous access is unchecked, digest
authentication is unchecked, basic authentication is unchecked, and
Integrated Windows Authentication is checked.

The problem: This works like a charm on my local pc running IIS and
connecting to SQL Server A, but the momemnt I load it up on our development web site with the same web.config file and same IIS settings, the connection to SQL Server A bombs with the error message:
"Login failed for user '(null)'. Reason: Not associated with a trusted SQL
Server connection." Note that the rest of the site that does not use a
connection to SQL Server works just fine.

Any ideas?? Thanks in advance for your help! We appreciate it.

Use the Integrated Security keyword for Connection String, set to a value of
SSPI, to specify Windows Authentication

--
WBR, Roman S. Golubin
ICQ UIN 63253392
go****************@arhcity.ru
Nov 15 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

5 posts views Thread by Dave | last post: by
1 post views Thread by fl | last post: by
2 posts views Thread by news.microsoft.com | last post: by
12 posts views Thread by Michael | last post: by
27 posts views Thread by didacticone | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.