469,625 Members | 1,843 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,625 developers. It's quick & easy.

ASP.NET -> SQL Server : Impersonation not working!

I set my web.config as follows:
<authentication mode="Windows" />
<identity impersonate="true" />

Logon to my ASP.NET website as a user who can authenticate to the target
database.

1) Works fine on my local PC running IIS5.1 on WinXP Pro SP1
2) does not work on IIS6.0 on Windows 2003 server:
System.Data.SqlClient.SqlException: Login failed for user '(null)'. Reason:
Not associated with a trusted SQL Server connection.
at System.Data.SqlClient.ConnectionPool.GetConnection (Boolean&
isInTransaction)
at
System.Data.SqlClient.SqlConnectionPoolManager.Get PooledConnection(SqlConnectionString options, Boolean& isInTransaction)
at System.Data.SqlClient.SqlConnection.Open()
at Microsoft.Practices.EnterpriseLibrary.Data.Databas e.OpenConnection()
HOWEVER, Environment.UserName returns the correct username!
Why? How to fix?
Nov 19 '05 #1
15 3066
> 2) does not work on IIS6.0 on Windows 2003 server:
System.Data.SqlClient.SqlException: Login failed for user '(null)'.
Reason:
Not associated with a trusted SQL Server connection.


I spent a lot of time fighting this error message and eventually figured it
all out.

How are you specifying the username and password that you want the process
to impersonate?

The way I solved this was as follows (this assumes you're not running in IIS
5.0 isolation mode):

1. Create a domain user that is allowed to access the SQL Server database.

2. On your Windows Server 2003 PC, edit the IIS_WPG usergroup and add the
user you have configured.

3. Right-click the DefaultAppPool in IIS Manager and select Properties. On
the Identity tab, select "Configurable" and then enter the DOMAIN\UserName
and Password values into the appropriate boxes.

4. Back in IIS Manager, select Properties for your web site and ensure that
its Application pool is set to DefaultAppPool, that it has an Application
name (click Create if it's not set) and that the Execute permissions are set
to Scripts only.

With this all done, it worked fine for me, using the user credentials
entered against the Application pool as its impersonation user.

Hope that helps,

--

(O)enone
Nov 19 '05 #2
What I do NOT want connection to the SQL Server to be with a fixed Domain
username/password, but rather I want the user to pass the username/password
from the web browser to IIS6 and for IIS6/ASP.NET to pass the credentials to
SQL Server.

"Oenone" wrote:
2) does not work on IIS6.0 on Windows 2003 server:
System.Data.SqlClient.SqlException: Login failed for user '(null)'.
Reason:
Not associated with a trusted SQL Server connection.


I spent a lot of time fighting this error message and eventually figured it
all out.

How are you specifying the username and password that you want the process
to impersonate?

The way I solved this was as follows (this assumes you're not running in IIS
5.0 isolation mode):

1. Create a domain user that is allowed to access the SQL Server database.

2. On your Windows Server 2003 PC, edit the IIS_WPG usergroup and add the
user you have configured.

3. Right-click the DefaultAppPool in IIS Manager and select Properties. On
the Identity tab, select "Configurable" and then enter the DOMAIN\UserName
and Password values into the appropriate boxes.

4. Back in IIS Manager, select Properties for your web site and ensure that
its Application pool is set to DefaultAppPool, that it has an Application
name (click Create if it's not set) and that the Execute permissions are set
to Scripts only.

With this all done, it worked fine for me, using the user credentials
entered against the Application pool as its impersonation user.

Hope that helps,

--

(O)enone

Nov 19 '05 #3
Patrick wrote:
What I do NOT want connection to the SQL Server to be with a fixed
Domain username/password, but rather I want the user to pass the
username/password from the web browser to IIS6 and for IIS6/ASP.NET
to pass the credentials to SQL Server.


Aha -- I'm not sure how you'd do it in that case...

Are you wanting the user credentials to be those of the user in whose
identity the browser is running? (For example, if I logged on to your
network as MYDOMAIN\Fred and opened the web browser, would you want the
connection to the server to be under the user credentials of MYDOMAIN\Fred?)
Or would you want the user to type them into a form in the browser?

--

(O)enone
Nov 19 '05 #4
wanting the user credentials to be those of the user in whose identity the
browser is running? (For example, if I logged on to your network as
MYDOMAIN\Fred and opened the web browser, would you want the connection to
the server to be under the user credentials of MYDOMAIN\Fred?)

"Oenone" wrote:
Patrick wrote:
What I do NOT want connection to the SQL Server to be with a fixed
Domain username/password, but rather I want the user to pass the
username/password from the web browser to IIS6 and for IIS6/ASP.NET
to pass the credentials to SQL Server.


Aha -- I'm not sure how you'd do it in that case...

Are you wanting the user credentials to be those of the user in whose
identity the browser is running? (For example, if I logged on to your
network as MYDOMAIN\Fred and opened the web browser, would you want the
connection to the server to be under the user credentials of MYDOMAIN\Fred?)
Or would you want the user to type them into a form in the browser?

--

(O)enone

Nov 19 '05 #5
this will only work if the sqlserver is on the same box as IIS. this is
because ntlm authentication does not allow forwarding of creditals (1 hop
rule). you have 4 options:

1) switch to basic authentication. this will give IIS a primary token it can
use to access a remore sqlserver.
2) switch to kerberos authentication and enable creditials forwarding.
3) use a fixed account
4) move the SqlServer to the IIS box.
-- bruce (sqlwork.com)

"Patrick" <qu*******@newsgroup.nospam> wrote in message
news:5A**********************************@microsof t.com...
I set my web.config as follows:
<authentication mode="Windows" />
<identity impersonate="true" />

Logon to my ASP.NET website as a user who can authenticate to the target
database.

1) Works fine on my local PC running IIS5.1 on WinXP Pro SP1
2) does not work on IIS6.0 on Windows 2003 server:
System.Data.SqlClient.SqlException: Login failed for user '(null)'.
Reason:
Not associated with a trusted SQL Server connection.
at System.Data.SqlClient.ConnectionPool.GetConnection (Boolean&
isInTransaction)
at
System.Data.SqlClient.SqlConnectionPoolManager.Get PooledConnection(SqlConnectionString
options, Boolean& isInTransaction)
at System.Data.SqlClient.SqlConnection.Open()
at Microsoft.Practices.EnterpriseLibrary.Data.Databas e.OpenConnection()
HOWEVER, Environment.UserName returns the correct username!
Why? How to fix?

Nov 19 '05 #6
Why does it work when the ASP.NET is on IIS5.1 on WinXP SP1 (which is on a
different box but in the same domain as the SQL Server)?

"Bruce Barker" wrote:
this will only work if the sqlserver is on the same box as IIS. this is
because ntlm authentication does not allow forwarding of creditals (1 hop
rule). you have 4 options:

1) switch to basic authentication. this will give IIS a primary token it can
use to access a remore sqlserver.
2) switch to kerberos authentication and enable creditials forwarding.
3) use a fixed account
4) move the SqlServer to the IIS box.
-- bruce (sqlwork.com)

"Patrick" <qu*******@newsgroup.nospam> wrote in message
news:5A**********************************@microsof t.com...
I set my web.config as follows:
<authentication mode="Windows" />
<identity impersonate="true" />

Logon to my ASP.NET website as a user who can authenticate to the target
database.

1) Works fine on my local PC running IIS5.1 on WinXP Pro SP1
2) does not work on IIS6.0 on Windows 2003 server:
System.Data.SqlClient.SqlException: Login failed for user '(null)'.
Reason:
Not associated with a trusted SQL Server connection.
at System.Data.SqlClient.ConnectionPool.GetConnection (Boolean&
isInTransaction)
at
System.Data.SqlClient.SqlConnectionPoolManager.Get PooledConnection(SqlConnectionString
options, Boolean& isInTransaction)
at System.Data.SqlClient.SqlConnection.Open()
at Microsoft.Practices.EnterpriseLibrary.Data.Databas e.OpenConnection()
HOWEVER, Environment.UserName returns the correct username!
Why? How to fix?


Nov 19 '05 #7
WJ

"Patrick" <qu*******@newsgroup.nospam> wrote in message
news:E6**********************************@microsof t.com...
Why does it work when the ASP.NET is on IIS5.1 on WinXP SP1 (which is on a
different box but in the same domain as the SQL Server)?


Because you "login" to Windows XP where the IIS-5 is on the same box. This
is called integrated Windows security.

John
Nov 19 '05 #8
Thanks a lot for Bruce and John's informative inputs.

Hi Patrick,

For the ASP.NET impersonation, when we use implicit impersonation like:

<identity impersonate="true" />

the remote client's credential will be used to establish a network logon
session which doesn't have network credential for further network hop.
That's why for general condition, when client visist your asp.net app and
the asp.net use clientside credential to access the remote sqlserver will
fail.

For the local IIS5 XP condition, because you are test through the local
browser , when the IIS accept the clientside credential (local client), it
directly use the client user's interactive logon session( rather than
establish a network logon session) which surely contains the network
credential, so in such condiitino, the asp.net is able to use the
credential to access the remote sqlserver.

Anyway, I think Bruce has completely listed all the possible solutions
currently we have. If there're anything else unclear ,please feel free to
post here.

Thanks & Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


--------------------
| From: "WJ" <Jo*******@HotMail.Com>
| References: <5A**********************************@microsoft.co m>
<#k**************@tk2msftngp13.phx.gbl>
<E6**********************************@microsoft.co m>
| Subject: Re: ASP.NET -> SQL Server : Impersonation not working!
| Date: Mon, 8 Aug 2005 20:58:36 -0400
| Lines: 13
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2527
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2527
| X-RFC2646: Format=Flowed; Original
| Message-ID: <OE**************@TK2MSFTNGP10.phx.gbl>
| Newsgroups:
microsoft.public.dotnet.framework.adonet,microsoft .public.dotnet.framework.a
spnet
| NNTP-Posting-Host: ip70-187-233-38.dc.dc.cox.net 70.187.233.38
| Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGP10.phx.gbl
| Xref: TK2MSFTNGXA01.phx.gbl
microsoft.public.dotnet.framework.aspnet:116826
microsoft.public.dotnet.framework.adonet:33679
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
|
| "Patrick" <qu*******@newsgroup.nospam> wrote in message
| news:E6**********************************@microsof t.com...
| > Why does it work when the ASP.NET is on IIS5.1 on WinXP SP1 (which is
on a
| > different box but in the same domain as the SQL Server)?
| >
|
| Because you "login" to Windows XP where the IIS-5 is on the same box.
This
| is called integrated Windows security.
|
| John
|
|
|

Nov 19 '05 #9
But surely, when I login to my XP, then open up
http://myServer/impersonation.aspx, my IE6 browser also pass in my
credentials to myServer, and that is called Integrated Windows
Authentication, too regardless of whether myServer is IIS6.0 or IIS5.1, as
long as it is in the same domain!

How else did myServer managed to log Environment.UserName correctly
(corresponding to the user launching http://myServer/impersonation from a
remote WinXP IE6 browser in the same domain)?
"WJ" wrote:

"Patrick" <qu*******@newsgroup.nospam> wrote in message
news:E6**********************************@microsof t.com...
Why does it work when the ASP.NET is on IIS5.1 on WinXP SP1 (which is on a
different box but in the same domain as the SQL Server)?


Because you "login" to Windows XP where the IIS-5 is on the same box. This
is called integrated Windows security.

John

Nov 19 '05 #10
On Tue, 9 Aug 2005 02:31:59 -0700, "Patrick" <qu*******@newsgroup.nospam> wrote:

¤ But surely, when I login to my XP, then open up
¤ http://myServer/impersonation.aspx, my IE6 browser also pass in my
¤ credentials to myServer, and that is called Integrated Windows
¤ Authentication, too regardless of whether myServer is IIS6.0 or IIS5.1, as
¤ long as it is in the same domain!
¤

No, NTLM does not pass credentials to IIS when your web app is configured for Integrated Windows
security. NTLM handles the authentication. In order to delegate credentials via the web server NTLM
must be used in conjunction with Kerberos.

¤ How else did myServer managed to log Environment.UserName correctly
¤ (corresponding to the user launching http://myServer/impersonation from a
¤ remote WinXP IE6 browser in the same domain)?
¤

As was mentioned, the difference is that IIS is not capable of forwarding encrypted credentials (it
does not have) for delegation to a remote server when using Integrated Windows security. This is
different than being authenticated locally on your machine where the credentials are known and can
be forwarded for remote resource authentication. In addition, while the authenticated user name may
be known, the password is not.

BTW if you were using Basic authentication, where clear text credentials can be delegated remotely,
the integrated security mechanism should function as you expect.
Paul
~~~~
Microsoft MVP (Visual Basic)
Nov 19 '05 #11
I have the same problem. Is there a book or something that spells out exactly
what needs to happen to make this work? I also have it working locally with
XP (so i thought this solution was good), promoted it to the server, only to
run into this problem. Seems to be more difficult than it has to be for
something that appears to be common to do (retrieve data from your SQL server
and display it in your .net pages).

Looking for an answer also,
lyners

"Patrick" wrote:
I set my web.config as follows:
<authentication mode="Windows" />
<identity impersonate="true" />

Logon to my ASP.NET website as a user who can authenticate to the target
database.

1) Works fine on my local PC running IIS5.1 on WinXP Pro SP1
2) does not work on IIS6.0 on Windows 2003 server:
System.Data.SqlClient.SqlException: Login failed for user '(null)'. Reason:
Not associated with a trusted SQL Server connection.
at System.Data.SqlClient.ConnectionPool.GetConnection (Boolean&
isInTransaction)
at
System.Data.SqlClient.SqlConnectionPoolManager.Get PooledConnection(SqlConnectionString options, Boolean& isInTransaction)
at System.Data.SqlClient.SqlConnection.Open()
at Microsoft.Practices.EnterpriseLibrary.Data.Databas e.OpenConnection()
HOWEVER, Environment.UserName returns the correct username!
Why? How to fix?

Nov 19 '05 #12
Hi Lyners,

For such accessing remote resource on client's forward identity issue, you
can refer to
Bruce's former message whicn mentioned the 4 possible options:
===============

1) switch to basic authentication. this will give IIS a primary token it
can
use to access a remore sqlserver.
2) switch to kerberos authentication and enable creditials forwarding.
3) use a fixed account
4) move the SqlServer to the IIS box.

================

In addition, if you have interests, I also recommend that you have a look
at the

"Programming windows security" or
"The .NET Developer's Guide to Windows Security"

authored by Keith Brown. The twos are good guide on windows security
programming.

Thanks & Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


--------------------
| Thread-Topic: ASP.NET -> SQL Server : Impersonation not working!
| thread-index: AcWd9XWiDDZC3JczQtemxmLiosdewg==
| X-WBNR-Posting-Host: 204.194.251.3
| From: =?Utf-8?B?THluZXJz?= <Ly****@discussions.microsoft.com>
| References: <5A**********************************@microsoft.co m>
| Subject: RE: ASP.NET -> SQL Server : Impersonation not working!
| Date: Wed, 10 Aug 2005 14:50:01 -0700
| Lines: 33
| Message-ID: <95**********************************@microsoft.co m>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups:
microsoft.public.dotnet.framework.adonet,microsoft .public.dotnet.framework.a
spnet
| NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGXA03.phx.gbl
| Xref: TK2MSFTNGXA01.phx.gbl
microsoft.public.dotnet.framework.aspnet:117266
microsoft.public.dotnet.framework.adonet:33797
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| I have the same problem. Is there a book or something that spells out
exactly
| what needs to happen to make this work? I also have it working locally
with
| XP (so i thought this solution was good), promoted it to the server, only
to
| run into this problem. Seems to be more difficult than it has to be for
| something that appears to be common to do (retrieve data from your SQL
server
| and display it in your .net pages).
|
| Looking for an answer also,
| lyners
|
| "Patrick" wrote:
|
| > I set my web.config as follows:
| > <authentication mode="Windows" />
| > <identity impersonate="true" />
| >
| > Logon to my ASP.NET website as a user who can authenticate to the
target
| > database.
| >
| > 1) Works fine on my local PC running IIS5.1 on WinXP Pro SP1
| > 2) does not work on IIS6.0 on Windows 2003 server:
| > System.Data.SqlClient.SqlException: Login failed for user '(null)'.
Reason:
| > Not associated with a trusted SQL Server connection.
| > at System.Data.SqlClient.ConnectionPool.GetConnection (Boolean&
| > isInTransaction)
| > at
| >
System.Data.SqlClient.SqlConnectionPoolManager.Get PooledConnection(SqlConnec
tionString options, Boolean& isInTransaction)
| > at System.Data.SqlClient.SqlConnection.Open()
| > at
Microsoft.Practices.EnterpriseLibrary.Data.Databas e.OpenConnection()
| > HOWEVER, Environment.UserName returns the correct username!
| >
| >
| > Why? How to fix?
|

Nov 19 '05 #13
Assuming you are using windows auth to connect to SQL Server - which it
looks like you are - you are more than likely running into the infamous
"double hop" issue. You cannot go from client -> (one hop) web server ->
(2nd hop) sql server unless you allowed delegation for the account that are
trying to authenticate.

It is possible to achieve what you are trying to do, but it will require
some additional setup. Check out these links for more info:

http://odetocode.com/Blogs/scott/arc...2/24/1053.aspx
http://support.microsoft.com/default...b;en-us;810572
http://pluralsight.com/blogs/keith/a...7/08/1586.aspx

Kevin Cunningham

"Lyners" <Ly****@discussions.microsoft.com> wrote in message
news:95**********************************@microsof t.com...
I have the same problem. Is there a book or something that spells out
exactly
what needs to happen to make this work? I also have it working locally
with
XP (so i thought this solution was good), promoted it to the server, only
to
run into this problem. Seems to be more difficult than it has to be for
something that appears to be common to do (retrieve data from your SQL
server
and display it in your .net pages).

Looking for an answer also,
lyners

"Patrick" wrote:
I set my web.config as follows:
<authentication mode="Windows" />
<identity impersonate="true" />

Logon to my ASP.NET website as a user who can authenticate to the target
database.

1) Works fine on my local PC running IIS5.1 on WinXP Pro SP1
2) does not work on IIS6.0 on Windows 2003 server:
System.Data.SqlClient.SqlException: Login failed for user '(null)'.
Reason:
Not associated with a trusted SQL Server connection.
at System.Data.SqlClient.ConnectionPool.GetConnection (Boolean&
isInTransaction)
at
System.Data.SqlClient.SqlConnectionPoolManager.Get PooledConnection(SqlConnectionString
options, Boolean& isInTransaction)
at System.Data.SqlClient.SqlConnection.Open()
at
Microsoft.Practices.EnterpriseLibrary.Data.Databas e.OpenConnection()
HOWEVER, Environment.UserName returns the correct username!
Why? How to fix?

Nov 19 '05 #14
Actually, if the user is logged onto our intranet, that is good enough
security. I am trying to make the IIS talk to the SQL server, I have been
experimenting with different setups, but i can't get any data back. I usually
get "Login failed for user '(null)'. Reason: Not associated with a trusted
SQL Server connection" What is the correct way to setup a connection to a SQL
server running on a Windows 2003 server from an IIS Windows 2003 server? I
know the second hop is my problem, but what is the best business practice for
setting up the conection?

"kevin cunningham" wrote:
Assuming you are using windows auth to connect to SQL Server - which it
looks like you are - you are more than likely running into the infamous
"double hop" issue. You cannot go from client -> (one hop) web server ->
(2nd hop) sql server unless you allowed delegation for the account that are
trying to authenticate.

It is possible to achieve what you are trying to do, but it will require
some additional setup. Check out these links for more info:

http://odetocode.com/Blogs/scott/arc...2/24/1053.aspx
http://support.microsoft.com/default...b;en-us;810572
http://pluralsight.com/blogs/keith/a...7/08/1586.aspx

Kevin Cunningham

"Lyners" <Ly****@discussions.microsoft.com> wrote in message
news:95**********************************@microsof t.com...
I have the same problem. Is there a book or something that spells out
exactly
what needs to happen to make this work? I also have it working locally
with
XP (so i thought this solution was good), promoted it to the server, only
to
run into this problem. Seems to be more difficult than it has to be for
something that appears to be common to do (retrieve data from your SQL
server
and display it in your .net pages).

Looking for an answer also,
lyners

"Patrick" wrote:
I set my web.config as follows:
<authentication mode="Windows" />
<identity impersonate="true" />

Logon to my ASP.NET website as a user who can authenticate to the target
database.

1) Works fine on my local PC running IIS5.1 on WinXP Pro SP1
2) does not work on IIS6.0 on Windows 2003 server:
System.Data.SqlClient.SqlException: Login failed for user '(null)'.
Reason:
Not associated with a trusted SQL Server connection.
at System.Data.SqlClient.ConnectionPool.GetConnection (Boolean&
isInTransaction)
at
System.Data.SqlClient.SqlConnectionPoolManager.Get PooledConnection(SqlConnectionString
options, Boolean& isInTransaction)
at System.Data.SqlClient.SqlConnection.Open()
at
Microsoft.Practices.EnterpriseLibrary.Data.Databas e.OpenConnection()
HOWEVER, Environment.UserName returns the correct username!
Why? How to fix?


Nov 19 '05 #15
Hi Patrick,

Have you had a chance to look at Paul and Kevins' further suggestions.
Also, as I mentioned in my former reply, currently the four options Bruce
has suggested:
=========
1) switch to basic authentication. this will give IIS a primary token it
can
use to access a remore sqlserver.
2) switch to kerberos authentication and enable creditials forwarding.
3) use a fixed account
4) move the SqlServer to the IIS box
=========

are the reasonable approach avaiable for multi-tier application. Please
feel free to post here if there'r anything else we can help. Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| Thread-Topic: ASP.NET -> SQL Server : Impersonation not working!
| thread-index: AcWcOezYxxuAGdPfQ5acH2lDwOZtOg==
| X-WBNR-Posting-Host: 198.240.128.75
| From: "=?Utf-8?B?UGF0cmljaw==?=" <qu*******@newsgroup.nospam>
| References: <5A**********************************@microsoft.co m>
<ex**************@TK2MSFTNGP10.phx.gbl>
<F1**********************************@microsoft.co m>
<##**************@TK2MSFTNGP15.phx.gbl>
| Subject: Re: ASP.NET -> SQL Server : Impersonation not working!
| Date: Mon, 8 Aug 2005 09:55:05 -0700
| Lines: 27
| Message-ID: <94**********************************@microsoft.co m>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 7bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups:
microsoft.public.dotnet.framework.adonet,microsoft .public.dotnet.framework.a
spnet
| NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGXA03.phx.gbl
| Xref: TK2MSFTNGXA01.phx.gbl
microsoft.public.dotnet.framework.aspnet:116740
microsoft.public.dotnet.framework.adonet:33653
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| wanting the user credentials to be those of the user in whose identity
the
| browser is running? (For example, if I logged on to your network as
| MYDOMAIN\Fred and opened the web browser, would you want the connection
to
| the server to be under the user credentials of MYDOMAIN\Fred?)
|
| "Oenone" wrote:
|
| > Patrick wrote:
| > > What I do NOT want connection to the SQL Server to be with a fixed
| > > Domain username/password, but rather I want the user to pass the
| > > username/password from the web browser to IIS6 and for IIS6/ASP.NET
| > > to pass the credentials to SQL Server.
| >
| > Aha -- I'm not sure how you'd do it in that case...
| >
| > Are you wanting the user credentials to be those of the user in whose
| > identity the browser is running? (For example, if I logged on to your
| > network as MYDOMAIN\Fred and opened the web browser, would you want the
| > connection to the server to be under the user credentials of
MYDOMAIN\Fred?)
| > Or would you want the user to type them into a form in the browser?
| >
| > --
| >
| > (O)enone
| >
| >
| >
|

Nov 19 '05 #16

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

9 posts views Thread by Ludwig Moser | last post: by
4 posts views Thread by Tim Mulholland | last post: by
reply views Thread by Bill | last post: by
reply views Thread by gheharukoh7 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.