By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,231 Members | 1,333 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,231 IT Pros & Developers. It's quick & easy.

Spanish characters problem

P: n/a
Hi everybody.

I am using streamreader to show spanish .htm page on my website.
Unfortunately those spanish characters that have stresses on top (like: Ó,á,
....) do not show correctly. Is there any way to overcome this problem?
Mar 11 '08 #1
Share this Question
Share on Google+
4 Replies


P: n/a
If you want .htm files to be governed by ASP.NET's rules,
you need to map the .htm extension to the asp.net isapi dll.

You will also need to configure the globalization settings :

<globalization
requestEncoding="iso-8859-1"
responseEncoding="iso-8859-1"
fileEncoding="iso-8859-1"
/>


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaol : http://asp.net.do/foros/
======================================
"Leon" <Le**@discussions.microsoft.comwrote in message news:B1**********************************@microsof t.com...
Hi everybody.

I am using streamreader to show spanish .htm page on my website.
Unfortunately those spanish characters that have stresses on top (like: ,,
...) do not show correctly. Is there any way to overcome this problem?


Mar 11 '08 #2

P: n/a
Juan. Thanks a lot for your help.
I added globalization section to my web.config. For some reason right now it
shows ? instead of those characters. Do you know what am I still missing?

"Juan T. Llibre" wrote:
If you want .htm files to be governed by ASP.NET's rules,
you need to map the .htm extension to the asp.net isapi dll.

You will also need to configure the globalization settings :

<globalization
requestEncoding="iso-8859-1"
responseEncoding="iso-8859-1"
fileEncoding="iso-8859-1"
/>


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"Leon" <Le**@discussions.microsoft.comwrote in message news:B1**********************************@microsof t.com...
Hi everybody.

I am using streamreader to show spanish .htm page on my website.
Unfortunately those spanish characters that have stresses on top (like: Ó,á,
...) do not show correctly. Is there any way to overcome this problem?


Mar 11 '08 #3

P: n/a
re:
!I added globalization section to my web.config. For some reason right now it
!shows ? instead of those characters. Do you know what am I still missing?

Mapping the .htm extension to the ASP.NET isapi ... ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaol : http://asp.net.do/foros/
======================================
"Leon" <Le**@discussions.microsoft.comwrote in message news:C9**********************************@microsof t.com...
Juan. Thanks a lot for your help.
I added globalization section to my web.config. For some reason right now it
shows ? instead of those characters. Do you know what am I still missing?

"Juan T. Llibre" wrote:
>If you want .htm files to be governed by ASP.NET's rules,
you need to map the .htm extension to the asp.net isapi dll.

You will also need to configure the globalization settings :

<globalization
requestEncoding="iso-8859-1"
responseEncoding="iso-8859-1"
fileEncoding="iso-8859-1"
/>


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaol : http://asp.net.do/foros/
======================================
"Leon" <Le**@discussions.microsoft.comwrote in message news:B1**********************************@microsof t.com...
Hi everybody.

I am using streamreader to show spanish .htm page on my website.
Unfortunately those spanish characters that have stresses on top (like: ,,
...) do not show correctly. Is there any way to overcome this problem?




Mar 11 '08 #4

P: n/a
Juan.
Can you prompted me how to do it?
I went to IIS, selected my home application folder, went to properties then
directory configuration.
When I was trying to add new mapping, 'Ok' button is always disabled. I am
not sure what I am doing wrong. BTW I logged in as Administrator to my box.

"Juan T. Llibre" wrote:
re:
!I added globalization section to my web.config. For some reason right now it
!shows ? instead of those characters. Do you know what am I still missing?

Mapping the .htm extension to the ASP.NET isapi ... ?


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"Leon" <Le**@discussions.microsoft.comwrote in message news:C9**********************************@microsof t.com...
Juan. Thanks a lot for your help.
I added globalization section to my web.config. For some reason right now it
shows ? instead of those characters. Do you know what am I still missing?

"Juan T. Llibre" wrote:
If you want .htm files to be governed by ASP.NET's rules,
you need to map the .htm extension to the asp.net isapi dll.

You will also need to configure the globalization settings :

<globalization
requestEncoding="iso-8859-1"
responseEncoding="iso-8859-1"
fileEncoding="iso-8859-1"
/>


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"Leon" <Le**@discussions.microsoft.comwrote in message news:B1**********************************@microsof t.com...
Hi everybody.

I am using streamreader to show spanish .htm page on my website.
Unfortunately those spanish characters that have stresses on top (like: Ó,á,
...) do not show correctly. Is there any way to overcome this problem?




Mar 11 '08 #5

This discussion thread is closed

Replies have been disabled for this discussion.