By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
458,165 Members | 1,323 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 458,165 IT Pros & Developers. It's quick & easy.

Can no longer publish my web site project

P: n/a
Hi all,

I am no longer able to publish a web site project using Visual Studio 2005
Professional.

I am publishing it to an FTP url, and this used to work just fine.

I enter the username and password and select "passive mode" when publishing
the site, like I have always done. Visual Studio deletes the existing files,
but then doesn't write the new ones, though it tells me the operation was
successful:
------ Build started: Project: C:\WebDev\WebNet\, Configuration: Debug
..NET ------
Pre-compiling Web Site

Building directory '/WebNet/admin/'.

Building directory '/WebNet/UserControls/'.

Pre-compilation Complete

------ Publish started: Project: C:\WebDev\WebNet\, Configuration: Debug
..NET ------

========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped ==========

========== Publish: 1 succeeded, 0 failed, 0 skipped ==========

I have tried resetting the permissions on the web folder, and also deleted
an re-created the Server Extensions 2002 Web, but to no avail.

Any ideas?

Thanks very much
May 4 '07 #1
Share this Question
Share on Google+
9 Replies


P: n/a
Can you ping the site for the machine, i'd check that first. VS writes an
error log out to disk that you can examine. Another option is to debug the
publish process. Open another copy of visual studio and attach it to the
first copy of visual studio, set it to break on all exceptions. Run the
publish process from the first copy and see what exceptions are thrown in
the second copy when the debug breakpoint catches.

--
Regards,
Alvin Bruney
------------------------------------------------------
Shameless author plug
Excel Services for .NET is coming...
OWC Black book on Amazon and
www.lulu.com/owc
Professional VSTO 2005 - Wrox/Wiley
"Jason" <Ja********@nospam.nospamwrote in message
news:u7**************@TK2MSFTNGP03.phx.gbl...
Hi all,

I am no longer able to publish a web site project using Visual Studio 2005
Professional.

I am publishing it to an FTP url, and this used to work just fine.

I enter the username and password and select "passive mode" when
publishing the site, like I have always done. Visual Studio deletes the
existing files, but then doesn't write the new ones, though it tells me
the operation was successful:
------ Build started: Project: C:\WebDev\WebNet\, Configuration: Debug
.NET ------
Pre-compiling Web Site

Building directory '/WebNet/admin/'.

Building directory '/WebNet/UserControls/'.

Pre-compilation Complete

------ Publish started: Project: C:\WebDev\WebNet\, Configuration: Debug
.NET ------

========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped
==========

========== Publish: 1 succeeded, 0 failed, 0 skipped ==========

I have tried resetting the permissions on the web folder, and also deleted
an re-created the Server Extensions 2002 Web, but to no avail.

Any ideas?

Thanks very much

May 5 '07 #2

P: n/a
Hi Jason,

Are you using IIS's ftp server ? Besides Alvin's suggestion, I would also
suggestion to check the ftp server's log to see if there's anything wrong.

#How to enable logging in Internet Information Services (IIS)
http://support.microsoft.com/kb/313437
Regards,
Walter Wang (wa****@online.microsoft.com, remove 'online.')
Microsoft Online Community Support

==================================================
When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.
==================================================

This posting is provided "AS IS" with no warranties, and confers no rights.

May 7 '07 #3

P: n/a
Hi Alvin,

Thanks for your response. Trying to ping the machine from the command line
yields "Request timed out."

I am able to connect to the machine via ftp from the command line and
another ftp client, CuteFtp, though.

As for the error log that VS writes out - where is that file written? I
couldn't find anything in the Visual Studio help docs.

And as for attaching to another process, the help docs mention:

"...choose Attach to Process from the Tools menu..."

which doesn't exist. How do I go about attaching to another process?

Thanks for your help

/jason

"Alvin Bruney [MVP]" <some guy without an email addresswrote in message
news:OF**************@TK2MSFTNGP03.phx.gbl...
Can you ping the site for the machine, i'd check that first. VS writes an
error log out to disk that you can examine. Another option is to debug the
publish process. Open another copy of visual studio and attach it to the
first copy of visual studio, set it to break on all exceptions. Run the
publish process from the first copy and see what exceptions are thrown in
the second copy when the debug breakpoint catches.

--
Regards,
Alvin Bruney
------------------------------------------------------
Shameless author plug
Excel Services for .NET is coming...
OWC Black book on Amazon and
www.lulu.com/owc
Professional VSTO 2005 - Wrox/Wiley
"Jason" <Ja********@nospam.nospamwrote in message
news:u7**************@TK2MSFTNGP03.phx.gbl...
>Hi all,

I am no longer able to publish a web site project using Visual Studio
2005 Professional.

I am publishing it to an FTP url, and this used to work just fine.

I enter the username and password and select "passive mode" when
publishing the site, like I have always done. Visual Studio deletes the
existing files, but then doesn't write the new ones, though it tells me
the operation was successful:
------ Build started: Project: C:\WebDev\WebNet\, Configuration: Debug
.NET ------
Pre-compiling Web Site

Building directory '/WebNet/admin/'.

Building directory '/WebNet/UserControls/'.

Pre-compilation Complete

------ Publish started: Project: C:\WebDev\WebNet\, Configuration: Debug
.NET ------

========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped
==========

========== Publish: 1 succeeded, 0 failed, 0 skipped ==========

I have tried resetting the permissions on the web folder, and also
deleted an re-created the Server Extensions 2002 Web, but to no avail.

Any ideas?

Thanks very much


May 7 '07 #4

P: n/a
OK I figured out how to attach to another process - just opened up a new
blank web application project, and from there was able to attach to the
other devenv.exe process. Easy enough.

There is a "Break All" option on the debug menu - is that what you mean by
"set it to break on all exceptions" ? I tried setting that but the first
devenv.exe instance hung at that point - it didn't survive far enough for me
to publish it.

Arg!

Am I doing something wrong?

/jason


"Alvin Bruney [MVP]" <some guy without an email addresswrote in message
news:OF**************@TK2MSFTNGP03.phx.gbl...
Can you ping the site for the machine, i'd check that first. VS writes an
error log out to disk that you can examine. Another option is to debug the
publish process. Open another copy of visual studio and attach it to the
first copy of visual studio, set it to break on all exceptions. Run the
publish process from the first copy and see what exceptions are thrown in
the second copy when the debug breakpoint catches.

--
Regards,
Alvin Bruney
------------------------------------------------------
Shameless author plug
Excel Services for .NET is coming...
OWC Black book on Amazon and
www.lulu.com/owc
Professional VSTO 2005 - Wrox/Wiley
"Jason" <Ja********@nospam.nospamwrote in message
news:u7**************@TK2MSFTNGP03.phx.gbl...
>Hi all,

I am no longer able to publish a web site project using Visual Studio
2005 Professional.

I am publishing it to an FTP url, and this used to work just fine.

I enter the username and password and select "passive mode" when
publishing the site, like I have always done. Visual Studio deletes the
existing files, but then doesn't write the new ones, though it tells me
the operation was successful:
------ Build started: Project: C:\WebDev\WebNet\, Configuration: Debug
.NET ------
Pre-compiling Web Site

Building directory '/WebNet/admin/'.

Building directory '/WebNet/UserControls/'.

Pre-compilation Complete

------ Publish started: Project: C:\WebDev\WebNet\, Configuration: Debug
.NET ------

========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped
==========

========== Publish: 1 succeeded, 0 failed, 0 skipped ==========

I have tried resetting the permissions on the web folder, and also
deleted an re-created the Server Extensions 2002 Web, but to no avail.

Any ideas?

Thanks very much


May 7 '07 #5

P: n/a
Hi Walter,

Yes, I'm using IIS's ftp server.

I enabled logging on the FTP server like you suggested...I see entries where
the _private and images folders are deleted then created, but nothing else,
like VS is not trying to write the files to the server.

Is there a setting in Visual Studio to tell it to publish files as well as
folders when publishing the web site?

/jason

"Walter Wang [MSFT]" <wa****@online.microsoft.comwrote in message
news:oM**************@TK2MSFTNGHUB02.phx.gbl...
Hi Jason,

Are you using IIS's ftp server ? Besides Alvin's suggestion, I would also
suggestion to check the ftp server's log to see if there's anything wrong.

#How to enable logging in Internet Information Services (IIS)
http://support.microsoft.com/kb/313437
Regards,
Walter Wang (wa****@online.microsoft.com, remove 'online.')
Microsoft Online Community Support

==================================================
When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.
==================================================

This posting is provided "AS IS" with no warranties, and confers no
rights.

May 7 '07 #6

P: n/a
Hi Jason,

I'm aware of any settings are related to how Visual Studio publishs the web
site. You're using VS2005, right?

Since you mentioned that it works before, and I cannot reproduce it on my
side, I think this should be an environment specific issue.

Have you tried not using PASV mode?

We need to first determine if it's related to the ftp server or the VS2005
instance. To do that, we will need another VS2005 and ftp server. With the
correct combination, we should be able to narrow down the issue.

At last, please note for such non-reproducible issue, what I can help in
newsgroup is to see if there's any similar issue in our support database,
and give some suggestion to try. Therefore, the progress may not be very
satisfying. I hope you could understand that. Thanks.
Regards,
Walter Wang (wa****@online.microsoft.com, remove 'online.')
Microsoft Online Community Support

==================================================
When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.
==================================================

This posting is provided "AS IS" with no warranties, and confers no rights.

May 8 '07 #7

P: n/a
Walter I appreciate your help.

Yes I am using VS 2005.

I created another WebSite project and was also unable to publish that as
well via ftp.

However I can ftp files to the folder just fine with CuteFTP using the same
username and password.

I tried to publish to in Visual Studio with "Connect using passive mode"
unchecked, and Visual Studio went into some kind of horrible loop. I had to
use Task Manager to bring it down - not very pretty.

I removed the 2002 Server Extensions from the folder in IIS, and Removed the
virtual application via the properties pages. I then republish the site and
Visual Studio tells me:

========== Publish: 1 succeeded, 0 failed, 0 skipped ==========

I check the folder on the server and nothing is there, so VS is incorrectly
reporting that the process succeeded.

So yes, it does seem to be specific to my Visual Studio Development
Environment.

Despite my frustration, I'm not ready to throw Visual Studio in the trash
yet. I will give MS a call and see if they can sort it out. I'll let you
know what the solution is.

Again, I appreciate your help,

/jason

"Walter Wang [MSFT]" <wa****@online.microsoft.comwrote in message
news:ea**************@TK2MSFTNGHUB02.phx.gbl...
Hi Jason,

I'm aware of any settings are related to how Visual Studio publishs the
web
site. You're using VS2005, right?

Since you mentioned that it works before, and I cannot reproduce it on my
side, I think this should be an environment specific issue.

Have you tried not using PASV mode?

We need to first determine if it's related to the ftp server or the VS2005
instance. To do that, we will need another VS2005 and ftp server. With the
correct combination, we should be able to narrow down the issue.

At last, please note for such non-reproducible issue, what I can help in
newsgroup is to see if there's any similar issue in our support database,
and give some suggestion to try. Therefore, the progress may not be very
satisfying. I hope you could understand that. Thanks.
Regards,
Walter Wang (wa****@online.microsoft.com, remove 'online.')
Microsoft Online Community Support

==================================================
When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.
==================================================

This posting is provided "AS IS" with no warranties, and confers no
rights.

May 9 '07 #8

P: n/a
OK, I decided to try one more thing before getting in touch with MS:
converting the web site project to a web application project.

And that did the trick.

Here's the link I used:

http://webproject.scottgu.com/CSharp...igration2.aspx

Thanks again for the help!

jason

"Jason" <Ja********@nospam.nospamwrote in message
news:%2***************@TK2MSFTNGP06.phx.gbl...
Walter I appreciate your help.

Yes I am using VS 2005.

I created another WebSite project and was also unable to publish that as
well via ftp.

However I can ftp files to the folder just fine with CuteFTP using the
same username and password.

I tried to publish to in Visual Studio with "Connect using passive mode"
unchecked, and Visual Studio went into some kind of horrible loop. I had
to use Task Manager to bring it down - not very pretty.

I removed the 2002 Server Extensions from the folder in IIS, and Removed
the virtual application via the properties pages. I then republish the
site and Visual Studio tells me:

========== Publish: 1 succeeded, 0 failed, 0 skipped ==========

I check the folder on the server and nothing is there, so VS is
incorrectly reporting that the process succeeded.

So yes, it does seem to be specific to my Visual Studio Development
Environment.

Despite my frustration, I'm not ready to throw Visual Studio in the trash
yet. I will give MS a call and see if they can sort it out. I'll let you
know what the solution is.

Again, I appreciate your help,

/jason

"Walter Wang [MSFT]" <wa****@online.microsoft.comwrote in message
news:ea**************@TK2MSFTNGHUB02.phx.gbl...
>Hi Jason,

I'm aware of any settings are related to how Visual Studio publishs the
web
site. You're using VS2005, right?

Since you mentioned that it works before, and I cannot reproduce it on my
side, I think this should be an environment specific issue.

Have you tried not using PASV mode?

We need to first determine if it's related to the ftp server or the
VS2005
instance. To do that, we will need another VS2005 and ftp server. With
the
correct combination, we should be able to narrow down the issue.

At last, please note for such non-reproducible issue, what I can help in
newsgroup is to see if there's any similar issue in our support database,
and give some suggestion to try. Therefore, the progress may not be very
satisfying. I hope you could understand that. Thanks.
Regards,
Walter Wang (wa****@online.microsoft.com, remove 'online.')
Microsoft Online Community Support

================================================= =
When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.
================================================= =

This posting is provided "AS IS" with no warranties, and confers no
rights.


May 9 '07 #9

P: n/a
Hi Jason,

I'm glad to know that you've found a workaround, thank you for sharing this
experience here.

Regards,
Walter Wang (wa****@online.microsoft.com, remove 'online.')
Microsoft Online Community Support

==================================================
When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.
==================================================

This posting is provided "AS IS" with no warranties, and confers no rights.

May 10 '07 #10

This discussion thread is closed

Replies have been disabled for this discussion.