By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,292 Members | 1,711 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,292 IT Pros & Developers. It's quick & easy.

ASP.NET Web Site Admin tool & Custom Provider

P: n/a
I have written two custom providers for our Oracle 9i database...a
Membershp provider and a Role provider. I've been testing these over
the last few days and they seem to be working well. However, when I try
to use the ASP.NET 2.0 Web Site Administration Tool in VS 2005, I get
an error when I click on the "Create User" link.

On the tool's Provider tab, I _have_ selected to use my custom
providers! Also, I do not seem to have a problem managing existing
users or creating/managing roles. Nor do I have any problems when I
programmatically create a new user using the "Membership.CreateUser()"
method. The error only seems to occur when I try to use the "Create
User" link via the ASP.NET 2.0 Web Site Administration Tool's Security
tab.

The following info is a portion of what's written to the Application
Event Log:
/**********************************/
Exception information:
Exception type: ConfigurationErrorsException
Exception message: The connection name 'LocalSqlServer' was not
found in the applications configuration or the connection string is
empty.
(C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Con fig\machine.config
line 120)
/**********************************/

In my application's WEB.CONFIG file, I have removed the default
connection info for the "LocalSqlServer" connection.

In the computer's MACHINE.CONFIG file, I do have an entry for the
"LocalSqlServer" connection, as well as entries for the default
AspNetSqlMembershipProvider, AspNetSqlProfileProvider and
AspNetSqlRoleProvider providers. I've tried commenting out all of these
entries but then I still get an error (although a different one) when I
try to use the "Create User" link via the ASP.NET 2.0 Web Site
Administration Tool's Security tab.

Has anyone else encountered this error and know of a solution? Any
ideas why this error occurs only via the one link in the ASP.NET 2.0
Web Site Administration Tool?

I'd greatly appreciate any assistance with this issue. Thank you!

Nov 17 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.