By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,359 Members | 1,495 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,359 IT Pros & Developers. It's quick & easy.

Web Site Administration Tool

P: n/a
I am trying to use the Personal Web Site Starter Kit. I am planning on
showing my class how easy it is to create a website in VS 2005. Only I
am finding it not to be so easy. I am following the instructions on the
default.aspx page and they are as follows.

Creating an Administrative User
The first step you must take is to create an administrative user. The
administrative user has permission to upload photos and create albums.

To create an administrative user

Run the site at least once before proceeding. This ensures the
initialization of the Membership and Roles databases.
In the Website menu, click ASP.NET Configuration.
Click the Security tab.
Click Create user.
In the Create User box, type a user name, password, and e-mail address
for the administrator user. You must also provide a security question
and answer that is used to help you recover your password, if
necessary. In the Roles box, select both the Administrators and Friends
check boxes to make the user into an administrator and a member of the
Friends role.
Click Create User.
Close the Web Site Administration Tool window.

But after I click on the Security tab, I get this message and I can't
proceed:
There is a problem with your selected data store. This can be caused by
an invalid server name or credentials, or by insufficient permission.
It can also be caused by the role manager feature not being enabled.
Click the button below to be redirected to a page where you can choose
a new data store.

The following message may help in diagnosing the problem: Unable to
connect to SQL Server database.

Do I have to configur the Configuration tool?

Lost please help

Nov 19 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Sanity check :

Are you running SQL Server Express 2005 ?

The default localSQLServer is set to SSE, and the
AspNetSqlMembership Provider is set to the LocalSqlServer.

If you're not using SSE 2005, you need to change those and run
aspnetregsql.exe ( in the .Net Framework directory ) to configure
the database provider you want to use.

Open the Internet Service Manager, right-click the website where
the Personal Web Site points to, select "Properties", and open
the "ASP.NET" tab.

Once there, check the ASP.NET Configuration for the SQL Provider.

You will also find it in machine.config, in the <connectionStrings>
section, but don't change it there.

Right now, it probably reads :

<connectionStrings>
<add name="LocalSqlServer" connectionString="data source=.\SQLEXPRESS;Integrated
Security=SSPI;AttachDBFilename=|DataDirectory|aspn etdb.mdf;User Instance=true"
providerName="System.Data.SqlClient"/>
</connectionStrings>

Add the Provider you want to your application's web.config.

You may find the information in this article abundant and clear:
http://www.theserverside.net/article...rofileProvider

But, there's a complete sample for several Access providers,
including the databases at :

http://msdn.microsoft.com/asp.net/be...s/default.aspx
Scroll to the bottom to "Sample Access Providers" and download it.

Those sample Access Providers really save a lot of time and effort,
especially if you cannot, or won't, use SQL Server Express nor SQL Server 2000.


Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
Foros de ASP.NET en Español : http://asp.net.do/foros/
======================================
<da**@palfery.com> wrote in message
news:11**********************@g14g2000cwa.googlegr oups.com...
I am trying to use the Personal Web Site Starter Kit. I am planning on
showing my class how easy it is to create a website in VS 2005. Only I
am finding it not to be so easy. I am following the instructions on the
default.aspx page and they are as follows.

Creating an Administrative User
The first step you must take is to create an administrative user. The
administrative user has permission to upload photos and create albums.

To create an administrative user

Run the site at least once before proceeding. This ensures the
initialization of the Membership and Roles databases.
In the Website menu, click ASP.NET Configuration.
Click the Security tab.
Click Create user.
In the Create User box, type a user name, password, and e-mail address
for the administrator user. You must also provide a security question
and answer that is used to help you recover your password, if
necessary. In the Roles box, select both the Administrators and Friends
check boxes to make the user into an administrator and a member of the
Friends role.
Click Create User.
Close the Web Site Administration Tool window.

But after I click on the Security tab, I get this message and I can't
proceed:
There is a problem with your selected data store. This can be caused by
an invalid server name or credentials, or by insufficient permission.
It can also be caused by the role manager feature not being enabled.
Click the button below to be redirected to a page where you can choose
a new data store.

The following message may help in diagnosing the problem: Unable to
connect to SQL Server database.

Do I have to configur the Configuration tool?

Lost please help

Nov 19 '05 #2

P: n/a
>I am trying to use the Personal Web Site Starter Kit. I am planning on
showing my class how easy it is to create a website in VS 2005.
In that case, I suggest you forget the PWSSK and buld something from
scratch!! That starter kit is very impressive, but not at all easy to
fathom at first. If you want to show people how easy it is to build a
good web site, start from scratch and show them some of the quick and
simple ways it offers of producing sophisticated functionality.
Only I
am finding it not to be so easy.


I'm not surprised!!

--
Alan Silver
(anything added below this line is nothing to do with me)
Nov 19 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.