By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,805 Members | 1,100 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,805 IT Pros & Developers. It's quick & easy.

Server Unavailable - ASP.NET 2.0 on Windows XP

P: n/a
Hi All!

I have a ASP.NET 2.0 site that works on the Windows 2000 Server. However,
when I tried to view this site on my local Windows XP machine, I get "Server
Unavailable". If I switch the Windows XP IIS back to ASP.NET 1.1 then I get
the Configuration Error (which is understandable because I'm trying to run
an ASP.NET 2 site with 1.1 framework).

I can however view other ASP.NET 1.1 sites on my local Windows XP machine.
It's only the problem with

I've also tried the aspnet_regiis thing as well as setting permissions on
folders as described in this article:
http://support.microsoft.com/default.aspx?kbid=811320
but no solution.

In the event log, I see these three errors every I tried to view my ASP.NET
2.0 site on my local machine...

<errors>

1.) .aspnet_wp.exe (PID: 3988) stopped unexpectedly

2.) Failed to execute the request because the ASP.NET process identity does
not have read permissions to the global assembly cache. Error: 0x80131902

3.) Failed to initialize the AppDomain:/LM/W3SVC/1/Root

Exception: System.Configuration.ConfigurationErrorsException

Message: Exception of type
'System.Configuration.ConfigurationErrorsException ' was thrown.

</errors>

What could be the problem?!?!?!? Plz, any solutions or pointers to solutions
are much appreciated!!!

Thank you all in advance!!!

Jon
Apr 23 '06 #1
Share this Question
Share on Google+
17 Replies


P: n/a
If you're running on Windows XP, the account which needs permissions is
MACHINENAME\ASPNET...even if you're allowing anonymous access.

Try granting access permissions to the appropiate account, as outlined above.

If you are still having problems after that, and you're impersonating some account,
save this code as "identity.aspx" and run it :

identity.aspx
========

<%@ Page Language="VB" %>
<%@ Import NameSpace = System.Security.Principal %>
<script runat="server">
Sub Page_Load()
Dim tmp As String = WindowsIdentity.GetCurrent.Name()
Label1.Text = tmp
End Sub
</script>
<html>
<head>
<title>WindowsIdentity.GetCurrent.Name()</title>
</head>
<body>
<form id="form1" runat="server">
<div>
<asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
</div>
</form>
</body>
</html>
======

Running that file will tell you which account ASP.NET is running as.
Then, assign the appropiate permissions to that account.

Also, download and run Denis Bauer's ASP.NET Version Switcher,
and make sure that you're actually running 1.1 apps against the
1.1 .Net Framework and 2.0 apps against .Net Framework 2.0.

http://www.denisbauer.com/NETTools/A...nSwitcher.aspx


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message news:uT**************@TK2MSFTNGP04.phx.gbl...
Hi All!

I have a ASP.NET 2.0 site that works on the Windows 2000 Server. However, when I tried to view
this site on my local Windows XP machine, I get "Server Unavailable". If I switch the Windows XP
IIS back to ASP.NET 1.1 then I get the Configuration Error (which is understandable because I'm
trying to run an ASP.NET 2 site with 1.1 framework).

I can however view other ASP.NET 1.1 sites on my local Windows XP machine. It's only the problem
with

I've also tried the aspnet_regiis thing as well as setting permissions on folders as described in
this article:
http://support.microsoft.com/default.aspx?kbid=811320
but no solution.

In the event log, I see these three errors every I tried to view my ASP.NET 2.0 site on my local
machine...

<errors>

1.) .aspnet_wp.exe (PID: 3988) stopped unexpectedly

2.) Failed to execute the request because the ASP.NET process identity does not have read
permissions to the global assembly cache. Error: 0x80131902

3.) Failed to initialize the AppDomain:/LM/W3SVC/1/Root

Exception: System.Configuration.ConfigurationErrorsException

Message: Exception of type 'System.Configuration.ConfigurationErrorsException ' was thrown.

</errors>

What could be the problem?!?!?!? Plz, any solutions or pointers to solutions are much
appreciated!!!

Thank you all in advance!!!

Jon

Apr 23 '06 #2

P: n/a
Hi Juan,

Thanks for the reply. I've set permission to all the folders and everything
but still it doesn't work.

I've also tried the "Denis Bauer's ASP.NET Version Switcher" but that
doesn't help either.

Any other ideas?

Cheers,
Jon B

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:u5**************@TK2MSFTNGP02.phx.gbl...
If you're running on Windows XP, the account which needs permissions is
MACHINENAME\ASPNET...even if you're allowing anonymous access.

Try granting access permissions to the appropiate account, as outlined
above.

If you are still having problems after that, and you're impersonating some
account,
save this code as "identity.aspx" and run it :

identity.aspx
========

<%@ Page Language="VB" %>
<%@ Import NameSpace = System.Security.Principal %>
<script runat="server">
Sub Page_Load()
Dim tmp As String = WindowsIdentity.GetCurrent.Name()
Label1.Text = tmp
End Sub
</script>
<html>
<head>
<title>WindowsIdentity.GetCurrent.Name()</title>
</head>
<body>
<form id="form1" runat="server">
<div>
<asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
</div>
</form>
</body>
</html>
======

Running that file will tell you which account ASP.NET is running as.
Then, assign the appropiate permissions to that account.

Also, download and run Denis Bauer's ASP.NET Version Switcher,
and make sure that you're actually running 1.1 apps against the
1.1 .Net Framework and 2.0 apps against .Net Framework 2.0.

http://www.denisbauer.com/NETTools/A...nSwitcher.aspx


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message
news:uT**************@TK2MSFTNGP04.phx.gbl...
Hi All!

I have a ASP.NET 2.0 site that works on the Windows 2000 Server. However,
when I tried to view this site on my local Windows XP machine, I get
"Server Unavailable". If I switch the Windows XP IIS back to ASP.NET 1.1
then I get the Configuration Error (which is understandable because I'm
trying to run an ASP.NET 2 site with 1.1 framework).

I can however view other ASP.NET 1.1 sites on my local Windows XP
machine. It's only the problem with

I've also tried the aspnet_regiis thing as well as setting permissions on
folders as described in this article:
http://support.microsoft.com/default.aspx?kbid=811320
but no solution.

In the event log, I see these three errors every I tried to view my
ASP.NET 2.0 site on my local machine...

<errors>

1.) .aspnet_wp.exe (PID: 3988) stopped unexpectedly

2.) Failed to execute the request because the ASP.NET process identity
does not have read permissions to the global assembly cache. Error:
0x80131902

3.) Failed to initialize the AppDomain:/LM/W3SVC/1/Root

Exception: System.Configuration.ConfigurationErrorsException

Message: Exception of type
'System.Configuration.ConfigurationErrorsException ' was thrown.

</errors>

What could be the problem?!?!?!? Plz, any solutions or pointers to
solutions are much appreciated!!!

Thank you all in advance!!!

Jon


Apr 25 '06 #3

P: n/a
Are you still getting this error ?
2.) Failed to execute the request because the ASP.NET process identity does not have read
permissions to the global assembly cache. Error: 0x80131902

Did you run "identity.aspx", which I provided for you ?
Which user account was returned by it ?

How did you run the example command provided by the KB ?

cacls %windir%\assembly /e /t /p domain\useraccount:R

?

Have you read this article :
http://msdn.microsoft.com/library/de...aght000009.asp

?

Please review the steps in it, for creating a service account for an ASP.NET 2.0 application,
and make sure that the account retrned by "identity.aspx" has all the permissions
listed in that article.

In particular, make sure you run the following aspnet_regiis command :

aspnet_regiis -ga MachineName\AccountName

where "MachineName\AccountName" is the account returned by "identity.aspx".

Then post back your results.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message news:uA**************@TK2MSFTNGP03.phx.gbl... Hi Juan,

Thanks for the reply. I've set permission to all the folders and everything but still it doesn't
work.

I've also tried the "Denis Bauer's ASP.NET Version Switcher" but that doesn't help either.

Any other ideas?

Cheers,
Jon B

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:u5**************@TK2MSFTNGP02.phx.gbl...
If you're running on Windows XP, the account which needs permissions is
MACHINENAME\ASPNET...even if you're allowing anonymous access.

Try granting access permissions to the appropiate account, as outlined above.

If you are still having problems after that, and you're impersonating some account,
save this code as "identity.aspx" and run it :

identity.aspx
========

<%@ Page Language="VB" %>
<%@ Import NameSpace = System.Security.Principal %>
<script runat="server">
Sub Page_Load()
Dim tmp As String = WindowsIdentity.GetCurrent.Name()
Label1.Text = tmp
End Sub
</script>
<html>
<head>
<title>WindowsIdentity.GetCurrent.Name()</title>
</head>
<body>
<form id="form1" runat="server">
<div>
<asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
</div>
</form>
</body>
</html>
======

Running that file will tell you which account ASP.NET is running as.
Then, assign the appropiate permissions to that account.

Also, download and run Denis Bauer's ASP.NET Version Switcher,
and make sure that you're actually running 1.1 apps against the
1.1 .Net Framework and 2.0 apps against .Net Framework 2.0.

http://www.denisbauer.com/NETTools/A...nSwitcher.aspx


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message news:uT**************@TK2MSFTNGP04.phx.gbl...
Hi All!

I have a ASP.NET 2.0 site that works on the Windows 2000 Server. However, when I tried to view
this site on my local Windows XP machine, I get "Server Unavailable". If I switch the Windows XP
IIS back to ASP.NET 1.1 then I get the Configuration Error (which is understandable because I'm
trying to run an ASP.NET 2 site with 1.1 framework).

I can however view other ASP.NET 1.1 sites on my local Windows XP machine. It's only the problem
with

I've also tried the aspnet_regiis thing as well as setting permissions on folders as described
in this article:
http://support.microsoft.com/default.aspx?kbid=811320
but no solution.

In the event log, I see these three errors every I tried to view my ASP.NET 2.0 site on my local
machine...

<errors>

1.) .aspnet_wp.exe (PID: 3988) stopped unexpectedly

2.) Failed to execute the request because the ASP.NET process identity does not have read
permissions to the global assembly cache. Error: 0x80131902

3.) Failed to initialize the AppDomain:/LM/W3SVC/1/Root

Exception: System.Configuration.ConfigurationErrorsException

Message: Exception of type 'System.Configuration.ConfigurationErrorsException ' was thrown.

</errors>

What could be the problem?!?!?!? Plz, any solutions or pointers to solutions are much
appreciated!!!

Thank you all in advance!!!

Jon


Apr 25 '06 #4

P: n/a
Hi Juan,

The thing is, I cannot execute any ASP.NET pages. Even your Identity.aspx
page. I keep on getting the "Server Unavailable" error. That is of course,
in ASP.NET 2. However, when I tried with ASP.NET 1.1, I get...

HOME-WKSTATION\ASPNET

I ran the examples in KBs ***exactly*** the way it presented (with the
substitue of the variables of course).

And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of the
article you've provided me was about ASP.NET 2.0 with IIS6).

Another interesting thing is when I tried to do aspnet_regiis -ga
HOME-WKSTATION\ASPNET under v2.0.50215 folder (as described in the article),
I get "Invalid Command" and a list of switches that aspnet_regiis accepts,
which does not contains a 'ga' switch.

Plz help...

Henry

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:eF**************@TK2MSFTNGP02.phx.gbl...
Are you still getting this error ?
2.) Failed to execute the request because the ASP.NET process identity
does not have read
permissions to the global assembly cache. Error: 0x80131902


Did you run "identity.aspx", which I provided for you ?
Which user account was returned by it ?

How did you run the example command provided by the KB ?

cacls %windir%\assembly /e /t /p domain\useraccount:R

?

Have you read this article :
http://msdn.microsoft.com/library/de...aght000009.asp

?

Please review the steps in it, for creating a service account for an
ASP.NET 2.0 application,
and make sure that the account retrned by "identity.aspx" has all the
permissions
listed in that article.

In particular, make sure you run the following aspnet_regiis command :

aspnet_regiis -ga MachineName\AccountName

where "MachineName\AccountName" is the account returned by
"identity.aspx".

Then post back your results.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message
news:uA**************@TK2MSFTNGP03.phx.gbl...
Hi Juan,

Thanks for the reply. I've set permission to all the folders and
everything but still it doesn't
work.

I've also tried the "Denis Bauer's ASP.NET Version Switcher" but that
doesn't help either.

Any other ideas?

Cheers,
Jon B

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:u5**************@TK2MSFTNGP02.phx.gbl...
If you're running on Windows XP, the account which needs permissions is
MACHINENAME\ASPNET...even if you're allowing anonymous access.

Try granting access permissions to the appropiate account, as outlined
above.

If you are still having problems after that, and you're impersonating
some account,
save this code as "identity.aspx" and run it :

identity.aspx
========

<%@ Page Language="VB" %>
<%@ Import NameSpace = System.Security.Principal %>
<script runat="server">
Sub Page_Load()
Dim tmp As String = WindowsIdentity.GetCurrent.Name()
Label1.Text = tmp
End Sub
</script>
<html>
<head>
<title>WindowsIdentity.GetCurrent.Name()</title>
</head>
<body>
<form id="form1" runat="server">
<div>
<asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
</div>
</form>
</body>
</html>
======

Running that file will tell you which account ASP.NET is running as.
Then, assign the appropiate permissions to that account.

Also, download and run Denis Bauer's ASP.NET Version Switcher,
and make sure that you're actually running 1.1 apps against the
1.1 .Net Framework and 2.0 apps against .Net Framework 2.0.

http://www.denisbauer.com/NETTools/A...nSwitcher.aspx


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message
news:uT**************@TK2MSFTNGP04.phx.gbl...
Hi All!

I have a ASP.NET 2.0 site that works on the Windows 2000 Server.
However, when I tried to view
this site on my local Windows XP machine, I get "Server Unavailable".
If I switch the Windows XP
IIS back to ASP.NET 1.1 then I get the Configuration Error (which is
understandable because I'm
trying to run an ASP.NET 2 site with 1.1 framework).

I can however view other ASP.NET 1.1 sites on my local Windows XP
machine. It's only the problem
with

I've also tried the aspnet_regiis thing as well as setting permissions
on folders as described
in this article:
http://support.microsoft.com/default.aspx?kbid=811320
but no solution.

In the event log, I see these three errors every I tried to view my
ASP.NET 2.0 site on my local
machine...

<errors>

1.) .aspnet_wp.exe (PID: 3988) stopped unexpectedly

2.) Failed to execute the request because the ASP.NET process identity
does not have read
permissions to the global assembly cache. Error: 0x80131902

3.) Failed to initialize the AppDomain:/LM/W3SVC/1/Root

Exception: System.Configuration.ConfigurationErrorsException

Message: Exception of type
'System.Configuration.ConfigurationErrorsException ' was thrown.

</errors>

What could be the problem?!?!?!? Plz, any solutions or pointers to
solutions are much
appreciated!!!

Thank you all in advance!!!

Jon


Apr 29 '06 #5

P: n/a
Hi, Jon.

re:
Another interesting thing is when I tried to do aspnet_regiis -ga HOME-WKSTATION\ASPNET under
v2.0.50215 folder (as described in the article), I get "Invalid Command"
....there's your problem.

v2.0.50215 is the beta 2 version of the .Net Framework...which has many bugs.
The -ga command isn't a part of that beta version.

The released version of the .Net Framework is v2.0.50727.42

Uninstall that beta version and download/install -at least- the 2.0 redistributable :
http://www.microsoft.com/downloads/d...displaylang=en

You might want to -instead- download/install the full SDK from :
http://www.microsoft.com/downloads/d...displaylang=en

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message news:Oj**************@TK2MSFTNGP04.phx.gbl... Hi Juan,

The thing is, I cannot execute any ASP.NET pages. Even your Identity.aspx page. I keep on getting
the "Server Unavailable" error. That is of course, in ASP.NET 2. However, when I tried with
ASP.NET 1.1, I get...

HOME-WKSTATION\ASPNET

I ran the examples in KBs ***exactly*** the way it presented (with the substitue of the variables
of course).

And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of the article you've provided
me was about ASP.NET 2.0 with IIS6).

Another interesting thing is when I tried to do aspnet_regiis -ga HOME-WKSTATION\ASPNET under
v2.0.50215 folder (as described in the article), I get "Invalid Command" and a list of switches
that aspnet_regiis accepts, which does not contains a 'ga' switch.

Plz help...

Henry "Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:eF**************@TK2MSFTNGP02.phx.gbl...
Are you still getting this error ?
2.) Failed to execute the request because the ASP.NET process identity does not have read
permissions to the global assembly cache. Error: 0x80131902


Did you run "identity.aspx", which I provided for you ?
Which user account was returned by it ?

How did you run the example command provided by the KB ?

cacls %windir%\assembly /e /t /p domain\useraccount:R

?

Have you read this article :
http://msdn.microsoft.com/library/de...aght000009.asp

?

Please review the steps in it, for creating a service account for an ASP.NET 2.0 application,
and make sure that the account retrned by "identity.aspx" has all the permissions
listed in that article.

In particular, make sure you run the following aspnet_regiis command :

aspnet_regiis -ga MachineName\AccountName

where "MachineName\AccountName" is the account returned by "identity.aspx".

Then post back your results.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message news:uA**************@TK2MSFTNGP03.phx.gbl...
Hi Juan,

Thanks for the reply. I've set permission to all the folders and everything but still it doesn't
work.

I've also tried the "Denis Bauer's ASP.NET Version Switcher" but that doesn't help either.

Any other ideas?

Cheers,
Jon B

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:u5**************@TK2MSFTNGP02.phx.gbl...
If you're running on Windows XP, the account which needs permissions is
MACHINENAME\ASPNET...even if you're allowing anonymous access.

Try granting access permissions to the appropiate account, as outlined above.

If you are still having problems after that, and you're impersonating some account,
save this code as "identity.aspx" and run it :

identity.aspx
========

<%@ Page Language="VB" %>
<%@ Import NameSpace = System.Security.Principal %>
<script runat="server">
Sub Page_Load()
Dim tmp As String = WindowsIdentity.GetCurrent.Name()
Label1.Text = tmp
End Sub
</script>
<html>
<head>
<title>WindowsIdentity.GetCurrent.Name()</title>
</head>
<body>
<form id="form1" runat="server">
<div>
<asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
</div>
</form>
</body>
</html>
======

Running that file will tell you which account ASP.NET is running as.
Then, assign the appropiate permissions to that account.

Also, download and run Denis Bauer's ASP.NET Version Switcher,
and make sure that you're actually running 1.1 apps against the
1.1 .Net Framework and 2.0 apps against .Net Framework 2.0.

http://www.denisbauer.com/NETTools/A...nSwitcher.aspx


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message news:uT**************@TK2MSFTNGP04.phx.gbl...
> Hi All!
>
> I have a ASP.NET 2.0 site that works on the Windows 2000 Server. However, when I tried to view
> this site on my local Windows XP machine, I get "Server Unavailable". If I switch the Windows
> XP
> IIS back to ASP.NET 1.1 then I get the Configuration Error (which is understandable because
> I'm
> trying to run an ASP.NET 2 site with 1.1 framework).
>
> I can however view other ASP.NET 1.1 sites on my local Windows XP machine. It's only the
> problem
> with
>
> I've also tried the aspnet_regiis thing as well as setting permissions on folders as described
> in this article:
> http://support.microsoft.com/default.aspx?kbid=811320
> but no solution.
>
> In the event log, I see these three errors every I tried to view my ASP.NET 2.0 site on my
> local
> machine...
>
> <errors>
>
> 1.) .aspnet_wp.exe (PID: 3988) stopped unexpectedly
>
> 2.) Failed to execute the request because the ASP.NET process identity does not have read
> permissions to the global assembly cache. Error: 0x80131902
>
> 3.) Failed to initialize the AppDomain:/LM/W3SVC/1/Root
>
> Exception: System.Configuration.ConfigurationErrorsException
>
> Message: Exception of type 'System.Configuration.ConfigurationErrorsException ' was thrown.
>
> </errors>
>
> What could be the problem?!?!?!? Plz, any solutions or pointers to solutions are much
> appreciated!!!
>
> Thank you all in advance!!!
>
> Jon



Apr 29 '06 #6

P: n/a
Hi Juan,

Thanks for the reply. I have the latest version in following folder...

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

So I switched to that directory in Command Prompt and tried the following...

aspnet_regiis -ga HOME-WKSTATION\ASPNET

Command worked. However, I'm still getting the "Server Unavailable" error...

Thanks again.

Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:eW**************@TK2MSFTNGP05.phx.gbl...
Hi, Jon.

re:
Another interesting thing is when I tried to do aspnet_regiis -ga
HOME-WKSTATION\ASPNET under v2.0.50215 folder (as described in the
article), I get "Invalid Command"


...there's your problem.

v2.0.50215 is the beta 2 version of the .Net Framework...which has many
bugs.
The -ga command isn't a part of that beta version.

The released version of the .Net Framework is v2.0.50727.42

Uninstall that beta version and download/install -at least- the 2.0
redistributable :
http://www.microsoft.com/downloads/d...displaylang=en

You might want to -instead- download/install the full SDK from :
http://www.microsoft.com/downloads/d...displaylang=en

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message
news:Oj**************@TK2MSFTNGP04.phx.gbl...
Hi Juan,

The thing is, I cannot execute any ASP.NET pages. Even your Identity.aspx
page. I keep on getting the "Server Unavailable" error. That is of
course, in ASP.NET 2. However, when I tried with ASP.NET 1.1, I get...

HOME-WKSTATION\ASPNET

I ran the examples in KBs ***exactly*** the way it presented (with the
substitue of the variables of course).

And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of the
article you've provided me was about ASP.NET 2.0 with IIS6).

Another interesting thing is when I tried to do aspnet_regiis -ga
HOME-WKSTATION\ASPNET under v2.0.50215 folder (as described in the
article), I get "Invalid Command" and a list of switches that
aspnet_regiis accepts, which does not contains a 'ga' switch.

Plz help...

Henry

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:eF**************@TK2MSFTNGP02.phx.gbl...
Are you still getting this error ?

> 2.) Failed to execute the request because the ASP.NET process
> identity does not have read
> permissions to the global assembly cache. Error: 0x80131902

Did you run "identity.aspx", which I provided for you ?
Which user account was returned by it ?

How did you run the example command provided by the KB ?

cacls %windir%\assembly /e /t /p domain\useraccount:R

?

Have you read this article :
http://msdn.microsoft.com/library/de...aght000009.asp

?

Please review the steps in it, for creating a service account for an
ASP.NET 2.0 application,
and make sure that the account retrned by "identity.aspx" has all the
permissions
listed in that article.

In particular, make sure you run the following aspnet_regiis command :

aspnet_regiis -ga MachineName\AccountName

where "MachineName\AccountName" is the account returned by
"identity.aspx".

Then post back your results.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message
news:uA**************@TK2MSFTNGP03.phx.gbl...
Hi Juan,

Thanks for the reply. I've set permission to all the folders and
everything but still it doesn't
work.

I've also tried the "Denis Bauer's ASP.NET Version Switcher" but that
doesn't help either.

Any other ideas?

Cheers,
Jon B

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:u5**************@TK2MSFTNGP02.phx.gbl...
> If you're running on Windows XP, the account which needs permissions
> is
> MACHINENAME\ASPNET...even if you're allowing anonymous access.
>
> Try granting access permissions to the appropiate account, as outlined
> above.
>
> If you are still having problems after that, and you're impersonating
> some account,
> save this code as "identity.aspx" and run it :
>
> identity.aspx
> ========
>
> <%@ Page Language="VB" %>
> <%@ Import NameSpace = System.Security.Principal %>
> <script runat="server">
> Sub Page_Load()
> Dim tmp As String = WindowsIdentity.GetCurrent.Name()
> Label1.Text = tmp
> End Sub
> </script>
> <html>
> <head>
> <title>WindowsIdentity.GetCurrent.Name()</title>
> </head>
> <body>
> <form id="form1" runat="server">
> <div>
> <asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
> </div>
> </form>
> </body>
> </html>
> ======
>
> Running that file will tell you which account ASP.NET is running as.
> Then, assign the appropiate permissions to that account.
>
> Also, download and run Denis Bauer's ASP.NET Version Switcher,
> and make sure that you're actually running 1.1 apps against the
> 1.1 .Net Framework and 2.0 apps against .Net Framework 2.0.
>
> http://www.denisbauer.com/NETTools/A...nSwitcher.aspx
>
>
>
>
> Juan T. Llibre, asp.net MVP
> aspnetfaq.com : http://www.aspnetfaq.com/
> asp.net faq : http://asp.net.do/faq/
> foros de asp.net, en espaņol : http://asp.net.do/foros/
> ===================================
> "Jon B" <no*****@sorry.sorry> wrote in message
> news:uT**************@TK2MSFTNGP04.phx.gbl...
>> Hi All!
>>
>> I have a ASP.NET 2.0 site that works on the Windows 2000 Server.
>> However, when I tried to view
>> this site on my local Windows XP machine, I get "Server Unavailable".
>> If I switch the Windows XP
>> IIS back to ASP.NET 1.1 then I get the Configuration Error (which is
>> understandable because I'm
>> trying to run an ASP.NET 2 site with 1.1 framework).
>>
>> I can however view other ASP.NET 1.1 sites on my local Windows XP
>> machine. It's only the problem
>> with
>>
>> I've also tried the aspnet_regiis thing as well as setting
>> permissions on folders as described
>> in this article:
>> http://support.microsoft.com/default.aspx?kbid=811320
>> but no solution.
>>
>> In the event log, I see these three errors every I tried to view my
>> ASP.NET 2.0 site on my local
>> machine...
>>
>> <errors>
>>
>> 1.) .aspnet_wp.exe (PID: 3988) stopped unexpectedly
>>
>> 2.) Failed to execute the request because the ASP.NET process
>> identity does not have read
>> permissions to the global assembly cache. Error: 0x80131902
>>
>> 3.) Failed to initialize the AppDomain:/LM/W3SVC/1/Root
>>
>> Exception: System.Configuration.ConfigurationErrorsException
>>
>> Message: Exception of type
>> 'System.Configuration.ConfigurationErrorsException ' was thrown.
>>
>> </errors>
>>
>> What could be the problem?!?!?!? Plz, any solutions or pointers to
>> solutions are much
>> appreciated!!!
>>
>> Thank you all in advance!!!
>>
>> Jon



Apr 29 '06 #7

P: n/a
re;
Command worked. However, I'm still getting the "Server Unavailable" error...
OK...

re: And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of the article you've provided
me was about ASP.NET 2.0 with IIS6).
Nevertheless, the article is valid for IIS 5.1 ( which is what you're running, not 5.0 )
and ASP.NET 2.0, as long as you disregard the Application Pool info.

Please review the permissions outlined in this article.
They were written for ASP.NET 1.1, but they are just as valid for ASP.NET 2.0:

http://msdn.microsoft.com/library/de...secnetht01.asp

Make sure that the HOME-WKSTATION\ASPNET account has been assigned NTFS
permissions to all the directories listed in the chart, making sure, of course, that the proper
directory ( \WINDOWS\Microsoft.NET\Framework\v2.0.50727 ) is checked.

Make sure you read the instructions in the "Comments" column.
*All* the directories listed in the left-most column need the correct NTFS permissions applied.

When you're done doing that, test and post your results.



Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message news:uf**************@TK2MSFTNGP02.phx.gbl... Hi Juan,

Thanks for the reply. I have the latest version in following folder...

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

So I switched to that directory in Command Prompt and tried the following...

aspnet_regiis -ga HOME-WKSTATION\ASPNET

Command worked. However, I'm still getting the "Server Unavailable" error...

Thanks again.

Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:eW**************@TK2MSFTNGP05.phx.gbl...
Hi, Jon.

re:
Another interesting thing is when I tried to do aspnet_regiis -ga HOME-WKSTATION\ASPNET under
v2.0.50215 folder (as described in the article), I get "Invalid Command"


...there's your problem.

v2.0.50215 is the beta 2 version of the .Net Framework...which has many bugs.
The -ga command isn't a part of that beta version.

The released version of the .Net Framework is v2.0.50727.42

Uninstall that beta version and download/install -at least- the 2.0 redistributable :
http://www.microsoft.com/downloads/d...displaylang=en

You might want to -instead- download/install the full SDK from :
http://www.microsoft.com/downloads/d...displaylang=en

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message news:Oj**************@TK2MSFTNGP04.phx.gbl...
Hi Juan,

The thing is, I cannot execute any ASP.NET pages. Even your Identity.aspx page. I keep on
getting the "Server Unavailable" error. That is of course, in ASP.NET 2. However, when I tried
with ASP.NET 1.1, I get...

HOME-WKSTATION\ASPNET

I ran the examples in KBs ***exactly*** the way it presented (with the substitue of the
variables of course).

And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of the article you've provided
me was about ASP.NET 2.0 with IIS6).

Another interesting thing is when I tried to do aspnet_regiis -ga HOME-WKSTATION\ASPNET under
v2.0.50215 folder (as described in the article), I get "Invalid Command" and a list of switches
that aspnet_regiis accepts, which does not contains a 'ga' switch.

Plz help...

Henry

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:eF**************@TK2MSFTNGP02.phx.gbl...
Are you still getting this error ?

>> 2.) Failed to execute the request because the ASP.NET process identity does not have read
>> permissions to the global assembly cache. Error: 0x80131902

Did you run "identity.aspx", which I provided for you ?
Which user account was returned by it ?

How did you run the example command provided by the KB ?

cacls %windir%\assembly /e /t /p domain\useraccount:R

?

Have you read this article :
http://msdn.microsoft.com/library/de...aght000009.asp

?

Please review the steps in it, for creating a service account for an ASP.NET 2.0 application,
and make sure that the account retrned by "identity.aspx" has all the permissions
listed in that article.

In particular, make sure you run the following aspnet_regiis command :

aspnet_regiis -ga MachineName\AccountName

where "MachineName\AccountName" is the account returned by "identity.aspx".

Then post back your results.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message news:uA**************@TK2MSFTNGP03.phx.gbl...
> Hi Juan,
>
> Thanks for the reply. I've set permission to all the folders and everything but still it
> doesn't
> work.
>
> I've also tried the "Denis Bauer's ASP.NET Version Switcher" but that doesn't help either.
>
> Any other ideas?
>
> Cheers,
> Jon B
>
> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
> news:u5**************@TK2MSFTNGP02.phx.gbl...
>> If you're running on Windows XP, the account which needs permissions is
>> MACHINENAME\ASPNET...even if you're allowing anonymous access.
>>
>> Try granting access permissions to the appropiate account, as outlined above.
>>
>> If you are still having problems after that, and you're impersonating some account,
>> save this code as "identity.aspx" and run it :
>>
>> identity.aspx
>> ========
>>
>> <%@ Page Language="VB" %>
>> <%@ Import NameSpace = System.Security.Principal %>
>> <script runat="server">
>> Sub Page_Load()
>> Dim tmp As String = WindowsIdentity.GetCurrent.Name()
>> Label1.Text = tmp
>> End Sub
>> </script>
>> <html>
>> <head>
>> <title>WindowsIdentity.GetCurrent.Name()</title>
>> </head>
>> <body>
>> <form id="form1" runat="server">
>> <div>
>> <asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
>> </div>
>> </form>
>> </body>
>> </html>
>> ======
>>
>> Running that file will tell you which account ASP.NET is running as.
>> Then, assign the appropiate permissions to that account.
>>
>> Also, download and run Denis Bauer's ASP.NET Version Switcher,
>> and make sure that you're actually running 1.1 apps against the
>> 1.1 .Net Framework and 2.0 apps against .Net Framework 2.0.
>>
>> http://www.denisbauer.com/NETTools/A...nSwitcher.aspx
>>
>>
>>
>>
>> Juan T. Llibre, asp.net MVP
>> aspnetfaq.com : http://www.aspnetfaq.com/
>> asp.net faq : http://asp.net.do/faq/
>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>> ===================================
>> "Jon B" <no*****@sorry.sorry> wrote in message news:uT**************@TK2MSFTNGP04.phx.gbl...
>>> Hi All!
>>>
>>> I have a ASP.NET 2.0 site that works on the Windows 2000 Server. However, when I tried to
>>> view
>>> this site on my local Windows XP machine, I get "Server Unavailable". If I switch the
>>> Windows XP
>>> IIS back to ASP.NET 1.1 then I get the Configuration Error (which is understandable because
>>> I'm
>>> trying to run an ASP.NET 2 site with 1.1 framework).
>>>
>>> I can however view other ASP.NET 1.1 sites on my local Windows XP machine. It's only the
>>> problem
>>> with
>>>
>>> I've also tried the aspnet_regiis thing as well as setting permissions on folders as
>>> described
>>> in this article:
>>> http://support.microsoft.com/default.aspx?kbid=811320
>>> but no solution.
>>>
>>> In the event log, I see these three errors every I tried to view my ASP.NET 2.0 site on my
>>> local
>>> machine...
>>>
>>> <errors>
>>>
>>> 1.) .aspnet_wp.exe (PID: 3988) stopped unexpectedly
>>>
>>> 2.) Failed to execute the request because the ASP.NET process identity does not have read
>>> permissions to the global assembly cache. Error: 0x80131902
>>>
>>> 3.) Failed to initialize the AppDomain:/LM/W3SVC/1/Root
>>>
>>> Exception: System.Configuration.ConfigurationErrorsException
>>>
>>> Message: Exception of type 'System.Configuration.ConfigurationErrorsException ' was thrown.
>>>
>>> </errors>
>>>
>>> What could be the problem?!?!?!? Plz, any solutions or pointers to solutions are much
>>> appreciated!!!
>>>
>>> Thank you all in advance!!!
>>>
>>> Jon




Apr 29 '06 #8

P: n/a
One more thing...

Is the error message "Server Application Unavailable" or is it "Server Unavailable" ?

Could you look in the event log, and see what additional info is
there about your "Server Application Unavailable" error message ?

Look in "Start Menu", "Programs", "Administrative Tools", "Event Viewer".
You should be able to find the specific error in the Application log.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
re;
Command worked. However, I'm still getting the "Server Unavailable" error...


OK...

re:
And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of the article you've provided
me was about ASP.NET 2.0 with IIS6).


Nevertheless, the article is valid for IIS 5.1 ( which is what you're running, not 5.0 )
and ASP.NET 2.0, as long as you disregard the Application Pool info.

Please review the permissions outlined in this article.
They were written for ASP.NET 1.1, but they are just as valid for ASP.NET 2.0:

http://msdn.microsoft.com/library/de...secnetht01.asp

Make sure that the HOME-WKSTATION\ASPNET account has been assigned NTFS
permissions to all the directories listed in the chart, making sure, of course, that the proper
directory ( \WINDOWS\Microsoft.NET\Framework\v2.0.50727 ) is checked.

Make sure you read the instructions in the "Comments" column.
*All* the directories listed in the left-most column need the correct NTFS permissions applied.

When you're done doing that, test and post your results.



Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message news:uf**************@TK2MSFTNGP02.phx.gbl...
Hi Juan,

Thanks for the reply. I have the latest version in following folder...

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

So I switched to that directory in Command Prompt and tried the following...

aspnet_regiis -ga HOME-WKSTATION\ASPNET

Command worked. However, I'm still getting the "Server Unavailable" error...

Thanks again.

Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:eW**************@TK2MSFTNGP05.phx.gbl...
Hi, Jon.

re:
Another interesting thing is when I tried to do aspnet_regiis -ga HOME-WKSTATION\ASPNET under
v2.0.50215 folder (as described in the article), I get "Invalid Command"

...there's your problem.

v2.0.50215 is the beta 2 version of the .Net Framework...which has many bugs.
The -ga command isn't a part of that beta version.

The released version of the .Net Framework is v2.0.50727.42

Uninstall that beta version and download/install -at least- the 2.0 redistributable :
http://www.microsoft.com/downloads/d...displaylang=en

You might want to -instead- download/install the full SDK from :
http://www.microsoft.com/downloads/d...displaylang=en

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message news:Oj**************@TK2MSFTNGP04.phx.gbl...
Hi Juan,

The thing is, I cannot execute any ASP.NET pages. Even your Identity.aspx page. I keep on
getting the "Server Unavailable" error. That is of course, in ASP.NET 2. However, when I tried
with ASP.NET 1.1, I get...

HOME-WKSTATION\ASPNET

I ran the examples in KBs ***exactly*** the way it presented (with the substitue of the
variables of course).

And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of the article you've
provided me was about ASP.NET 2.0 with IIS6).

Another interesting thing is when I tried to do aspnet_regiis -ga HOME-WKSTATION\ASPNET under
v2.0.50215 folder (as described in the article), I get "Invalid Command" and a list of switches
that aspnet_regiis accepts, which does not contains a 'ga' switch.

Plz help...

Henry

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:eF**************@TK2MSFTNGP02.phx.gbl...
> Are you still getting this error ?
>
>>> 2.) Failed to execute the request because the ASP.NET process identity does not have read
>>> permissions to the global assembly cache. Error: 0x80131902
>
> Did you run "identity.aspx", which I provided for you ?
> Which user account was returned by it ?
>
> How did you run the example command provided by the KB ?
>
> cacls %windir%\assembly /e /t /p domain\useraccount:R
>
> ?
>
> Have you read this article :
> http://msdn.microsoft.com/library/de...aght000009.asp
>
> ?
>
> Please review the steps in it, for creating a service account for an ASP.NET 2.0 application,
> and make sure that the account retrned by "identity.aspx" has all the permissions
> listed in that article.
>
> In particular, make sure you run the following aspnet_regiis command :
>
> aspnet_regiis -ga MachineName\AccountName
>
> where "MachineName\AccountName" is the account returned by "identity.aspx".
>
> Then post back your results.
>
>
>
>
> Juan T. Llibre, asp.net MVP
> aspnetfaq.com : http://www.aspnetfaq.com/
> asp.net faq : http://asp.net.do/faq/
> foros de asp.net, en espaņol : http://asp.net.do/foros/
> ===================================
> "Jon B" <no*****@sorry.sorry> wrote in message news:uA**************@TK2MSFTNGP03.phx.gbl...
>> Hi Juan,
>>
>> Thanks for the reply. I've set permission to all the folders and everything but still it
>> doesn't
>> work.
>>
>> I've also tried the "Denis Bauer's ASP.NET Version Switcher" but that doesn't help either.
>>
>> Any other ideas?
>>
>> Cheers,
>> Jon B
>>
>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>> news:u5**************@TK2MSFTNGP02.phx.gbl...
>>> If you're running on Windows XP, the account which needs permissions is
>>> MACHINENAME\ASPNET...even if you're allowing anonymous access.
>>>
>>> Try granting access permissions to the appropiate account, as outlined above.
>>>
>>> If you are still having problems after that, and you're impersonating some account,
>>> save this code as "identity.aspx" and run it :
>>>
>>> identity.aspx
>>> ========
>>>
>>> <%@ Page Language="VB" %>
>>> <%@ Import NameSpace = System.Security.Principal %>
>>> <script runat="server">
>>> Sub Page_Load()
>>> Dim tmp As String = WindowsIdentity.GetCurrent.Name()
>>> Label1.Text = tmp
>>> End Sub
>>> </script>
>>> <html>
>>> <head>
>>> <title>WindowsIdentity.GetCurrent.Name()</title>
>>> </head>
>>> <body>
>>> <form id="form1" runat="server">
>>> <div>
>>> <asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
>>> </div>
>>> </form>
>>> </body>
>>> </html>
>>> ======
>>>
>>> Running that file will tell you which account ASP.NET is running as.
>>> Then, assign the appropiate permissions to that account.
>>>
>>> Also, download and run Denis Bauer's ASP.NET Version Switcher,
>>> and make sure that you're actually running 1.1 apps against the
>>> 1.1 .Net Framework and 2.0 apps against .Net Framework 2.0.
>>>
>>> http://www.denisbauer.com/NETTools/A...nSwitcher.aspx
>>>
>>>
>>>
>>>
>>> Juan T. Llibre, asp.net MVP
>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>> asp.net faq : http://asp.net.do/faq/
>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>> ===================================
>>> "Jon B" <no*****@sorry.sorry> wrote in message news:uT**************@TK2MSFTNGP04.phx.gbl...
>>>> Hi All!
>>>>
>>>> I have a ASP.NET 2.0 site that works on the Windows 2000 Server. However, when I tried to
>>>> view
>>>> this site on my local Windows XP machine, I get "Server Unavailable". If I switch the
>>>> Windows XP
>>>> IIS back to ASP.NET 1.1 then I get the Configuration Error (which is understandable because
>>>> I'm
>>>> trying to run an ASP.NET 2 site with 1.1 framework).
>>>>
>>>> I can however view other ASP.NET 1.1 sites on my local Windows XP machine. It's only the
>>>> problem
>>>> with
>>>>
>>>> I've also tried the aspnet_regiis thing as well as setting permissions on folders as
>>>> described
>>>> in this article:
>>>> http://support.microsoft.com/default.aspx?kbid=811320
>>>> but no solution.
>>>>
>>>> In the event log, I see these three errors every I tried to view my ASP.NET 2.0 site on my
>>>> local
>>>> machine...
>>>>
>>>> <errors>
>>>>
>>>> 1.) .aspnet_wp.exe (PID: 3988) stopped unexpectedly
>>>>
>>>> 2.) Failed to execute the request because the ASP.NET process identity does not have read
>>>> permissions to the global assembly cache. Error: 0x80131902
>>>>
>>>> 3.) Failed to initialize the AppDomain:/LM/W3SVC/1/Root
>>>>
>>>> Exception: System.Configuration.ConfigurationErrorsException
>>>>
>>>> Message: Exception of type 'System.Configuration.ConfigurationErrorsException ' was thrown.
>>>>
>>>> </errors>
>>>>
>>>> What could be the problem?!?!?!? Plz, any solutions or pointers to solutions are much
>>>> appreciated!!!
>>>>
>>>> Thank you all in advance!!!
>>>>
>>>> Jon

Apr 29 '06 #9

P: n/a
Hi Juan,

The error message is "Server Application Unavailable". The user account I've
setup in "Directory Security" tab of IIS is "HOME-WKSTATION\ASPNET".

In the event viewer, I get one warning...

The server was unable to logon the Windows NT account
'HOME-WKSTATION\ASPNET' due to the following error: Logon failure: unknown
user name or bad password.
followed by 6 errors of the same...

The application-specific permission settings do not grant Local Activation
permission for the COM Server application with CLSID
{A9E69610-B80D-11D0-B9B9-00A0C922E750}
to the user HOME-WKSTATION\ASPNET SID
(S-1-5-21-515967899-413027322-839522115-1007). This security permission can
be modified using the Component Services administrative tool.
I tried setting the user to just "ASPNET" instead of "HOME-WKSTATION\ASPNET"
and I tried to refresh the page in browser and I get "The specified module
could not be found" error.

This time, in the event viewer, I only got one warning...

The server was unable to logon the Windows NT account 'ASPNET' due to the
following error: The specified module could not be found. The data is the
error code.
Just for the record, all I doing was just executing a test ASP.NET page with
the "Hello World" code in it.

Thanks,
Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:Ov**************@TK2MSFTNGP03.phx.gbl...
One more thing...

Is the error message "Server Application Unavailable" or is it "Server
Unavailable" ?

Could you look in the event log, and see what additional info is
there about your "Server Application Unavailable" error message ?

Look in "Start Menu", "Programs", "Administrative Tools", "Event Viewer".
You should be able to find the specific error in the Application log.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
re;
Command worked. However, I'm still getting the "Server Unavailable"
error...


OK...

re:
And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of the
article you've provided me was about ASP.NET 2.0 with IIS6).


Nevertheless, the article is valid for IIS 5.1 ( which is what you're
running, not 5.0 )
and ASP.NET 2.0, as long as you disregard the Application Pool info.

Please review the permissions outlined in this article.
They were written for ASP.NET 1.1, but they are just as valid for ASP.NET
2.0:

http://msdn.microsoft.com/library/de...secnetht01.asp

Make sure that the HOME-WKSTATION\ASPNET account has been assigned NTFS
permissions to all the directories listed in the chart, making sure, of
course, that the proper
directory ( \WINDOWS\Microsoft.NET\Framework\v2.0.50727 ) is checked.

Make sure you read the instructions in the "Comments" column.
*All* the directories listed in the left-most column need the correct
NTFS permissions applied.

When you're done doing that, test and post your results.



Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message
news:uf**************@TK2MSFTNGP02.phx.gbl...
Hi Juan,

Thanks for the reply. I have the latest version in following folder...

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

So I switched to that directory in Command Prompt and tried the
following...

aspnet_regiis -ga HOME-WKSTATION\ASPNET

Command worked. However, I'm still getting the "Server Unavailable"
error...

Thanks again.

Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:eW**************@TK2MSFTNGP05.phx.gbl...
Hi, Jon.

re:
> Another interesting thing is when I tried to do aspnet_regiis -ga
> HOME-WKSTATION\ASPNET under v2.0.50215 folder (as described in the
> article), I get "Invalid Command"

...there's your problem.

v2.0.50215 is the beta 2 version of the .Net Framework...which has many
bugs.
The -ga command isn't a part of that beta version.

The released version of the .Net Framework is v2.0.50727.42

Uninstall that beta version and download/install -at least- the 2.0
redistributable :
http://www.microsoft.com/downloads/d...displaylang=en

You might want to -instead- download/install the full SDK from :
http://www.microsoft.com/downloads/d...displaylang=en

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message
news:Oj**************@TK2MSFTNGP04.phx.gbl...
> Hi Juan,
>
> The thing is, I cannot execute any ASP.NET pages. Even your
> Identity.aspx page. I keep on getting the "Server Unavailable" error.
> That is of course, in ASP.NET 2. However, when I tried with ASP.NET
> 1.1, I get...
>
> HOME-WKSTATION\ASPNET
>
> I ran the examples in KBs ***exactly*** the way it presented (with the
> substitue of the variables of course).
>
> And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of
> the article you've provided me was about ASP.NET 2.0 with IIS6).
>
> Another interesting thing is when I tried to do aspnet_regiis -ga
> HOME-WKSTATION\ASPNET under v2.0.50215 folder (as described in the
> article), I get "Invalid Command" and a list of switches that
> aspnet_regiis accepts, which does not contains a 'ga' switch.
>
> Plz help...
>
> Henry

> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
> news:eF**************@TK2MSFTNGP02.phx.gbl...
>> Are you still getting this error ?
>>
>>>> 2.) Failed to execute the request because the ASP.NET process
>>>> identity does not have read
>>>> permissions to the global assembly cache. Error: 0x80131902
>>
>> Did you run "identity.aspx", which I provided for you ?
>> Which user account was returned by it ?
>>
>> How did you run the example command provided by the KB ?
>>
>> cacls %windir%\assembly /e /t /p domain\useraccount:R
>>
>> ?
>>
>> Have you read this article :
>> http://msdn.microsoft.com/library/de...aght000009.asp
>>
>> ?
>>
>> Please review the steps in it, for creating a service account for an
>> ASP.NET 2.0 application,
>> and make sure that the account retrned by "identity.aspx" has all the
>> permissions
>> listed in that article.
>>
>> In particular, make sure you run the following aspnet_regiis command
>> :
>>
>> aspnet_regiis -ga MachineName\AccountName
>>
>> where "MachineName\AccountName" is the account returned by
>> "identity.aspx".
>>
>> Then post back your results.
>>
>>
>>
>>
>> Juan T. Llibre, asp.net MVP
>> aspnetfaq.com : http://www.aspnetfaq.com/
>> asp.net faq : http://asp.net.do/faq/
>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>> ===================================
>> "Jon B" <no*****@sorry.sorry> wrote in message
>> news:uA**************@TK2MSFTNGP03.phx.gbl...
>>> Hi Juan,
>>>
>>> Thanks for the reply. I've set permission to all the folders and
>>> everything but still it doesn't
>>> work.
>>>
>>> I've also tried the "Denis Bauer's ASP.NET Version Switcher" but
>>> that doesn't help either.
>>>
>>> Any other ideas?
>>>
>>> Cheers,
>>> Jon B
>>>
>>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>>> news:u5**************@TK2MSFTNGP02.phx.gbl...
>>>> If you're running on Windows XP, the account which needs
>>>> permissions is
>>>> MACHINENAME\ASPNET...even if you're allowing anonymous access.
>>>>
>>>> Try granting access permissions to the appropiate account, as
>>>> outlined above.
>>>>
>>>> If you are still having problems after that, and you're
>>>> impersonating some account,
>>>> save this code as "identity.aspx" and run it :
>>>>
>>>> identity.aspx
>>>> ========
>>>>
>>>> <%@ Page Language="VB" %>
>>>> <%@ Import NameSpace = System.Security.Principal %>
>>>> <script runat="server">
>>>> Sub Page_Load()
>>>> Dim tmp As String = WindowsIdentity.GetCurrent.Name()
>>>> Label1.Text = tmp
>>>> End Sub
>>>> </script>
>>>> <html>
>>>> <head>
>>>> <title>WindowsIdentity.GetCurrent.Name()</title>
>>>> </head>
>>>> <body>
>>>> <form id="form1" runat="server">
>>>> <div>
>>>> <asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
>>>> </div>
>>>> </form>
>>>> </body>
>>>> </html>
>>>> ======
>>>>
>>>> Running that file will tell you which account ASP.NET is running
>>>> as.
>>>> Then, assign the appropiate permissions to that account.
>>>>
>>>> Also, download and run Denis Bauer's ASP.NET Version Switcher,
>>>> and make sure that you're actually running 1.1 apps against the
>>>> 1.1 .Net Framework and 2.0 apps against .Net Framework 2.0.
>>>>
>>>> http://www.denisbauer.com/NETTools/A...nSwitcher.aspx
>>>>
>>>>
>>>>
>>>>
>>>> Juan T. Llibre, asp.net MVP
>>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>>> asp.net faq : http://asp.net.do/faq/
>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>> ===================================
>>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>>> news:uT**************@TK2MSFTNGP04.phx.gbl...
>>>>> Hi All!
>>>>>
>>>>> I have a ASP.NET 2.0 site that works on the Windows 2000 Server.
>>>>> However, when I tried to view
>>>>> this site on my local Windows XP machine, I get "Server
>>>>> Unavailable". If I switch the Windows XP
>>>>> IIS back to ASP.NET 1.1 then I get the Configuration Error (which
>>>>> is understandable because I'm
>>>>> trying to run an ASP.NET 2 site with 1.1 framework).
>>>>>
>>>>> I can however view other ASP.NET 1.1 sites on my local Windows XP
>>>>> machine. It's only the problem
>>>>> with
>>>>>
>>>>> I've also tried the aspnet_regiis thing as well as setting
>>>>> permissions on folders as described
>>>>> in this article:
>>>>> http://support.microsoft.com/default.aspx?kbid=811320
>>>>> but no solution.
>>>>>
>>>>> In the event log, I see these three errors every I tried to view
>>>>> my ASP.NET 2.0 site on my local
>>>>> machine...
>>>>>
>>>>> <errors>
>>>>>
>>>>> 1.) .aspnet_wp.exe (PID: 3988) stopped unexpectedly
>>>>>
>>>>> 2.) Failed to execute the request because the ASP.NET process
>>>>> identity does not have read
>>>>> permissions to the global assembly cache. Error: 0x80131902
>>>>>
>>>>> 3.) Failed to initialize the AppDomain:/LM/W3SVC/1/Root
>>>>>
>>>>> Exception: System.Configuration.ConfigurationErrorsException
>>>>>
>>>>> Message: Exception of type
>>>>> 'System.Configuration.ConfigurationErrorsException ' was thrown.
>>>>>
>>>>> </errors>
>>>>>
>>>>> What could be the problem?!?!?!? Plz, any solutions or pointers to
>>>>> solutions are much
>>>>> appreciated!!!
>>>>>
>>>>> Thank you all in advance!!!
>>>>>
>>>>> Jon


Apr 29 '06 #10

P: n/a
Hi Juan,

Here's the batch file I used to set permissions...

[batch]

cd C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

aspnet_regiis -ga ASPNET
aspnet_regiis -ga home-wkstation\ASPNET

cacls "%windir%\Microsoft.NET\Framework\v2.0.50727\Tempo rary ASP.NET Files"
/e /t /p ASPNET:F
cacls "%windir%\Microsoft.NET\Framework\v2.0.50727\Tempo rary ASP.NET Files"
/e /t /p home-wkstation\ASPNET:F

cacls "%windir%\Temp" /e /t /p ASPNET:F
cacls "%windir%\Temp" /e /t /p home-wkstation\ASPNET:F

cacls "C:\wwwRoot\asp.net_2.0" /e /t /p ASPNET:R
cacls "C:\wwwRoot\asp.net_2.0" /e /t /p home-wkstation\ASPNET:R

cacls "%windir%\Microsoft.NET\Framework\v2.0.50727" /e /t /p ASPNET:R
cacls "%windir%\Microsoft.NET\Framework\v2.0.50727" /e /t /p
home-wkstation\ASPNET:R

cacls "%windir%\System32" /e /t /p ASPNET:R
cacls "%windir%\System32" /e /t /p home-wkstation\ASPNET:R

cacls "%windir%\assembly" /e /t /p ASPNET:R
cacls "%windir%\assembly" /e /t /p home-wkstation\ASPNET:R

pause

[/batch]

Am I missing any directories? My ASP.NET folder is in
"C:\wwwRoot\asp.net_2.0". Note that I'm giving permissions to both "ASPNET"
and "NMA-WKSTATION\ASPNET" accounts, just to make sure.

Thanks,
Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
re;
Command worked. However, I'm still getting the "Server Unavailable"
error...


OK...

re:
And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of the
article you've provided me was about ASP.NET 2.0 with IIS6).


Nevertheless, the article is valid for IIS 5.1 ( which is what you're
running, not 5.0 )
and ASP.NET 2.0, as long as you disregard the Application Pool info.

Please review the permissions outlined in this article.
They were written for ASP.NET 1.1, but they are just as valid for ASP.NET
2.0:

http://msdn.microsoft.com/library/de...secnetht01.asp

Make sure that the HOME-WKSTATION\ASPNET account has been assigned NTFS
permissions to all the directories listed in the chart, making sure, of
course, that the proper
directory ( \WINDOWS\Microsoft.NET\Framework\v2.0.50727 ) is checked.

Make sure you read the instructions in the "Comments" column.
*All* the directories listed in the left-most column need the correct NTFS
permissions applied.

When you're done doing that, test and post your results.



Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message
news:uf**************@TK2MSFTNGP02.phx.gbl...
Hi Juan,

Thanks for the reply. I have the latest version in following folder...

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

So I switched to that directory in Command Prompt and tried the
following...

aspnet_regiis -ga HOME-WKSTATION\ASPNET

Command worked. However, I'm still getting the "Server Unavailable"
error...

Thanks again.

Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:eW**************@TK2MSFTNGP05.phx.gbl...
Hi, Jon.

re:
Another interesting thing is when I tried to do aspnet_regiis -ga
HOME-WKSTATION\ASPNET under v2.0.50215 folder (as described in the
article), I get "Invalid Command"

...there's your problem.

v2.0.50215 is the beta 2 version of the .Net Framework...which has many
bugs.
The -ga command isn't a part of that beta version.

The released version of the .Net Framework is v2.0.50727.42

Uninstall that beta version and download/install -at least- the 2.0
redistributable :
http://www.microsoft.com/downloads/d...displaylang=en

You might want to -instead- download/install the full SDK from :
http://www.microsoft.com/downloads/d...displaylang=en

Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message
news:Oj**************@TK2MSFTNGP04.phx.gbl...
Hi Juan,

The thing is, I cannot execute any ASP.NET pages. Even your
Identity.aspx page. I keep on getting the "Server Unavailable" error.
That is of course, in ASP.NET 2. However, when I tried with ASP.NET
1.1, I get...

HOME-WKSTATION\ASPNET

I ran the examples in KBs ***exactly*** the way it presented (with the
substitue of the variables of course).

And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of
the article you've provided me was about ASP.NET 2.0 with IIS6).

Another interesting thing is when I tried to do aspnet_regiis -ga
HOME-WKSTATION\ASPNET under v2.0.50215 folder (as described in the
article), I get "Invalid Command" and a list of switches that
aspnet_regiis accepts, which does not contains a 'ga' switch.

Plz help...

Henry

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:eF**************@TK2MSFTNGP02.phx.gbl...
> Are you still getting this error ?
>
>>> 2.) Failed to execute the request because the ASP.NET process
>>> identity does not have read
>>> permissions to the global assembly cache. Error: 0x80131902
>
> Did you run "identity.aspx", which I provided for you ?
> Which user account was returned by it ?
>
> How did you run the example command provided by the KB ?
>
> cacls %windir%\assembly /e /t /p domain\useraccount:R
>
> ?
>
> Have you read this article :
> http://msdn.microsoft.com/library/de...aght000009.asp
>
> ?
>
> Please review the steps in it, for creating a service account for an
> ASP.NET 2.0 application,
> and make sure that the account retrned by "identity.aspx" has all the
> permissions
> listed in that article.
>
> In particular, make sure you run the following aspnet_regiis command :
>
> aspnet_regiis -ga MachineName\AccountName
>
> where "MachineName\AccountName" is the account returned by
> "identity.aspx".
>
> Then post back your results.
>
>
>
>
> Juan T. Llibre, asp.net MVP
> aspnetfaq.com : http://www.aspnetfaq.com/
> asp.net faq : http://asp.net.do/faq/
> foros de asp.net, en espaņol : http://asp.net.do/foros/
> ===================================
> "Jon B" <no*****@sorry.sorry> wrote in message
> news:uA**************@TK2MSFTNGP03.phx.gbl...
>> Hi Juan,
>>
>> Thanks for the reply. I've set permission to all the folders and
>> everything but still it doesn't
>> work.
>>
>> I've also tried the "Denis Bauer's ASP.NET Version Switcher" but that
>> doesn't help either.
>>
>> Any other ideas?
>>
>> Cheers,
>> Jon B
>>
>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>> news:u5**************@TK2MSFTNGP02.phx.gbl...
>>> If you're running on Windows XP, the account which needs permissions
>>> is
>>> MACHINENAME\ASPNET...even if you're allowing anonymous access.
>>>
>>> Try granting access permissions to the appropiate account, as
>>> outlined above.
>>>
>>> If you are still having problems after that, and you're
>>> impersonating some account,
>>> save this code as "identity.aspx" and run it :
>>>
>>> identity.aspx
>>> ========
>>>
>>> <%@ Page Language="VB" %>
>>> <%@ Import NameSpace = System.Security.Principal %>
>>> <script runat="server">
>>> Sub Page_Load()
>>> Dim tmp As String = WindowsIdentity.GetCurrent.Name()
>>> Label1.Text = tmp
>>> End Sub
>>> </script>
>>> <html>
>>> <head>
>>> <title>WindowsIdentity.GetCurrent.Name()</title>
>>> </head>
>>> <body>
>>> <form id="form1" runat="server">
>>> <div>
>>> <asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
>>> </div>
>>> </form>
>>> </body>
>>> </html>
>>> ======
>>>
>>> Running that file will tell you which account ASP.NET is running as.
>>> Then, assign the appropiate permissions to that account.
>>>
>>> Also, download and run Denis Bauer's ASP.NET Version Switcher,
>>> and make sure that you're actually running 1.1 apps against the
>>> 1.1 .Net Framework and 2.0 apps against .Net Framework 2.0.
>>>
>>> http://www.denisbauer.com/NETTools/A...nSwitcher.aspx
>>>
>>>
>>>
>>>
>>> Juan T. Llibre, asp.net MVP
>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>> asp.net faq : http://asp.net.do/faq/
>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>> ===================================
>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>> news:uT**************@TK2MSFTNGP04.phx.gbl...
>>>> Hi All!
>>>>
>>>> I have a ASP.NET 2.0 site that works on the Windows 2000 Server.
>>>> However, when I tried to view
>>>> this site on my local Windows XP machine, I get "Server
>>>> Unavailable". If I switch the Windows XP
>>>> IIS back to ASP.NET 1.1 then I get the Configuration Error (which
>>>> is understandable because I'm
>>>> trying to run an ASP.NET 2 site with 1.1 framework).
>>>>
>>>> I can however view other ASP.NET 1.1 sites on my local Windows XP
>>>> machine. It's only the problem
>>>> with
>>>>
>>>> I've also tried the aspnet_regiis thing as well as setting
>>>> permissions on folders as described
>>>> in this article:
>>>> http://support.microsoft.com/default.aspx?kbid=811320
>>>> but no solution.
>>>>
>>>> In the event log, I see these three errors every I tried to view my
>>>> ASP.NET 2.0 site on my local
>>>> machine...
>>>>
>>>> <errors>
>>>>
>>>> 1.) .aspnet_wp.exe (PID: 3988) stopped unexpectedly
>>>>
>>>> 2.) Failed to execute the request because the ASP.NET process
>>>> identity does not have read
>>>> permissions to the global assembly cache. Error: 0x80131902
>>>>
>>>> 3.) Failed to initialize the AppDomain:/LM/W3SVC/1/Root
>>>>
>>>> Exception: System.Configuration.ConfigurationErrorsException
>>>>
>>>> Message: Exception of type
>>>> 'System.Configuration.ConfigurationErrorsException ' was thrown.
>>>>
>>>> </errors>
>>>>
>>>> What could be the problem?!?!?!? Plz, any solutions or pointers to
>>>> solutions are much
>>>> appreciated!!!
>>>>
>>>> Thank you all in advance!!!
>>>>
>>>> Jon
>
>
>



Apr 29 '06 #11

P: n/a
Hi Juan,

I tried with "HOME-WKSTATION\ASPNET" in "Directory Security" tab of IIS
settings with the "Allow IIS to control password" option checked. I recieved
a warning saying it doesn't support for non-local account or so. I clicked
"Yes".

Now I tried to refresh the page in browser, and I no longer get "Server
Application Unavailable" but got the "The specified module
could not be found" error.

When I looked into the even log, i find only one warning...


The server was unable to logon the Windows NT account
'HOME-WKSTATION\ASPNET' due to the following error: The specified module
could not be found. The data is the error code.
Any ideas?

Thanks,
Jon

"Jon B" <no*****@sorry.sorry> wrote in message
news:u$**************@TK2MSFTNGP04.phx.gbl...
Hi Juan,

The error message is "Server Application Unavailable". The user account
I've setup in "Directory Security" tab of IIS is "HOME-WKSTATION\ASPNET".

In the event viewer, I get one warning...

> The server was unable to logon the Windows NT account
'HOME-WKSTATION\ASPNET' due to the following error: Logon failure: unknown
user name or bad password.

followed by 6 errors of the same...

> The application-specific permission settings do not grant Local Activation
permission for the COM Server application with CLSID
{A9E69610-B80D-11D0-B9B9-00A0C922E750}
to the user HOME-WKSTATION\ASPNET SID
(S-1-5-21-515967899-413027322-839522115-1007). This security permission
can be modified using the Component Services administrative tool.

I tried setting the user to just "ASPNET" instead of
"HOME-WKSTATION\ASPNET" and I tried to refresh the page in browser and I
get "The specified module could not be found" error.

This time, in the event viewer, I only got one warning...

> The server was unable to logon the Windows NT account 'ASPNET' due to the
following error: The specified module could not be found. The data is the
error code.

Just for the record, all I doing was just executing a test ASP.NET page
with the "Hello World" code in it.

Thanks,
Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:Ov**************@TK2MSFTNGP03.phx.gbl...
One more thing...

Is the error message "Server Application Unavailable" or is it "Server
Unavailable" ?

Could you look in the event log, and see what additional info is
there about your "Server Application Unavailable" error message ?

Look in "Start Menu", "Programs", "Administrative Tools", "Event Viewer".
You should be able to find the specific error in the Application log.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
re;
Command worked. However, I'm still getting the "Server Unavailable"
error...

OK...

re:
And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of
the article you've provided me was about ASP.NET 2.0 with IIS6).

Nevertheless, the article is valid for IIS 5.1 ( which is what you're
running, not 5.0 )
and ASP.NET 2.0, as long as you disregard the Application Pool info.

Please review the permissions outlined in this article.
They were written for ASP.NET 1.1, but they are just as valid for
ASP.NET 2.0:

http://msdn.microsoft.com/library/de...secnetht01.asp

Make sure that the HOME-WKSTATION\ASPNET account has been assigned NTFS
permissions to all the directories listed in the chart, making sure, of
course, that the proper
directory ( \WINDOWS\Microsoft.NET\Framework\v2.0.50727 ) is checked.

Make sure you read the instructions in the "Comments" column.
*All* the directories listed in the left-most column need the correct
NTFS permissions applied.

When you're done doing that, test and post your results.



Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message
news:uf**************@TK2MSFTNGP02.phx.gbl...
Hi Juan,

Thanks for the reply. I have the latest version in following folder...

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

So I switched to that directory in Command Prompt and tried the
following...

aspnet_regiis -ga HOME-WKSTATION\ASPNET

Command worked. However, I'm still getting the "Server Unavailable"
error...

Thanks again.

Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:eW**************@TK2MSFTNGP05.phx.gbl...
> Hi, Jon.
>
> re:
>> Another interesting thing is when I tried to do aspnet_regiis -ga
>> HOME-WKSTATION\ASPNET under v2.0.50215 folder (as described in the
>> article), I get "Invalid Command"
>
> ...there's your problem.
>
> v2.0.50215 is the beta 2 version of the .Net Framework...which has
> many bugs.
> The -ga command isn't a part of that beta version.
>
> The released version of the .Net Framework is v2.0.50727.42
>
> Uninstall that beta version and download/install -at least- the 2.0
> redistributable :
> http://www.microsoft.com/downloads/d...displaylang=en
>
> You might want to -instead- download/install the full SDK from :
> http://www.microsoft.com/downloads/d...displaylang=en
>
>
>
>
>
> Juan T. Llibre, asp.net MVP
> aspnetfaq.com : http://www.aspnetfaq.com/
> asp.net faq : http://asp.net.do/faq/
> foros de asp.net, en espaņol : http://asp.net.do/foros/
> ===================================
> "Jon B" <no*****@sorry.sorry> wrote in message
> news:Oj**************@TK2MSFTNGP04.phx.gbl...
>> Hi Juan,
>>
>> The thing is, I cannot execute any ASP.NET pages. Even your
>> Identity.aspx page. I keep on getting the "Server Unavailable" error.
>> That is of course, in ASP.NET 2. However, when I tried with ASP.NET
>> 1.1, I get...
>>
>> HOME-WKSTATION\ASPNET
>>
>> I ran the examples in KBs ***exactly*** the way it presented (with
>> the substitue of the variables of course).
>>
>> And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of
>> the article you've provided me was about ASP.NET 2.0 with IIS6).
>>
>> Another interesting thing is when I tried to do aspnet_regiis -ga
>> HOME-WKSTATION\ASPNET under v2.0.50215 folder (as described in the
>> article), I get "Invalid Command" and a list of switches that
>> aspnet_regiis accepts, which does not contains a 'ga' switch.
>>
>> Plz help...
>>
>> Henry
>
>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>> news:eF**************@TK2MSFTNGP02.phx.gbl...
>>> Are you still getting this error ?
>>>
>>>>> 2.) Failed to execute the request because the ASP.NET process
>>>>> identity does not have read
>>>>> permissions to the global assembly cache. Error: 0x80131902
>>>
>>> Did you run "identity.aspx", which I provided for you ?
>>> Which user account was returned by it ?
>>>
>>> How did you run the example command provided by the KB ?
>>>
>>> cacls %windir%\assembly /e /t /p domain\useraccount:R
>>>
>>> ?
>>>
>>> Have you read this article :
>>> http://msdn.microsoft.com/library/de...aght000009.asp
>>>
>>> ?
>>>
>>> Please review the steps in it, for creating a service account for an
>>> ASP.NET 2.0 application,
>>> and make sure that the account retrned by "identity.aspx" has all
>>> the permissions
>>> listed in that article.
>>>
>>> In particular, make sure you run the following aspnet_regiis command
>>> :
>>>
>>> aspnet_regiis -ga MachineName\AccountName
>>>
>>> where "MachineName\AccountName" is the account returned by
>>> "identity.aspx".
>>>
>>> Then post back your results.
>>>
>>>
>>>
>>>
>>> Juan T. Llibre, asp.net MVP
>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>> asp.net faq : http://asp.net.do/faq/
>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>> ===================================
>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>> news:uA**************@TK2MSFTNGP03.phx.gbl...
>>>> Hi Juan,
>>>>
>>>> Thanks for the reply. I've set permission to all the folders and
>>>> everything but still it doesn't
>>>> work.
>>>>
>>>> I've also tried the "Denis Bauer's ASP.NET Version Switcher" but
>>>> that doesn't help either.
>>>>
>>>> Any other ideas?
>>>>
>>>> Cheers,
>>>> Jon B
>>>>
>>>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>>>> news:u5**************@TK2MSFTNGP02.phx.gbl...
>>>>> If you're running on Windows XP, the account which needs
>>>>> permissions is
>>>>> MACHINENAME\ASPNET...even if you're allowing anonymous access.
>>>>>
>>>>> Try granting access permissions to the appropiate account, as
>>>>> outlined above.
>>>>>
>>>>> If you are still having problems after that, and you're
>>>>> impersonating some account,
>>>>> save this code as "identity.aspx" and run it :
>>>>>
>>>>> identity.aspx
>>>>> ========
>>>>>
>>>>> <%@ Page Language="VB" %>
>>>>> <%@ Import NameSpace = System.Security.Principal %>
>>>>> <script runat="server">
>>>>> Sub Page_Load()
>>>>> Dim tmp As String = WindowsIdentity.GetCurrent.Name()
>>>>> Label1.Text = tmp
>>>>> End Sub
>>>>> </script>
>>>>> <html>
>>>>> <head>
>>>>> <title>WindowsIdentity.GetCurrent.Name()</title>
>>>>> </head>
>>>>> <body>
>>>>> <form id="form1" runat="server">
>>>>> <div>
>>>>> <asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
>>>>> </div>
>>>>> </form>
>>>>> </body>
>>>>> </html>
>>>>> ======
>>>>>
>>>>> Running that file will tell you which account ASP.NET is running
>>>>> as.
>>>>> Then, assign the appropiate permissions to that account.
>>>>>
>>>>> Also, download and run Denis Bauer's ASP.NET Version Switcher,
>>>>> and make sure that you're actually running 1.1 apps against the
>>>>> 1.1 .Net Framework and 2.0 apps against .Net Framework 2.0.
>>>>>
>>>>> http://www.denisbauer.com/NETTools/A...nSwitcher.aspx
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> Juan T. Llibre, asp.net MVP
>>>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>>>> asp.net faq : http://asp.net.do/faq/
>>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>> ===================================
>>>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>>>> news:uT**************@TK2MSFTNGP04.phx.gbl...
>>>>>> Hi All!
>>>>>>
>>>>>> I have a ASP.NET 2.0 site that works on the Windows 2000 Server.
>>>>>> However, when I tried to view
>>>>>> this site on my local Windows XP machine, I get "Server
>>>>>> Unavailable". If I switch the Windows XP
>>>>>> IIS back to ASP.NET 1.1 then I get the Configuration Error (which
>>>>>> is understandable because I'm
>>>>>> trying to run an ASP.NET 2 site with 1.1 framework).
>>>>>>
>>>>>> I can however view other ASP.NET 1.1 sites on my local Windows XP
>>>>>> machine. It's only the problem
>>>>>> with
>>>>>>
>>>>>> I've also tried the aspnet_regiis thing as well as setting
>>>>>> permissions on folders as described
>>>>>> in this article:
>>>>>> http://support.microsoft.com/default.aspx?kbid=811320
>>>>>> but no solution.
>>>>>>
>>>>>> In the event log, I see these three errors every I tried to view
>>>>>> my ASP.NET 2.0 site on my local
>>>>>> machine...
>>>>>>
>>>>>> <errors>
>>>>>>
>>>>>> 1.) .aspnet_wp.exe (PID: 3988) stopped unexpectedly
>>>>>>
>>>>>> 2.) Failed to execute the request because the ASP.NET process
>>>>>> identity does not have read
>>>>>> permissions to the global assembly cache. Error: 0x80131902
>>>>>>
>>>>>> 3.) Failed to initialize the AppDomain:/LM/W3SVC/1/Root
>>>>>>
>>>>>> Exception: System.Configuration.ConfigurationErrorsException
>>>>>>
>>>>>> Message: Exception of type
>>>>>> 'System.Configuration.ConfigurationErrorsException ' was thrown.
>>>>>>
>>>>>> </errors>
>>>>>>
>>>>>> What could be the problem?!?!?!? Plz, any solutions or pointers
>>>>>> to solutions are much
>>>>>> appreciated!!!
>>>>>>
>>>>>> Thank you all in advance!!!
>>>>>>
>>>>>> Jon



Apr 29 '06 #12

P: n/a
re:
The application-specific permission settings do not grant Local Activation
permission for the COM Server application with CLSID
{A9E69610-B80D-11D0-B9B9-00A0C922E750}
to the user HOME-WKSTATION\ASPNET SID (S-1-5-21-515967899-413027322-839522115-1007). This
security permission can be modified using the Component Services administrative tool.
Have you attempted to grant Local Activation permission to the
COM Server application with CLSID {A9E69610-B80D-11D0-B9B9-00A0C922E750}
to the user HOME-WKSTATION\ASPNET ?

I hope not...because I think that's not the right account.

You say that : The user account I've setup in "Directory Security" tab of IIS is "HOME-WKSTATION\ASPNET".
But that account doesn't need to be granted browsing rights.

That account only needs execution rights and access permission to the files, so that
ASP.NET can *send* information to the anonymous account which is browsing the site.

Usually, for anonymous access, the user account selected in the
IIS Manager's Directory Security tab is "IUSR_MACHINENAME".

In your case, that would be "IUSR_HOME-WKSTATION".

Since you probably don't know what the password for that account is,
you might have to *first* change the password for that account...and *then* assign
the "IUSR_HOME-WKSTATION" account as the anonymous account,
making sure that you use the password which you just changed.

I've added the microsoft.public.inetserver.iis newsgroup to this post, so that we can get
opinions from the IIS MVPs and other IIS experts who frequent that newsgroup,
since that is more of an IIS problem than an ASP.NET one.

Guys ?


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message news:u$**************@TK2MSFTNGP04.phx.gbl... Hi Juan,

The error message is "Server Application Unavailable". The user account I've setup in "Directory
Security" tab of IIS is "HOME-WKSTATION\ASPNET".

In the event viewer, I get one warning...

> The server was unable to logon the Windows NT account 'HOME-WKSTATION\ASPNET' due to the following
error: Logon failure: unknown user name or bad password.

followed by 6 errors of the same...

> The application-specific permission settings do not grant Local Activation permission for the COM
Server application with CLSID
{A9E69610-B80D-11D0-B9B9-00A0C922E750}
to the user HOME-WKSTATION\ASPNET SID (S-1-5-21-515967899-413027322-839522115-1007). This
security permission can be modified using the Component Services administrative tool.

I tried setting the user to just "ASPNET" instead of "HOME-WKSTATION\ASPNET" and I tried to
refresh the page in browser and I get "The specified module could not be found" error.

This time, in the event viewer, I only got one warning...

> The server was unable to logon the Windows NT account 'ASPNET' due to the following error: The
specified module could not be found. The data is the error code.

Just for the record, all I doing was just executing a test ASP.NET page with the "Hello World"
code in it.

Thanks,
Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:Ov**************@TK2MSFTNGP03.phx.gbl...
One more thing...

Is the error message "Server Application Unavailable" or is it "Server Unavailable" ?

Could you look in the event log, and see what additional info is
there about your "Server Application Unavailable" error message ?

Look in "Start Menu", "Programs", "Administrative Tools", "Event Viewer".
You should be able to find the specific error in the Application log.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
re;
Command worked. However, I'm still getting the "Server Unavailable" error...

OK...

re:
And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of the article you've
provided me was about ASP.NET 2.0 with IIS6).

Nevertheless, the article is valid for IIS 5.1 ( which is what you're running, not 5.0 )
and ASP.NET 2.0, as long as you disregard the Application Pool info.

Please review the permissions outlined in this article.
They were written for ASP.NET 1.1, but they are just as valid for ASP.NET 2.0:

http://msdn.microsoft.com/library/de...secnetht01.asp

Make sure that the HOME-WKSTATION\ASPNET account has been assigned NTFS
permissions to all the directories listed in the chart, making sure, of course, that the proper
directory ( \WINDOWS\Microsoft.NET\Framework\v2.0.50727 ) is checked.

Make sure you read the instructions in the "Comments" column.
*All* the directories listed in the left-most column need the correct NTFS permissions applied.

When you're done doing that, test and post your results.



Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message news:uf**************@TK2MSFTNGP02.phx.gbl...
Hi Juan,

Thanks for the reply. I have the latest version in following folder...

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

So I switched to that directory in Command Prompt and tried the following...

aspnet_regiis -ga HOME-WKSTATION\ASPNET

Command worked. However, I'm still getting the "Server Unavailable" error...

Thanks again.

Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:eW**************@TK2MSFTNGP05.phx.gbl...
> Hi, Jon.
>
> re:
>> Another interesting thing is when I tried to do aspnet_regiis -ga HOME-WKSTATION\ASPNET under
>> v2.0.50215 folder (as described in the article), I get "Invalid Command"
>
> ...there's your problem.
>
> v2.0.50215 is the beta 2 version of the .Net Framework...which has many bugs.
> The -ga command isn't a part of that beta version.
>
> The released version of the .Net Framework is v2.0.50727.42
>
> Uninstall that beta version and download/install -at least- the 2.0 redistributable :
> http://www.microsoft.com/downloads/d...displaylang=en
>
> You might want to -instead- download/install the full SDK from :
> http://www.microsoft.com/downloads/d...displaylang=en
>
>
>
>
>
> Juan T. Llibre, asp.net MVP
> aspnetfaq.com : http://www.aspnetfaq.com/
> asp.net faq : http://asp.net.do/faq/
> foros de asp.net, en espaņol : http://asp.net.do/foros/
> ===================================
> "Jon B" <no*****@sorry.sorry> wrote in message news:Oj**************@TK2MSFTNGP04.phx.gbl...
>> Hi Juan,
>>
>> The thing is, I cannot execute any ASP.NET pages. Even your Identity.aspx page. I keep on
>> getting the "Server Unavailable" error. That is of course, in ASP.NET 2. However, when I
>> tried with ASP.NET 1.1, I get...
>>
>> HOME-WKSTATION\ASPNET
>>
>> I ran the examples in KBs ***exactly*** the way it presented (with the substitue of the
>> variables of course).
>>
>> And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of the article you've
>> provided me was about ASP.NET 2.0 with IIS6).
>>
>> Another interesting thing is when I tried to do aspnet_regiis -ga HOME-WKSTATION\ASPNET under
>> v2.0.50215 folder (as described in the article), I get "Invalid Command" and a list of
>> switches that aspnet_regiis accepts, which does not contains a 'ga' switch.
>>
>> Plz help...
>>
>> Henry
>
>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>> news:eF**************@TK2MSFTNGP02.phx.gbl...
>>> Are you still getting this error ?
>>>
>>>>> 2.) Failed to execute the request because the ASP.NET process identity does not have read
>>>>> permissions to the global assembly cache. Error: 0x80131902
>>>
>>> Did you run "identity.aspx", which I provided for you ?
>>> Which user account was returned by it ?
>>>
>>> How did you run the example command provided by the KB ?
>>>
>>> cacls %windir%\assembly /e /t /p domain\useraccount:R
>>>
>>> ?
>>>
>>> Have you read this article :
>>> http://msdn.microsoft.com/library/de...aght000009.asp
>>>
>>> ?
>>>
>>> Please review the steps in it, for creating a service account for an ASP.NET 2.0
>>> application,
>>> and make sure that the account retrned by "identity.aspx" has all the permissions
>>> listed in that article.
>>>
>>> In particular, make sure you run the following aspnet_regiis command :
>>>
>>> aspnet_regiis -ga MachineName\AccountName
>>>
>>> where "MachineName\AccountName" is the account returned by "identity.aspx".
>>>
>>> Then post back your results.
>>>
>>>
>>>
>>>
>>> Juan T. Llibre, asp.net MVP
>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>> asp.net faq : http://asp.net.do/faq/
>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>> ===================================
>>> "Jon B" <no*****@sorry.sorry> wrote in message news:uA**************@TK2MSFTNGP03.phx.gbl...
>>>> Hi Juan,
>>>>
>>>> Thanks for the reply. I've set permission to all the folders and everything but still it
>>>> doesn't
>>>> work.
>>>>
>>>> I've also tried the "Denis Bauer's ASP.NET Version Switcher" but that doesn't help either.
>>>>
>>>> Any other ideas?
>>>>
>>>> Cheers,
>>>> Jon B
>>>>
>>>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>>>> news:u5**************@TK2MSFTNGP02.phx.gbl...
>>>>> If you're running on Windows XP, the account which needs permissions is
>>>>> MACHINENAME\ASPNET...even if you're allowing anonymous access.
>>>>>
>>>>> Try granting access permissions to the appropiate account, as outlined above.
>>>>>
>>>>> If you are still having problems after that, and you're impersonating some account,
>>>>> save this code as "identity.aspx" and run it :
>>>>>
>>>>> identity.aspx
>>>>> ========
>>>>>
>>>>> <%@ Page Language="VB" %>
>>>>> <%@ Import NameSpace = System.Security.Principal %>
>>>>> <script runat="server">
>>>>> Sub Page_Load()
>>>>> Dim tmp As String = WindowsIdentity.GetCurrent.Name()
>>>>> Label1.Text = tmp
>>>>> End Sub
>>>>> </script>
>>>>> <html>
>>>>> <head>
>>>>> <title>WindowsIdentity.GetCurrent.Name()</title>
>>>>> </head>
>>>>> <body>
>>>>> <form id="form1" runat="server">
>>>>> <div>
>>>>> <asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
>>>>> </div>
>>>>> </form>
>>>>> </body>
>>>>> </html>
>>>>> ======
>>>>>
>>>>> Running that file will tell you which account ASP.NET is running as.
>>>>> Then, assign the appropiate permissions to that account.
>>>>>
>>>>> Also, download and run Denis Bauer's ASP.NET Version Switcher,
>>>>> and make sure that you're actually running 1.1 apps against the
>>>>> 1.1 .Net Framework and 2.0 apps against .Net Framework 2.0.
>>>>>
>>>>> http://www.denisbauer.com/NETTools/A...nSwitcher.aspx
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> Juan T. Llibre, asp.net MVP
>>>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>>>> asp.net faq : http://asp.net.do/faq/
>>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>> ===================================
>>>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>>>> news:uT**************@TK2MSFTNGP04.phx.gbl...
>>>>>> Hi All!
>>>>>>
>>>>>> I have a ASP.NET 2.0 site that works on the Windows 2000 Server. However, when I tried to
>>>>>> view
>>>>>> this site on my local Windows XP machine, I get "Server Unavailable". If I switch the
>>>>>> Windows XP
>>>>>> IIS back to ASP.NET 1.1 then I get the Configuration Error (which is understandable
>>>>>> because I'm
>>>>>> trying to run an ASP.NET 2 site with 1.1 framework).
>>>>>>
>>>>>> I can however view other ASP.NET 1.1 sites on my local Windows XP machine. It's only the
>>>>>> problem
>>>>>> with
>>>>>>
>>>>>> I've also tried the aspnet_regiis thing as well as setting permissions on folders as
>>>>>> described
>>>>>> in this article:
>>>>>> http://support.microsoft.com/default.aspx?kbid=811320
>>>>>> but no solution.
>>>>>>
>>>>>> In the event log, I see these three errors every I tried to view my ASP.NET 2.0 site on
>>>>>> my local
>>>>>> machine...
>>>>>>
>>>>>> <errors>
>>>>>>
>>>>>> 1.) .aspnet_wp.exe (PID: 3988) stopped unexpectedly
>>>>>>
>>>>>> 2.) Failed to execute the request because the ASP.NET process identity does not have
>>>>>> read
>>>>>> permissions to the global assembly cache. Error: 0x80131902
>>>>>>
>>>>>> 3.) Failed to initialize the AppDomain:/LM/W3SVC/1/Root
>>>>>>
>>>>>> Exception: System.Configuration.ConfigurationErrorsException
>>>>>>
>>>>>> Message: Exception of type 'System.Configuration.ConfigurationErrorsException ' was
>>>>>> thrown.
>>>>>>
>>>>>> </errors>
>>>>>>
>>>>>> What could be the problem?!?!?!? Plz, any solutions or pointers to solutions are much
>>>>>> appreciated!!!
>>>>>>
>>>>>> Thank you all in advance!!!
>>>>>>
>>>>>> Jon



Apr 29 '06 #13

P: n/a
I've tried with the IUSR_HOME-WKSTATION account and I'm still getting the
"The specified module could not be found." page.

Another interesting observation is that, I can type just about anything,
like http://localhost/sdfsfsdfsdds.aspx which doesnt exists and still get
the "The specified module could not be found." error page.

Thanks again,
Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:Oz**************@TK2MSFTNGP04.phx.gbl...
re:
The application-specific permission settings do not grant Local Activation
permission for the COM Server application with CLSID
{A9E69610-B80D-11D0-B9B9-00A0C922E750}
to the user HOME-WKSTATION\ASPNET SID
(S-1-5-21-515967899-413027322-839522115-1007). This security permission
can be modified using the Component Services administrative tool.


Have you attempted to grant Local Activation permission to the
COM Server application with CLSID {A9E69610-B80D-11D0-B9B9-00A0C922E750}
to the user HOME-WKSTATION\ASPNET ?

I hope not...because I think that's not the right account.

You say that :
The user account I've setup in "Directory Security" tab of IIS is
"HOME-WKSTATION\ASPNET".


But that account doesn't need to be granted browsing rights.

That account only needs execution rights and access permission to the
files, so that
ASP.NET can *send* information to the anonymous account which is browsing
the site.

Usually, for anonymous access, the user account selected in the
IIS Manager's Directory Security tab is "IUSR_MACHINENAME".

In your case, that would be "IUSR_HOME-WKSTATION".

Since you probably don't know what the password for that account is,
you might have to *first* change the password for that account...and
*then* assign
the "IUSR_HOME-WKSTATION" account as the anonymous account,
making sure that you use the password which you just changed.

I've added the microsoft.public.inetserver.iis newsgroup to this post, so
that we can get
opinions from the IIS MVPs and other IIS experts who frequent that
newsgroup,
since that is more of an IIS problem than an ASP.NET one.

Guys ?


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message
news:u$**************@TK2MSFTNGP04.phx.gbl...
Hi Juan,

The error message is "Server Application Unavailable". The user account
I've setup in "Directory Security" tab of IIS is "HOME-WKSTATION\ASPNET".

In the event viewer, I get one warning...

>> The server was unable to logon the Windows NT account
'HOME-WKSTATION\ASPNET' due to the following error: Logon failure:
unknown user name or bad password.

followed by 6 errors of the same...

>> The application-specific permission settings do not grant Local
Activation permission for the COM Server application with CLSID
{A9E69610-B80D-11D0-B9B9-00A0C922E750}
to the user HOME-WKSTATION\ASPNET SID
(S-1-5-21-515967899-413027322-839522115-1007). This security permission
can be modified using the Component Services administrative tool.

I tried setting the user to just "ASPNET" instead of
"HOME-WKSTATION\ASPNET" and I tried to refresh the page in browser and I
get "The specified module could not be found" error.

This time, in the event viewer, I only got one warning...

>> The server was unable to logon the Windows NT account 'ASPNET' due to the
following error: The specified module could not be found. The data is
the error code.

Just for the record, all I doing was just executing a test ASP.NET page
with the "Hello World" code in it.

Thanks,
Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:Ov**************@TK2MSFTNGP03.phx.gbl...
One more thing...

Is the error message "Server Application Unavailable" or is it "Server
Unavailable" ?

Could you look in the event log, and see what additional info is
there about your "Server Application Unavailable" error message ?

Look in "Start Menu", "Programs", "Administrative Tools", "Event
Viewer".
You should be able to find the specific error in the Application log.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
re;
> Command worked. However, I'm still getting the "Server Unavailable"
> error...

OK...

re:
> And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of
> the article you've provided me was about ASP.NET 2.0 with IIS6).

Nevertheless, the article is valid for IIS 5.1 ( which is what you're
running, not 5.0 )
and ASP.NET 2.0, as long as you disregard the Application Pool info.

Please review the permissions outlined in this article.
They were written for ASP.NET 1.1, but they are just as valid for
ASP.NET 2.0:

http://msdn.microsoft.com/library/de...secnetht01.asp

Make sure that the HOME-WKSTATION\ASPNET account has been assigned NTFS
permissions to all the directories listed in the chart, making sure, of
course, that the proper
directory ( \WINDOWS\Microsoft.NET\Framework\v2.0.50727 ) is checked.

Make sure you read the instructions in the "Comments" column.
*All* the directories listed in the left-most column need the correct
NTFS permissions applied.

When you're done doing that, test and post your results.



Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message
news:uf**************@TK2MSFTNGP02.phx.gbl...
> Hi Juan,
>
> Thanks for the reply. I have the latest version in following folder...
>
> C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
>
> So I switched to that directory in Command Prompt and tried the
> following...
>
> aspnet_regiis -ga HOME-WKSTATION\ASPNET
>
> Command worked. However, I'm still getting the "Server Unavailable"
> error...
>
> Thanks again.
>
> Jon
>
> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
> news:eW**************@TK2MSFTNGP05.phx.gbl...
>> Hi, Jon.
>>
>> re:
>>> Another interesting thing is when I tried to do aspnet_regiis -ga
>>> HOME-WKSTATION\ASPNET under v2.0.50215 folder (as described in the
>>> article), I get "Invalid Command"
>>
>> ...there's your problem.
>>
>> v2.0.50215 is the beta 2 version of the .Net Framework...which has
>> many bugs.
>> The -ga command isn't a part of that beta version.
>>
>> The released version of the .Net Framework is v2.0.50727.42
>>
>> Uninstall that beta version and download/install -at least- the 2.0
>> redistributable :
>> http://www.microsoft.com/downloads/d...displaylang=en
>>
>> You might want to -instead- download/install the full SDK from :
>> http://www.microsoft.com/downloads/d...displaylang=en
>>
>>
>>
>>
>>
>> Juan T. Llibre, asp.net MVP
>> aspnetfaq.com : http://www.aspnetfaq.com/
>> asp.net faq : http://asp.net.do/faq/
>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>> ===================================
>> "Jon B" <no*****@sorry.sorry> wrote in message
>> news:Oj**************@TK2MSFTNGP04.phx.gbl...
>>> Hi Juan,
>>>
>>> The thing is, I cannot execute any ASP.NET pages. Even your
>>> Identity.aspx page. I keep on getting the "Server Unavailable"
>>> error. That is of course, in ASP.NET 2. However, when I tried with
>>> ASP.NET 1.1, I get...
>>>
>>> HOME-WKSTATION\ASPNET
>>>
>>> I ran the examples in KBs ***exactly*** the way it presented (with
>>> the substitue of the variables of course).
>>>
>>> And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of
>>> the article you've provided me was about ASP.NET 2.0 with IIS6).
>>>
>>> Another interesting thing is when I tried to do aspnet_regiis -ga
>>> HOME-WKSTATION\ASPNET under v2.0.50215 folder (as described in the
>>> article), I get "Invalid Command" and a list of switches that
>>> aspnet_regiis accepts, which does not contains a 'ga' switch.
>>>
>>> Plz help...
>>>
>>> Henry
>>
>>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>>> news:eF**************@TK2MSFTNGP02.phx.gbl...
>>>> Are you still getting this error ?
>>>>
>>>>>> 2.) Failed to execute the request because the ASP.NET process
>>>>>> identity does not have read
>>>>>> permissions to the global assembly cache. Error: 0x80131902
>>>>
>>>> Did you run "identity.aspx", which I provided for you ?
>>>> Which user account was returned by it ?
>>>>
>>>> How did you run the example command provided by the KB ?
>>>>
>>>> cacls %windir%\assembly /e /t /p domain\useraccount:R
>>>>
>>>> ?
>>>>
>>>> Have you read this article :
>>>> http://msdn.microsoft.com/library/de...aght000009.asp
>>>>
>>>> ?
>>>>
>>>> Please review the steps in it, for creating a service account for
>>>> an ASP.NET 2.0 application,
>>>> and make sure that the account retrned by "identity.aspx" has all
>>>> the permissions
>>>> listed in that article.
>>>>
>>>> In particular, make sure you run the following aspnet_regiis
>>>> command :
>>>>
>>>> aspnet_regiis -ga MachineName\AccountName
>>>>
>>>> where "MachineName\AccountName" is the account returned by
>>>> "identity.aspx".
>>>>
>>>> Then post back your results.
>>>>
>>>>
>>>>
>>>>
>>>> Juan T. Llibre, asp.net MVP
>>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>>> asp.net faq : http://asp.net.do/faq/
>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>> ===================================
>>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>>> news:uA**************@TK2MSFTNGP03.phx.gbl...
>>>>> Hi Juan,
>>>>>
>>>>> Thanks for the reply. I've set permission to all the folders and
>>>>> everything but still it doesn't
>>>>> work.
>>>>>
>>>>> I've also tried the "Denis Bauer's ASP.NET Version Switcher" but
>>>>> that doesn't help either.
>>>>>
>>>>> Any other ideas?
>>>>>
>>>>> Cheers,
>>>>> Jon B
>>>>>
>>>>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>>>>> news:u5**************@TK2MSFTNGP02.phx.gbl...
>>>>>> If you're running on Windows XP, the account which needs
>>>>>> permissions is
>>>>>> MACHINENAME\ASPNET...even if you're allowing anonymous access.
>>>>>>
>>>>>> Try granting access permissions to the appropiate account, as
>>>>>> outlined above.
>>>>>>
>>>>>> If you are still having problems after that, and you're
>>>>>> impersonating some account,
>>>>>> save this code as "identity.aspx" and run it :
>>>>>>
>>>>>> identity.aspx
>>>>>> ========
>>>>>>
>>>>>> <%@ Page Language="VB" %>
>>>>>> <%@ Import NameSpace = System.Security.Principal %>
>>>>>> <script runat="server">
>>>>>> Sub Page_Load()
>>>>>> Dim tmp As String = WindowsIdentity.GetCurrent.Name()
>>>>>> Label1.Text = tmp
>>>>>> End Sub
>>>>>> </script>
>>>>>> <html>
>>>>>> <head>
>>>>>> <title>WindowsIdentity.GetCurrent.Name()</title>
>>>>>> </head>
>>>>>> <body>
>>>>>> <form id="form1" runat="server">
>>>>>> <div>
>>>>>> <asp:Label ID="Label1" Runat="server"
>>>>>> Text="Label"></asp:Label>
>>>>>> </div>
>>>>>> </form>
>>>>>> </body>
>>>>>> </html>
>>>>>> ======
>>>>>>
>>>>>> Running that file will tell you which account ASP.NET is running
>>>>>> as.
>>>>>> Then, assign the appropiate permissions to that account.
>>>>>>
>>>>>> Also, download and run Denis Bauer's ASP.NET Version Switcher,
>>>>>> and make sure that you're actually running 1.1 apps against the
>>>>>> 1.1 .Net Framework and 2.0 apps against .Net Framework 2.0.
>>>>>>
>>>>>> http://www.denisbauer.com/NETTools/A...nSwitcher.aspx
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> Juan T. Llibre, asp.net MVP
>>>>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>>>>> asp.net faq : http://asp.net.do/faq/
>>>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>> ===================================
>>>>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>>>>> news:uT**************@TK2MSFTNGP04.phx.gbl...
>>>>>>> Hi All!
>>>>>>>
>>>>>>> I have a ASP.NET 2.0 site that works on the Windows 2000 Server.
>>>>>>> However, when I tried to view
>>>>>>> this site on my local Windows XP machine, I get "Server
>>>>>>> Unavailable". If I switch the Windows XP
>>>>>>> IIS back to ASP.NET 1.1 then I get the Configuration Error
>>>>>>> (which is understandable because I'm
>>>>>>> trying to run an ASP.NET 2 site with 1.1 framework).
>>>>>>>
>>>>>>> I can however view other ASP.NET 1.1 sites on my local Windows
>>>>>>> XP machine. It's only the problem
>>>>>>> with
>>>>>>>
>>>>>>> I've also tried the aspnet_regiis thing as well as setting
>>>>>>> permissions on folders as described
>>>>>>> in this article:
>>>>>>> http://support.microsoft.com/default.aspx?kbid=811320
>>>>>>> but no solution.
>>>>>>>
>>>>>>> In the event log, I see these three errors every I tried to view
>>>>>>> my ASP.NET 2.0 site on my local
>>>>>>> machine...
>>>>>>>
>>>>>>> <errors>
>>>>>>>
>>>>>>> 1.) .aspnet_wp.exe (PID: 3988) stopped unexpectedly
>>>>>>>
>>>>>>> 2.) Failed to execute the request because the ASP.NET process
>>>>>>> identity does not have read
>>>>>>> permissions to the global assembly cache. Error: 0x80131902
>>>>>>>
>>>>>>> 3.) Failed to initialize the AppDomain:/LM/W3SVC/1/Root
>>>>>>>
>>>>>>> Exception: System.Configuration.ConfigurationErrorsException
>>>>>>>
>>>>>>> Message: Exception of type
>>>>>>> 'System.Configuration.ConfigurationErrorsException ' was thrown.
>>>>>>>
>>>>>>> </errors>
>>>>>>>
>>>>>>> What could be the problem?!?!?!? Plz, any solutions or pointers
>>>>>>> to solutions are much
>>>>>>> appreciated!!!
>>>>>>>
>>>>>>> Thank you all in advance!!!
>>>>>>>
>>>>>>> Jon



Apr 30 '06 #14

P: n/a
guys...

"Jon B" <no*****@sorry.sorry> wrote in message
news:ez****************@TK2MSFTNGP04.phx.gbl...
I've tried with the IUSR_HOME-WKSTATION account and I'm still getting the
"The specified module could not be found." page.

Another interesting observation is that, I can type just about anything,
like http://localhost/sdfsfsdfsdds.aspx which doesnt exists and still get
the "The specified module could not be found." error page.

Thanks again,
Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:Oz**************@TK2MSFTNGP04.phx.gbl...
re:
The application-specific permission settings do not grant Local
Activation
permission for the COM Server application with CLSID
{A9E69610-B80D-11D0-B9B9-00A0C922E750}
to the user HOME-WKSTATION\ASPNET SID
(S-1-5-21-515967899-413027322-839522115-1007). This security permission
can be modified using the Component Services administrative tool.


Have you attempted to grant Local Activation permission to the
COM Server application with CLSID {A9E69610-B80D-11D0-B9B9-00A0C922E750}
to the user HOME-WKSTATION\ASPNET ?

I hope not...because I think that's not the right account.

You say that :
The user account I've setup in "Directory Security" tab of IIS is
"HOME-WKSTATION\ASPNET".


But that account doesn't need to be granted browsing rights.

That account only needs execution rights and access permission to the
files, so that
ASP.NET can *send* information to the anonymous account which is browsing
the site.

Usually, for anonymous access, the user account selected in the
IIS Manager's Directory Security tab is "IUSR_MACHINENAME".

In your case, that would be "IUSR_HOME-WKSTATION".

Since you probably don't know what the password for that account is,
you might have to *first* change the password for that account...and
*then* assign
the "IUSR_HOME-WKSTATION" account as the anonymous account,
making sure that you use the password which you just changed.

I've added the microsoft.public.inetserver.iis newsgroup to this post, so
that we can get
opinions from the IIS MVPs and other IIS experts who frequent that
newsgroup,
since that is more of an IIS problem than an ASP.NET one.

Guys ?


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message
news:u$**************@TK2MSFTNGP04.phx.gbl...
Hi Juan,

The error message is "Server Application Unavailable". The user account
I've setup in "Directory Security" tab of IIS is
"HOME-WKSTATION\ASPNET".

In the event viewer, I get one warning...

>>> The server was unable to logon the Windows NT account
'HOME-WKSTATION\ASPNET' due to the following error: Logon failure:
unknown user name or bad password.

followed by 6 errors of the same...

>>> The application-specific permission settings do not grant Local
Activation permission for the COM Server application with CLSID
{A9E69610-B80D-11D0-B9B9-00A0C922E750}
to the user HOME-WKSTATION\ASPNET SID
(S-1-5-21-515967899-413027322-839522115-1007). This security permission
can be modified using the Component Services administrative tool.

I tried setting the user to just "ASPNET" instead of
"HOME-WKSTATION\ASPNET" and I tried to refresh the page in browser and I
get "The specified module could not be found" error.

This time, in the event viewer, I only got one warning...

>>> The server was unable to logon the Windows NT account 'ASPNET' due to
the following error: The specified module could not be found. The data
is the error code.

Just for the record, all I doing was just executing a test ASP.NET page
with the "Hello World" code in it.

Thanks,
Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:Ov**************@TK2MSFTNGP03.phx.gbl...
One more thing...

Is the error message "Server Application Unavailable" or is it "Server
Unavailable" ?

Could you look in the event log, and see what additional info is
there about your "Server Application Unavailable" error message ?

Look in "Start Menu", "Programs", "Administrative Tools", "Event
Viewer".
You should be able to find the specific error in the Application log.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
> re;
>> Command worked. However, I'm still getting the "Server Unavailable"
>> error...
>
> OK...
>
> re:
>> And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of
>> the article you've provided me was about ASP.NET 2.0 with IIS6).
>
> Nevertheless, the article is valid for IIS 5.1 ( which is what you're
> running, not 5.0 )
> and ASP.NET 2.0, as long as you disregard the Application Pool info.
>
> Please review the permissions outlined in this article.
> They were written for ASP.NET 1.1, but they are just as valid for
> ASP.NET 2.0:
>
> http://msdn.microsoft.com/library/de...secnetht01.asp
>
> Make sure that the HOME-WKSTATION\ASPNET account has been assigned
> NTFS
> permissions to all the directories listed in the chart, making sure,
> of course, that the proper
> directory ( \WINDOWS\Microsoft.NET\Framework\v2.0.50727 ) is checked.
>
> Make sure you read the instructions in the "Comments" column.
> *All* the directories listed in the left-most column need the correct
> NTFS permissions applied.
>
> When you're done doing that, test and post your results.
>
>
>
>
>
>
>
> Juan T. Llibre, asp.net MVP
> aspnetfaq.com : http://www.aspnetfaq.com/
> asp.net faq : http://asp.net.do/faq/
> foros de asp.net, en espaņol : http://asp.net.do/foros/
> ===================================
> "Jon B" <no*****@sorry.sorry> wrote in message
> news:uf**************@TK2MSFTNGP02.phx.gbl...
>> Hi Juan,
>>
>> Thanks for the reply. I have the latest version in following
>> folder...
>>
>> C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
>>
>> So I switched to that directory in Command Prompt and tried the
>> following...
>>
>> aspnet_regiis -ga HOME-WKSTATION\ASPNET
>>
>> Command worked. However, I'm still getting the "Server Unavailable"
>> error...
>>
>> Thanks again.
>>
>> Jon
>>
>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>> news:eW**************@TK2MSFTNGP05.phx.gbl...
>>> Hi, Jon.
>>>
>>> re:
>>>> Another interesting thing is when I tried to do aspnet_regiis -ga
>>>> HOME-WKSTATION\ASPNET under v2.0.50215 folder (as described in the
>>>> article), I get "Invalid Command"
>>>
>>> ...there's your problem.
>>>
>>> v2.0.50215 is the beta 2 version of the .Net Framework...which has
>>> many bugs.
>>> The -ga command isn't a part of that beta version.
>>>
>>> The released version of the .Net Framework is v2.0.50727.42
>>>
>>> Uninstall that beta version and download/install -at least- the 2.0
>>> redistributable :
>>> http://www.microsoft.com/downloads/d...displaylang=en
>>>
>>> You might want to -instead- download/install the full SDK from :
>>> http://www.microsoft.com/downloads/d...displaylang=en
>>>
>>>
>>>
>>>
>>>
>>> Juan T. Llibre, asp.net MVP
>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>> asp.net faq : http://asp.net.do/faq/
>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>> ===================================
>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>> news:Oj**************@TK2MSFTNGP04.phx.gbl...
>>>> Hi Juan,
>>>>
>>>> The thing is, I cannot execute any ASP.NET pages. Even your
>>>> Identity.aspx page. I keep on getting the "Server Unavailable"
>>>> error. That is of course, in ASP.NET 2. However, when I tried with
>>>> ASP.NET 1.1, I get...
>>>>
>>>> HOME-WKSTATION\ASPNET
>>>>
>>>> I ran the examples in KBs ***exactly*** the way it presented (with
>>>> the substitue of the variables of course).
>>>>
>>>> And btw, I'm using IIS5 with WinXP not IIS6 (just telling because
>>>> of the article you've provided me was about ASP.NET 2.0 with IIS6).
>>>>
>>>> Another interesting thing is when I tried to do aspnet_regiis -ga
>>>> HOME-WKSTATION\ASPNET under v2.0.50215 folder (as described in the
>>>> article), I get "Invalid Command" and a list of switches that
>>>> aspnet_regiis accepts, which does not contains a 'ga' switch.
>>>>
>>>> Plz help...
>>>>
>>>> Henry
>>>
>>>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>>>> news:eF**************@TK2MSFTNGP02.phx.gbl...
>>>>> Are you still getting this error ?
>>>>>
>>>>>>> 2.) Failed to execute the request because the ASP.NET process
>>>>>>> identity does not have read
>>>>>>> permissions to the global assembly cache. Error: 0x80131902
>>>>>
>>>>> Did you run "identity.aspx", which I provided for you ?
>>>>> Which user account was returned by it ?
>>>>>
>>>>> How did you run the example command provided by the KB ?
>>>>>
>>>>> cacls %windir%\assembly /e /t /p domain\useraccount:R
>>>>>
>>>>> ?
>>>>>
>>>>> Have you read this article :
>>>>> http://msdn.microsoft.com/library/de...aght000009.asp
>>>>>
>>>>> ?
>>>>>
>>>>> Please review the steps in it, for creating a service account for
>>>>> an ASP.NET 2.0 application,
>>>>> and make sure that the account retrned by "identity.aspx" has all
>>>>> the permissions
>>>>> listed in that article.
>>>>>
>>>>> In particular, make sure you run the following aspnet_regiis
>>>>> command :
>>>>>
>>>>> aspnet_regiis -ga MachineName\AccountName
>>>>>
>>>>> where "MachineName\AccountName" is the account returned by
>>>>> "identity.aspx".
>>>>>
>>>>> Then post back your results.
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> Juan T. Llibre, asp.net MVP
>>>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>>>> asp.net faq : http://asp.net.do/faq/
>>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>> ===================================
>>>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>>>> news:uA**************@TK2MSFTNGP03.phx.gbl...
>>>>>> Hi Juan,
>>>>>>
>>>>>> Thanks for the reply. I've set permission to all the folders and
>>>>>> everything but still it doesn't
>>>>>> work.
>>>>>>
>>>>>> I've also tried the "Denis Bauer's ASP.NET Version Switcher" but
>>>>>> that doesn't help either.
>>>>>>
>>>>>> Any other ideas?
>>>>>>
>>>>>> Cheers,
>>>>>> Jon B
>>>>>>
>>>>>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>>>>>> news:u5**************@TK2MSFTNGP02.phx.gbl...
>>>>>>> If you're running on Windows XP, the account which needs
>>>>>>> permissions is
>>>>>>> MACHINENAME\ASPNET...even if you're allowing anonymous access.
>>>>>>>
>>>>>>> Try granting access permissions to the appropiate account, as
>>>>>>> outlined above.
>>>>>>>
>>>>>>> If you are still having problems after that, and you're
>>>>>>> impersonating some account,
>>>>>>> save this code as "identity.aspx" and run it :
>>>>>>>
>>>>>>> identity.aspx
>>>>>>> ========
>>>>>>>
>>>>>>> <%@ Page Language="VB" %>
>>>>>>> <%@ Import NameSpace = System.Security.Principal %>
>>>>>>> <script runat="server">
>>>>>>> Sub Page_Load()
>>>>>>> Dim tmp As String = WindowsIdentity.GetCurrent.Name()
>>>>>>> Label1.Text = tmp
>>>>>>> End Sub
>>>>>>> </script>
>>>>>>> <html>
>>>>>>> <head>
>>>>>>> <title>WindowsIdentity.GetCurrent.Name()</title>
>>>>>>> </head>
>>>>>>> <body>
>>>>>>> <form id="form1" runat="server">
>>>>>>> <div>
>>>>>>> <asp:Label ID="Label1" Runat="server"
>>>>>>> Text="Label"></asp:Label>
>>>>>>> </div>
>>>>>>> </form>
>>>>>>> </body>
>>>>>>> </html>
>>>>>>> ======
>>>>>>>
>>>>>>> Running that file will tell you which account ASP.NET is running
>>>>>>> as.
>>>>>>> Then, assign the appropiate permissions to that account.
>>>>>>>
>>>>>>> Also, download and run Denis Bauer's ASP.NET Version Switcher,
>>>>>>> and make sure that you're actually running 1.1 apps against the
>>>>>>> 1.1 .Net Framework and 2.0 apps against .Net Framework 2.0.
>>>>>>>
>>>>>>> http://www.denisbauer.com/NETTools/A...nSwitcher.aspx
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> Juan T. Llibre, asp.net MVP
>>>>>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>>>>>> asp.net faq : http://asp.net.do/faq/
>>>>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>>> ===================================
>>>>>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>>>>>> news:uT**************@TK2MSFTNGP04.phx.gbl...
>>>>>>>> Hi All!
>>>>>>>>
>>>>>>>> I have a ASP.NET 2.0 site that works on the Windows 2000
>>>>>>>> Server. However, when I tried to view
>>>>>>>> this site on my local Windows XP machine, I get "Server
>>>>>>>> Unavailable". If I switch the Windows XP
>>>>>>>> IIS back to ASP.NET 1.1 then I get the Configuration Error
>>>>>>>> (which is understandable because I'm
>>>>>>>> trying to run an ASP.NET 2 site with 1.1 framework).
>>>>>>>>
>>>>>>>> I can however view other ASP.NET 1.1 sites on my local Windows
>>>>>>>> XP machine. It's only the problem
>>>>>>>> with
>>>>>>>>
>>>>>>>> I've also tried the aspnet_regiis thing as well as setting
>>>>>>>> permissions on folders as described
>>>>>>>> in this article:
>>>>>>>> http://support.microsoft.com/default.aspx?kbid=811320
>>>>>>>> but no solution.
>>>>>>>>
>>>>>>>> In the event log, I see these three errors every I tried to
>>>>>>>> view my ASP.NET 2.0 site on my local
>>>>>>>> machine...
>>>>>>>>
>>>>>>>> <errors>
>>>>>>>>
>>>>>>>> 1.) .aspnet_wp.exe (PID: 3988) stopped unexpectedly
>>>>>>>>
>>>>>>>> 2.) Failed to execute the request because the ASP.NET process
>>>>>>>> identity does not have read
>>>>>>>> permissions to the global assembly cache. Error: 0x80131902
>>>>>>>>
>>>>>>>> 3.) Failed to initialize the AppDomain:/LM/W3SVC/1/Root
>>>>>>>>
>>>>>>>> Exception: System.Configuration.ConfigurationErrorsException
>>>>>>>>
>>>>>>>> Message: Exception of type
>>>>>>>> 'System.Configuration.ConfigurationErrorsException ' was thrown.
>>>>>>>>
>>>>>>>> </errors>
>>>>>>>>
>>>>>>>> What could be the problem?!?!?!? Plz, any solutions or pointers
>>>>>>>> to solutions are much
>>>>>>>> appreciated!!!
>>>>>>>>
>>>>>>>> Thank you all in advance!!!
>>>>>>>>
>>>>>>>> Jon



Apr 30 '06 #15

P: n/a
Maybe it's time for a complete uninstall/reinstall,
instead of trying to fix what seems to be a major screw-up ?

1. uninstall the .Net Framework 2.0
2. uninstall IIS
3. backup your website(s) [ c:\inetpub\wwwroot\* ]
4. delete c:\WINDOWS\system32\inetsrv and all its subdirectories
5. reinstall IIS
6. reinstall the .Net Framework 2.0
7. restore your website(s)

You should be OK, with all default options, after that.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message news:Ok**************@TK2MSFTNGP04.phx.gbl...
guys...

"Jon B" <no*****@sorry.sorry> wrote in message news:ez****************@TK2MSFTNGP04.phx.gbl...
I've tried with the IUSR_HOME-WKSTATION account and I'm still getting the "The specified module
could not be found." page.

Another interesting observation is that, I can type just about anything, like
http://localhost/sdfsfsdfsdds.aspx which doesnt exists and still get the "The specified module
could not be found." error page.

Thanks again,
Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:Oz**************@TK2MSFTNGP04.phx.gbl...
re:
The application-specific permission settings do not grant Local Activation
permission for the COM Server application with CLSID
{A9E69610-B80D-11D0-B9B9-00A0C922E750}
to the user HOME-WKSTATION\ASPNET SID (S-1-5-21-515967899-413027322-839522115-1007). This
security permission can be modified using the Component Services administrative tool.

Have you attempted to grant Local Activation permission to the
COM Server application with CLSID {A9E69610-B80D-11D0-B9B9-00A0C922E750}
to the user HOME-WKSTATION\ASPNET ?

I hope not...because I think that's not the right account.

You say that :
The user account I've setup in "Directory Security" tab of IIS is "HOME-WKSTATION\ASPNET".

But that account doesn't need to be granted browsing rights.

That account only needs execution rights and access permission to the files, so that
ASP.NET can *send* information to the anonymous account which is browsing the site.

Usually, for anonymous access, the user account selected in the
IIS Manager's Directory Security tab is "IUSR_MACHINENAME".

In your case, that would be "IUSR_HOME-WKSTATION".

Since you probably don't know what the password for that account is,
you might have to *first* change the password for that account...and *then* assign
the "IUSR_HOME-WKSTATION" account as the anonymous account,
making sure that you use the password which you just changed.

I've added the microsoft.public.inetserver.iis newsgroup to this post, so that we can get
opinions from the IIS MVPs and other IIS experts who frequent that newsgroup,
since that is more of an IIS problem than an ASP.NET one.

Guys ?


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message news:u$**************@TK2MSFTNGP04.phx.gbl...
Hi Juan,

The error message is "Server Application Unavailable". The user account I've setup in
"Directory Security" tab of IIS is "HOME-WKSTATION\ASPNET".

In the event viewer, I get one warning...

>>>> The server was unable to logon the Windows NT account 'HOME-WKSTATION\ASPNET' due to the
following error: Logon failure: unknown user name or bad password.

followed by 6 errors of the same...

>>>> The application-specific permission settings do not grant Local Activation permission for the
COM Server application with CLSID
{A9E69610-B80D-11D0-B9B9-00A0C922E750}
to the user HOME-WKSTATION\ASPNET SID (S-1-5-21-515967899-413027322-839522115-1007). This
security permission can be modified using the Component Services administrative tool.

I tried setting the user to just "ASPNET" instead of "HOME-WKSTATION\ASPNET" and I tried to
refresh the page in browser and I get "The specified module could not be found" error.

This time, in the event viewer, I only got one warning...

>>>> The server was unable to logon the Windows NT account 'ASPNET' due to the following error: The
specified module could not be found. The data is the error code.

Just for the record, all I doing was just executing a test ASP.NET page with the "Hello World"
code in it.

Thanks,
Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:Ov**************@TK2MSFTNGP03.phx.gbl...
> One more thing...
>
> Is the error message "Server Application Unavailable" or is it "Server Unavailable" ?
>
> Could you look in the event log, and see what additional info is
> there about your "Server Application Unavailable" error message ?
>
> Look in "Start Menu", "Programs", "Administrative Tools", "Event Viewer".
> You should be able to find the specific error in the Application log.
>
>
>
>
> Juan T. Llibre, asp.net MVP
> aspnetfaq.com : http://www.aspnetfaq.com/
> asp.net faq : http://asp.net.do/faq/
> foros de asp.net, en espaņol : http://asp.net.do/foros/
> ===================================
> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
> news:%2****************@TK2MSFTNGP03.phx.gbl...
>> re;
>>> Command worked. However, I'm still getting the "Server Unavailable" error...
>>
>> OK...
>>
>> re:
>>> And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of the article you've
>>> provided me was about ASP.NET 2.0 with IIS6).
>>
>> Nevertheless, the article is valid for IIS 5.1 ( which is what you're running, not 5.0 )
>> and ASP.NET 2.0, as long as you disregard the Application Pool info.
>>
>> Please review the permissions outlined in this article.
>> They were written for ASP.NET 1.1, but they are just as valid for ASP.NET 2.0:
>>
>> http://msdn.microsoft.com/library/de...secnetht01.asp
>>
>> Make sure that the HOME-WKSTATION\ASPNET account has been assigned NTFS
>> permissions to all the directories listed in the chart, making sure, of course, that the
>> proper
>> directory ( \WINDOWS\Microsoft.NET\Framework\v2.0.50727 ) is checked.
>>
>> Make sure you read the instructions in the "Comments" column.
>> *All* the directories listed in the left-most column need the correct NTFS permissions
>> applied.
>>
>> When you're done doing that, test and post your results.
>>
>>
>>
>>
>>
>>
>>
>> Juan T. Llibre, asp.net MVP
>> aspnetfaq.com : http://www.aspnetfaq.com/
>> asp.net faq : http://asp.net.do/faq/
>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>> ===================================
>> "Jon B" <no*****@sorry.sorry> wrote in message news:uf**************@TK2MSFTNGP02.phx.gbl...
>>> Hi Juan,
>>>
>>> Thanks for the reply. I have the latest version in following folder...
>>>
>>> C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
>>>
>>> So I switched to that directory in Command Prompt and tried the following...
>>>
>>> aspnet_regiis -ga HOME-WKSTATION\ASPNET
>>>
>>> Command worked. However, I'm still getting the "Server Unavailable" error...
>>>
>>> Thanks again.
>>>
>>> Jon
>>>
>>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>>> news:eW**************@TK2MSFTNGP05.phx.gbl...
>>>> Hi, Jon.
>>>>
>>>> re:
>>>>> Another interesting thing is when I tried to do aspnet_regiis -ga HOME-WKSTATION\ASPNET
>>>>> under v2.0.50215 folder (as described in the article), I get "Invalid Command"
>>>>
>>>> ...there's your problem.
>>>>
>>>> v2.0.50215 is the beta 2 version of the .Net Framework...which has many bugs.
>>>> The -ga command isn't a part of that beta version.
>>>>
>>>> The released version of the .Net Framework is v2.0.50727.42
>>>>
>>>> Uninstall that beta version and download/install -at least- the 2.0 redistributable :
>>>> http://www.microsoft.com/downloads/d...displaylang=en
>>>>
>>>> You might want to -instead- download/install the full SDK from :
>>>> http://www.microsoft.com/downloads/d...displaylang=en
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> Juan T. Llibre, asp.net MVP
>>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>>> asp.net faq : http://asp.net.do/faq/
>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>> ===================================
>>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>>> news:Oj**************@TK2MSFTNGP04.phx.gbl...
>>>>> Hi Juan,
>>>>>
>>>>> The thing is, I cannot execute any ASP.NET pages. Even your Identity.aspx page. I keep on
>>>>> getting the "Server Unavailable" error. That is of course, in ASP.NET 2. However, when I
>>>>> tried with ASP.NET 1.1, I get...
>>>>>
>>>>> HOME-WKSTATION\ASPNET
>>>>>
>>>>> I ran the examples in KBs ***exactly*** the way it presented (with the substitue of the
>>>>> variables of course).
>>>>>
>>>>> And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of the article you've
>>>>> provided me was about ASP.NET 2.0 with IIS6).
>>>>>
>>>>> Another interesting thing is when I tried to do aspnet_regiis -ga HOME-WKSTATION\ASPNET
>>>>> under v2.0.50215 folder (as described in the article), I get "Invalid Command" and a list
>>>>> of switches that aspnet_regiis accepts, which does not contains a 'ga' switch.
>>>>>
>>>>> Plz help...
>>>>>
>>>>> Henry
>>>>
>>>>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>>>>> news:eF**************@TK2MSFTNGP02.phx.gbl...
>>>>>> Are you still getting this error ?
>>>>>>
>>>>>>>> 2.) Failed to execute the request because the ASP.NET process identity does not have
>>>>>>>> read
>>>>>>>> permissions to the global assembly cache. Error: 0x80131902
>>>>>>
>>>>>> Did you run "identity.aspx", which I provided for you ?
>>>>>> Which user account was returned by it ?
>>>>>>
>>>>>> How did you run the example command provided by the KB ?
>>>>>>
>>>>>> cacls %windir%\assembly /e /t /p domain\useraccount:R
>>>>>>
>>>>>> ?
>>>>>>
>>>>>> Have you read this article :
>>>>>> http://msdn.microsoft.com/library/de...aght000009.asp
>>>>>>
>>>>>> ?
>>>>>>
>>>>>> Please review the steps in it, for creating a service account for an ASP.NET 2.0
>>>>>> application,
>>>>>> and make sure that the account retrned by "identity.aspx" has all the permissions
>>>>>> listed in that article.
>>>>>>
>>>>>> In particular, make sure you run the following aspnet_regiis command :
>>>>>>
>>>>>> aspnet_regiis -ga MachineName\AccountName
>>>>>>
>>>>>> where "MachineName\AccountName" is the account returned by "identity.aspx".
>>>>>>
>>>>>> Then post back your results.
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> Juan T. Llibre, asp.net MVP
>>>>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>>>>> asp.net faq : http://asp.net.do/faq/
>>>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>> ===================================
>>>>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>>>>> news:uA**************@TK2MSFTNGP03.phx.gbl...
>>>>>>> Hi Juan,
>>>>>>>
>>>>>>> Thanks for the reply. I've set permission to all the folders and everything but still it
>>>>>>> doesn't
>>>>>>> work.
>>>>>>>
>>>>>>> I've also tried the "Denis Bauer's ASP.NET Version Switcher" but that doesn't help
>>>>>>> either.
>>>>>>>
>>>>>>> Any other ideas?
>>>>>>>
>>>>>>> Cheers,
>>>>>>> Jon B
>>>>>>>
>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>>>>>>> news:u5**************@TK2MSFTNGP02.phx.gbl...
>>>>>>>> If you're running on Windows XP, the account which needs permissions is
>>>>>>>> MACHINENAME\ASPNET...even if you're allowing anonymous access.
>>>>>>>>
>>>>>>>> Try granting access permissions to the appropiate account, as outlined above.
>>>>>>>>
>>>>>>>> If you are still having problems after that, and you're impersonating some account,
>>>>>>>> save this code as "identity.aspx" and run it :
>>>>>>>>
>>>>>>>> identity.aspx
>>>>>>>> ========
>>>>>>>>
>>>>>>>> <%@ Page Language="VB" %>
>>>>>>>> <%@ Import NameSpace = System.Security.Principal %>
>>>>>>>> <script runat="server">
>>>>>>>> Sub Page_Load()
>>>>>>>> Dim tmp As String = WindowsIdentity.GetCurrent.Name()
>>>>>>>> Label1.Text = tmp
>>>>>>>> End Sub
>>>>>>>> </script>
>>>>>>>> <html>
>>>>>>>> <head>
>>>>>>>> <title>WindowsIdentity.GetCurrent.Name()</title>
>>>>>>>> </head>
>>>>>>>> <body>
>>>>>>>> <form id="form1" runat="server">
>>>>>>>> <div>
>>>>>>>> <asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
>>>>>>>> </div>
>>>>>>>> </form>
>>>>>>>> </body>
>>>>>>>> </html>
>>>>>>>> ======
>>>>>>>>
>>>>>>>> Running that file will tell you which account ASP.NET is running as.
>>>>>>>> Then, assign the appropiate permissions to that account.
>>>>>>>>
>>>>>>>> Also, download and run Denis Bauer's ASP.NET Version Switcher,
>>>>>>>> and make sure that you're actually running 1.1 apps against the
>>>>>>>> 1.1 .Net Framework and 2.0 apps against .Net Framework 2.0.
>>>>>>>>
>>>>>>>> http://www.denisbauer.com/NETTools/A...nSwitcher.aspx
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> Juan T. Llibre, asp.net MVP
>>>>>>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>>>>>>> asp.net faq : http://asp.net.do/faq/
>>>>>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>>>> ===================================
>>>>>>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>>>>>>> news:uT**************@TK2MSFTNGP04.phx.gbl...
>>>>>>>>> Hi All!
>>>>>>>>>
>>>>>>>>> I have a ASP.NET 2.0 site that works on the Windows 2000 Server. However, when I tried
>>>>>>>>> to view
>>>>>>>>> this site on my local Windows XP machine, I get "Server Unavailable". If I switch the
>>>>>>>>> Windows XP
>>>>>>>>> IIS back to ASP.NET 1.1 then I get the Configuration Error (which is understandable
>>>>>>>>> because I'm
>>>>>>>>> trying to run an ASP.NET 2 site with 1.1 framework).
>>>>>>>>>
>>>>>>>>> I can however view other ASP.NET 1.1 sites on my local Windows XP machine. It's only
>>>>>>>>> the problem
>>>>>>>>> with
>>>>>>>>>
>>>>>>>>> I've also tried the aspnet_regiis thing as well as setting permissions on folders as
>>>>>>>>> described
>>>>>>>>> in this article:
>>>>>>>>> http://support.microsoft.com/default.aspx?kbid=811320
>>>>>>>>> but no solution.
>>>>>>>>>
>>>>>>>>> In the event log, I see these three errors every I tried to view my ASP.NET 2.0 site
>>>>>>>>> on my local
>>>>>>>>> machine...
>>>>>>>>>
>>>>>>>>> <errors>
>>>>>>>>>
>>>>>>>>> 1.) .aspnet_wp.exe (PID: 3988) stopped unexpectedly
>>>>>>>>>
>>>>>>>>> 2.) Failed to execute the request because the ASP.NET process identity does not have
>>>>>>>>> read
>>>>>>>>> permissions to the global assembly cache. Error: 0x80131902
>>>>>>>>>
>>>>>>>>> 3.) Failed to initialize the AppDomain:/LM/W3SVC/1/Root
>>>>>>>>>
>>>>>>>>> Exception: System.Configuration.ConfigurationErrorsException
>>>>>>>>>
>>>>>>>>> Message: Exception of type 'System.Configuration.ConfigurationErrorsException ' was
>>>>>>>>> thrown.
>>>>>>>>>
>>>>>>>>> </errors>
>>>>>>>>>
>>>>>>>>> What could be the problem?!?!?!? Plz, any solutions or pointers to solutions are much
>>>>>>>>> appreciated!!!
>>>>>>>>>
>>>>>>>>> Thank you all in advance!!!
>>>>>>>>>
>>>>>>>>> Jon
>
>




Apr 30 '06 #16

P: n/a
Hi Juan,

I did the exact followings...

1. uninstall the .Net Framework 2.0
2. uninstall IIS
3. backup your website(s) [ c:\inetpub\wwwroot\* ]
4. delete c:\WINDOWS\system32\inetsrv and all its subdirectories
5. reinstall IIS
6. reinstall the .Net Framework 2.0
7. restore your website(s)

Now, both ASP.NET 1.1 and 2 is not working and throwing me the "specified
module could not be found" error.

Any ideas why?

Thanks again,
Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2****************@TK2MSFTNGP02.phx.gbl...
Maybe it's time for a complete uninstall/reinstall,
instead of trying to fix what seems to be a major screw-up ?

1. uninstall the .Net Framework 2.0
2. uninstall IIS
3. backup your website(s) [ c:\inetpub\wwwroot\* ]
4. delete c:\WINDOWS\system32\inetsrv and all its subdirectories
5. reinstall IIS
6. reinstall the .Net Framework 2.0
7. restore your website(s)

You should be OK, with all default options, after that.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message
news:Ok**************@TK2MSFTNGP04.phx.gbl...
guys...

"Jon B" <no*****@sorry.sorry> wrote in message
news:ez****************@TK2MSFTNGP04.phx.gbl...
I've tried with the IUSR_HOME-WKSTATION account and I'm still getting
the "The specified module
could not be found." page.

Another interesting observation is that, I can type just about anything,
like
http://localhost/sdfsfsdfsdds.aspx which doesnt exists and still get the
"The specified module
could not be found." error page.

Thanks again,
Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:Oz**************@TK2MSFTNGP04.phx.gbl...
re:
The application-specific permission settings do not grant Local
Activation
> permission for the COM Server application with CLSID
> {A9E69610-B80D-11D0-B9B9-00A0C922E750}
> to the user HOME-WKSTATION\ASPNET SID
> (S-1-5-21-515967899-413027322-839522115-1007). This
> security permission can be modified using the Component Services
> administrative tool.

Have you attempted to grant Local Activation permission to the
COM Server application with CLSID
{A9E69610-B80D-11D0-B9B9-00A0C922E750}
to the user HOME-WKSTATION\ASPNET ?

I hope not...because I think that's not the right account.

You say that :
> The user account I've setup in "Directory Security" tab of IIS is
> "HOME-WKSTATION\ASPNET".

But that account doesn't need to be granted browsing rights.

That account only needs execution rights and access permission to the
files, so that
ASP.NET can *send* information to the anonymous account which is
browsing the site.

Usually, for anonymous access, the user account selected in the
IIS Manager's Directory Security tab is "IUSR_MACHINENAME".

In your case, that would be "IUSR_HOME-WKSTATION".

Since you probably don't know what the password for that account is,
you might have to *first* change the password for that account...and
*then* assign
the "IUSR_HOME-WKSTATION" account as the anonymous account,
making sure that you use the password which you just changed.

I've added the microsoft.public.inetserver.iis newsgroup to this post,
so that we can get
opinions from the IIS MVPs and other IIS experts who frequent that
newsgroup,
since that is more of an IIS problem than an ASP.NET one.

Guys ?


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message
news:u$**************@TK2MSFTNGP04.phx.gbl...
> Hi Juan,
>
> The error message is "Server Application Unavailable". The user
> account I've setup in
> "Directory Security" tab of IIS is "HOME-WKSTATION\ASPNET".
>
> In the event viewer, I get one warning...
>
>
>>>>> The server was unable to logon the Windows NT account
> 'HOME-WKSTATION\ASPNET' due to the
> following error: Logon failure: unknown user name or bad password.
>
>
> followed by 6 errors of the same...
>
>
>>>>> The application-specific permission settings do not grant Local
> Activation permission for the
> COM Server application with CLSID
> {A9E69610-B80D-11D0-B9B9-00A0C922E750}
> to the user HOME-WKSTATION\ASPNET SID
> (S-1-5-21-515967899-413027322-839522115-1007). This
> security permission can be modified using the Component Services
> administrative tool.
>
>
> I tried setting the user to just "ASPNET" instead of
> "HOME-WKSTATION\ASPNET" and I tried to
> refresh the page in browser and I get "The specified module could not
> be found" error.
>
> This time, in the event viewer, I only got one warning...
>
>
>>>>> The server was unable to logon the Windows NT account 'ASPNET' due to
> the following error: The
> specified module could not be found. The data is the error code.
>
>
> Just for the record, all I doing was just executing a test ASP.NET
> page with the "Hello World"
> code in it.
>
> Thanks,
> Jon
>
> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
> news:Ov**************@TK2MSFTNGP03.phx.gbl...
>> One more thing...
>>
>> Is the error message "Server Application Unavailable" or is it
>> "Server Unavailable" ?
>>
>> Could you look in the event log, and see what additional info is
>> there about your "Server Application Unavailable" error message ?
>>
>> Look in "Start Menu", "Programs", "Administrative Tools", "Event
>> Viewer".
>> You should be able to find the specific error in the Application log.
>>
>>
>>
>>
>> Juan T. Llibre, asp.net MVP
>> aspnetfaq.com : http://www.aspnetfaq.com/
>> asp.net faq : http://asp.net.do/faq/
>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>> ===================================
>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>> news:%2****************@TK2MSFTNGP03.phx.gbl...
>>> re;
>>>> Command worked. However, I'm still getting the "Server Unavailable"
>>>> error...
>>>
>>> OK...
>>>
>>> re:
>>>> And btw, I'm using IIS5 with WinXP not IIS6 (just telling because
>>>> of the article you've
>>>> provided me was about ASP.NET 2.0 with IIS6).
>>>
>>> Nevertheless, the article is valid for IIS 5.1 ( which is what
>>> you're running, not 5.0 )
>>> and ASP.NET 2.0, as long as you disregard the Application Pool info.
>>>
>>> Please review the permissions outlined in this article.
>>> They were written for ASP.NET 1.1, but they are just as valid for
>>> ASP.NET 2.0:
>>>
>>> http://msdn.microsoft.com/library/de...secnetht01.asp
>>>
>>> Make sure that the HOME-WKSTATION\ASPNET account has been assigned
>>> NTFS
>>> permissions to all the directories listed in the chart, making sure,
>>> of course, that the
>>> proper
>>> directory ( \WINDOWS\Microsoft.NET\Framework\v2.0.50727 ) is
>>> checked.
>>>
>>> Make sure you read the instructions in the "Comments" column.
>>> *All* the directories listed in the left-most column need the
>>> correct NTFS permissions
>>> applied.
>>>
>>> When you're done doing that, test and post your results.
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>> Juan T. Llibre, asp.net MVP
>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>> asp.net faq : http://asp.net.do/faq/
>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>> ===================================
>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>> news:uf**************@TK2MSFTNGP02.phx.gbl...
>>>> Hi Juan,
>>>>
>>>> Thanks for the reply. I have the latest version in following
>>>> folder...
>>>>
>>>> C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
>>>>
>>>> So I switched to that directory in Command Prompt and tried the
>>>> following...
>>>>
>>>> aspnet_regiis -ga HOME-WKSTATION\ASPNET
>>>>
>>>> Command worked. However, I'm still getting the "Server Unavailable"
>>>> error...
>>>>
>>>> Thanks again.
>>>>
>>>> Jon
>>>>
>>>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>>>> news:eW**************@TK2MSFTNGP05.phx.gbl...
>>>>> Hi, Jon.
>>>>>
>>>>> re:
>>>>>> Another interesting thing is when I tried to do aspnet_regiis -ga
>>>>>> HOME-WKSTATION\ASPNET
>>>>>> under v2.0.50215 folder (as described in the article), I get
>>>>>> "Invalid Command"
>>>>>
>>>>> ...there's your problem.
>>>>>
>>>>> v2.0.50215 is the beta 2 version of the .Net Framework...which has
>>>>> many bugs.
>>>>> The -ga command isn't a part of that beta version.
>>>>>
>>>>> The released version of the .Net Framework is v2.0.50727.42
>>>>>
>>>>> Uninstall that beta version and download/install -at least- the
>>>>> 2.0 redistributable :
>>>>> http://www.microsoft.com/downloads/d...displaylang=en
>>>>>
>>>>> You might want to -instead- download/install the full SDK from :
>>>>> http://www.microsoft.com/downloads/d...displaylang=en
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> Juan T. Llibre, asp.net MVP
>>>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>>>> asp.net faq : http://asp.net.do/faq/
>>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>> ===================================
>>>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>>>> news:Oj**************@TK2MSFTNGP04.phx.gbl...
>>>>>> Hi Juan,
>>>>>>
>>>>>> The thing is, I cannot execute any ASP.NET pages. Even your
>>>>>> Identity.aspx page. I keep on
>>>>>> getting the "Server Unavailable" error. That is of course, in
>>>>>> ASP.NET 2. However, when I
>>>>>> tried with ASP.NET 1.1, I get...
>>>>>>
>>>>>> HOME-WKSTATION\ASPNET
>>>>>>
>>>>>> I ran the examples in KBs ***exactly*** the way it presented
>>>>>> (with the substitue of the
>>>>>> variables of course).
>>>>>>
>>>>>> And btw, I'm using IIS5 with WinXP not IIS6 (just telling because
>>>>>> of the article you've
>>>>>> provided me was about ASP.NET 2.0 with IIS6).
>>>>>>
>>>>>> Another interesting thing is when I tried to do aspnet_regiis -ga
>>>>>> HOME-WKSTATION\ASPNET
>>>>>> under v2.0.50215 folder (as described in the article), I get
>>>>>> "Invalid Command" and a list
>>>>>> of switches that aspnet_regiis accepts, which does not contains a
>>>>>> 'ga' switch.
>>>>>>
>>>>>> Plz help...
>>>>>>
>>>>>> Henry
>>>>>
>>>>>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>>>>>> news:eF**************@TK2MSFTNGP02.phx.gbl...
>>>>>>> Are you still getting this error ?
>>>>>>>
>>>>>>>>> 2.) Failed to execute the request because the ASP.NET process
>>>>>>>>> identity does not have
>>>>>>>>> read
>>>>>>>>> permissions to the global assembly cache. Error: 0x80131902
>>>>>>>
>>>>>>> Did you run "identity.aspx", which I provided for you ?
>>>>>>> Which user account was returned by it ?
>>>>>>>
>>>>>>> How did you run the example command provided by the KB ?
>>>>>>>
>>>>>>> cacls %windir%\assembly /e /t /p domain\useraccount:R
>>>>>>>
>>>>>>> ?
>>>>>>>
>>>>>>> Have you read this article :
>>>>>>> http://msdn.microsoft.com/library/de...aght000009.asp
>>>>>>>
>>>>>>> ?
>>>>>>>
>>>>>>> Please review the steps in it, for creating a service account
>>>>>>> for an ASP.NET 2.0
>>>>>>> application,
>>>>>>> and make sure that the account retrned by "identity.aspx" has
>>>>>>> all the permissions
>>>>>>> listed in that article.
>>>>>>>
>>>>>>> In particular, make sure you run the following aspnet_regiis
>>>>>>> command :
>>>>>>>
>>>>>>> aspnet_regiis -ga MachineName\AccountName
>>>>>>>
>>>>>>> where "MachineName\AccountName" is the account returned by
>>>>>>> "identity.aspx".
>>>>>>>
>>>>>>> Then post back your results.
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> Juan T. Llibre, asp.net MVP
>>>>>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>>>>>> asp.net faq : http://asp.net.do/faq/
>>>>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>>> ===================================
>>>>>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>>>>>> news:uA**************@TK2MSFTNGP03.phx.gbl...
>>>>>>>> Hi Juan,
>>>>>>>>
>>>>>>>> Thanks for the reply. I've set permission to all the folders
>>>>>>>> and everything but still it
>>>>>>>> doesn't
>>>>>>>> work.
>>>>>>>>
>>>>>>>> I've also tried the "Denis Bauer's ASP.NET Version Switcher"
>>>>>>>> but that doesn't help
>>>>>>>> either.
>>>>>>>>
>>>>>>>> Any other ideas?
>>>>>>>>
>>>>>>>> Cheers,
>>>>>>>> Jon B
>>>>>>>>
>>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>>>>>>>> news:u5**************@TK2MSFTNGP02.phx.gbl...
>>>>>>>>> If you're running on Windows XP, the account which needs
>>>>>>>>> permissions is
>>>>>>>>> MACHINENAME\ASPNET...even if you're allowing anonymous access.
>>>>>>>>>
>>>>>>>>> Try granting access permissions to the appropiate account, as
>>>>>>>>> outlined above.
>>>>>>>>>
>>>>>>>>> If you are still having problems after that, and you're
>>>>>>>>> impersonating some account,
>>>>>>>>> save this code as "identity.aspx" and run it :
>>>>>>>>>
>>>>>>>>> identity.aspx
>>>>>>>>> ========
>>>>>>>>>
>>>>>>>>> <%@ Page Language="VB" %>
>>>>>>>>> <%@ Import NameSpace = System.Security.Principal %>
>>>>>>>>> <script runat="server">
>>>>>>>>> Sub Page_Load()
>>>>>>>>> Dim tmp As String = WindowsIdentity.GetCurrent.Name()
>>>>>>>>> Label1.Text = tmp
>>>>>>>>> End Sub
>>>>>>>>> </script>
>>>>>>>>> <html>
>>>>>>>>> <head>
>>>>>>>>> <title>WindowsIdentity.GetCurrent.Name()</title>
>>>>>>>>> </head>
>>>>>>>>> <body>
>>>>>>>>> <form id="form1" runat="server">
>>>>>>>>> <div>
>>>>>>>>> <asp:Label ID="Label1" Runat="server"
>>>>>>>>> Text="Label"></asp:Label>
>>>>>>>>> </div>
>>>>>>>>> </form>
>>>>>>>>> </body>
>>>>>>>>> </html>
>>>>>>>>> ======
>>>>>>>>>
>>>>>>>>> Running that file will tell you which account ASP.NET is
>>>>>>>>> running as.
>>>>>>>>> Then, assign the appropiate permissions to that account.
>>>>>>>>>
>>>>>>>>> Also, download and run Denis Bauer's ASP.NET Version Switcher,
>>>>>>>>> and make sure that you're actually running 1.1 apps against
>>>>>>>>> the
>>>>>>>>> 1.1 .Net Framework and 2.0 apps against .Net Framework 2.0.
>>>>>>>>>
>>>>>>>>> http://www.denisbauer.com/NETTools/A...nSwitcher.aspx
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Juan T. Llibre, asp.net MVP
>>>>>>>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>>>>>>>> asp.net faq : http://asp.net.do/faq/
>>>>>>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>>>>> ===================================
>>>>>>>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>>>>>>>> news:uT**************@TK2MSFTNGP04.phx.gbl...
>>>>>>>>>> Hi All!
>>>>>>>>>>
>>>>>>>>>> I have a ASP.NET 2.0 site that works on the Windows 2000
>>>>>>>>>> Server. However, when I tried
>>>>>>>>>> to view
>>>>>>>>>> this site on my local Windows XP machine, I get "Server
>>>>>>>>>> Unavailable". If I switch the
>>>>>>>>>> Windows XP
>>>>>>>>>> IIS back to ASP.NET 1.1 then I get the Configuration Error
>>>>>>>>>> (which is understandable
>>>>>>>>>> because I'm
>>>>>>>>>> trying to run an ASP.NET 2 site with 1.1 framework).
>>>>>>>>>>
>>>>>>>>>> I can however view other ASP.NET 1.1 sites on my local
>>>>>>>>>> Windows XP machine. It's only
>>>>>>>>>> the problem
>>>>>>>>>> with
>>>>>>>>>>
>>>>>>>>>> I've also tried the aspnet_regiis thing as well as setting
>>>>>>>>>> permissions on folders as
>>>>>>>>>> described
>>>>>>>>>> in this article:
>>>>>>>>>> http://support.microsoft.com/default.aspx?kbid=811320
>>>>>>>>>> but no solution.
>>>>>>>>>>
>>>>>>>>>> In the event log, I see these three errors every I tried to
>>>>>>>>>> view my ASP.NET 2.0 site
>>>>>>>>>> on my local
>>>>>>>>>> machine...
>>>>>>>>>>
>>>>>>>>>> <errors>
>>>>>>>>>>
>>>>>>>>>> 1.) .aspnet_wp.exe (PID: 3988) stopped unexpectedly
>>>>>>>>>>
>>>>>>>>>> 2.) Failed to execute the request because the ASP.NET
>>>>>>>>>> process identity does not have
>>>>>>>>>> read
>>>>>>>>>> permissions to the global assembly cache. Error: 0x80131902
>>>>>>>>>>
>>>>>>>>>> 3.) Failed to initialize the AppDomain:/LM/W3SVC/1/Root
>>>>>>>>>>
>>>>>>>>>> Exception: System.Configuration.ConfigurationErrorsException
>>>>>>>>>>
>>>>>>>>>> Message: Exception of type
>>>>>>>>>> 'System.Configuration.ConfigurationErrorsException ' was
>>>>>>>>>> thrown.
>>>>>>>>>>
>>>>>>>>>> </errors>
>>>>>>>>>>
>>>>>>>>>> What could be the problem?!?!?!? Plz, any solutions or
>>>>>>>>>> pointers to solutions are much
>>>>>>>>>> appreciated!!!
>>>>>>>>>>
>>>>>>>>>> Thank you all in advance!!!
>>>>>>>>>>
>>>>>>>>>> Jon
>>
>>
>
>



May 1 '06 #17

P: n/a
To re-register the .Net Framework 1.1, run this command from
a command window in the .Net Framework 1.1 directory :

aspnet_regiis -i


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message news:%2****************@TK2MSFTNGP02.phx.gbl...
Hi Juan,

I did the exact followings...

1. uninstall the .Net Framework 2.0
2. uninstall IIS
3. backup your website(s) [ c:\inetpub\wwwroot\* ]
4. delete c:\WINDOWS\system32\inetsrv and all its subdirectories
5. reinstall IIS
6. reinstall the .Net Framework 2.0
7. restore your website(s)

Now, both ASP.NET 1.1 and 2 is not working and throwing me the "specified module could not be
found" error.

Any ideas why?

Thanks again,
Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:%2****************@TK2MSFTNGP02.phx.gbl...
Maybe it's time for a complete uninstall/reinstall,
instead of trying to fix what seems to be a major screw-up ?

1. uninstall the .Net Framework 2.0
2. uninstall IIS
3. backup your website(s) [ c:\inetpub\wwwroot\* ]
4. delete c:\WINDOWS\system32\inetsrv and all its subdirectories
5. reinstall IIS
6. reinstall the .Net Framework 2.0
7. restore your website(s)

You should be OK, with all default options, after that.


Juan T. Llibre, asp.net MVP
aspnetfaq.com : http://www.aspnetfaq.com/
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en espaņol : http://asp.net.do/foros/
===================================
"Jon B" <no*****@sorry.sorry> wrote in message news:Ok**************@TK2MSFTNGP04.phx.gbl...
guys...

"Jon B" <no*****@sorry.sorry> wrote in message news:ez****************@TK2MSFTNGP04.phx.gbl...
I've tried with the IUSR_HOME-WKSTATION account and I'm still getting the "The specified module
could not be found." page.

Another interesting observation is that, I can type just about anything, like
http://localhost/sdfsfsdfsdds.aspx which doesnt exists and still get the "The specified module
could not be found." error page.

Thanks again,
Jon

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:Oz**************@TK2MSFTNGP04.phx.gbl...
> re:
> The application-specific permission settings do not grant Local Activation
>> permission for the COM Server application with CLSID
>> {A9E69610-B80D-11D0-B9B9-00A0C922E750}
>> to the user HOME-WKSTATION\ASPNET SID (S-1-5-21-515967899-413027322-839522115-1007). This
>> security permission can be modified using the Component Services administrative tool.
>
> Have you attempted to grant Local Activation permission to the
> COM Server application with CLSID {A9E69610-B80D-11D0-B9B9-00A0C922E750}
> to the user HOME-WKSTATION\ASPNET ?
>
> I hope not...because I think that's not the right account.
>
> You say that :
>> The user account I've setup in "Directory Security" tab of IIS is "HOME-WKSTATION\ASPNET".
>
> But that account doesn't need to be granted browsing rights.
>
> That account only needs execution rights and access permission to the files, so that
> ASP.NET can *send* information to the anonymous account which is browsing the site.
>
> Usually, for anonymous access, the user account selected in the
> IIS Manager's Directory Security tab is "IUSR_MACHINENAME".
>
> In your case, that would be "IUSR_HOME-WKSTATION".
>
> Since you probably don't know what the password for that account is,
> you might have to *first* change the password for that account...and *then* assign
> the "IUSR_HOME-WKSTATION" account as the anonymous account,
> making sure that you use the password which you just changed.
>
> I've added the microsoft.public.inetserver.iis newsgroup to this post, so that we can get
> opinions from the IIS MVPs and other IIS experts who frequent that newsgroup,
> since that is more of an IIS problem than an ASP.NET one.
>
> Guys ?
>
>
>
>
> Juan T. Llibre, asp.net MVP
> aspnetfaq.com : http://www.aspnetfaq.com/
> asp.net faq : http://asp.net.do/faq/
> foros de asp.net, en espaņol : http://asp.net.do/foros/
> ===================================
> "Jon B" <no*****@sorry.sorry> wrote in message news:u$**************@TK2MSFTNGP04.phx.gbl...
>> Hi Juan,
>>
>> The error message is "Server Application Unavailable". The user account I've setup in
>> "Directory Security" tab of IIS is "HOME-WKSTATION\ASPNET".
>>
>> In the event viewer, I get one warning...
>>
>>
>>>>>> The server was unable to logon the Windows NT account 'HOME-WKSTATION\ASPNET' due to the
>> following error: Logon failure: unknown user name or bad password.
>>
>>
>> followed by 6 errors of the same...
>>
>>
>>>>>> The application-specific permission settings do not grant Local Activation permission for the
>> COM Server application with CLSID
>> {A9E69610-B80D-11D0-B9B9-00A0C922E750}
>> to the user HOME-WKSTATION\ASPNET SID (S-1-5-21-515967899-413027322-839522115-1007). This
>> security permission can be modified using the Component Services administrative tool.
>>
>>
>> I tried setting the user to just "ASPNET" instead of "HOME-WKSTATION\ASPNET" and I tried to
>> refresh the page in browser and I get "The specified module could not be found" error.
>>
>> This time, in the event viewer, I only got one warning...
>>
>>
>>>>>> The server was unable to logon the Windows NT account 'ASPNET' due to the following error:
>> The
>> specified module could not be found. The data is the error code.
>>
>>
>> Just for the record, all I doing was just executing a test ASP.NET page with the "Hello
>> World"
>> code in it.
>>
>> Thanks,
>> Jon
>>
>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>> news:Ov**************@TK2MSFTNGP03.phx.gbl...
>>> One more thing...
>>>
>>> Is the error message "Server Application Unavailable" or is it "Server Unavailable" ?
>>>
>>> Could you look in the event log, and see what additional info is
>>> there about your "Server Application Unavailable" error message ?
>>>
>>> Look in "Start Menu", "Programs", "Administrative Tools", "Event Viewer".
>>> You should be able to find the specific error in the Application log.
>>>
>>>
>>>
>>>
>>> Juan T. Llibre, asp.net MVP
>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>> asp.net faq : http://asp.net.do/faq/
>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>> ===================================
>>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>>> news:%2****************@TK2MSFTNGP03.phx.gbl...
>>>> re;
>>>>> Command worked. However, I'm still getting the "Server Unavailable" error...
>>>>
>>>> OK...
>>>>
>>>> re:
>>>>> And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of the article you've
>>>>> provided me was about ASP.NET 2.0 with IIS6).
>>>>
>>>> Nevertheless, the article is valid for IIS 5.1 ( which is what you're running, not 5.0 )
>>>> and ASP.NET 2.0, as long as you disregard the Application Pool info.
>>>>
>>>> Please review the permissions outlined in this article.
>>>> They were written for ASP.NET 1.1, but they are just as valid for ASP.NET 2.0:
>>>>
>>>> http://msdn.microsoft.com/library/de...secnetht01.asp
>>>>
>>>> Make sure that the HOME-WKSTATION\ASPNET account has been assigned NTFS
>>>> permissions to all the directories listed in the chart, making sure, of course, that the
>>>> proper
>>>> directory ( \WINDOWS\Microsoft.NET\Framework\v2.0.50727 ) is checked.
>>>>
>>>> Make sure you read the instructions in the "Comments" column.
>>>> *All* the directories listed in the left-most column need the correct NTFS permissions
>>>> applied.
>>>>
>>>> When you're done doing that, test and post your results.
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> Juan T. Llibre, asp.net MVP
>>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>>> asp.net faq : http://asp.net.do/faq/
>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>> ===================================
>>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>>> news:uf**************@TK2MSFTNGP02.phx.gbl...
>>>>> Hi Juan,
>>>>>
>>>>> Thanks for the reply. I have the latest version in following folder...
>>>>>
>>>>> C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
>>>>>
>>>>> So I switched to that directory in Command Prompt and tried the following...
>>>>>
>>>>> aspnet_regiis -ga HOME-WKSTATION\ASPNET
>>>>>
>>>>> Command worked. However, I'm still getting the "Server Unavailable" error...
>>>>>
>>>>> Thanks again.
>>>>>
>>>>> Jon
>>>>>
>>>>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>>>>> news:eW**************@TK2MSFTNGP05.phx.gbl...
>>>>>> Hi, Jon.
>>>>>>
>>>>>> re:
>>>>>>> Another interesting thing is when I tried to do aspnet_regiis -ga HOME-WKSTATION\ASPNET
>>>>>>> under v2.0.50215 folder (as described in the article), I get "Invalid Command"
>>>>>>
>>>>>> ...there's your problem.
>>>>>>
>>>>>> v2.0.50215 is the beta 2 version of the .Net Framework...which has many bugs.
>>>>>> The -ga command isn't a part of that beta version.
>>>>>>
>>>>>> The released version of the .Net Framework is v2.0.50727.42
>>>>>>
>>>>>> Uninstall that beta version and download/install -at least- the 2.0 redistributable :
>>>>>> http://www.microsoft.com/downloads/d...displaylang=en
>>>>>>
>>>>>> You might want to -instead- download/install the full SDK from :
>>>>>> http://www.microsoft.com/downloads/d...displaylang=en
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> Juan T. Llibre, asp.net MVP
>>>>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>>>>> asp.net faq : http://asp.net.do/faq/
>>>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>> ===================================
>>>>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>>>>> news:Oj**************@TK2MSFTNGP04.phx.gbl...
>>>>>>> Hi Juan,
>>>>>>>
>>>>>>> The thing is, I cannot execute any ASP.NET pages. Even your Identity.aspx page. I keep
>>>>>>> on
>>>>>>> getting the "Server Unavailable" error. That is of course, in ASP.NET 2. However, when I
>>>>>>> tried with ASP.NET 1.1, I get...
>>>>>>>
>>>>>>> HOME-WKSTATION\ASPNET
>>>>>>>
>>>>>>> I ran the examples in KBs ***exactly*** the way it presented (with the substitue of the
>>>>>>> variables of course).
>>>>>>>
>>>>>>> And btw, I'm using IIS5 with WinXP not IIS6 (just telling because of the article you've
>>>>>>> provided me was about ASP.NET 2.0 with IIS6).
>>>>>>>
>>>>>>> Another interesting thing is when I tried to do aspnet_regiis -ga HOME-WKSTATION\ASPNET
>>>>>>> under v2.0.50215 folder (as described in the article), I get "Invalid Command" and a
>>>>>>> list
>>>>>>> of switches that aspnet_regiis accepts, which does not contains a 'ga' switch.
>>>>>>>
>>>>>>> Plz help...
>>>>>>>
>>>>>>> Henry
>>>>>>
>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>>>>>>> news:eF**************@TK2MSFTNGP02.phx.gbl...
>>>>>>>> Are you still getting this error ?
>>>>>>>>
>>>>>>>>>> 2.) Failed to execute the request because the ASP.NET process identity does not have
>>>>>>>>>> read
>>>>>>>>>> permissions to the global assembly cache. Error: 0x80131902
>>>>>>>>
>>>>>>>> Did you run "identity.aspx", which I provided for you ?
>>>>>>>> Which user account was returned by it ?
>>>>>>>>
>>>>>>>> How did you run the example command provided by the KB ?
>>>>>>>>
>>>>>>>> cacls %windir%\assembly /e /t /p domain\useraccount:R
>>>>>>>>
>>>>>>>> ?
>>>>>>>>
>>>>>>>> Have you read this article :
>>>>>>>> http://msdn.microsoft.com/library/de...aght000009.asp
>>>>>>>>
>>>>>>>> ?
>>>>>>>>
>>>>>>>> Please review the steps in it, for creating a service account for an ASP.NET 2.0
>>>>>>>> application,
>>>>>>>> and make sure that the account retrned by "identity.aspx" has all the permissions
>>>>>>>> listed in that article.
>>>>>>>>
>>>>>>>> In particular, make sure you run the following aspnet_regiis command :
>>>>>>>>
>>>>>>>> aspnet_regiis -ga MachineName\AccountName
>>>>>>>>
>>>>>>>> where "MachineName\AccountName" is the account returned by "identity.aspx".
>>>>>>>>
>>>>>>>> Then post back your results.
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> Juan T. Llibre, asp.net MVP
>>>>>>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>>>>>>> asp.net faq : http://asp.net.do/faq/
>>>>>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>>>> ===================================
>>>>>>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>>>>>>> news:uA**************@TK2MSFTNGP03.phx.gbl...
>>>>>>>>> Hi Juan,
>>>>>>>>>
>>>>>>>>> Thanks for the reply. I've set permission to all the folders and everything but still
>>>>>>>>> it
>>>>>>>>> doesn't
>>>>>>>>> work.
>>>>>>>>>
>>>>>>>>> I've also tried the "Denis Bauer's ASP.NET Version Switcher" but that doesn't help
>>>>>>>>> either.
>>>>>>>>>
>>>>>>>>> Any other ideas?
>>>>>>>>>
>>>>>>>>> Cheers,
>>>>>>>>> Jon B
>>>>>>>>>
>>>>>>>>> "Juan T. Llibre" <no***********@nowhere.com> wrote in message
>>>>>>>>> news:u5**************@TK2MSFTNGP02.phx.gbl...
>>>>>>>>>> If you're running on Windows XP, the account which needs permissions is
>>>>>>>>>> MACHINENAME\ASPNET...even if you're allowing anonymous access.
>>>>>>>>>>
>>>>>>>>>> Try granting access permissions to the appropiate account, as outlined above.
>>>>>>>>>>
>>>>>>>>>> If you are still having problems after that, and you're impersonating some account,
>>>>>>>>>> save this code as "identity.aspx" and run it :
>>>>>>>>>>
>>>>>>>>>> identity.aspx
>>>>>>>>>> ========
>>>>>>>>>>
>>>>>>>>>> <%@ Page Language="VB" %>
>>>>>>>>>> <%@ Import NameSpace = System.Security.Principal %>
>>>>>>>>>> <script runat="server">
>>>>>>>>>> Sub Page_Load()
>>>>>>>>>> Dim tmp As String = WindowsIdentity.GetCurrent.Name()
>>>>>>>>>> Label1.Text = tmp
>>>>>>>>>> End Sub
>>>>>>>>>> </script>
>>>>>>>>>> <html>
>>>>>>>>>> <head>
>>>>>>>>>> <title>WindowsIdentity.GetCurrent.Name()</title>
>>>>>>>>>> </head>
>>>>>>>>>> <body>
>>>>>>>>>> <form id="form1" runat="server">
>>>>>>>>>> <div>
>>>>>>>>>> <asp:Label ID="Label1" Runat="server" Text="Label"></asp:Label>
>>>>>>>>>> </div>
>>>>>>>>>> </form>
>>>>>>>>>> </body>
>>>>>>>>>> </html>
>>>>>>>>>> ======
>>>>>>>>>>
>>>>>>>>>> Running that file will tell you which account ASP.NET is running as.
>>>>>>>>>> Then, assign the appropiate permissions to that account.
>>>>>>>>>>
>>>>>>>>>> Also, download and run Denis Bauer's ASP.NET Version Switcher,
>>>>>>>>>> and make sure that you're actually running 1.1 apps against the
>>>>>>>>>> 1.1 .Net Framework and 2.0 apps against .Net Framework 2.0.
>>>>>>>>>>
>>>>>>>>>> http://www.denisbauer.com/NETTools/A...nSwitcher.aspx
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Juan T. Llibre, asp.net MVP
>>>>>>>>>> aspnetfaq.com : http://www.aspnetfaq.com/
>>>>>>>>>> asp.net faq : http://asp.net.do/faq/
>>>>>>>>>> foros de asp.net, en espaņol : http://asp.net.do/foros/
>>>>>>>>>> ===================================
>>>>>>>>>> "Jon B" <no*****@sorry.sorry> wrote in message
>>>>>>>>>> news:uT**************@TK2MSFTNGP04.phx.gbl...
>>>>>>>>>>> Hi All!
>>>>>>>>>>>
>>>>>>>>>>> I have a ASP.NET 2.0 site that works on the Windows 2000 Server. However, when I
>>>>>>>>>>> tried
>>>>>>>>>>> to view
>>>>>>>>>>> this site on my local Windows XP machine, I get "Server Unavailable". If I switch
>>>>>>>>>>> the
>>>>>>>>>>> Windows XP
>>>>>>>>>>> IIS back to ASP.NET 1.1 then I get the Configuration Error (which is understandable
>>>>>>>>>>> because I'm
>>>>>>>>>>> trying to run an ASP.NET 2 site with 1.1 framework).
>>>>>>>>>>>
>>>>>>>>>>> I can however view other ASP.NET 1.1 sites on my local Windows XP machine. It's only
>>>>>>>>>>> the problem
>>>>>>>>>>> with
>>>>>>>>>>>
>>>>>>>>>>> I've also tried the aspnet_regiis thing as well as setting permissions on folders as
>>>>>>>>>>> described
>>>>>>>>>>> in this article:
>>>>>>>>>>> http://support.microsoft.com/default.aspx?kbid=811320
>>>>>>>>>>> but no solution.
>>>>>>>>>>>
>>>>>>>>>>> In the event log, I see these three errors every I tried to view my ASP.NET 2.0 site
>>>>>>>>>>> on my local
>>>>>>>>>>> machine...
>>>>>>>>>>>
>>>>>>>>>>> <errors>
>>>>>>>>>>>
>>>>>>>>>>> 1.) .aspnet_wp.exe (PID: 3988) stopped unexpectedly
>>>>>>>>>>>
>>>>>>>>>>> 2.) Failed to execute the request because the ASP.NET process identity does not
>>>>>>>>>>> have
>>>>>>>>>>> read
>>>>>>>>>>> permissions to the global assembly cache. Error: 0x80131902
>>>>>>>>>>>
>>>>>>>>>>> 3.) Failed to initialize the AppDomain:/LM/W3SVC/1/Root
>>>>>>>>>>>
>>>>>>>>>>> Exception: System.Configuration.ConfigurationErrorsException
>>>>>>>>>>>
>>>>>>>>>>> Message: Exception of type 'System.Configuration.ConfigurationErrorsException ' was
>>>>>>>>>>> thrown.
>>>>>>>>>>>
>>>>>>>>>>> </errors>
>>>>>>>>>>>
>>>>>>>>>>> What could be the problem?!?!?!? Plz, any solutions or pointers to solutions are
>>>>>>>>>>> much
>>>>>>>>>>> appreciated!!!
>>>>>>>>>>>
>>>>>>>>>>> Thank you all in advance!!!
>>>>>>>>>>>
>>>>>>>>>>> Jon
>>>
>>>
>>
>>
>
>



May 1 '06 #18

This discussion thread is closed

Replies have been disabled for this discussion.