By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,973 Members | 1,854 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,973 IT Pros & Developers. It's quick & easy.

Login failed for user ''. The user is not associated with a truste

P: n/a
I am new with this personalization stuff.

Everything was working fine, however, now I always get the Login failed for
user ''. The user is not associated with a trusted SQL Server connection.
error message.

This is for anonymous personalization, very simple. I am just trying to
retrieve a string from Profile. This is what I have in my web.config file:

<system.web>
<anonymousIdentification enabled="true" />
<profile enabled="true">
<properties>
<add name="MainMapPane1XML" defaultValue="" type="string"
allowAnonymous="true" />
<add name="MB2_LocatorXML" defaultValue="" type="string"
allowAnonymous="true" />
<add name="MB2_MapPaneXML" defaultValue="" type="string"
allowAnonymous="true" />

</properties>
</profile>
</system.web>
It also does this on my identical ISP site. Any ideas?

--
Roger Bedell, President, Sylvan Ascent Inc.
Nov 23 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Sounds like your connection string is using "Integrated Security".

Jeff

"Sylvan" wrote:
I am new with this personalization stuff.

Everything was working fine, however, now I always get the Login failed for
user ''. The user is not associated with a trusted SQL Server connection.
error message.

This is for anonymous personalization, very simple. I am just trying to
retrieve a string from Profile. This is what I have in my web.config file:

<system.web>
<anonymousIdentification enabled="true" />
<profile enabled="true">
<properties>
<add name="MainMapPane1XML" defaultValue="" type="string"
allowAnonymous="true" />
<add name="MB2_LocatorXML" defaultValue="" type="string"
allowAnonymous="true" />
<add name="MB2_MapPaneXML" defaultValue="" type="string"
allowAnonymous="true" />

</properties>
</profile>
</system.web>
It also does this on my identical ISP site. Any ideas?

--
Roger Bedell, President, Sylvan Ascent Inc.

Nov 23 '05 #2

P: n/a
First, I made a mistake, it works fine on my dev computer, just not on my ISP
site.
Here are the connection strings I am using:

<connectionStrings>
<!--<add name="Personal" connectionString="Data
Source=.\SQLExpress;Integrated Security=True;User
Instance=True;AttachDBFilename=|DataDirectory|Pers onal.mdf"
providerName="System.Data.SqlClient"/>-->
<!--<add name="Personal" connectionString="Data
Source=sql2005.aspnix.com;Integrated Security=True;User
Instance=True;AttachDBFilename=c:\domains\topodepo t.com\wwwroot\App_Data\Personal.mdf" providerName="System.Data.SqlClient"/>-->
<add name="Personal" connectionString="Data
Source=sql2005.aspnix.com;Integrated Security=True;User
Instance=True;AttachDBFilename=|DataDirectory|Pers onal.mdf"
providerName="System.Data.SqlClient"/>
<remove name="LocalSqlServer"/>

<!--<add name="LocalSqlServer" connectionString="Data
Source=.\SQLExpress;Integrated Security=True;User
Instance=True;AttachDBFilename=|DataDirectory|aspn etdb.mdf"/>-->
<!--<add name="LocalSqlServer" connectionString="Data
Source=sql2005.aspnix.com;Integrated Security=True;User
Instance=True;AttachDBFilename=c:\domains\topodepo t.com\wwwroot\App_Data\aspnetdb.mdf"/>-->
<add name="LocalSqlServer" connectionString="Data
Source=sql2005.aspnix.com;Integrated Security=True;User
Instance=True;AttachDBFilename=|DataDirectory|aspn etdb.mdf"/>
</connectionStrings>
The first commented out one in each section is the local connection string
that works fine on my dev computer. The second commented out one used to work
on my ISP. It now gives the "Login failed for user" error. The third one I
tried, but it gives the "Invalid value for key 'attachdbfilename'. " error.
Is there any log files anywhere that might give more information, or does
anyone there know what might be causing this problem? I used the "Copy web
site..." procedure to deploy from my dev machine to my ISP (ASPNix BTW).

--
Roger Bedell, President, Sylvan Ascent Inc.
"Jeff" wrote:
Sounds like your connection string is using "Integrated Security".

Jeff

"Sylvan" wrote:
I am new with this personalization stuff.

Everything was working fine, however, now I always get the Login failed for
user ''. The user is not associated with a trusted SQL Server connection.
error message.

This is for anonymous personalization, very simple. I am just trying to
retrieve a string from Profile. This is what I have in my web.config file:

<system.web>
<anonymousIdentification enabled="true" />
<profile enabled="true">
<properties>
<add name="MainMapPane1XML" defaultValue="" type="string"
allowAnonymous="true" />
<add name="MB2_LocatorXML" defaultValue="" type="string"
allowAnonymous="true" />
<add name="MB2_MapPaneXML" defaultValue="" type="string"
allowAnonymous="true" />

</properties>
</profile>
</system.web>
It also does this on my identical ISP site. Any ideas?

--
Roger Bedell, President, Sylvan Ascent Inc.

Nov 23 '05 #3

P: n/a
Hi Roger,

Most ISPs require the User ID and Password you were issued in the connection
string. Try checking the support forum on your ISP for more information on
the proper format for the connection string when using SQL Express.
'Integrated Security = true' almost always implies that you have been
authenticated via windows security.

Sorry I can't offer more help - perhaps other forum users can chime in..

Jeff

"Sylvan" wrote:
First, I made a mistake, it works fine on my dev computer, just not on my ISP
site.
Here are the connection strings I am using:

<connectionStrings>
<!--<add name="Personal" connectionString="Data
Source=.\SQLExpress;Integrated Security=True;User
Instance=True;AttachDBFilename=|DataDirectory|Pers onal.mdf"
providerName="System.Data.SqlClient"/>-->
<!--<add name="Personal" connectionString="Data
Source=sql2005.aspnix.com;Integrated Security=True;User
Instance=True;AttachDBFilename=c:\domains\topodepo t.com\wwwroot\App_Data\Personal.mdf" providerName="System.Data.SqlClient"/>-->
<add name="Personal" connectionString="Data
Source=sql2005.aspnix.com;Integrated Security=True;User
Instance=True;AttachDBFilename=|DataDirectory|Pers onal.mdf"
providerName="System.Data.SqlClient"/>
<remove name="LocalSqlServer"/>

<!--<add name="LocalSqlServer" connectionString="Data
Source=.\SQLExpress;Integrated Security=True;User
Instance=True;AttachDBFilename=|DataDirectory|aspn etdb.mdf"/>-->
<!--<add name="LocalSqlServer" connectionString="Data
Source=sql2005.aspnix.com;Integrated Security=True;User
Instance=True;AttachDBFilename=c:\domains\topodepo t.com\wwwroot\App_Data\aspnetdb.mdf"/>-->
<add name="LocalSqlServer" connectionString="Data
Source=sql2005.aspnix.com;Integrated Security=True;User
Instance=True;AttachDBFilename=|DataDirectory|aspn etdb.mdf"/>
</connectionStrings>
The first commented out one in each section is the local connection string
that works fine on my dev computer. The second commented out one used to work
on my ISP. It now gives the "Login failed for user" error. The third one I
tried, but it gives the "Invalid value for key 'attachdbfilename'. " error.
Is there any log files anywhere that might give more information, or does
anyone there know what might be causing this problem? I used the "Copy web
site..." procedure to deploy from my dev machine to my ISP (ASPNix BTW).

--
Roger Bedell, President, Sylvan Ascent Inc.
"Jeff" wrote:
Sounds like your connection string is using "Integrated Security".

Jeff

"Sylvan" wrote:
I am new with this personalization stuff.

Everything was working fine, however, now I always get the Login failed for
user ''. The user is not associated with a trusted SQL Server connection.
error message.

This is for anonymous personalization, very simple. I am just trying to
retrieve a string from Profile. This is what I have in my web.config file:

<system.web>
<anonymousIdentification enabled="true" />
<profile enabled="true">
<properties>
<add name="MainMapPane1XML" defaultValue="" type="string"
allowAnonymous="true" />
<add name="MB2_LocatorXML" defaultValue="" type="string"
allowAnonymous="true" />
<add name="MB2_MapPaneXML" defaultValue="" type="string"
allowAnonymous="true" />

</properties>
</profile>
</system.web>
It also does this on my identical ISP site. Any ideas?

--
Roger Bedell, President, Sylvan Ascent Inc.

Nov 23 '05 #4

P: n/a
Ok, It's all figured out.

Actually, the personalization stuff in ASP.NET 2.0 was not working. After
much research, I found the following blog which explains why. Basically,
since ASPNix (my ISP) is using the real SQL 2005, not SQL Express, it is more
difficult to create and use the databases that ASP.NET uses internally. See
the blog, and especially my entry toward the end:

http://weblogs.asp.net/bsimser/archi...x?Pending=true

Roger
--
Roger Bedell, President, Sylvan Ascent Inc.
"Jeff" wrote:
Hi Roger,

Most ISPs require the User ID and Password you were issued in the connection
string. Try checking the support forum on your ISP for more information on
the proper format for the connection string when using SQL Express.
'Integrated Security = true' almost always implies that you have been
authenticated via windows security.

Sorry I can't offer more help - perhaps other forum users can chime in..

Jeff

"Sylvan" wrote:
First, I made a mistake, it works fine on my dev computer, just not on my ISP
site.
Here are the connection strings I am using:

<connectionStrings>
<!--<add name="Personal" connectionString="Data
Source=.\SQLExpress;Integrated Security=True;User
Instance=True;AttachDBFilename=|DataDirectory|Pers onal.mdf"
providerName="System.Data.SqlClient"/>-->
<!--<add name="Personal" connectionString="Data
Source=sql2005.aspnix.com;Integrated Security=True;User
Instance=True;AttachDBFilename=c:\domains\topodepo t.com\wwwroot\App_Data\Personal.mdf" providerName="System.Data.SqlClient"/>-->
<add name="Personal" connectionString="Data
Source=sql2005.aspnix.com;Integrated Security=True;User
Instance=True;AttachDBFilename=|DataDirectory|Pers onal.mdf"
providerName="System.Data.SqlClient"/>
<remove name="LocalSqlServer"/>

<!--<add name="LocalSqlServer" connectionString="Data
Source=.\SQLExpress;Integrated Security=True;User
Instance=True;AttachDBFilename=|DataDirectory|aspn etdb.mdf"/>-->
<!--<add name="LocalSqlServer" connectionString="Data
Source=sql2005.aspnix.com;Integrated Security=True;User
Instance=True;AttachDBFilename=c:\domains\topodepo t.com\wwwroot\App_Data\aspnetdb.mdf"/>-->
<add name="LocalSqlServer" connectionString="Data
Source=sql2005.aspnix.com;Integrated Security=True;User
Instance=True;AttachDBFilename=|DataDirectory|aspn etdb.mdf"/>
</connectionStrings>
The first commented out one in each section is the local connection string
that works fine on my dev computer. The second commented out one used to work
on my ISP. It now gives the "Login failed for user" error. The third one I
tried, but it gives the "Invalid value for key 'attachdbfilename'. " error.
Is there any log files anywhere that might give more information, or does
anyone there know what might be causing this problem? I used the "Copy web
site..." procedure to deploy from my dev machine to my ISP (ASPNix BTW).

--
Roger Bedell, President, Sylvan Ascent Inc.
"Jeff" wrote:
Sounds like your connection string is using "Integrated Security".

Jeff

"Sylvan" wrote:

> I am new with this personalization stuff.
>
> Everything was working fine, however, now I always get the Login failed for
> user ''. The user is not associated with a trusted SQL Server connection.
> error message.
>
> This is for anonymous personalization, very simple. I am just trying to
> retrieve a string from Profile. This is what I have in my web.config file:
>
> <system.web>
> <anonymousIdentification enabled="true" />
> <profile enabled="true">
> <properties>
> <add name="MainMapPane1XML" defaultValue="" type="string"
> allowAnonymous="true" />
> <add name="MB2_LocatorXML" defaultValue="" type="string"
> allowAnonymous="true" />
> <add name="MB2_MapPaneXML" defaultValue="" type="string"
> allowAnonymous="true" />
>
> </properties>
> </profile>
> </system.web>
>
>
> It also does this on my identical ISP site. Any ideas?
>
> --
> Roger Bedell, President, Sylvan Ascent Inc.

Nov 26 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.