By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,602 Members | 1,533 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,602 IT Pros & Developers. It's quick & easy.

faild to start listening port 1034

P: n/a
kai
Hi,
I was tring to run an example (HelloWorld.aspx) from MSPrss book, I get
this message:

"ASP.NET Development Server faild to start listening port 1034.

Error message:

An attempt was made to access a socket in a way fobidden by its access
permissions."

I cannot fix it. Please help.

Thanks
Kai


Nov 20 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
Hi Kai,

Welcome to ASPNET newsgroup.
From your description, when you try running an ASP.NET 2.0 web app in
VS.NET 2005 through filesystem server, you got the following error:

"ASP.NET Development Server faild to start listening port 1034."

From the exception info, it is caused by the random port for running VS.NET
2005 debug server not accessible. What's the OS version of the development
server? You can try turn off the windows firewall to see whether it is the
cause. Also, as for developing the ASP.NET 2.0 project in VS.NET 2005
through filesystem, we can manually specify a port number for the project.
Just select the ASP.NET project in VS2005 ide, and set the "use dynamic
port" property to "false" in the project setting, then we can manually
specify a unused port number. Please try using some other ports to see
whether you also get such error. If there're any other finding, please feel
free to post here.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| From: "kai" <ka******@earthlink.net>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| Subject: faild to start listening port 1034
| Lines: 21
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Original
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <tF****************@newsread1.news.atl.earthlink.n et>
| Date: Sun, 20 Nov 2005 22:21:13 GMT
| NNTP-Posting-Host: 66.32.86.150
| X-Complaints-To: ab***@earthlink.net
| X-Trace: newsread1.news.atl.earthlink.net 1132525273 66.32.86.150 (Sun,
20 Nov 2005 14:21:13 PST)
| NNTP-Posting-Date: Sun, 20 Nov 2005 14:21:13 PST
| Organization: EarthLink Inc. -- http://www.EarthLink.net
| Path:
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSF TFEED02.phx.gbl!tornado.fa
stwebnet.it!tiscali!newsfeed1.ip.tiscali.net!newsh ub.sdsu.edu!nx02.iad01.new
shosting.com!newshosting.com!207.69.154.102.MISMAT CH!elnk-atl-nf2!newsfeed.e
arthlink.net!stamper.news.atl.earthlink.net!newsre ad1.news.atl.earthlink.net
POSTED!a96f5a29!not-for-mail
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:359667
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi,
| I was tring to run an example (HelloWorld.aspx) from MSPrss book, I get
| this message:
|
| "ASP.NET Development Server faild to start listening port 1034.
|
| Error message:
|
| An attempt was made to access a socket in a way fobidden by its access
| permissions."
|
| I cannot fix it. Please help.
|
| Thanks
| Kai
|
|
|
|
|
|
|

Nov 21 '05 #2

P: n/a
kai
Steven,
Thanks for your elp.

I use XP Pro. This is the exisiting HelloWorld program, every time I run,
it uses the same port. If I want to change port 1034 to different one, where
can I re-set the port number for existing application?

Thanks
Kai
"Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
news:Aj*************@TK2MSFTNGXA02.phx.gbl...
Hi Kai,

Welcome to ASPNET newsgroup.
From your description, when you try running an ASP.NET 2.0 web app in
VS.NET 2005 through filesystem server, you got the following error:

"ASP.NET Development Server faild to start listening port 1034."

From the exception info, it is caused by the random port for running
VS.NET
2005 debug server not accessible. What's the OS version of the
development
server? You can try turn off the windows firewall to see whether it is the
cause. Also, as for developing the ASP.NET 2.0 project in VS.NET 2005
through filesystem, we can manually specify a port number for the project.
Just select the ASP.NET project in VS2005 ide, and set the "use dynamic
port" property to "false" in the project setting, then we can manually
specify a unused port number. Please try using some other ports to see
whether you also get such error. If there're any other finding, please
feel
free to post here.

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| From: "kai" <ka******@earthlink.net>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| Subject: faild to start listening port 1034
| Lines: 21
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-RFC2646: Format=Flowed; Original
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| Message-ID: <tF****************@newsread1.news.atl.earthlink.n et>
| Date: Sun, 20 Nov 2005 22:21:13 GMT
| NNTP-Posting-Host: 66.32.86.150
| X-Complaints-To: ab***@earthlink.net
| X-Trace: newsread1.news.atl.earthlink.net 1132525273 66.32.86.150 (Sun,
20 Nov 2005 14:21:13 PST)
| NNTP-Posting-Date: Sun, 20 Nov 2005 14:21:13 PST
| Organization: EarthLink Inc. -- http://www.EarthLink.net
| Path:
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSF TFEED02.phx.gbl!tornado.fa
stwebnet.it!tiscali!newsfeed1.ip.tiscali.net!newsh ub.sdsu.edu!nx02.iad01.new
shosting.com!newshosting.com!207.69.154.102.MISMAT CH!elnk-atl-nf2!newsfeed.e
arthlink.net!stamper.news.atl.earthlink.net!newsre ad1.news.atl.earthlink.net
POSTED!a96f5a29!not-for-mail
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:359667
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi,
| I was tring to run an example (HelloWorld.aspx) from MSPrss book, I
get
| this message:
|
| "ASP.NET Development Server faild to start listening port 1034.
|
| Error message:
|
| An attempt was made to access a socket in a way fobidden by its access
| permissions."
|
| I cannot fix it. Please help.
|
| Thanks
| Kai
|
|
|
|
|
|
|

Nov 21 '05 #3

P: n/a
Thanks for your response Kai,

Since you're using XP pro, I think the windows XP sp2's firewall setting is
also a possible cause. Have you tried turn off it (if you're currently
turning on it) to see whether it helps? Also, for manually specifying port
number for ASP.NET 2.0 project(use FileSystem....) in VS.NET 2005, we can
follow the below steps:

1. Select the "WebSite" node in VS.NET 2005 IDE's Solution Explorer.

2. In the Property window, you can find there is two properties under the
"Web Developer Server" category:

"Port Number" and "Use Dynamic Port".

Set the "Use Dynamnmic Port" to false, then we can change the "Port Number"
....

Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| From: "kai" <ka******@earthlink.net>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| References: <tF****************@newsread1.news.atl.earthlink.n et>
<Aj*************@TK2MSFTNGXA02.phx.gbl>
| Subject: Re: faild to start listening port 1034
| Lines: 96
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| X-RFC2646: Format=Flowed; Original
| Message-ID: <lm****************@newsread2.news.atl.earthlink.n et>
| Date: Mon, 21 Nov 2005 12:48:17 GMT
| NNTP-Posting-Host: 66.32.86.150
| X-Complaints-To: ab***@earthlink.net
| X-Trace: newsread2.news.atl.earthlink.net 1132577297 66.32.86.150 (Mon,
21 Nov 2005 04:48:17 PST)
| NNTP-Posting-Date: Mon, 21 Nov 2005 04:48:17 PST
| Organization: EarthLink Inc. -- http://www.EarthLink.net
| Path:
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfee d00.sul.t-online.de!t-onli
ne.de!newshub.sdsu.edu!elnk-nf2-pas!newsfeed.earthlink.net!stamper.news.pas.
earthlink.net!stamper.news.atl.earthlink.net!newsr ead2.news.atl.earthlink.ne
t.POSTED!a96f5a29!not-for-mail
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:359762
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Steven,
| Thanks for your elp.
|
| I use XP Pro. This is the exisiting HelloWorld program, every time I
run,
| it uses the same port. If I want to change port 1034 to different one,
where
| can I re-set the port number for existing application?
|
| Thanks
| Kai
| "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| news:Aj*************@TK2MSFTNGXA02.phx.gbl...
| > Hi Kai,
| >
| > Welcome to ASPNET newsgroup.
| > From your description, when you try running an ASP.NET 2.0 web app in
| > VS.NET 2005 through filesystem server, you got the following error:
| >
| > "ASP.NET Development Server faild to start listening port 1034."
| >
| > From the exception info, it is caused by the random port for running
| > VS.NET
| > 2005 debug server not accessible. What's the OS version of the
| > development
| > server? You can try turn off the windows firewall to see whether it is
the
| > cause. Also, as for developing the ASP.NET 2.0 project in VS.NET 2005
| > through filesystem, we can manually specify a port number for the
project.
| > Just select the ASP.NET project in VS2005 ide, and set the "use dynamic
| > port" property to "false" in the project setting, then we can manually
| > specify a unused port number. Please try using some other ports to see
| > whether you also get such error. If there're any other finding, please
| > feel
| > free to post here.
| >
| > Thanks,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| > --------------------
| > | From: "kai" <ka******@earthlink.net>
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | Subject: faild to start listening port 1034
| > | Lines: 21
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | X-RFC2646: Format=Flowed; Original
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | Message-ID: <tF****************@newsread1.news.atl.earthlink.n et>
| > | Date: Sun, 20 Nov 2005 22:21:13 GMT
| > | NNTP-Posting-Host: 66.32.86.150
| > | X-Complaints-To: ab***@earthlink.net
| > | X-Trace: newsread1.news.atl.earthlink.net 1132525273 66.32.86.150
(Sun,
| > 20 Nov 2005 14:21:13 PST)
| > | NNTP-Posting-Date: Sun, 20 Nov 2005 14:21:13 PST
| > | Organization: EarthLink Inc. -- http://www.EarthLink.net
| > | Path:
| >
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSF TFEED02.phx.gbl!tornado.fa
| >
stwebnet.it!tiscali!newsfeed1.ip.tiscali.net!newsh ub.sdsu.edu!nx02.iad01.new
| >
shosting.com!newshosting.com!207.69.154.102.MISMAT CH!elnk-atl-nf2!newsfeed.e
| >
arthlink.net!stamper.news.atl.earthlink.net!newsre ad1.news.atl.earthlink.net
| > POSTED!a96f5a29!not-for-mail
| > | Xref: TK2MSFTNGXA02.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:359667
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > |
| > | Hi,
| > | I was tring to run an example (HelloWorld.aspx) from MSPrss book, I
| > get
| > | this message:
| > |
| > | "ASP.NET Development Server faild to start listening port 1034.
| > |
| > | Error message:
| > |
| > | An attempt was made to access a socket in a way fobidden by its access
| > | permissions."
| > |
| > | I cannot fix it. Please help.
| > |
| > | Thanks
| > | Kai
| > |
| > |
| > |
| > |
| > |
| > |
| > |
| >
|
|
|

Nov 23 '05 #4

P: n/a
Hi Kai,

Have you got any further progress on this issue? If there're anything else
we can help, please feel free to post here.

Thanks & Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| X-Tomcat-ID: 222779052
| References: <tF****************@newsread1.news.atl.earthlink.n et>
<Aj*************@TK2MSFTNGXA02.phx.gbl>
<lm****************@newsread2.news.atl.earthlink.n et>
| MIME-Version: 1.0
| Content-Type: text/plain
| Content-Transfer-Encoding: 7bit
| From: st*****@online.microsoft.com (Steven Cheng[MSFT])
| Organization: Microsoft
| Date: Tue, 22 Nov 2005 11:10:59 GMT
| Subject: Re: faild to start listening port 1034
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| Message-ID: <9N**************@TK2MSFTNGXA02.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| Lines: 143
| Path: TK2MSFTNGXA02.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:360065
| NNTP-Posting-Host: TOMCATIMPORT1 10.201.218.122
|
| Thanks for your response Kai,
|
| Since you're using XP pro, I think the windows XP sp2's firewall setting
is
| also a possible cause. Have you tried turn off it (if you're currently
| turning on it) to see whether it helps? Also, for manually specifying
port
| number for ASP.NET 2.0 project(use FileSystem....) in VS.NET 2005, we can
| follow the below steps:
|
| 1. Select the "WebSite" node in VS.NET 2005 IDE's Solution Explorer.
|
| 2. In the Property window, you can find there is two properties under
the
| "Web Developer Server" category:
|
| "Port Number" and "Use Dynamic Port".
|
| Set the "Use Dynamnmic Port" to false, then we can change the "Port
Number"
| ...
|
| Thanks,
|
| Steven Cheng
| Microsoft Online Support
|
| Get Secure! www.microsoft.com/security
| (This posting is provided "AS IS", with no warranties, and confers no
| rights.)
|
|
|
|
|
| --------------------
| | From: "kai" <ka******@earthlink.net>
| | Newsgroups: microsoft.public.dotnet.framework.aspnet
| | References: <tF****************@newsread1.news.atl.earthlink.n et>
| <Aj*************@TK2MSFTNGXA02.phx.gbl>
| | Subject: Re: faild to start listening port 1034
| | Lines: 96
| | X-Priority: 3
| | X-MSMail-Priority: Normal
| | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| | X-RFC2646: Format=Flowed; Original
| | Message-ID: <lm****************@newsread2.news.atl.earthlink.n et>
| | Date: Mon, 21 Nov 2005 12:48:17 GMT
| | NNTP-Posting-Host: 66.32.86.150
| | X-Complaints-To: ab***@earthlink.net
| | X-Trace: newsread2.news.atl.earthlink.net 1132577297 66.32.86.150 (Mon,
| 21 Nov 2005 04:48:17 PST)
| | NNTP-Posting-Date: Mon, 21 Nov 2005 04:48:17 PST
| | Organization: EarthLink Inc. -- http://www.EarthLink.net
| | Path:
|
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfee d00.sul.t-online.de!t-onli
|
ne.de!newshub.sdsu.edu!elnk-nf2-pas!newsfeed.earthlink.net!stamper.news.pas.
|
earthlink.net!stamper.news.atl.earthlink.net!newsr ead2.news.atl.earthlink.ne
| t.POSTED!a96f5a29!not-for-mail
| | Xref: TK2MSFTNGXA02.phx.gbl
| microsoft.public.dotnet.framework.aspnet:359762
| | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| |
| | Steven,
| | Thanks for your elp.
| |
| | I use XP Pro. This is the exisiting HelloWorld program, every time I
| run,
| | it uses the same port. If I want to change port 1034 to different one,
| where
| | can I re-set the port number for existing application?
| |
| | Thanks
| | Kai
| | "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| | news:Aj*************@TK2MSFTNGXA02.phx.gbl...
| | > Hi Kai,
| | >
| | > Welcome to ASPNET newsgroup.
| | > From your description, when you try running an ASP.NET 2.0 web app in
| | > VS.NET 2005 through filesystem server, you got the following error:
| | >
| | > "ASP.NET Development Server faild to start listening port 1034."
| | >
| | > From the exception info, it is caused by the random port for running
| | > VS.NET
| | > 2005 debug server not accessible. What's the OS version of the
| | > development
| | > server? You can try turn off the windows firewall to see whether it
is
| the
| | > cause. Also, as for developing the ASP.NET 2.0 project in VS.NET 2005
| | > through filesystem, we can manually specify a port number for the
| project.
| | > Just select the ASP.NET project in VS2005 ide, and set the "use
dynamic
| | > port" property to "false" in the project setting, then we can manually
| | > specify a unused port number. Please try using some other ports to see
| | > whether you also get such error. If there're any other finding,
please
| | > feel
| | > free to post here.
| | >
| | > Thanks,
| | >
| | > Steven Cheng
| | > Microsoft Online Support
| | >
| | > Get Secure! www.microsoft.com/security
| | > (This posting is provided "AS IS", with no warranties, and confers no
| | > rights.)
| | >
| | > --------------------
| | > | From: "kai" <ka******@earthlink.net>
| | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| | > | Subject: faild to start listening port 1034
| | > | Lines: 21
| | > | X-Priority: 3
| | > | X-MSMail-Priority: Normal
| | > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| | > | X-RFC2646: Format=Flowed; Original
| | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| | > | Message-ID: <tF****************@newsread1.news.atl.earthlink.n et>
| | > | Date: Sun, 20 Nov 2005 22:21:13 GMT
| | > | NNTP-Posting-Host: 66.32.86.150
| | > | X-Complaints-To: ab***@earthlink.net
| | > | X-Trace: newsread1.news.atl.earthlink.net 1132525273 66.32.86.150
| (Sun,
| | > 20 Nov 2005 14:21:13 PST)
| | > | NNTP-Posting-Date: Sun, 20 Nov 2005 14:21:13 PST
| | > | Organization: EarthLink Inc. -- http://www.EarthLink.net
| | > | Path:
| | >
|
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSF TFEED02.phx.gbl!tornado.fa
| | >
|
stwebnet.it!tiscali!newsfeed1.ip.tiscali.net!newsh ub.sdsu.edu!nx02.iad01.new
| | >
|
shosting.com!newshosting.com!207.69.154.102.MISMAT CH!elnk-atl-nf2!newsfeed.e
| | >
|
arthlink.net!stamper.news.atl.earthlink.net!newsre ad1.news.atl.earthlink.net
| | > POSTED!a96f5a29!not-for-mail
| | > | Xref: TK2MSFTNGXA02.phx.gbl
| | > microsoft.public.dotnet.framework.aspnet:359667
| | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| | > |
| | > | Hi,
| | > | I was tring to run an example (HelloWorld.aspx) from MSPrss book,
I
| | > get
| | > | this message:
| | > |
| | > | "ASP.NET Development Server faild to start listening port 1034.
| | > |
| | > | Error message:
| | > |
| | > | An attempt was made to access a socket in a way fobidden by its
access
| | > | permissions."
| | > |
| | > | I cannot fix it. Please help.
| | > |
| | > | Thanks
| | > | Kai
| | > |
| | > |
| | > |
| | > |
| | > |
| | > |
| | > |
| | >
| |
| |
| |
|
|

Nov 24 '05 #5

P: n/a
kai
Hi, Steven
I turned off firewall, it did not work. After I reboot my computer, it
works. Than I turned on the fire wall again, it is working.
Thank you very much for your expertise. It really helps me a lot.

Kai

"Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
news:Nu****************@TK2MSFTNGXA02.phx.gbl...
Hi Kai,

Have you got any further progress on this issue? If there're anything else
we can help, please feel free to post here.

Thanks & Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

--------------------
| X-Tomcat-ID: 222779052
| References: <tF****************@newsread1.news.atl.earthlink.n et>
<Aj*************@TK2MSFTNGXA02.phx.gbl>
<lm****************@newsread2.news.atl.earthlink.n et>
| MIME-Version: 1.0
| Content-Type: text/plain
| Content-Transfer-Encoding: 7bit
| From: st*****@online.microsoft.com (Steven Cheng[MSFT])
| Organization: Microsoft
| Date: Tue, 22 Nov 2005 11:10:59 GMT
| Subject: Re: faild to start listening port 1034
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| Message-ID: <9N**************@TK2MSFTNGXA02.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| Lines: 143
| Path: TK2MSFTNGXA02.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:360065
| NNTP-Posting-Host: TOMCATIMPORT1 10.201.218.122
|
| Thanks for your response Kai,
|
| Since you're using XP pro, I think the windows XP sp2's firewall setting
is
| also a possible cause. Have you tried turn off it (if you're currently
| turning on it) to see whether it helps? Also, for manually specifying
port
| number for ASP.NET 2.0 project(use FileSystem....) in VS.NET 2005, we
can
| follow the below steps:
|
| 1. Select the "WebSite" node in VS.NET 2005 IDE's Solution Explorer.
|
| 2. In the Property window, you can find there is two properties under
the
| "Web Developer Server" category:
|
| "Port Number" and "Use Dynamic Port".
|
| Set the "Use Dynamnmic Port" to false, then we can change the "Port
Number"
| ...
|
| Thanks,
|
| Steven Cheng
| Microsoft Online Support
|
| Get Secure! www.microsoft.com/security
| (This posting is provided "AS IS", with no warranties, and confers no
| rights.)
|
|
|
|
|
| --------------------
| | From: "kai" <ka******@earthlink.net>
| | Newsgroups: microsoft.public.dotnet.framework.aspnet
| | References: <tF****************@newsread1.news.atl.earthlink.n et>
| <Aj*************@TK2MSFTNGXA02.phx.gbl>
| | Subject: Re: faild to start listening port 1034
| | Lines: 96
| | X-Priority: 3
| | X-MSMail-Priority: Normal
| | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| | X-RFC2646: Format=Flowed; Original
| | Message-ID: <lm****************@newsread2.news.atl.earthlink.n et>
| | Date: Mon, 21 Nov 2005 12:48:17 GMT
| | NNTP-Posting-Host: 66.32.86.150
| | X-Complaints-To: ab***@earthlink.net
| | X-Trace: newsread2.news.atl.earthlink.net 1132577297 66.32.86.150
(Mon,
| 21 Nov 2005 04:48:17 PST)
| | NNTP-Posting-Date: Mon, 21 Nov 2005 04:48:17 PST
| | Organization: EarthLink Inc. -- http://www.EarthLink.net
| | Path:
|
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfee d00.sul.t-online.de!t-onli
|
ne.de!newshub.sdsu.edu!elnk-nf2-pas!newsfeed.earthlink.net!stamper.news.pas.
|
earthlink.net!stamper.news.atl.earthlink.net!newsr ead2.news.atl.earthlink.ne
| t.POSTED!a96f5a29!not-for-mail
| | Xref: TK2MSFTNGXA02.phx.gbl
| microsoft.public.dotnet.framework.aspnet:359762
| | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| |
| | Steven,
| | Thanks for your elp.
| |
| | I use XP Pro. This is the exisiting HelloWorld program, every time I
| run,
| | it uses the same port. If I want to change port 1034 to different one,
| where
| | can I re-set the port number for existing application?
| |
| | Thanks
| | Kai
| | "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| | news:Aj*************@TK2MSFTNGXA02.phx.gbl...
| | > Hi Kai,
| | >
| | > Welcome to ASPNET newsgroup.
| | > From your description, when you try running an ASP.NET 2.0 web app
in
| | > VS.NET 2005 through filesystem server, you got the following error:
| | >
| | > "ASP.NET Development Server faild to start listening port 1034."
| | >
| | > From the exception info, it is caused by the random port for running
| | > VS.NET
| | > 2005 debug server not accessible. What's the OS version of the
| | > development
| | > server? You can try turn off the windows firewall to see whether it
is
| the
| | > cause. Also, as for developing the ASP.NET 2.0 project in VS.NET
2005
| | > through filesystem, we can manually specify a port number for the
| project.
| | > Just select the ASP.NET project in VS2005 ide, and set the "use
dynamic
| | > port" property to "false" in the project setting, then we can
manually
| | > specify a unused port number. Please try using some other ports to
see
| | > whether you also get such error. If there're any other finding,
please
| | > feel
| | > free to post here.
| | >
| | > Thanks,
| | >
| | > Steven Cheng
| | > Microsoft Online Support
| | >
| | > Get Secure! www.microsoft.com/security
| | > (This posting is provided "AS IS", with no warranties, and confers
no
| | > rights.)
| | >
| | > --------------------
| | > | From: "kai" <ka******@earthlink.net>
| | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| | > | Subject: faild to start listening port 1034
| | > | Lines: 21
| | > | X-Priority: 3
| | > | X-MSMail-Priority: Normal
| | > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| | > | X-RFC2646: Format=Flowed; Original
| | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| | > | Message-ID: <tF****************@newsread1.news.atl.earthlink.n et>
| | > | Date: Sun, 20 Nov 2005 22:21:13 GMT
| | > | NNTP-Posting-Host: 66.32.86.150
| | > | X-Complaints-To: ab***@earthlink.net
| | > | X-Trace: newsread1.news.atl.earthlink.net 1132525273 66.32.86.150
| (Sun,
| | > 20 Nov 2005 14:21:13 PST)
| | > | NNTP-Posting-Date: Sun, 20 Nov 2005 14:21:13 PST
| | > | Organization: EarthLink Inc. -- http://www.EarthLink.net
| | > | Path:
| | >
|
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSF TFEED02.phx.gbl!tornado.fa
| | >
|
stwebnet.it!tiscali!newsfeed1.ip.tiscali.net!newsh ub.sdsu.edu!nx02.iad01.new
| | >
|
shosting.com!newshosting.com!207.69.154.102.MISMAT CH!elnk-atl-nf2!newsfeed.e
| | >
|
arthlink.net!stamper.news.atl.earthlink.net!newsre ad1.news.atl.earthlink.net
| | > POSTED!a96f5a29!not-for-mail
| | > | Xref: TK2MSFTNGXA02.phx.gbl
| | > microsoft.public.dotnet.framework.aspnet:359667
| | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| | > |
| | > | Hi,
| | > | I was tring to run an example (HelloWorld.aspx) from MSPrss
book,
I
| | > get
| | > | this message:
| | > |
| | > | "ASP.NET Development Server faild to start listening port 1034.
| | > |
| | > | Error message:
| | > |
| | > | An attempt was made to access a socket in a way fobidden by its
access
| | > | permissions."
| | > |
| | > | I cannot fix it. Please help.
| | > |
| | > | Thanks
| | > | Kai
| | > |
| | > |
| | > |
| | > |
| | > |
| | > |
| | > |
| | >
| |
| |
| |
|
|

Nov 25 '05 #6

P: n/a
Thanks for your followup Kai,

Glad that our suggestions are of assistance. Also, as for the firewall
setting, it may require your rebooting to make effect. Also, you can choose
to add an exception (tcp/udp port) for your debugging server's listening
port instead of turn off the whole firewall for secuirty consideration.

Good luck!

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| From: "kai" <ka******@earthlink.net>
| Newsgroups: microsoft.public.dotnet.framework.aspnet
| References: <tF****************@newsread1.news.atl.earthlink.n et>
<Aj*************@TK2MSFTNGXA02.phx.gbl>
<lm****************@newsread2.news.atl.earthlink.n et>
<9N**************@TK2MSFTNGXA02.phx.gbl>
<Nu**************@TK2MSFTNGXA02.phx.gbl>
| Subject: Re: faild to start listening port 1034
| Lines: 239
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| X-RFC2646: Format=Flowed; Original
| Message-ID: <Zr****************@newsread3.news.atl.earthlink.n et>
| Date: Fri, 25 Nov 2005 19:18:17 GMT
| NNTP-Posting-Host: 66.32.86.150
| X-Complaints-To: ab***@earthlink.net
| X-Trace: newsread3.news.atl.earthlink.net 1132946297 66.32.86.150 (Fri,
25 Nov 2005 11:18:17 PST)
| NNTP-Posting-Date: Fri, 25 Nov 2005 11:18:17 PST
| Organization: EarthLink Inc. -- http://www.EarthLink.net
| Path:
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfee d00.sul.t-online.de!t-onli
ne.de!border2.nntp.dca.giganews.com!nntp.giganews. com!elnk-atl-nf1!newsfeed.
earthlink.net!stamper.news.atl.earthlink.net!newsr ead3.news.atl.earthlink.ne
t.POSTED!a96f5a29!not-for-mail
| Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.framework.aspnet:360976
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
|
| Hi, Steven
| I turned off firewall, it did not work. After I reboot my computer, it
| works. Than I turned on the fire wall again, it is working.
| Thank you very much for your expertise. It really helps me a lot.
|
| Kai
|
| "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| news:Nu****************@TK2MSFTNGXA02.phx.gbl...
| > Hi Kai,
| >
| > Have you got any further progress on this issue? If there're anything
else
| > we can help, please feel free to post here.
| >
| > Thanks & Regards,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| > --------------------
| > | X-Tomcat-ID: 222779052
| > | References: <tF****************@newsread1.news.atl.earthlink.n et>
| > <Aj*************@TK2MSFTNGXA02.phx.gbl>
| > <lm****************@newsread2.news.atl.earthlink.n et>
| > | MIME-Version: 1.0
| > | Content-Type: text/plain
| > | Content-Transfer-Encoding: 7bit
| > | From: st*****@online.microsoft.com (Steven Cheng[MSFT])
| > | Organization: Microsoft
| > | Date: Tue, 22 Nov 2005 11:10:59 GMT
| > | Subject: Re: faild to start listening port 1034
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > | Message-ID: <9N**************@TK2MSFTNGXA02.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | Lines: 143
| > | Path: TK2MSFTNGXA02.phx.gbl
| > | Xref: TK2MSFTNGXA02.phx.gbl
| > microsoft.public.dotnet.framework.aspnet:360065
| > | NNTP-Posting-Host: TOMCATIMPORT1 10.201.218.122
| > |
| > | Thanks for your response Kai,
| > |
| > | Since you're using XP pro, I think the windows XP sp2's firewall
setting
| > is
| > | also a possible cause. Have you tried turn off it (if you're currently
| > | turning on it) to see whether it helps? Also, for manually specifying
| > port
| > | number for ASP.NET 2.0 project(use FileSystem....) in VS.NET 2005, we
| > can
| > | follow the below steps:
| > |
| > | 1. Select the "WebSite" node in VS.NET 2005 IDE's Solution Explorer.
| > |
| > | 2. In the Property window, you can find there is two properties under
| > the
| > | "Web Developer Server" category:
| > |
| > | "Port Number" and "Use Dynamic Port".
| > |
| > | Set the "Use Dynamnmic Port" to false, then we can change the "Port
| > Number"
| > | ...
| > |
| > | Thanks,
| > |
| > | Steven Cheng
| > | Microsoft Online Support
| > |
| > | Get Secure! www.microsoft.com/security
| > | (This posting is provided "AS IS", with no warranties, and confers no
| > | rights.)
| > |
| > |
| > |
| > |
| > |
| > | --------------------
| > | | From: "kai" <ka******@earthlink.net>
| > | | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | | References: <tF****************@newsread1.news.atl.earthlink.n et>
| > | <Aj*************@TK2MSFTNGXA02.phx.gbl>
| > | | Subject: Re: faild to start listening port 1034
| > | | Lines: 96
| > | | X-Priority: 3
| > | | X-MSMail-Priority: Normal
| > | | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | | X-RFC2646: Format=Flowed; Original
| > | | Message-ID: <lm****************@newsread2.news.atl.earthlink.n et>
| > | | Date: Mon, 21 Nov 2005 12:48:17 GMT
| > | | NNTP-Posting-Host: 66.32.86.150
| > | | X-Complaints-To: ab***@earthlink.net
| > | | X-Trace: newsread2.news.atl.earthlink.net 1132577297 66.32.86.150
| > (Mon,
| > | 21 Nov 2005 04:48:17 PST)
| > | | NNTP-Posting-Date: Mon, 21 Nov 2005 04:48:17 PST
| > | | Organization: EarthLink Inc. -- http://www.EarthLink.net
| > | | Path:
| > |
| >
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfee d00.sul.t-online.de!t-onli
| > |
| >
ne.de!newshub.sdsu.edu!elnk-nf2-pas!newsfeed.earthlink.net!stamper.news.pas.
| > |
| >
earthlink.net!stamper.news.atl.earthlink.net!newsr ead2.news.atl.earthlink.ne
| > | t.POSTED!a96f5a29!not-for-mail
| > | | Xref: TK2MSFTNGXA02.phx.gbl
| > | microsoft.public.dotnet.framework.aspnet:359762
| > | | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > | |
| > | | Steven,
| > | | Thanks for your elp.
| > | |
| > | | I use XP Pro. This is the exisiting HelloWorld program, every
time I
| > | run,
| > | | it uses the same port. If I want to change port 1034 to different
one,
| > | where
| > | | can I re-set the port number for existing application?
| > | |
| > | | Thanks
| > | | Kai
| > | | "Steven Cheng[MSFT]" <st*****@online.microsoft.com> wrote in message
| > | | news:Aj*************@TK2MSFTNGXA02.phx.gbl...
| > | | > Hi Kai,
| > | | >
| > | | > Welcome to ASPNET newsgroup.
| > | | > From your description, when you try running an ASP.NET 2.0 web
app
| > in
| > | | > VS.NET 2005 through filesystem server, you got the following
error:
| > | | >
| > | | > "ASP.NET Development Server faild to start listening port 1034."
| > | | >
| > | | > From the exception info, it is caused by the random port for
running
| > | | > VS.NET
| > | | > 2005 debug server not accessible. What's the OS version of the
| > | | > development
| > | | > server? You can try turn off the windows firewall to see whether
it
| > is
| > | the
| > | | > cause. Also, as for developing the ASP.NET 2.0 project in VS.NET
| > 2005
| > | | > through filesystem, we can manually specify a port number for the
| > | project.
| > | | > Just select the ASP.NET project in VS2005 ide, and set the "use
| > dynamic
| > | | > port" property to "false" in the project setting, then we can
| > manually
| > | | > specify a unused port number. Please try using some other ports
to
| > see
| > | | > whether you also get such error. If there're any other finding,
| > please
| > | | > feel
| > | | > free to post here.
| > | | >
| > | | > Thanks,
| > | | >
| > | | > Steven Cheng
| > | | > Microsoft Online Support
| > | | >
| > | | > Get Secure! www.microsoft.com/security
| > | | > (This posting is provided "AS IS", with no warranties, and
confers
| > no
| > | | > rights.)
| > | | >
| > | | > --------------------
| > | | > | From: "kai" <ka******@earthlink.net>
| > | | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
| > | | > | Subject: faild to start listening port 1034
| > | | > | Lines: 21
| > | | > | X-Priority: 3
| > | | > | X-MSMail-Priority: Normal
| > | | > | X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
| > | | > | X-RFC2646: Format=Flowed; Original
| > | | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
| > | | > | Message-ID:
<tF****************@newsread1.news.atl.earthlink.n et>
| > | | > | Date: Sun, 20 Nov 2005 22:21:13 GMT
| > | | > | NNTP-Posting-Host: 66.32.86.150
| > | | > | X-Complaints-To: ab***@earthlink.net
| > | | > | X-Trace: newsread1.news.atl.earthlink.net 1132525273
66.32.86.150
| > | (Sun,
| > | | > 20 Nov 2005 14:21:13 PST)
| > | | > | NNTP-Posting-Date: Sun, 20 Nov 2005 14:21:13 PST
| > | | > | Organization: EarthLink Inc. -- http://www.EarthLink.net
| > | | > | Path:
| > | | >
| > |
| >
TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA01.phx.gbl!TK2MSF TFEED02.phx.gbl!tornado.fa
| > | | >
| > |
| >
stwebnet.it!tiscali!newsfeed1.ip.tiscali.net!newsh ub.sdsu.edu!nx02.iad01.new
| > | | >
| > |
| >
shosting.com!newshosting.com!207.69.154.102.MISMAT CH!elnk-atl-nf2!newsfeed.e
| > | | >
| > |
| >
arthlink.net!stamper.news.atl.earthlink.net!newsre ad1.news.atl.earthlink.net
| > | | > POSTED!a96f5a29!not-for-mail
| > | | > | Xref: TK2MSFTNGXA02.phx.gbl
| > | | > microsoft.public.dotnet.framework.aspnet:359667
| > | | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
| > | | > |
| > | | > | Hi,
| > | | > | I was tring to run an example (HelloWorld.aspx) from MSPrss
| > book,
| > I
| > | | > get
| > | | > | this message:
| > | | > |
| > | | > | "ASP.NET Development Server faild to start listening port 1034.
| > | | > |
| > | | > | Error message:
| > | | > |
| > | | > | An attempt was made to access a socket in a way fobidden by its
| > access
| > | | > | permissions."
| > | | > |
| > | | > | I cannot fix it. Please help.
| > | | > |
| > | | > | Thanks
| > | | > | Kai
| > | | > |
| > | | > |
| > | | > |
| > | | > |
| > | | > |
| > | | > |
| > | | > |
| > | | >
| > | |
| > | |
| > | |
| > |
| > |
| >
|
|
|

Nov 28 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.