By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,069 Members | 1,716 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,069 IT Pros & Developers. It's quick & easy.

Help, Please: Server Error in '/' Application.

P: n/a
"Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine. "

This is happening when I ry to process an aspx in my default directory
(inetpub\wwwroot).

Well, I'm viewing it on the local machine so why is it saying that?

I've tried editing the web.config file to no effect - it doesn't make any
difference.

I've tried editing the application name and that does have an effect (it
changes the error page, but not the basic message).

I've tried using an asp file istead, but still no joy.

I've tried using an html file and it works. So IIS does have permission to
read files in the root directory, but it cant execute asp or aspx.

Anyone have any ideas, please?

Nov 19 '05 #1
Share this Question
Share on Google+
13 Replies


P: n/a
in IE, turn off "Friendly Error Messages" once...

--
Curt Christianson
site: http://www.darkfalz.com
blog: http://blog.darkfalz.com

"JebBushell" wrote:
"Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine. "

This is happening when I ry to process an aspx in my default directory
(inetpub\wwwroot).

Well, I'm viewing it on the local machine so why is it saying that?

I've tried editing the web.config file to no effect - it doesn't make any
difference.

I've tried editing the application name and that does have an effect (it
changes the error page, but not the basic message).

I've tried using an asp file istead, but still no joy.

I've tried using an html file and it works. So IIS does have permission to
read files in the root directory, but it cant execute asp or aspx.

Anyone have any ideas, please?

Nov 19 '05 #2

P: n/a
JebBushell wrote:
"Description: An application error occurred on the server. The
current custom error settings for this application prevent the
details of the application error from being viewed remotely (for
security reasons). It could, however, be viewed by browsers running
on the local server machine. "

This is happening when I ry to process an aspx in my default directory
(inetpub\wwwroot).

Well, I'm viewing it on the local machine so why is it saying that?

I've tried editing the web.config file to no effect - it doesn't make
any difference.

I've tried editing the application name and that does have an effect
(it changes the error page, but not the basic message).

I've tried using an asp file istead, but still no joy.

I've tried using an html file and it works. So IIS does have
permission to read files in the root directory, but it cant execute
asp or aspx.

Anyone have any ideas, please?


What OS? If on non-Win2003, give the process account (ASPNET by default)
the default permissions on wwwroot. If on Win2003, give the IIS_WPG group
the same ACLs on wwwroot.

--
Jim Cheshire
JIMCO Software
http://www.jimcosoftware.com

FrontPage add-ins for FrontPage 2000 - 2003


Nov 19 '05 #3

P: n/a
i set the "Show friendly HTTP Messages" to off in IE Internet Options but it
made no difference. I get a 500 status when I look at it over a GPRS
connection (mobile phone).

"Curt_C [MVP]" wrote:
in IE, turn off "Friendly Error Messages" once...

--
Curt Christianson
site: http://www.darkfalz.com
blog: http://blog.darkfalz.com

"JebBushell" wrote:
"Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine. "

This is happening when I ry to process an aspx in my default directory
(inetpub\wwwroot).

Well, I'm viewing it on the local machine so why is it saying that?

I've tried editing the web.config file to no effect - it doesn't make any
difference.

I've tried editing the application name and that does have an effect (it
changes the error page, but not the basic message).

I've tried using an asp file istead, but still no joy.

I've tried using an html file and it works. So IIS does have permission to
read files in the root directory, but it cant execute asp or aspx.

Anyone have any ideas, please?

Nov 19 '05 #4

P: n/a
The OS is XP and I am using simple sharing so I do not know how to grant
access rights. Is it possible to manage rights without tossing simple
sharing? I'm somewhat reluctant to put my whole network at risk. It took
weeks to set up.

"JIMCO Software" wrote:
JebBushell wrote:
"Description: An application error occurred on the server. The
current custom error settings for this application prevent the
details of the application error from being viewed remotely (for
security reasons). It could, however, be viewed by browsers running
on the local server machine. "

This is happening when I ry to process an aspx in my default directory
(inetpub\wwwroot).

Well, I'm viewing it on the local machine so why is it saying that?

I've tried editing the web.config file to no effect - it doesn't make
any difference.

I've tried editing the application name and that does have an effect
(it changes the error page, but not the basic message).

I've tried using an asp file istead, but still no joy.

I've tried using an html file and it works. So IIS does have
permission to read files in the root directory, but it cant execute
asp or aspx.

Anyone have any ideas, please?


What OS? If on non-Win2003, give the process account (ASPNET by default)
the default permissions on wwwroot. If on Win2003, give the IIS_WPG group
the same ACLs on wwwroot.

--
Jim Cheshire
JIMCO Software
http://www.jimcosoftware.com

FrontPage add-ins for FrontPage 2000 - 2003


Nov 19 '05 #5

P: n/a
Thanks, I forgot to mention that I had already checked that.

"John Morales" wrote:
Hello JebBushell" jebbushell AT yahoo DOT com,

Check that you have the "scripts" or "scripts and executables" options selected in IIS for your wwwroot/ website.
attached is a screenshot of the option in question.

-john
"Description: An application error occurred on the server. The current
custom error settings for this application prevent the details of the
application error from being viewed remotely (for security reasons).
It could, however, be viewed by browsers running on the local server
machine. "

This is happening when I ry to process an aspx in my default directory
(inetpub\wwwroot).

Well, I'm viewing it on the local machine so why is it saying that?

I've tried editing the web.config file to no effect - it doesn't make
any difference.

I've tried editing the application name and that does have an effect
(it changes the error page, but not the basic message).

I've tried using an asp file istead, but still no joy.

I've tried using an html file and it works. So IIS does have
permission to read files in the root directory, but it cant execute
asp or aspx.

Anyone have any ideas, please?

Nov 19 '05 #6

P: n/a
Hello JebBushell" jebbushell AT yahoo DOT com,
How are you accessing the machine, if you are accessing from a local browser
then the error doesnt make sense?
have you tried
http://127.0.0.1/
?
Thanks, I forgot to mention that I had already checked that.

"John Morales" wrote:
Hello JebBushell" jebbushell AT yahoo DOT com,

Check that you have the "scripts" or "scripts and executables"
options selected in IIS for your wwwroot/ website.

attached is a screenshot of the option in question.

-john
"Description: An application error occurred on the server. The
current custom error settings for this application prevent the
details of the application error from being viewed remotely (for
security reasons). It could, however, be viewed by browsers running
on the local server machine. "

This is happening when I ry to process an aspx in my default
directory (inetpub\wwwroot).

Well, I'm viewing it on the local machine so why is it saying that?

I've tried editing the web.config file to no effect - it doesn't
make any difference.

I've tried editing the application name and that does have an effect
(it changes the error page, but not the basic message).

I've tried using an asp file istead, but still no joy.

I've tried using an html file and it works. So IIS does have
permission to read files in the root directory, but it cant execute
asp or aspx.

Anyone have any ideas, please?

Nov 19 '05 #7

P: n/a
JebBushell wrote:
The OS is XP and I am using simple sharing so I do not know how to
grant access rights. Is it possible to manage rights without
tossing simple sharing? I'm somewhat reluctant to put my whole
network at risk. It took weeks to set up.


I'm going to have to bow out. I have no idea how Simple Sharing would
affect this. I have never dealt with anyone who was using it. Sorry.

--
Jim Cheshire
JIMCO Software
http://www.jimcosoftware.com

FrontPage add-ins for FrontPage 2000 - 2003


Nov 19 '05 #8

P: n/a
Reinstall IIS.

"JebBushell" wrote:
"Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine. "

This is happening when I ry to process an aspx in my default directory
(inetpub\wwwroot).

Well, I'm viewing it on the local machine so why is it saying that?

I've tried editing the web.config file to no effect - it doesn't make any
difference.

I've tried editing the application name and that does have an effect (it
changes the error page, but not the basic message).

I've tried using an asp file istead, but still no joy.

I've tried using an html file and it works. So IIS does have permission to
read files in the root directory, but it cant execute asp or aspx.

Anyone have any ideas, please?

Nov 19 '05 #9

P: n/a
Thanks, yes I'd tried that as well, not that I understand its significance.
However, I have now fixed the problem, I think, by reinstalling IIS. Phew!
What a sweat.

Thanks to you and Jimco and Curt_C for helping.

"John Morales" wrote:
Hello JebBushell" jebbushell AT yahoo DOT com,
How are you accessing the machine, if you are accessing from a local browser
then the error doesnt make sense?
have you tried
http://127.0.0.1/
?
Thanks, I forgot to mention that I had already checked that.

"John Morales" wrote:
Hello JebBushell" jebbushell AT yahoo DOT com,

Check that you have the "scripts" or "scripts and executables"
options selected in IIS for your wwwroot/ website.

attached is a screenshot of the option in question.

-john

"Description: An application error occurred on the server. The
current custom error settings for this application prevent the
details of the application error from being viewed remotely (for
security reasons). It could, however, be viewed by browsers running
on the local server machine. "

This is happening when I ry to process an aspx in my default
directory (inetpub\wwwroot).

Well, I'm viewing it on the local machine so why is it saying that?

I've tried editing the web.config file to no effect - it doesn't
make any difference.

I've tried editing the application name and that does have an effect
(it changes the error page, but not the basic message).

I've tried using an asp file istead, but still no joy.

I've tried using an html file and it works. So IIS does have
permission to read files in the root directory, but it cant execute
asp or aspx.

Anyone have any ideas, please?


Nov 19 '05 #10

P: n/a
Thanks for trying. I reinstalled IIS in the end and it seems to have worked.

"JIMCO Software" wrote:
JebBushell wrote:
The OS is XP and I am using simple sharing so I do not know how to
grant access rights. Is it possible to manage rights without
tossing simple sharing? I'm somewhat reluctant to put my whole
network at risk. It took weeks to set up.


I'm going to have to bow out. I have no idea how Simple Sharing would
affect this. I have never dealt with anyone who was using it. Sorry.

--
Jim Cheshire
JIMCO Software
http://www.jimcosoftware.com

FrontPage add-ins for FrontPage 2000 - 2003


Nov 19 '05 #11

P: n/a
How do you reinstall IIS? I"m having a page won't display issue that no-one
seems to understand or know how to fix. Maybe reinstalling IIS will help me,
but I wouldn't have a clue how to.

Thanks,
Sarah

"JebBushell" wrote:
Reinstall IIS.

"JebBushell" wrote:
"Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine. "

This is happening when I ry to process an aspx in my default directory
(inetpub\wwwroot).

Well, I'm viewing it on the local machine so why is it saying that?

I've tried editing the web.config file to no effect - it doesn't make any
difference.

I've tried editing the application name and that does have an effect (it
changes the error page, but not the basic message).

I've tried using an asp file istead, but still no joy.

I've tried using an html file and it works. So IIS does have permission to
read files in the root directory, but it cant execute asp or aspx.

Anyone have any ideas, please?

Nov 19 '05 #12

P: n/a
Add/Remove - Windows Components
Uncheck IIS, click ok, reboot.
Go in again, check it.

--
Curt Christianson
site: http://www.darkfalz.com
blog: http://blog.darkfalz.com

"Sarah Sarah" wrote:
How do you reinstall IIS? I"m having a page won't display issue that no-one
seems to understand or know how to fix. Maybe reinstalling IIS will help me,
but I wouldn't have a clue how to.

Thanks,
Sarah

"JebBushell" wrote:
Reinstall IIS.

"JebBushell" wrote:
"Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine. "

This is happening when I ry to process an aspx in my default directory
(inetpub\wwwroot).

Well, I'm viewing it on the local machine so why is it saying that?

I've tried editing the web.config file to no effect - it doesn't make any
difference.

I've tried editing the application name and that does have an effect (it
changes the error page, but not the basic message).

I've tried using an asp file istead, but still no joy.

I've tried using an html file and it works. So IIS does have permission to
read files in the root directory, but it cant execute asp or aspx.

Anyone have any ideas, please?

Nov 19 '05 #13

P: n/a
Thanks, I'll try that.

"Curt_C [MVP]" wrote:
Add/Remove - Windows Components
Uncheck IIS, click ok, reboot.
Go in again, check it.

--
Curt Christianson
site: http://www.darkfalz.com
blog: http://blog.darkfalz.com

"Sarah Sarah" wrote:
How do you reinstall IIS? I"m having a page won't display issue that no-one
seems to understand or know how to fix. Maybe reinstalling IIS will help me,
but I wouldn't have a clue how to.

Thanks,
Sarah

"JebBushell" wrote:
Reinstall IIS.

"JebBushell" wrote:

> "Description: An application error occurred on the server. The current custom
> error settings for this application prevent the details of the application
> error from being viewed remotely (for security reasons). It could, however,
> be viewed by browsers running on the local server machine. "
>
> This is happening when I ry to process an aspx in my default directory
> (inetpub\wwwroot).
>
> Well, I'm viewing it on the local machine so why is it saying that?
>
> I've tried editing the web.config file to no effect - it doesn't make any
> difference.
>
> I've tried editing the application name and that does have an effect (it
> changes the error page, but not the basic message).
>
> I've tried using an asp file istead, but still no joy.
>
> I've tried using an html file and it works. So IIS does have permission to
> read files in the root directory, but it cant execute asp or aspx.
>
> Anyone have any ideas, please?
>

Nov 19 '05 #14

This discussion thread is closed

Replies have been disabled for this discussion.