By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,665 Members | 1,952 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,665 IT Pros & Developers. It's quick & easy.

Why does my asp.net application now get "Server Application Unavailable"

P: n/a
On 4th May at 7.45 in the evening my asp.net web sites stopped working on my
development server.

The page that appears says:

Server Application Unavailable
The web application you are attempting to access on this web server is
currently unavailable. Please hit the "Refresh" button in your web browser
to retry your request.

Administrator Note: An error message detailing the cause of this specific
request failure can be found in the application event log of the web server.
Please review this log entry to discover what caused this error to occur.

The windows error log gives two entries in the application log:

Event Type: Error
Event Source: ASP.NET 1.1.4322.0
Event Category: None
Event ID: 1084
Date: 10/05/2005
Time: 17:32:20
User: N/A
Computer: (my server)
Description:
aspnet_wp.exe could not be started. The error code for the failure is
80004005. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure that the
..NET Framework is correctly installed and that the ACLs on the installation
directory allow access to the configured account.

and

Event Type: Error
Event Source: ASP.NET 1.1.4322.0
Event Category: None
Event ID: 1007
Date: 10/05/2005
Time: 17:32:20
User: N/A
Computer: (my server)
Description:
aspnet_wp.exe could not be launched because the username and/or password
supplied in the processModel section of the config file are invalid.

I didn't update my asp.net web applications on this date, so something else
has caused the problem.

I did a search for processModel in the config file, and found a
machine.config file in my .net folder:

C:\WINNT\Microsoft.NET\Framework\v1.1.4322\CONFIG\ machine.config

The processModel username and password in this file are set to:

userName="machine"
password="AutoGenerate"

The full entry is:

<processModel
enable="true"
timeout="Infinite"
idleTimeout="Infinite"
shutdownTimeout="0:00:05"
requestLimit="Infinite"
requestQueueLimit="5000"
restartQueueLimit="10"
memoryLimit="60"
webGarden="false"
cpuMask="0xffffffff"
userName="machine"
password="AutoGenerate"
logLevel="Errors"
clientConnectedCheck="0:00:05"
comAuthenticationLevel="Connect"
comImpersonationLevel="Impersonate"
responseDeadlockInterval="00:03:00"
maxWorkerThreads="20"
maxIoThreads="20"
/>

I think these are all just default settings.

I did a google search to see if I could find an answer and found this:

http://weblogs.asp.net/jambrose/arch...01/224226.aspx

In which he author says the cause of the problem is the server installing
..net 1.1 SP1. The solution to this problem is:

Well, it turns out that the ASPNET account got locked out. I guess my
domain policy here gets applied to local accounts. I unlocked it and reset
IIS, and voila, we're back in business.

The problem is, I don't understand what he means. How is the "machine"
account locked out? How do you unlock it?

My server is running windows 2000 (build 2195) service pack 4.

How can I fix this problem?
Nov 19 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
I think the following KB articles would be a good reference.

http://support.microsoft.com/default...b;en-us;323292
http://support.microsoft.com/default...b;en-us;811320
http://support.microsoft.com/default...b;en-us;315158

--
David Lloyd
MCSD .NET
http://LemingtonConsulting.com

This response is supplied "as is" without any representations or warranties.
"Robert Halford" <ro************@tiscali.com> wrote in message
news:#t**************@TK2MSFTNGP14.phx.gbl...
On 4th May at 7.45 in the evening my asp.net web sites stopped working on my
development server.

The page that appears says:

Server Application Unavailable
The web application you are attempting to access on this web server is
currently unavailable. Please hit the "Refresh" button in your web browser
to retry your request.

Administrator Note: An error message detailing the cause of this specific
request failure can be found in the application event log of the web server.
Please review this log entry to discover what caused this error to occur.

The windows error log gives two entries in the application log:

Event Type: Error
Event Source: ASP.NET 1.1.4322.0
Event Category: None
Event ID: 1084
Date: 10/05/2005
Time: 17:32:20
User: N/A
Computer: (my server)
Description:
aspnet_wp.exe could not be started. The error code for the failure is
80004005. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure that the
..NET Framework is correctly installed and that the ACLs on the installation
directory allow access to the configured account.

and

Event Type: Error
Event Source: ASP.NET 1.1.4322.0
Event Category: None
Event ID: 1007
Date: 10/05/2005
Time: 17:32:20
User: N/A
Computer: (my server)
Description:
aspnet_wp.exe could not be launched because the username and/or password
supplied in the processModel section of the config file are invalid.

I didn't update my asp.net web applications on this date, so something else
has caused the problem.

I did a search for processModel in the config file, and found a
machine.config file in my .net folder:

C:\WINNT\Microsoft.NET\Framework\v1.1.4322\CONFIG\ machine.config

The processModel username and password in this file are set to:

userName="machine"
password="AutoGenerate"

The full entry is:

<processModel
enable="true"
timeout="Infinite"
idleTimeout="Infinite"
shutdownTimeout="0:00:05"
requestLimit="Infinite"
requestQueueLimit="5000"
restartQueueLimit="10"
memoryLimit="60"
webGarden="false"
cpuMask="0xffffffff"
userName="machine"
password="AutoGenerate"
logLevel="Errors"
clientConnectedCheck="0:00:05"
comAuthenticationLevel="Connect"
comImpersonationLevel="Impersonate"
responseDeadlockInterval="00:03:00"
maxWorkerThreads="20"
maxIoThreads="20"
/>

I think these are all just default settings.

I did a google search to see if I could find an answer and found this:

http://weblogs.asp.net/jambrose/arch...01/224226.aspx

In which he author says the cause of the problem is the server installing
..net 1.1 SP1. The solution to this problem is:

Well, it turns out that the ASPNET account got locked out. I guess my
domain policy here gets applied to local accounts. I unlocked it and reset
IIS, and voila, we're back in business.

The problem is, I don't understand what he means. How is the "machine"
account locked out? How do you unlock it?

My server is running windows 2000 (build 2195) service pack 4.

How can I fix this problem?

Nov 19 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.