By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,214 Members | 2,066 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,214 IT Pros & Developers. It's quick & easy.

I hate IIS - "Server Application Unavailable" error message

P: n/a
Yes, I wasted the past two days trying to fix this.
Yes, this is on a Win2003 Server.
Yes, this machine is a domain controller.

Yes, I seen the dozens of KB articles like this one:
http://support.microsoft.com/default...;en-us;Q315158

But the problem is that 99% of these are for ASP .NET 1.x and this
is .NET 2.x which I just installed to try and get .net working for the
first time ever. I've see all the HACKS to get .net 1.x working... but
this is for .net 2.x so these worthless KB articles do nothing for me.

Example -
http://support.microsoft.com/default...;en-us;Q315158

RESOLUTION
To work around this problem, use one of the following methods: ·
Create a weak account that has the correct permissions, and then
configure the <processModelsection of the Machine.config file to use
that account.
· Set the userName attribute to SYSTEM in the <processModelsection
of the Machine.config file.
· Configure the <processModelsection of the Machine.config file to
use an administrator account.
THIS IS USELESS !!!!! There is no "userName" attribute in the
Machine.config file in .net 2.x. And if this is a known problem then
why doesn't the installer warn me or fix it automatically. Sorry, but
your software sucks lately.!!!!!!!

The event log is filled with messages like:

<quote>
aspnet_wp.exe could not be started. The error code for the failure is
800700CB. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure
that the .NET Framework is correctly installed and that the ACLs on
the installation directory allow access to the configured account.
</quote>
Sorry Microsoft - But you are getting WORSE and WORSE. How about
software that simply works????

It's no wonder that Linux is kicking your butt and I'm about 30
seconds away from saying goodbye to your over-complicated bug ridden
crap and making the transition to linux myself.

Jul 3 '07 #1
Share this Question
Share on Google+
13 Replies


P: n/a
Framework versions mixup maybe? Did you check the ASP.NET tab page on the
site properties and made sure it is set to the right version? Did you go to
the Web Service Extensions and made sure the proper extensions are enabled?
If nothing else works, try re-registering 2.0 for asp.net
(aspnet_regiis.exe)

Calm down, 2.0 is way better than 1.1 and it is worth the trouble.

Otavio
"Kevin Liebowicz" <li*******@lycos.comwrote in message
news:11*********************@w5g2000hsg.googlegrou ps.com...
Yes, I wasted the past two days trying to fix this.
Yes, this is on a Win2003 Server.
Yes, this machine is a domain controller.

Yes, I seen the dozens of KB articles like this one:
http://support.microsoft.com/default...;en-us;Q315158

But the problem is that 99% of these are for ASP .NET 1.x and this
is .NET 2.x which I just installed to try and get .net working for the
first time ever. I've see all the HACKS to get .net 1.x working... but
this is for .net 2.x so these worthless KB articles do nothing for me.

Example -
http://support.microsoft.com/default...;en-us;Q315158

RESOLUTION
To work around this problem, use one of the following methods: ·
Create a weak account that has the correct permissions, and then
configure the <processModelsection of the Machine.config file to use
that account.
· Set the userName attribute to SYSTEM in the <processModelsection
of the Machine.config file.
· Configure the <processModelsection of the Machine.config file to
use an administrator account.
THIS IS USELESS !!!!! There is no "userName" attribute in the
Machine.config file in .net 2.x. And if this is a known problem then
why doesn't the installer warn me or fix it automatically. Sorry, but
your software sucks lately.!!!!!!!

The event log is filled with messages like:

<quote>
aspnet_wp.exe could not be started. The error code for the failure is
800700CB. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure
that the .NET Framework is correctly installed and that the ACLs on
the installation directory allow access to the configured account.
</quote>
Sorry Microsoft - But you are getting WORSE and WORSE. How about
software that simply works????

It's no wonder that Linux is kicking your butt and I'm about 30
seconds away from saying goodbye to your over-complicated bug ridden
crap and making the transition to linux myself.
Jul 3 '07 #2

P: n/a
re:
!Yes, this is on a Win2003 Server.
!Yes, this machine is a domain controller.

Bad idea.

In general, it's not advisable to run your Web server on a domain controller,
because a compromise of the machine is a compromise of the domain.

But, if you *really* need to do that...

re:
!There is no "userName" attribute in the Machine.config file in .net 2.x.

Yes, there is.

<processModel enable="true" userName="SYSTEM" password="AutoGenerate" />

....ought to cover it for you, if you *really* want to run ASP.NET
as the SYSTEM account on a domain controller, although I would encrypt the section.

Even better, I would NOT run ASP.NET as the System account. See below...

re:
!The event log is filled with messages like:

It's no wonder that is happening.

re:
!How about software that simply works????

If you deliberately run ASP.NET on a domain controller,
something which is not recommended, don't blame Microsoft
if you can't RTFM to implement the workaround.

http://msdn2.microsoft.com/en-us/library/7w2sway1.aspx

Even better than using the System account would be specifing an explicit account.

That works around the security problems which
running ASP.NET on a domain controller exposes you to.

To do that, follow the instructions in this article...

How To: Create a Service Account for an ASP.NET 2.0 Application:
http://msdn2.microsoft.com/en-us/library/ms998297.aspx

Try it. It's really easy to do.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"Kevin Liebowicz" <li*******@lycos.comwrote in message news:11*********************@w5g2000hsg.googlegrou ps.com...
Yes, I wasted the past two days trying to fix this.
Yes, this is on a Win2003 Server.
Yes, this machine is a domain controller.

Yes, I seen the dozens of KB articles like this one:
http://support.microsoft.com/default...;en-us;Q315158

But the problem is that 99% of these are for ASP .NET 1.x and this
is .NET 2.x which I just installed to try and get .net working for the
first time ever. I've see all the HACKS to get .net 1.x working... but
this is for .net 2.x so these worthless KB articles do nothing for me.

Example -
http://support.microsoft.com/default...;en-us;Q315158

RESOLUTION
To work around this problem, use one of the following methods: ·
Create a weak account that has the correct permissions, and then
configure the <processModelsection of the Machine.config file to use
that account.
· Set the userName attribute to SYSTEM in the <processModelsection
of the Machine.config file.
· Configure the <processModelsection of the Machine.config file to
use an administrator account.
THIS IS USELESS !!!!! There is no "userName" attribute in the
Machine.config file in .net 2.x. And if this is a known problem then
why doesn't the installer warn me or fix it automatically. Sorry, but
your software sucks lately.!!!!!!!

The event log is filled with messages like:

<quote>
aspnet_wp.exe could not be started. The error code for the failure is
800700CB. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure
that the .NET Framework is correctly installed and that the ACLs on
the installation directory allow access to the configured account.
</quote>
Sorry Microsoft - But you are getting WORSE and WORSE. How about
software that simply works????

It's no wonder that Linux is kicking your butt and I'm about 30
seconds away from saying goodbye to your over-complicated bug ridden
crap and making the transition to linux myself.

Jul 3 '07 #3

P: n/a
Ouch Juan. I am praying for this guy's funeral. :-)

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA
http://gregorybeamer.spaces.live.com
Co-author: Microsoft Expression Web Bible (upcoming)

************************************************
Think outside the box!
************************************************
"Juan T. Llibre" <no***********@nowhere.comwrote in message
news:ej**************@TK2MSFTNGP03.phx.gbl...
re:
!Yes, this is on a Win2003 Server.
!Yes, this machine is a domain controller.

Bad idea.

In general, it's not advisable to run your Web server on a domain
controller,
because a compromise of the machine is a compromise of the domain.

But, if you *really* need to do that...

re:
!There is no "userName" attribute in the Machine.config file in .net
2.x.

Yes, there is.

<processModel enable="true" userName="SYSTEM" password="AutoGenerate" />

...ought to cover it for you, if you *really* want to run ASP.NET
as the SYSTEM account on a domain controller, although I would encrypt the
section.

Even better, I would NOT run ASP.NET as the System account. See below...

re:
!The event log is filled with messages like:

It's no wonder that is happening.

re:
!How about software that simply works????

If you deliberately run ASP.NET on a domain controller,
something which is not recommended, don't blame Microsoft
if you can't RTFM to implement the workaround.

http://msdn2.microsoft.com/en-us/library/7w2sway1.aspx

Even better than using the System account would be specifing an explicit
account.

That works around the security problems which
running ASP.NET on a domain controller exposes you to.

To do that, follow the instructions in this article...

How To: Create a Service Account for an ASP.NET 2.0 Application:
http://msdn2.microsoft.com/en-us/library/ms998297.aspx

Try it. It's really easy to do.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"Kevin Liebowicz" <li*******@lycos.comwrote in message
news:11*********************@w5g2000hsg.googlegrou ps.com...
Yes, I wasted the past two days trying to fix this.
Yes, this is on a Win2003 Server.
Yes, this machine is a domain controller.

Yes, I seen the dozens of KB articles like this one:
http://support.microsoft.com/default...;en-us;Q315158

But the problem is that 99% of these are for ASP .NET 1.x and this
is .NET 2.x which I just installed to try and get .net working for the
first time ever. I've see all the HACKS to get .net 1.x working... but
this is for .net 2.x so these worthless KB articles do nothing for me.

Example -
http://support.microsoft.com/default...;en-us;Q315158

RESOLUTION
To work around this problem, use one of the following methods: ·
Create a weak account that has the correct permissions, and then
configure the <processModelsection of the Machine.config file to use
that account.
· Set the userName attribute to SYSTEM in the <processModelsection
of the Machine.config file.
· Configure the <processModelsection of the Machine.config file to
use an administrator account.
THIS IS USELESS !!!!! There is no "userName" attribute in the
Machine.config file in .net 2.x. And if this is a known problem then
why doesn't the installer warn me or fix it automatically. Sorry, but
your software sucks lately.!!!!!!!

The event log is filled with messages like:

<quote>
aspnet_wp.exe could not be started. The error code for the failure is
800700CB. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure
that the .NET Framework is correctly installed and that the ACLs on
the installation directory allow access to the configured account.
</quote>
Sorry Microsoft - But you are getting WORSE and WORSE. How about
software that simply works????

It's no wonder that Linux is kicking your butt and I'm about 30
seconds away from saying goodbye to your over-complicated bug ridden
crap and making the transition to linux myself.

Jul 3 '07 #4

P: n/a
Juan has given you the hangman's noose. Now I am going to inform you why
Juan told you not to do this.

You can get it running on a domain controller by altering this account. The
problem is you now leave a big hole into your domain controller.

Why is this a problem? Well, once someone has control of your domain
controller, they have control of your domain.

And, why is that dangerous? Do you hold ANY secrets. You know, things like
customer's credit cards, you own employee's social security numbers?
Anything like that? Well, you have the potential of leaving it all open for
someone.

Can this really happen? Well, the likelihood is fairly low. It is almost
impossible on a NORMAL web server, but it is a bit more of a risk on web
server that happens to sit on a DC.

Can you mitigate this. Certainly. Buy a web server.

Here is the bottom line. Is it less risky to tell the person forcing you to
do this to buy a web server or to have your customer's data stolen (and
perhaps your own) or to risk you job telling your boss he needs to spend a
few thousand on a web server? If the later, then find a better job. And, if
it is you that is the boss deciding you need to risk your whole business
over a couple of thosand dollars, then I am wating my time.

Don't put your web server on a DC ... EVER.

Nuff said. If you ignore this, you can take Juan's "fix" and hang yourself.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA
http://gregorybeamer.spaces.live.com
Co-author: Microsoft Expression Web Bible (upcoming)

************************************************
Think outside the box!
************************************************
"Kevin Liebowicz" <li*******@lycos.comwrote in message
news:11*********************@w5g2000hsg.googlegrou ps.com...
Yes, I wasted the past two days trying to fix this.
Yes, this is on a Win2003 Server.
Yes, this machine is a domain controller.

Yes, I seen the dozens of KB articles like this one:
http://support.microsoft.com/default...;en-us;Q315158

But the problem is that 99% of these are for ASP .NET 1.x and this
is .NET 2.x which I just installed to try and get .net working for the
first time ever. I've see all the HACKS to get .net 1.x working... but
this is for .net 2.x so these worthless KB articles do nothing for me.

Example -
http://support.microsoft.com/default...;en-us;Q315158

RESOLUTION
To work around this problem, use one of the following methods: ·
Create a weak account that has the correct permissions, and then
configure the <processModelsection of the Machine.config file to use
that account.
· Set the userName attribute to SYSTEM in the <processModelsection
of the Machine.config file.
· Configure the <processModelsection of the Machine.config file to
use an administrator account.
THIS IS USELESS !!!!! There is no "userName" attribute in the
Machine.config file in .net 2.x. And if this is a known problem then
why doesn't the installer warn me or fix it automatically. Sorry, but
your software sucks lately.!!!!!!!

The event log is filled with messages like:

<quote>
aspnet_wp.exe could not be started. The error code for the failure is
800700CB. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure
that the .NET Framework is correctly installed and that the ACLs on
the installation directory allow access to the configured account.
</quote>
Sorry Microsoft - But you are getting WORSE and WORSE. How about
software that simply works????

It's no wonder that Linux is kicking your butt and I'm about 30
seconds away from saying goodbye to your over-complicated bug ridden
crap and making the transition to linux myself.
Jul 3 '07 #5

P: n/a
re:
!Ouch Juan. I am praying for this guy's funeral. :-)

heh...

The problem is that some people like going to funerals
so much that they are willing to die so they get to go to one.

;-)

What gets me most, though, is the tendency to blame Microsoft, instead of taking advantage
of the immense technical knowledge of the regulars who come here quite willing to help anybody
who asks nicely, at the cheapest price possible : free.

There's all kinds of specialists who frequent here.

You are one of the best architecture guys there is; I'm more of a setup, optimization and troubleshooting
specialist; there's programming whizzes like Bruce Barker, Kevin Spencer and Mark Rae here, and
creative application specialists like Peter Bromberg, and that's just the tip of the iceberg.

There's many more whom it would be exhausting to mention
....and our collective knowledge can be had just for the asking.

Why someone would rant against Microsoft when just asking nicely,
right here, would get him on the road to solving his problems is beyond me.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"Cowboy (Gregory A. Beamer)" <No************@comcast.netNoSpamMwrote in message
news:%2****************@TK2MSFTNGP05.phx.gbl...
Ouch Juan. I am praying for this guy's funeral. :-)
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA
http://gregorybeamer.spaces.live.com
Co-author: Microsoft Expression Web Bible (upcoming)
"Juan T. Llibre" <no***********@nowhere.comwrote in message news:ej**************@TK2MSFTNGP03.phx.gbl...
>re:
!Yes, this is on a Win2003 Server.
!Yes, this machine is a domain controller.

Bad idea.

In general, it's not advisable to run your Web server on a domain controller, because a compromise of the machine is
a compromise of the domain.

But, if you *really* need to do that...

re:
!There is no "userName" attribute in the Machine.config file in .net 2.x.

Yes, there is.

<processModel enable="true" userName="SYSTEM" password="AutoGenerate" />

...ought to cover it for you, if you *really* want to run ASP.NET
as the SYSTEM account on a domain controller, although I would encrypt the section.

Even better, I would NOT run ASP.NET as the System account. See below...

re:
!The event log is filled with messages like:

It's no wonder that is happening.

re:
!How about software that simply works????

If you deliberately run ASP.NET on a domain controller,
something which is not recommended, don't blame Microsoft
if you can't RTFM to implement the workaround.

http://msdn2.microsoft.com/en-us/library/7w2sway1.aspx

Even better than using the System account would be specifying an explicit account.

That works around the security problems which
running ASP.NET on a domain controller exposes you to.

To do that, follow the instructions in this article...

How To: Create a Service Account for an ASP.NET 2.0 Application:
http://msdn2.microsoft.com/en-us/library/ms998297.aspx

Try it. It's really easy to do.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"Kevin Liebowicz" <li*******@lycos.comwrote in message news:11*********************@w5g2000hsg.googlegrou ps.com...
Yes, I wasted the past two days trying to fix this.
Yes, this is on a Win2003 Server.
Yes, this machine is a domain controller.

Yes, I seen the dozens of KB articles like this one:
http://support.microsoft.com/default...;en-us;Q315158

But the problem is that 99% of these are for ASP .NET 1.x and this
is .NET 2.x which I just installed to try and get .net working for the
first time ever. I've see all the HACKS to get .net 1.x working... but
this is for .net 2.x so these worthless KB articles do nothing for me.

Example -
http://support.microsoft.com/default...;en-us;Q315158

RESOLUTION
To work around this problem, use one of the following methods: ·
Create a weak account that has the correct permissions, and then
configure the <processModelsection of the Machine.config file to use
that account.
· Set the userName attribute to SYSTEM in the <processModelsection
of the Machine.config file.
· Configure the <processModelsection of the Machine.config file to
use an administrator account.
THIS IS USELESS !!!!! There is no "userName" attribute in the
Machine.config file in .net 2.x. And if this is a known problem then
why doesn't the installer warn me or fix it automatically. Sorry, but
your software sucks lately.!!!!!!!

The event log is filled with messages like:

<quote>
aspnet_wp.exe could not be started. The error code for the failure is
800700CB. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure
that the .NET Framework is correctly installed and that the ACLs on
the installation directory allow access to the configured account.
</quote>
Sorry Microsoft - But you are getting WORSE and WORSE. How about
software that simply works????

It's no wonder that Linux is kicking your butt and I'm about 30
seconds away from saying goodbye to your over-complicated bug ridden
crap and making the transition to linux myself.

Jul 3 '07 #6

P: n/a
On Jul 2, 10:38 pm, "Cowboy \(Gregory A. Beamer\)"
<NoSpamMgbwo...@comcast.netNoSpamMwrote:
Juan has given you the hangman's noose. Now I am going to inform you why
Juan told you not to do this.

You can get it running on a domain controller by altering this account. The
problem is you now leave a big hole into your domain controller.

Why is this a problem? Well, once someone has control of your domain
controller, they have control of your domain.

And, why is that dangerous? Do you hold ANY secrets. You know, things like
customer's credit cards, you own employee's social security numbers?
Anything like that? Well, you have the potential of leaving it all open for
someone.
Not at all. This domain controller is in the basement of my house
where it sits behind a firewall. There is no external access to the
network and the domain controller simply provides me with centralized
management for my computers and those that my kids use. I run a web
server on the same machine to serve mp3s, photos and videos.
Can this really happen? Well, the likelihood is fairly low. It is almost
impossible on a NORMAL web server, but it is a bit more of a risk on web
server that happens to sit on a DC.
Not a problem for me unless my wife plans on hacking into the server.
Don't think that you and/or Microsoft understand every customer
scenario because you don't.

Can you mitigate this. Certainly. Buy a web server.
I don't need yet another machine. The one I currently have is more
than capable.

Here is the bottom line. Is it less risky to tell the person forcing you to
do this to buy a web server or to have your customer's data stolen (and
perhaps your own) or to risk you job telling your boss
There is no customer data. I don't need another computer. And there is
no boss.
he needs to spend a
few thousand on a web server? If the later, then find a better job. And, if
it is you that is the boss deciding you need to risk your whole business
over a couple of thosand dollars, then I am wating my time.
Yeah, yeah, yeah. Once again... one size does NOT fit all.
Don't put your web server on a DC ... EVER.
EVER? Then do explain why my family intranet needs a 2nd machine to
server web pages.
Nuff said. If you ignore this, you can take Juan's "fix" and hang yourself.
Ignored because you believe that you understand my situation better
than I do. You do not.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBAhttp://gregorybeamer.spaces.live.com
Co-author: Microsoft Expression Web Bible (upcoming)

************************************************
Think outside the box!
************************************************"K evin Liebowicz" <linux-....@lycos.comwrote in message

news:11*********************@w5g2000hsg.googlegrou ps.com...
Yes, I wasted the past two days trying to fix this.
Yes, this is on a Win2003 Server.
Yes, this machine is a domain controller.

Yes, I seen the dozens of KB articles like this one:http://support.microsoft.com/default...;en-us;Q315158

But the problem is that 99% of these are for ASP .NET 1.x and this
is .NET 2.x which I just installed to try and get .net working for the
first time ever. I've see all the HACKS to get .net 1.x working... but
this is for .net 2.x so these worthless KB articles do nothing for me.

Example -http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

RESOLUTION
To work around this problem, use one of the following methods: ·
Create a weak account that has the correct permissions, and then
configure the <processModelsection of the Machine.config file to use
that account.
· Set the userName attribute to SYSTEM in the <processModelsection
of the Machine.config file.
· Configure the <processModelsection of the Machine.config file to
use an administrator account.

THIS IS USELESS !!!!! There is no "userName" attribute in the
Machine.config file in .net 2.x. And if this is a known problem then
why doesn't the installer warn me or fix it automatically. Sorry, but
your software sucks lately.!!!!!!!

The event log is filled with messages like:

<quote>
aspnet_wp.exe could not be started. The error code for the failure is
800700CB. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure
that the .NET Framework is correctly installed and that the ACLs on
the installation directory allow access to the configured account.
</quote>

Sorry Microsoft - But you are getting WORSE and WORSE. How about
software that simply works????

It's no wonder that Linux is kicking your butt and I'm about 30
seconds away from saying goodbye to your over-complicated bug ridden
crap and making the transition to linux myself.

Jul 3 '07 #7

P: n/a
Kevin,

in your case all you have to do is set up an ad-hoc service account,
as indicated in the link I sent you :

How To: Create a Service Account for an ASP.NET 2.0 Application:
http://msdn2.microsoft.com/en-us/library/ms998297.aspx

You really shouldn't run ASP.NET as the System account,
just in case something goes wrong with the boxes' security

Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"Kevin Liebowicz" <li*******@lycos.comwrote in message news:11**********************@k79g2000hse.googlegr oups.com...
On Jul 2, 10:38 pm, "Cowboy \(Gregory A. Beamer\)"
<NoSpamMgbwo...@comcast.netNoSpamMwrote:
Juan has given you the hangman's noose. Now I am going to inform you why
Juan told you not to do this.

You can get it running on a domain controller by altering this account. The
problem is you now leave a big hole into your domain controller.

Why is this a problem? Well, once someone has control of your domain
controller, they have control of your domain.

And, why is that dangerous? Do you hold ANY secrets. You know, things like
customer's credit cards, you own employee's social security numbers?
Anything like that? Well, you have the potential of leaving it all open for
someone.
Not at all. This domain controller is in the basement of my house
where it sits behind a firewall. There is no external access to the
network and the domain controller simply provides me with centralized
management for my computers and those that my kids use. I run a web
server on the same machine to serve mp3s, photos and videos.
Can this really happen? Well, the likelihood is fairly low. It is almost
impossible on a NORMAL web server, but it is a bit more of a risk on web
server that happens to sit on a DC.
Not a problem for me unless my wife plans on hacking into the server.
Don't think that you and/or Microsoft understand every customer
scenario because you don't.

Can you mitigate this. Certainly. Buy a web server.
I don't need yet another machine. The one I currently have is more
than capable.

Here is the bottom line. Is it less risky to tell the person forcing you to
do this to buy a web server or to have your customer's data stolen (and
perhaps your own) or to risk you job telling your boss
There is no customer data. I don't need another computer. And there is
no boss.
he needs to spend a
few thousand on a web server? If the later, then find a better job. And, if
it is you that is the boss deciding you need to risk your whole business
over a couple of thosand dollars, then I am wating my time.
Yeah, yeah, yeah. Once again... one size does NOT fit all.
Don't put your web server on a DC ... EVER.
EVER? Then do explain why my family intranet needs a 2nd machine to
server web pages.
Nuff said. If you ignore this, you can take Juan's "fix" and hang yourself.
Ignored because you believe that you understand my situation better
than I do. You do not.

--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBAhttp://gregorybeamer.spaces.live.com
Co-author: Microsoft Expression Web Bible (upcoming)

************************************************
Think outside the box!
************************************************"K evin Liebowicz" <linux-...@lycos.comwrote in message

news:11*********************@w5g2000hsg.googlegrou ps.com...
Yes, I wasted the past two days trying to fix this.
Yes, this is on a Win2003 Server.
Yes, this machine is a domain controller.

Yes, I seen the dozens of KB articles like this one:http://support.microsoft.com/default...;en-us;Q315158

But the problem is that 99% of these are for ASP .NET 1.x and this
is .NET 2.x which I just installed to try and get .net working for the
first time ever. I've see all the HACKS to get .net 1.x working... but
this is for .net 2.x so these worthless KB articles do nothing for me.

Example -http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

RESOLUTION
To work around this problem, use one of the following methods: ·
Create a weak account that has the correct permissions, and then
configure the <processModelsection of the Machine.config file to use
that account.
· Set the userName attribute to SYSTEM in the <processModelsection
of the Machine.config file.
· Configure the <processModelsection of the Machine.config file to
use an administrator account.

THIS IS USELESS !!!!! There is no "userName" attribute in the
Machine.config file in .net 2.x. And if this is a known problem then
why doesn't the installer warn me or fix it automatically. Sorry, but
your software sucks lately.!!!!!!!

The event log is filled with messages like:

<quote>
aspnet_wp.exe could not be started. The error code for the failure is
800700CB. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure
that the .NET Framework is correctly installed and that the ACLs on
the installation directory allow access to the configured account.
</quote>

Sorry Microsoft - But you are getting WORSE and WORSE. How about
software that simply works????

It's no wonder that Linux is kicking your butt and I'm about 30
seconds away from saying goodbye to your over-complicated bug ridden
crap and making the transition to linux myself.


Jul 3 '07 #8

P: n/a
On Jul 3, 9:57 am, "Juan T. Llibre" <nomailrepl...@nowhere.comwrote:
Kevin,

in your case all you have to do is set up an ad-hoc service account,
as indicated in the link I sent you :

How To: Create a Service Account for an ASP.NET 2.0 Application:http://msdn2.microsoft.com/en-us/library/ms998297.aspx
Except that it still does not work.

I followed the directions -

#1 - I created a new account (in the User group) named
aspxuseraccount.
[Works]

#2 - Assign ASP.NET permissions to the new account
(FAMILY is the domain name since it's the home/family domain
controller)

C:\WINNT\Microsoft.NET\Framework\v2.0.50727>aspnet _regiis.exe -ga
FAMILY\aspxuseraccount

Start granting FAMILY\aspxuseraccount access to the IIS metabase and
other directories used by ASP.NET.
Finished granting FAMILY\aspxuseraccount access to the IIS metabase
and other directories used by ASP.NET.
[Works]
#3 - Create a Test ASP.NET Application
WRONG! This is a server that sits in the basement. I don't have visual
studio .net installed on this machine nor do I intend on buying it
just to "enable" my machine to serve a simple .aspx page.

So I create a small file named Default.aspx and I paste the text from
the article into it. Without VS.net I can't compile or run the app but
I ought to at least be able to serve this page. Nope... still can't do
that:

http://bubba/default.aspx

<quote>
Server Application Unavailable
The web application you are attempting to access on this web server is
currently unavailable. Please hit the "Refresh" button in your web
browser to retry your request.

Administrator Note: An error message detailing the cause of this
specific request failure can be found in the application event log of
the web server. Please review this log entry to discover what caused
this error to occur.
</quote>
You really shouldn't run ASP.NET as the System account,
just in case something goes wrong with the boxes' security

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================"Kevin Liebowicz" <linux-...@lycos.comwrote in messagenews:11**********************@k79g2000hse.g ooglegroups.com...

On Jul 2, 10:38 pm, "Cowboy \(Gregory A. Beamer\)"

<NoSpamMgbwo...@comcast.netNoSpamMwrote:
Juan has given you the hangman's noose. Now I am going to inform you why
Juan told you not to do this.
You can get it running on a domain controller by altering this account.The
problem is you now leave a big hole into your domain controller.
Why is this a problem? Well, once someone has control of your domain
controller, they have control of your domain.
And, why is that dangerous? Do you hold ANY secrets. You know, things like
customer's credit cards, you own employee's social security numbers?
Anything like that? Well, you have the potential of leaving it all openfor
someone.

Not at all. This domain controller is in the basement of my house
where it sits behind a firewall. There is no external access to the
network and the domain controller simply provides me with centralized
management for my computers and those that my kids use. I run a web
server on the same machine to serve mp3s, photos and videos.
Can this really happen? Well, the likelihood is fairly low. It is almost
impossible on a NORMAL web server, but it is a bit more of a risk on web
server that happens to sit on a DC.

Not a problem for me unless my wife plans on hacking into the server.
Don't think that you and/or Microsoft understand every customer
scenario because you don't.
Can you mitigate this. Certainly. Buy a web server.

I don't need yet another machine. The one I currently have is more
than capable.
Here is the bottom line. Is it less risky to tell the person forcing you to
do this to buy a web server or to have your customer's data stolen (and
perhaps your own) or to risk you job telling your boss

There is no customer data. I don't need another computer. And there is
no boss.
he needs to spend a
few thousand on a web server? If the later, then find a better job. And, if
it is you that is the boss deciding you need to risk your whole business
over a couple of thosand dollars, then I am wating my time.

Yeah, yeah, yeah. Once again... one size does NOT fit all.
Don't put your web server on a DC ... EVER.

EVER? Then do explain why my family intranet needs a 2nd machine to
server web pages.
Nuff said. If you ignore this, you can take Juan's "fix" and hang yourself.

Ignored because you believe that you understand my situation better
than I do. You do not.
--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBAhttp://gregorybeamer.spaces.live.com
Co-author: Microsoft Expression Web Bible (upcoming)
************************************************
Think outside the box!
************************************************"K evin Liebowicz" <linux-...@lycos.comwrote in message
news:11*********************@w5g2000hsg.googlegrou ps.com...
Yes, I wasted the past two days trying to fix this.
Yes, this is on a Win2003 Server.
Yes, this machine is a domain controller.
Yes, I seen the dozens of KB articles like this one:http://support.microsoft.com/default...;en-us;Q315158
But the problem is that 99% of these are for ASP .NET 1.x and this
is .NET 2.x which I just installed to try and get .net working for the
first time ever. I've see all the HACKS to get .net 1.x working... but
this is for .net 2.x so these worthless KB articles do nothing for me.
Example -http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158
RESOLUTION
To work around this problem, use one of the following methods: ·
Create a weak account that has the correct permissions, and then
configure the <processModelsection of the Machine.config file to use
that account.
· Set the userName attribute to SYSTEM in the <processModelsection
of the Machine.config file.
· Configure the <processModelsection of the Machine.config file to
use an administrator account.
THIS IS USELESS !!!!! There is no "userName" attribute in the
Machine.config file in .net 2.x. And if this is a known problem then
why doesn't the installer warn me or fix it automatically. Sorry, but
your software sucks lately.!!!!!!!
The event log is filled with messages like:
<quote>
aspnet_wp.exe could not be started. The error code for the failure is
800700CB. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure
that the .NET Framework is correctly installed and that the ACLs on
the installation directory allow access to the configured account.
</quote>
Sorry Microsoft - But you are getting WORSE and WORSE. How about
software that simply works????
It's no wonder that Linux is kicking your butt and I'm about 30
seconds away from saying goodbye to your over-complicated bug ridden
crap and making the transition to linux myself.- Hide quoted text -

- Show quoted text -

Jul 3 '07 #9

P: n/a
re:
!Server Application Unavailable
!The web application you are attempting to access on this web server is currently unavailable.

In Windows 2003, you have to specifically enable ASP.NET.
The default, for security reasons, is that ASP.NET is not enabled.

Open the IIS Manager, scroll on the left to "Web Service Extensions", then select
the ASP.NET version you want to allow on the right pane, and click the "Allow" button.

You can also run:

aspnet_regiis -enable

Both procedures do the same thing : enable ASP.NET to run on W2K3.


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"Kevin Liebowicz" <li*******@lycos.comwrote in message news:11*********************@g4g2000hsf.googlegrou ps.com...
On Jul 3, 9:57 am, "Juan T. Llibre" <nomailrepl...@nowhere.comwrote:
Kevin,

in your case all you have to do is set up an ad-hoc service account,
as indicated in the link I sent you :

How To: Create a Service Account for an ASP.NET 2.0 Application:
http://msdn2.microsoft.com/en-us/library/ms998297.aspx

Except that it still does not work.

I followed the directions -

#1 - I created a new account (in the User group) named
aspxuseraccount.
[Works]

#2 - Assign ASP.NET permissions to the new account
(FAMILY is the domain name since it's the home/family domain
controller)

C:\WINNT\Microsoft.NET\Framework\v2.0.50727>aspnet _regiis.exe -ga
FAMILY\aspxuseraccount

Start granting FAMILY\aspxuseraccount access to the IIS metabase and
other directories used by ASP.NET.
Finished granting FAMILY\aspxuseraccount access to the IIS metabase
and other directories used by ASP.NET.
[Works]
#3 - Create a Test ASP.NET Application
WRONG! This is a server that sits in the basement. I don't have visual
studio .net installed on this machine nor do I intend on buying it
just to "enable" my machine to serve a simple .aspx page.

So I create a small file named Default.aspx and I paste the text from
the article into it. Without VS.net I can't compile or run the app but
I ought to at least be able to serve this page. Nope... still can't do
that:

http://bubba/default.aspx

<quote>
Server Application Unavailable
The web application you are attempting to access on this web server is
currently unavailable. Please hit the "Refresh" button in your web
browser to retry your request.

Administrator Note: An error message detailing the cause of this
specific request failure can be found in the application event log of
the web server. Please review this log entry to discover what caused
this error to occur.
</quote>

Jul 3 '07 #10

P: n/a
Three more things...

1. Did you setup the root site to run against ASP.NET 2.0 ?

http://bubba/default.aspx will need to run using the .Net Framework 2.0

Open the IIS Manager and, in the properties for the "Default Web Site"
( right-click it and select "Properties" ), select the ASP.NET tab,
and make sure that 2.0.50727 is selected... )

2. Did you create the Application Pool for ASP.NET 2.0 ?
( as detailed in the same article : http://msdn2.microsoft.com/en-us/library/ms998297.aspx )

3. Make sure the root application is running in the Application Pool you just created.
( Again...in the Default Web Sites' properties in the IIS Manager )


Juan T. Llibre, asp.net MVP
asp.net faq : http://asp.net.do/faq/
foros de asp.net, en español : http://asp.net.do/foros/
======================================
"Kevin Liebowicz" <li*******@lycos.comwrote in message news:11*********************@g4g2000hsf.googlegrou ps.com...
On Jul 3, 9:57 am, "Juan T. Llibre" <nomailrepl...@nowhere.comwrote:
Kevin,

in your case all you have to do is set up an ad-hoc service account,
as indicated in the link I sent you :

How To: Create a Service Account for an ASP.NET 2.0 Application:
http://msdn2.microsoft.com/en-us/library/ms998297.aspx
Except that it still does not work.

I followed the directions -

#1 - I created a new account (in the User group) named
aspxuseraccount.
[Works]

#2 - Assign ASP.NET permissions to the new account
(FAMILY is the domain name since it's the home/family domain
controller)

C:\WINNT\Microsoft.NET\Framework\v2.0.50727>aspnet _regiis.exe -ga
FAMILY\aspxuseraccount

Start granting FAMILY\aspxuseraccount access to the IIS metabase and
other directories used by ASP.NET.
Finished granting FAMILY\aspxuseraccount access to the IIS metabase
and other directories used by ASP.NET.
[Works]
#3 - Create a Test ASP.NET Application
WRONG! This is a server that sits in the basement. I don't have visual
studio .net installed on this machine nor do I intend on buying it
just to "enable" my machine to serve a simple .aspx page.

So I create a small file named Default.aspx and I paste the text from
the article into it. Without VS.net I can't compile or run the app but
I ought to at least be able to serve this page. Nope... still can't do
that:

http://bubba/default.aspx

<quote>
Server Application Unavailable
The web application you are attempting to access on this web server is
currently unavailable. Please hit the "Refresh" button in your web
browser to retry your request.

Administrator Note: An error message detailing the cause of this
specific request failure can be found in the application event log of
the web server. Please review this log entry to discover what caused
this error to occur.
</quote>
You really shouldn't run ASP.NET as the System account,
just in case something goes wrong with the boxes' security

Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================"Kevin Liebowicz" <linux-...@lycos.comwrote in
messagenews:11**********************@k79g2000hse.g ooglegroups.com...

On Jul 2, 10:38 pm, "Cowboy \(Gregory A. Beamer\)"

<NoSpamMgbwo...@comcast.netNoSpamMwrote:
Juan has given you the hangman's noose. Now I am going to inform you why
Juan told you not to do this.
You can get it running on a domain controller by altering this account. The
problem is you now leave a big hole into your domain controller.
Why is this a problem? Well, once someone has control of your domain
controller, they have control of your domain.
And, why is that dangerous? Do you hold ANY secrets. You know, things like
customer's credit cards, you own employee's social security numbers?
Anything like that? Well, you have the potential of leaving it all open for
someone.

Not at all. This domain controller is in the basement of my house
where it sits behind a firewall. There is no external access to the
network and the domain controller simply provides me with centralized
management for my computers and those that my kids use. I run a web
server on the same machine to serve mp3s, photos and videos.
Can this really happen? Well, the likelihood is fairly low. It is almost
impossible on a NORMAL web server, but it is a bit more of a risk on web
server that happens to sit on a DC.

Not a problem for me unless my wife plans on hacking into the server.
Don't think that you and/or Microsoft understand every customer
scenario because you don't.
Can you mitigate this. Certainly. Buy a web server.

I don't need yet another machine. The one I currently have is more
than capable.
Here is the bottom line. Is it less risky to tell the person forcing you to
do this to buy a web server or to have your customer's data stolen (and
perhaps your own) or to risk you job telling your boss

There is no customer data. I don't need another computer. And there is
no boss.
he needs to spend a
few thousand on a web server? If the later, then find a better job. And, if
it is you that is the boss deciding you need to risk your whole business
over a couple of thosand dollars, then I am wating my time.

Yeah, yeah, yeah. Once again... one size does NOT fit all.
Don't put your web server on a DC ... EVER.

EVER? Then do explain why my family intranet needs a 2nd machine to
server web pages.
Nuff said. If you ignore this, you can take Juan's "fix" and hang yourself.

Ignored because you believe that you understand my situation better
than I do. You do not.
--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBAhttp://gregorybeamer.spaces.live.com
Co-author: Microsoft Expression Web Bible (upcoming)
************************************************
Think outside the box!
************************************************"K evin Liebowicz" <linux-...@lycos.comwrote in message
news:11*********************@w5g2000hsg.googlegrou ps.com...
Yes, I wasted the past two days trying to fix this.
Yes, this is on a Win2003 Server.
Yes, this machine is a domain controller.
Yes, I seen the dozens of KB articles like this one:http://support.microsoft.com/default...;en-us;Q315158
But the problem is that 99% of these are for ASP .NET 1.x and this
is .NET 2.x which I just installed to try and get .net working for the
first time ever. I've see all the HACKS to get .net 1.x working... but
this is for .net 2.x so these worthless KB articles do nothing for me.
Example -http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158
RESOLUTION
To work around this problem, use one of the following methods: ·
Create a weak account that has the correct permissions, and then
configure the <processModelsection of the Machine.config file to use
that account.
· Set the userName attribute to SYSTEM in the <processModelsection
of the Machine.config file.
· Configure the <processModelsection of the Machine.config file to
use an administrator account.
THIS IS USELESS !!!!! There is no "userName" attribute in the
Machine.config file in .net 2.x. And if this is a known problem then
why doesn't the installer warn me or fix it automatically. Sorry, but
your software sucks lately.!!!!!!!
The event log is filled with messages like:
<quote>
aspnet_wp.exe could not be started. The error code for the failure is
800700CB. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure
that the .NET Framework is correctly installed and that the ACLs on
the installation directory allow access to the configured account.
</quote>
Sorry Microsoft - But you are getting WORSE and WORSE. How about
software that simply works????
It's no wonder that Linux is kicking your butt and I'm about 30
seconds away from saying goodbye to your over-complicated bug ridden
crap and making the transition to linux myself.- Hide quoted text -

- Show quoted text -


Jul 3 '07 #11

P: n/a
On Jul 3, 10:40 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
re:
!Server Application Unavailable
!The web application you are attempting to access on this web server is currently unavailable.

In Windows 2003, you have to specifically enable ASP.NET.
The default, for security reasons, is that ASP.NET is not enabled.

Open the IIS Manager, scroll on the left to "Web Service Extensions", then select
the ASP.NET version you want to allow on the right pane, and click the "Allow" button.

Yes - I did this yesterday.
You can also run:

aspnet_regiis -enable

Both procedures do the same thing : enable ASP.NET to run on W2K3.
I did this too. I didn't realize they did the same thing.


Jul 3 '07 #12

P: n/a
On Jul 3, 10:45 am, "Juan T. Llibre" <nomailrepl...@nowhere.com>
wrote:
Three more things...

1. Did you setup the root site to run against ASP.NET 2.0 ?

http://bubba/default.aspxwill need to run using the .Net Framework 2.0

Open the IIS Manager and, in the properties for the "Default Web Site"
( right-click it and select "Properties" ), select the ASP.NET tab,
and make sure that 2.0.50727 is selected... )
It is selected and it is the only option that's available.

On this tab there's an entry for "File location" which is c:\inetpub
\wwwroot\web.config. - There is no such file. Should there be? Where
does this file come from?

Since there is no web.config file both entries for "File creation
date" and "File last mod" read "Date not available."

But if I go up one level (Web Sites - which is at the same level as
FTP Sites) and I go to the same dialog tab it has this which does
exist:

C:\WINNT\Microsoft.NET\Framework\v2.0.50727\config \web.config

2. Did you create the Application Pool for ASP.NET 2.0 ?
( as detailed in the same article :http://msdn2.microsoft.com/en-us/library/ms998297.aspx)
NO - Because the instructions say to expand the "Application Pools"
item in IIS manager. This does NOT exist on my computer. Without
Application Pools there's simply nothing to configure.

3. Make sure the root application is running in the Application Pool you just created.
( Again...in the Default Web Sites' properties in the IIS Manager )
My configuration doesn't have any Application Pools. And I have no
idea where I would set this if I did have an application pool. I right
click on the web-site and select properties. But I don't see anything
anywhere that lets me select an application pool. What tab is this on?
Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================"Kevin Liebowicz" <linux-...@lycos.comwrote in messagenews:11*********************@g4g2000hsf.goo glegroups.com...

On Jul 3, 9:57 am, "Juan T. Llibre" <nomailrepl...@nowhere.comwrote:
Kevin,
in your case all you have to do is set up an ad-hoc service account,
as indicated in the link I sent you :
How To: Create a Service Account for an ASP.NET 2.0 Application:
http://msdn2.microsoft.com/en-us/library/ms998297.aspx

Except that it still does not work.

I followed the directions -

#1 - I created a new account (in the User group) named
aspxuseraccount.
[Works]

#2 - Assign ASP.NET permissions to the new account
(FAMILY is the domain name since it's the home/family domain
controller)

C:\WINNT\Microsoft.NET\Framework\v2.0.50727>aspnet _regiis.exe -ga
FAMILY\aspxuseraccount

Start granting FAMILY\aspxuseraccount access to the IIS metabase and
other directories used by ASP.NET.
Finished granting FAMILY\aspxuseraccount access to the IIS metabase
and other directories used by ASP.NET.
[Works]

#3 - Create a Test ASP.NET Application
WRONG! This is a server that sits in the basement. I don't have visual
studio .net installed on this machine nor do I intend on buying it
just to "enable" my machine to serve a simple .aspx page.

So I create a small file named Default.aspx and I paste the text from
the article into it. Without VS.net I can't compile or run the app but
I ought to at least be able to serve this page. Nope... still can't do
that:

http://bubba/default.aspx

<quote>
Server Application Unavailable
The web application you are attempting to access on this web server is
currently unavailable. Please hit the "Refresh" button in your web
browser to retry your request.

Administrator Note: An error message detailing the cause of this
specific request failure can be found in the application event log of
the web server. Please review this log entry to discover what caused
this error to occur.
</quote>
You really shouldn't run ASP.NET as the System account,
just in case something goes wrong with the boxes' security
Juan T. Llibre, asp.net MVP
asp.net faq :http://asp.net.do/faq/
foros de asp.net, en español :http://asp.net.do/foros/
======================================"Kevin Liebowicz" <linux-...@lycos.comwrote in
messagenews:11**********************@k79g2000hse.g ooglegroups.com...
On Jul 2, 10:38 pm, "Cowboy \(Gregory A. Beamer\)"
<NoSpamMgbwo...@comcast.netNoSpamMwrote:
Juan has given you the hangman's noose. Now I am going to inform you why
Juan told you not to do this.
You can get it running on a domain controller by altering this account. The
problem is you now leave a big hole into your domain controller.
Why is this a problem? Well, once someone has control of your domain
controller, they have control of your domain.
And, why is that dangerous? Do you hold ANY secrets. You know, thingslike
customer's credit cards, you own employee's social security numbers?
Anything like that? Well, you have the potential of leaving it all open for
someone.
Not at all. This domain controller is in the basement of my house
where it sits behind a firewall. There is no external access to the
network and the domain controller simply provides me with centralized
management for my computers and those that my kids use. I run a web
server on the same machine to serve mp3s, photos and videos.
Can this really happen? Well, the likelihood is fairly low. It is almost
impossible on a NORMAL web server, but it is a bit more of a risk on web
server that happens to sit on a DC.
Not a problem for me unless my wife plans on hacking into the server.
Don't think that you and/or Microsoft understand every customer
scenario because you don't.
Can you mitigate this. Certainly. Buy a web server.
I don't need yet another machine. The one I currently have is more
than capable.
Here is the bottom line. Is it less risky to tell the person forcing you to
do this to buy a web server or to have your customer's data stolen (and
perhaps your own) or to risk you job telling your boss
There is no customer data. I don't need another computer. And there is
no boss.
he needs to spend a
few thousand on a web server? If the later, then find a better job. And, if
it is you that is the boss deciding you need to risk your whole business
over a couple of thosand dollars, then I am wating my time.
Yeah, yeah, yeah. Once again... one size does NOT fit all.
Don't put your web server on a DC ... EVER.
EVER? Then do explain why my family intranet needs a 2nd machine to
server web pages.
Nuff said. If you ignore this, you can take Juan's "fix" and hang yourself.
Ignored because you believe that you understand my situation better
than I do. You do not.
--
Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBAhttp://gregorybeamer.spaces.live.com
Co-author: Microsoft Expression Web Bible (upcoming)
************************************************
Think outside the box!
************************************************"K evin Liebowicz" <linux-...@lycos.comwrote in message
>news:11*********************@w5g2000hsg.googlegro ups.com...
Yes, I wasted the past two days trying to fix this.
Yes, this is on a Win2003 Server.
Yes, this machine is a domain controller.
Yes, I seen the dozens of KB articles like this one:http://support.microsoft.com/default...;en-us;Q315158
But the problem is that 99% of these are for ASP .NET 1.x and this
is .NET 2.x which I just installed to try and get .net working for the
first time ever. I've see all the HACKS to get .net 1.x working... but
this is for .net 2.x so these worthless KB articles do nothing for me.
Example -http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158
RESOLUTION
To work around this problem, use one of the following methods: ·
Create a weak account that has the correct permissions, and then
configure the <processModelsection of the Machine.config file to use
that account.
· Set the userName attribute to SYSTEM in the <processModelsection
of the Machine.config file.
· Configure the <processModelsection of the Machine.config file to
use an administrator account.
THIS IS USELESS !!!!! There is no "userName" attribute in the
Machine.config file in .net 2.x. And if this is a known problem then
why doesn't the installer warn me or fix it automatically. Sorry, but
your software sucks lately.!!!!!!!
The event log is filled with messages like:
<quote>
aspnet_wp.exe could not be started. The error code for the failure is
800700CB. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure
that the .NET Framework is correctly installed and that the ACLs on
the installation directory allow access to the configured account.
</quote>
Sorry Microsoft - But you are getting WORSE and WORSE. How about
software that simply works????
It's no wonder that Linux is kicking your butt and I'm about 30
seconds away from saying goodbye to your over-complicated bug ridden
crap and making the transition to linux myself.- Hide quoted text -
- Show quoted text -- Hide quoted text -

- Show quoted text -

Jul 3 '07 #13

P: n/a

"Kevin Liebowicz" <li*******@lycos.comwrote in message
news:11*********************@w5g2000hsg.googlegrou ps.com...
Yes, I wasted the past two days trying to fix this.
Yes, this is on a Win2003 Server.
Yes, this machine is a domain controller.
I had the same problem late last year and never got anywhere with it.
Microsoft wants to sell you another software license to run everything.
Seems that one Linux server is more than capable of running Apache, LDAP,
MySQL, SendMail and a slew of other software. Microsoft servers on the other
hand can only run two apps at once, a virus checker and an application of
your choice.

I'll bet you dollars to donuts that if you want to run a web server,
database, active directory, mail server, etc. then the answer will be that
you need to buy a dedicated machine for each task. Mark my words. Each
Mickeysoft "server" can barely function as a single-purpose dedicated
server. It's a joke.



--
Posted via a free Usenet account from http://www.teranews.com

Jul 3 '07 #14

This discussion thread is closed

Replies have been disabled for this discussion.