By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,357 Members | 1,021 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,357 IT Pros & Developers. It's quick & easy.

Access Denied ASP.NET 1.1.4322...

P: n/a
Hi,

I am getting an "Access Denied" error when attempting to browse asp.net
pages.

I have installed ASP.NET 1.1.4322 on a domain controller.
The machine also has ASP.NET 1.0.3705 installed on it.
The machine is win 2k server. IIS is installed.

I have already run aspnet_regiis - i to reinstall the .net framework.
I have set IIS to run under a domain account. (and this works cause classic
asp pages are working)

I found the following article
http://support.microsoft.com/default...;en-us;Q315158
that talks about running asp.net on a domain controller, but it says that
there is only an issue with v1.0.3705 and it is fixed in v1.1.4322.

never the less I changed the <processModel> to run under a domain account
but still this doesn't work.

I still get an access denied error.
The aspx that I am attempting to view only has plain text in it and the NTFS
and security permissions on the directory (and also the file) are full
controll for everyone.

can naybody please help me out or tell me where I am going wrong.

many thanks in advance.

cheers

martin.


Nov 19 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Does the virtual directory have
script execution rights assigned ?

Open the MMC and check the
virtual directory's script execution permissions.


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Martin" <ma*******************@martinz.co.nz> wrote in message
news:e%*****************@TK2MSFTNGP12.phx.gbl...
Hi,

I am getting an "Access Denied" error when attempting to browse asp.net
pages.

I have installed ASP.NET 1.1.4322 on a domain controller.
The machine also has ASP.NET 1.0.3705 installed on it.
The machine is win 2k server. IIS is installed.

I have already run aspnet_regiis - i to reinstall the .net framework.
I have set IIS to run under a domain account. (and this works cause
classic asp pages are working)

I found the following article
http://support.microsoft.com/default...;en-us;Q315158
that talks about running asp.net on a domain controller, but it says that
there is only an issue with v1.0.3705 and it is fixed in v1.1.4322.

never the less I changed the <processModel> to run under a domain account
but still this doesn't work.

I still get an access denied error.
The aspx that I am attempting to view only has plain text in it and the
NTFS and security permissions on the directory (and also the file) are
full controll for everyone.

can naybody please help me out or tell me where I am going wrong.

many thanks in advance.

cheers

martin.


Nov 19 '05 #2

P: n/a
Hi,

My site is actally at the root of a site (not in its own virtual dir)
By "script execution rights" i assume that you mean go to propertys of site,
then "Home directory" tab and check box that says "Script Source Access"

This is aleady ticked.
Classic ASP page run fine on this site.
The error that I am getting is an asp.net error indicating that I have been
denied access to a resource. All Share and security settings are set to
"Full Control" for everyone.

cheers

martin.
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:eC**************@TK2MSFTNGP15.phx.gbl...
Does the virtual directory have
script execution rights assigned ?

Open the MMC and check the
virtual directory's script execution permissions.


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Martin" <ma*******************@martinz.co.nz> wrote in message
news:e%*****************@TK2MSFTNGP12.phx.gbl...
Hi,

I am getting an "Access Denied" error when attempting to browse asp.net
pages.

I have installed ASP.NET 1.1.4322 on a domain controller.
The machine also has ASP.NET 1.0.3705 installed on it.
The machine is win 2k server. IIS is installed.

I have already run aspnet_regiis - i to reinstall the .net framework.
I have set IIS to run under a domain account. (and this works cause
classic asp pages are working)

I found the following article
http://support.microsoft.com/default...;en-us;Q315158
that talks about running asp.net on a domain controller, but it says that
there is only an issue with v1.0.3705 and it is fixed in v1.1.4322.

never the less I changed the <processModel> to run under a domain account
but still this doesn't work.

I still get an access denied error.
The aspx that I am attempting to view only has plain text in it and the
NTFS and security permissions on the directory (and also the file) are
full controll for everyone.

can naybody please help me out or tell me where I am going wrong.

many thanks in advance.

cheers

martin.



Nov 19 '05 #3

P: n/a
re:
By "script execution rights" i assume that you mean go to propertys of
site, then "Home directory" tab and check box that says "Script Source
Access"
No. I mean the "Execute Permissions" box with dropdown
right under the Application's name.

The choices are : None, Scripts Only
and Scripts and Executables.

You should have "Scripts Only" selected.

btw, I noticed you changed the <processModel>
to run under a domain account.

Did you also give write permissions to that account for
\WINNT\Microsoft.NET\Framework\V1.1.4322\Temporary ASP.NET Files\
for compiler use, and, also the \WINNT\TEMP\ directory if
you are going to be running Web Services ?

btw, running ASP.NET on a Domain Controller is
not considered an example of best security practices.

Look through this document for a detailed explanation
of the process you need to go through to downsize the risks :

"Running ASP.NET on a Domain Controller"
http://msdn.microsoft.com/library/de...et_on_a_dc.asp


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Martin" <ma*******************@martinz.co.nz> wrote in message
news:uW**************@TK2MSFTNGP10.phx.gbl... Hi,

My site is actally at the root of a site (not in its own virtual dir)
By "script execution rights" i assume that you mean go to propertys of
site,
then "Home directory" tab and check box that says "Script Source Access"

This is aleady ticked.
Classic ASP page run fine on this site.
The error that I am getting is an asp.net error indicating that I have
been denied access to a resource. All Share and security settings are set
to "Full Control" for everyone.

cheers

martin.
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:eC**************@TK2MSFTNGP15.phx.gbl...
Does the virtual directory have
script execution rights assigned ?

Open the MMC and check the
virtual directory's script execution permissions.


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Martin" <ma*******************@martinz.co.nz> wrote in message
news:e%*****************@TK2MSFTNGP12.phx.gbl...
Hi,

I am getting an "Access Denied" error when attempting to browse asp.net
pages.

I have installed ASP.NET 1.1.4322 on a domain controller.
The machine also has ASP.NET 1.0.3705 installed on it.
The machine is win 2k server. IIS is installed.

I have already run aspnet_regiis - i to reinstall the .net framework.
I have set IIS to run under a domain account. (and this works cause
classic asp pages are working)

I found the following article
http://support.microsoft.com/default...;en-us;Q315158
that talks about running asp.net on a domain controller, but it says
that there is only an issue with v1.0.3705 and it is fixed in v1.1.4322.

never the less I changed the <processModel> to run under a domain
account but still this doesn't work.

I still get an access denied error.
The aspx that I am attempting to view only has plain text in it and the
NTFS and security permissions on the directory (and also the file) are
full controll for everyone.

can naybody please help me out or tell me where I am going wrong.

many thanks in advance.

cheers

martin.

Nov 19 '05 #4

P: n/a
Hi,

Thanks for the reply, however niether of the things you suggested worked.
I still get the following error

Error message 401.3: You do not have permission to view this directory or
page using the credentials you supplied (access denied due to ACLs). Ask the
Web server's administrator to give you access to
'C:\Inetpub\wwwroot\wwwCCLRAssistTitan\martin.aspx '.

But I have changed the ACL's so that theaccount has permission to this
directory.
Everyone has permission to this dir and asp.net tempory files.

I will have a look through the article that you suggested.

cheers

martin.

"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:O6**************@TK2MSFTNGP15.phx.gbl...
re:
By "script execution rights" i assume that you mean go to propertys of
site, then "Home directory" tab and check box that says "Script Source
Access"


No. I mean the "Execute Permissions" box with dropdown
right under the Application's name.

The choices are : None, Scripts Only
and Scripts and Executables.

You should have "Scripts Only" selected.

btw, I noticed you changed the <processModel>
to run under a domain account.

Did you also give write permissions to that account for
\WINNT\Microsoft.NET\Framework\V1.1.4322\Temporary ASP.NET Files\
for compiler use, and, also the \WINNT\TEMP\ directory if
you are going to be running Web Services ?

btw, running ASP.NET on a Domain Controller is
not considered an example of best security practices.

Look through this document for a detailed explanation
of the process you need to go through to downsize the risks :

"Running ASP.NET on a Domain Controller"
http://msdn.microsoft.com/library/de...et_on_a_dc.asp


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Martin" <ma*******************@martinz.co.nz> wrote in message
news:uW**************@TK2MSFTNGP10.phx.gbl...
Hi,

My site is actally at the root of a site (not in its own virtual dir)
By "script execution rights" i assume that you mean go to propertys of
site,
then "Home directory" tab and check box that says "Script Source Access"

This is aleady ticked.
Classic ASP page run fine on this site.
The error that I am getting is an asp.net error indicating that I have
been denied access to a resource. All Share and security settings are set
to "Full Control" for everyone.

cheers

martin.
"Juan T. Llibre" <no***********@nowhere.com> wrote in message
news:eC**************@TK2MSFTNGP15.phx.gbl...
Does the virtual directory have
script execution rights assigned ?

Open the MMC and check the
virtual directory's script execution permissions.


Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Martin" <ma*******************@martinz.co.nz> wrote in message
news:e%*****************@TK2MSFTNGP12.phx.gbl...
Hi,

I am getting an "Access Denied" error when attempting to browse asp.net
pages.

I have installed ASP.NET 1.1.4322 on a domain controller.
The machine also has ASP.NET 1.0.3705 installed on it.
The machine is win 2k server. IIS is installed.

I have already run aspnet_regiis - i to reinstall the .net framework.
I have set IIS to run under a domain account. (and this works cause
classic asp pages are working)

I found the following article
http://support.microsoft.com/default...;en-us;Q315158
that talks about running asp.net on a domain controller, but it says
that there is only an issue with v1.0.3705 and it is fixed in
v1.1.4322.

never the less I changed the <processModel> to run under a domain
account but still this doesn't work.

I still get an access denied error.
The aspx that I am attempting to view only has plain text in it and the
NTFS and security permissions on the directory (and also the file) are
full controll for everyone.

can naybody please help me out or tell me where I am going wrong.

many thanks in advance.

cheers

martin.


Nov 19 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.