By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,407 Members | 2,842 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,407 IT Pros & Developers. It's quick & easy.

Visual studio 2003 "HTTP/1.1 500 Internal Server Error"

P: n/a
Visual studio 2003 "HTTP/1.1 500 Internal Server Error" when trying to
create a new Asp.net site with Visual Studio 2003 on localServer/IIS
5.1.
Anyone have any new solutions or urls to point me to for this problem
short of reinstalling the local developer XP OS/IIS 5.1 ? I have tried
everything else listed in various threads.
I think my mistake was thinking the installation for v/st 2003 was
going to upgrade my V/Studio.net 2001, ( I "ass umed", since it was not
a total paradyne shift as it was from V/Studio 6 to V/Studio.net), I
didn't de-install 2001/frwrk 1.0 first. So AFTER V/Studio 2003
installation was done I add/removed programs- V/Studio 2001, plus
framework 1.0x...oops!
I guess I should have de-installed 2001/v 1.0 first. Did I miss a step
in the installation that offered to upgrade my V/Studio.net
2001/Framework 1.0x ???????

Thanks all,

Things I've tried
iisreset /stop
net user ASPNET /delete
aspnet_regiis -i
iisreset /start
----------
1. Uninstall .NET framework 2.
2. Uninstall ISS
3. Reinstall ISS with default options.
4. Install VS.NET prerequisites from the VS.NET installation.
-----------
Go to "Administrative Tools"
- Open "Microsoft .Net 1.1 Configuration"
- In the new window, expand the "Runtime Security Policy"
- Expand "Machine", then "Code Groups", then "All_Code".
- Right-Click on "My_Computer_Zone" and select properties.
- On the "Permission Set" tab, the selected value should be "Full
Trust"
- Checked "Full Trust" was set.
------------
no web.config allready in root.
------------------------------
Com services seem ok
-------------------------
no errors in event log
-----------------------
Win Security on c:\inetpub and below open for vs dev account and
IUSR...full control.
------------------------
Went to IIS right click on "Default web site" properties --> Home
directory --> Create (actually allread had that set)
------------------------
Uncheck "Run WWW in IIS 5 isolation mode" <- Actually could not find
that option in IIS mmc snap in.
-----------------------

Nov 19 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Sure you have asp_net extensions registered with iis?

Find aspnet_regiis.exe from framework 1.1. and run it, then try again.
"gerr" <ge*****@yahoo.com> wrote in message
news:11**********************@c13g2000cwb.googlegr oups.com...
Visual studio 2003 "HTTP/1.1 500 Internal Server Error" when trying to
create a new Asp.net site with Visual Studio 2003 on localServer/IIS
5.1.
Anyone have any new solutions or urls to point me to for this problem
short of reinstalling the local developer XP OS/IIS 5.1 ? I have tried
everything else listed in various threads.
I think my mistake was thinking the installation for v/st 2003 was
going to upgrade my V/Studio.net 2001, ( I "ass umed", since it was not
a total paradyne shift as it was from V/Studio 6 to V/Studio.net), I
didn't de-install 2001/frwrk 1.0 first. So AFTER V/Studio 2003
installation was done I add/removed programs- V/Studio 2001, plus
framework 1.0x...oops!
I guess I should have de-installed 2001/v 1.0 first. Did I miss a step
in the installation that offered to upgrade my V/Studio.net
2001/Framework 1.0x ???????

Thanks all,

Things I've tried
iisreset /stop
net user ASPNET /delete
aspnet_regiis -i
iisreset /start
----------
1. Uninstall .NET framework 2.
2. Uninstall ISS
3. Reinstall ISS with default options.
4. Install VS.NET prerequisites from the VS.NET installation.
-----------
Go to "Administrative Tools"
- Open "Microsoft .Net 1.1 Configuration"
- In the new window, expand the "Runtime Security Policy"
- Expand "Machine", then "Code Groups", then "All_Code".
- Right-Click on "My_Computer_Zone" and select properties.
- On the "Permission Set" tab, the selected value should be "Full
Trust"
- Checked "Full Trust" was set.
------------
no web.config allready in root.
------------------------------
Com services seem ok
-------------------------
no errors in event log
-----------------------
Win Security on c:\inetpub and below open for vs dev account and
IUSR...full control.
------------------------
Went to IIS right click on "Default web site" properties --> Home
directory --> Create (actually allread had that set)
------------------------
Uncheck "Run WWW in IIS 5 isolation mode" <- Actually could not find
that option in IIS mmc snap in.
-----------------------

Nov 19 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.