471,073 Members | 1,145 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,073 software developers and data experts.

Sending mail from domain controller with .NET

First some background...

I have an application whereby I send a mail, attach some attachments stored
in the windows/temp directory and then send them. This works fine on 2
servers both are not Domain controllers and therefore run under the ASPNET
userID.

I have one server (the live one) which is a domain controller and therefore
has to run using the IWAM_ account this makes things complicated and I have
had other issues with security policies already.

At present the problem is that when I send a mail the attachments fail to be
attached, I just get essentially an empty file. I found the following
suggestion on a forum:
====
"When I merge the two graphics, and write the file out to the disk, it is
then attached to an email and sent out. The problem was that the email
attachments were empty files.

The solution is to give the folder (in which the file you wish to attach
resides) explicit permission to the ASPNET machine account.

The problem is even though ASP.NET is a member of the USERS group, which by
default has permission for the local disk, ASP.NET runs out-of-process and
the SMTP SendMail call seems to be asynchronous, which may cause it to not
authenticate properly. Explicitly giving permission to the ASPNET process
solves this issue. The best thing to do is to create a folder that is made to
hold the files, far away from important folders such as system root, and give
the ASPNET account full control of that folder, and nothing else."

====

However since I am on a Domain Controller using the IWAM account this does
not work. I presume whatever is spawning to send the mail does not have the
authority so finally the question:

What do I need to give authority to and where to make this work?!

I have already given full privileges to 'IWAM_...' , and 'Everyone' but no
joy although it works if I run from the local machine as 'Administrator'

Any suggestions?

Thanks,

Richard.
Nov 19 '05 #1
0 1326

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

7 posts views Thread by D. Patrick | last post: by
reply views Thread by leo001 | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.