470,619 Members | 1,444 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,619 developers. It's quick & easy.

ASP.NET breaks on every reboot??

Every time I reboot my machine, I can no longer run ASP.NET
applications. I have to run aspnet_regiis.exe /i after every reboot.

The error:

Server Application Unavailable
The web application you are attempting to access on this web server is
currently unavailable. Please hit the "Refresh" button in your web
browser to retry your request.

Administrator Note: An error message detailing the cause of this
specific request failure can be found in the application event log of
the web server. Please review this log entry to discover what caused
this error to occur.

The error log contains:

aspnet_wp.exe could not be started. The error code for the failure is
80070545. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure
that the .NET Framework is correctly installed and that the ACLs on
the installation directory allow access to the configured account.

I "solve" the problem by running:

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322>aspne t_regiis.exe /i
Start installing ASP.NET (1.1.4322.0).
Finished installing ASP.NET (1.1.4322.0).

Then I have to restart IIS. Then ASP.NET applications run fine until
the next time I reboot the machine (a Windows 2000 SP4 workstation).
Any ideas? Incidentally the IWAM_<machine> account is a member of both
Users and Power Users.
Nov 18 '05 #1
1 1745
Hi,

have you checked if information given in this article (regarding the Win2k
SP 4) would help?
http://support.microsoft.com/default...b;EN-US;821546
-
Teemu Keiski
MCP, Microsoft MVP (ASP.NET), AspInsiders member
ASP.NET Forum Moderator, AspAlliance Columnist
http://blogs.aspadvice.com/joteke

"Howard Pinsley" <hp******@kayescholer.com> wrote in message
news:de**************************@posting.google.c om...
Every time I reboot my machine, I can no longer run ASP.NET
applications. I have to run aspnet_regiis.exe /i after every reboot.

The error:

Server Application Unavailable
The web application you are attempting to access on this web server is
currently unavailable. Please hit the "Refresh" button in your web
browser to retry your request.

Administrator Note: An error message detailing the cause of this
specific request failure can be found in the application event log of
the web server. Please review this log entry to discover what caused
this error to occur.

The error log contains:

aspnet_wp.exe could not be started. The error code for the failure is
80070545. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure
that the .NET Framework is correctly installed and that the ACLs on
the installation directory allow access to the configured account.

I "solve" the problem by running:

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322>aspne t_regiis.exe /i
Start installing ASP.NET (1.1.4322.0).
Finished installing ASP.NET (1.1.4322.0).

Then I have to restart IIS. Then ASP.NET applications run fine until
the next time I reboot the machine (a Windows 2000 SP4 workstation).
Any ideas? Incidentally the IWAM_<machine> account is a member of both
Users and Power Users.

Nov 18 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Bihari Srinivasan | last post: by
2 posts views Thread by Mike | last post: by
2 posts views Thread by msnews.microsoft.com | last post: by
2 posts views Thread by =?Utf-8?B?VHJhY2tz?= | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.