By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
444,208 Members | 1,592 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 444,208 IT Pros & Developers. It's quick & easy.

403 forbidden error when trying to access a webservice

P: n/a
I have two computers. Both computers have Windows 2003 installed as well
as Visual Studio.Net 2003 installed.

Computer A has active directory set and also has .Net and the webservice
called WebserviceTest with a method called Service1 that only returns
the string "Hello World".

I have enabled Anonymous Access and have a user called ASPNET set up
with normal permissions for this user.

All directory permissions are set. I also have the Scripts and
Executables enabled in the Home Directory.

Computer B also has .Net and a test project called TestWebServices. The
form is called Form1.

Form1 has a textbox and a button.

I set the reference to the webservice and instantiate a variable to
point to it in the Load event. So far so good.

In the Button_Click event, I try to access the web service result and
place the result into the textbox. Instead, I get the 403 Forbidden
error message returned.

I tried changing the Anonymous Access, the permissions and other things
but nothing seems to work. I am presently back to the original setup as
described above.

Any suggestions?

Thanks for any help given.


*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 18 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a

Hope this helps

"403 Access Forbidden" when attempting to create an ASP.NET web project

A few weeks ago I had one of those days...

I hosed my development environment, so that every time I attempted to
create a new ASP.NET web application in VS.NET 2003, I would get the
following error message: The Web server reported the following error
when attempting to create or open the Web project located at the
following URL: 'http://localhost/WebApplication1'. 'HTTP/1.1 403
Access Forbidden'.

I could create a web project in VS.NET 2002 without any problem (on the
same machine). Another fun note was that if I created the virtual
directory first in IIS manager, and create a project in VS 2003
pointing to that vdir it would work.

I looked through the MSDN docs, through the news groups, etc., but
couldn't find a way to resolve the issue.

Turns out that I had somehow set my default web site’s Home Directory >
Execute Permissions to None. Once I changed it back to Scripts only,
bingo. VS.NET 2003 was happy.

So if you get a 403 Access Forbidden error message when attempting to
create an ASP.NET web app in VS 2003, take a look at your execute
permissions...

--
Ahh Hah!
------------------------------------------------------------------------
Posted via http://www.codecomments.com
------------------------------------------------------------------------

Nov 19 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.