By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,314 Members | 2,155 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,314 IT Pros & Developers. It's quick & easy.

Internal Server Error

P: n/a
I have used Visual Studio for about 8 months. I have developed some ASP solutions. I had to get on with some other things and have not worked with ASP.NET for a couple months. In the meantime, I have upgraded to .NET Framework 200
V1.1. Over the week end I had to go back to work on a project that needed some changes. I get the following error when I try to open an existing project or create a new one. I have XP Professional

An error occured while trying to create or open an existing project when trying to access the following URL
'http://localhost/SoftCost'.'HTTP:1.1 500 Internal Server Error'

I am not sure what caused the problem or what I need to do to fix it. Any ideas

Alan
Nov 18 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
Not sure how many reponses you're going to get with this one since there are
a large number of things that could be wrong. Looks like you're about to
experience your initiation.

They say that what doesn't kill you only makes you stronger.

Start by turning off "friendly" error messages in IE to see if the error
message has more information. Then check the configuration of IIS and make
sure you installed ASP.NET. Also, make sure you are sending detailed error
messages to the client.

From there, you could have any number of problems, from permissions (you
need to give ASPNET read privilege to any file or resource it touches on the
disk. If you are using Windows server 2003, you also need to give the same
acess to NETWORK SERVICE) all the way to virtual directory mappings and
application settings.

Good luck

"AlanS" <an*******@discussions.microsoft.com> wrote in message
news:A5**********************************@microsof t.com...
I have used Visual Studio for about 8 months. I have developed some ASP solutions. I had to get on with some other things and have not worked with
ASP.NET for a couple months. In the meantime, I have upgraded to .NET
Framework 2003 V1.1. Over the week end I had to go back to work on a project that needed some changes. I get the following error when I try to open an existing
project or create a new one. I have XP Professional.
An error occured while trying to create or open an existing project when trying to access the following URL, 'http://localhost/SoftCost'.'HTTP:1.1 500 Internal Server Error'.

I am not sure what caused the problem or what I need to do to fix it. Any ideas.
Alan

Nov 18 '05 #2

P: n/a
Michael ... Here is where I am at the preset time

I am using an XP Professional and VS Net 2003

I went to my IE Options (Tools>Interner Options>Advanced tab) Deselected "Show friendly HTTP error messages".

When starting an existing application, I still get the following message

(1
The web server reported the following error when attempting to create o
open the Web project at the following URL
'http://localhost/Softcost'.'HTTP/1.1 500 Internal Server Error.

If I click ok, the project will open up and everything appears to be ok

If I then try to run the following error is issued

(2
Error while trying to run project: Unable to start debugging on the Web server. Server side-error occurred on sending debug HTTP request.

Make sure the server is operating correctly. Verify there are no sybtax errors in web.config by doing a Debug. Start without Debugging. You may also want to refer to the ASP.NET and ATL server debugging topic in the online documentation

If I try to create a new project I get error message (1). If I click on OK I get an empty solution explorer

I was told it was a IIS setting. Affects VS NET 2003, but not VS NET 2002 and to do the following to correct

In the IIS console right-click the default web site, select Properties, then go to the Home Directory Tab. On that tab go to the Application Settings panel

There is an application name box that is blanked out and a button that says 'create'
Click on the create button and it will convert to saying 'remove' and the application name box fills in with 'default application'

Leave IIS and everything should work ..... It does not

I also have VS NET 2002 and when I try to create an ASP.NET application using 2002. I have the follwoing problem when I try to create and execute. Creating seems like no problem. When I try to execute I get message (2) above. By turing off debug I get the following message

(3
Server Application Unavailable
The web application you are attempting to access on this web server is currently unavailable. Please hit the "Refresh" button in your web browser to retry your request.

Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.

I went to the event viewer and here was what it said

aspnet_wp.exe could not be started. The error code for the failure is 80004005. This error can be caused when the worker process account has insufficient rights to read the .NET Framework files. Please ensure that the .NET Framework is correctly installed and that the ACLs on the installation directory allow access to the configured account

I think I need to reinstall one or all of the following

1) ASP.NE
2) II
3) VS NET

I had no problems with ASP.NET till I install the 2003 Upgrade. I may go back to 200

Any thoughts???????
Nov 18 '05 #3

P: n/a
I see. I have had this issue in the past and reinstalling .NET was my fix.

If you can, uninstall .NET 1.0 (not required, but it would clean things up a
bit).

Reinstall the .NET 1.1 framework (make sure you are logged in as
administrator when you do) and make sure you install ASP.NET.

You should not have to resintall VS.NET 2003.

Michael Earls
"Alan" <an*******@discussions.microsoft.com> wrote in message
news:92**********************************@microsof t.com...
Michael ... Here is where I am at the preset time.

I am using an XP Professional and VS Net 2003.

I went to my IE Options (Tools>Interner Options>Advanced tab) Deselected "Show friendly HTTP error messages".
When starting an existing application, I still get the following message.
(1)
The web server reported the following error when attempting to create or
open the Web project at the following URL.
'http://localhost/Softcost'.'HTTP/1.1 500 Internal Server Error.'
If I click ok, the project will open up and everything appears to be ok.

If I then try to run the following error is issued.

(2)
Error while trying to run project: Unable to start debugging on the Web server. Server side-error occurred on sending debug HTTP request.
Make sure the server is operating correctly. Verify there are no sybtax errors in web.config by doing a Debug. Start without Debugging. You may
also want to refer to the ASP.NET and ATL server debugging topic in the
online documentation.
If I try to create a new project I get error message (1). If I click on OK I get an empty solution explorer.

I was told it was a IIS setting. Affects VS NET 2003, but not VS NET 2002 and to do the following to correct.
In the IIS console right-click the default web site, select Properties, then go to the Home Directory Tab. On that tab go to the Application
Settings panel.
There is an application name box that is blanked out and a button that says 'create'. Click on the create button and it will convert to saying 'remove' and the application name box fills in with 'default application'.
Leave IIS and everything should work ..... It does not.

I also have VS NET 2002 and when I try to create an ASP.NET application using 2002. I have the follwoing problem when I try to create and execute.
Creating seems like no problem. When I try to execute I get message (2)
above. By turing off debug I get the following message.
(3)
Server Application Unavailable
The web application you are attempting to access on this web server is currently unavailable. Please hit the "Refresh" button in your web browser
to retry your request.
Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server.
Please review this log entry to discover what caused this error to occur.
I went to the event viewer and here was what it said.

aspnet_wp.exe could not be started. The error code for the failure is 80004005. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure that the
..NET Framework is correctly installed and that the ACLs on the installation
directory allow access to the configured account.
I think I need to reinstall one or all of the following.

1) ASP.NET
2) IIS
3) VS NET

I had no problems with ASP.NET till I install the 2003 Upgrade. I may go back to 2000
Any thoughts????????

Nov 18 '05 #4

P: n/a
Michael thanks for the help.
OK I have finally gotten the Problem fixed. I'll share this with everyone so if it happens to you.
I was not able to access or run web pages I had developed under .NET 2002.
I kept getting a number of errors saying the server was not accessible or Internal Server Error. Most of the time if you go to the event viewer you will see an error message...
aspnet_wp.exe could not be started. The error code for the failure is 80004005. This error can be caused when the worker process account has insufficient rights to read the .NET Framework files. Please ensure that the .NET Framework is correctly installed and that the ACLs on the installation directory allow access to the configured account
It will happen if,...
Your development machine is an XP Pro (some have said that they have gotten the problem on Windows 2000 and Windows server 2003)
You have installed .NET Framework 2003
You have installed IIS V5.1
You have installed ASP.NET V1.1 or V1.
You have applied the patch MS03-32 Security Update for Internet Explorer security patc
According to MS it can only happen with ASP.NET V1.0 and it can not happen ASP.NET V1.1...bull pat-too-ie
According to MS…
The symptom of this issue is that after installing the patch, all requests to ASP.NET result in an error message saying "Server Application Unavailable".

This issue only impacts installations running ASP.NET V1.0 on Windows XP Professional. It does not impact machines running Windows 2000 or Windows Server 2003. It also does not impact machines running Windows XP with ASP.NET v1.1 installed.

We are working hard on a permanent solution for this issue. In the meantime, you can visit this page to learn about the problem as well as a safe workaround you can apply immediately to fix the issue:

http://www.asp.net/faq/ms03-32-issue.asp

If you run the patch on a machine with ASP.NET V1.0, it works fine. It corrects the defect.

It, however, will not run on a machine with ASP.NET V1.1.

In the downloaded batch file "fixup" - make the following changes

REM if exist %SystemRoot%\microsoft.net\framework\v1.1.4322\msc orlib.dll goto v11_installed

REM "Changing to the Framework install directory"
cd /d %SystemRoot%\microsoft.net\framework\v1.1.4322

and then run it again. This should fix the issue

It works. I can now access and create ASP.NET projects without problems

Hope this helps some one so they do not lose 3 days like I did
If anyone wants me too I'll copy the whole modified batch file text here for you to look at.

Ala

Nov 18 '05 #5

P: n/a
"AlanS" <an*******@discussions.microsoft.com> wrote in message news:<5B**********************************@microso ft.com>...
Michael thanks for the help.. [snip] In the downloaded batch file "fixup" - make the following changes
REM if exist %SystemRoot%\microsoft.net\framework\v1.1.4322\msc orlib.dll goto v11_installed
REM "Changing to the Framework install directory"
cd /d %SystemRoot%\microsoft.net\framework\v1.1.4322
and then run it again. This should fix the issue.
It works. I can now access and create ASP.NET projects without problems.

Hope this helps some one so they do not lose 3 days like I did.
If anyone wants me too I'll copy the whole modified batch file text here for you to look at.


I've lost a week so far and guess what? This doesn't work for me
either - i still can't create Web Projects of either type. Oh well,
back to trawling for fixes....

--
RB
Nov 18 '05 #6

P: n/a
I get this problem when I go from running undocked to docked.

The only repeatable solution seems to be to:

1. uninstall .NET Framework (aspnet_regiis -u)
2. reboot
3. install .NET framework (aspnet_regiis -i)

It's a real pain!

-Chris
Nov 18 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.