470,595 Members | 1,615 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,595 developers. It's quick & easy.

Solution for "illegal characters in path" error message in ASP.NET

I have been having trouble the last few days opening any ASP.NET web
forms in the design view in the designer. Every time I clicked on an
aspx file I got a message box with the error "Unable to open in
designer. Illegal characters in path" and the file is instead opened
in HTML view. I don't know what application or situation may have
caused this error. I looked on the newsgroups and noticed that
numerous other people were having this problem.

The way I fixed it was to:
1> Go to another machine with same version of VS.NET and OS
2> run "regedit"
3> Select "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramewo rk" branch
from tree on the machine that does not have this issue.
4> Select File->Export from the menu of Registry Editor to export
branch to file.
5> Double-click on this file on the machine that is having the issue.

The error message should be gone and the aspx files should now be
viewed correctly in the designer. This is what worked for me.

I hope this helps other people who have struggled with the same issue.

------------

Steve Grahovac
Nov 18 '05 #1
1 4962
Steve,

Thank you for posting this to the group!

Jim Cheshire, MCSE, MCSD [MSFT]
Microsoft Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
From: sg******@hotmail.com (Steve Grahovac)
Newsgroups: microsoft.public.dotnet.framework.aspnet
Subject: Solution for "illegal characters in path" error message in ASP.NET
Date: 1 Jan 2004 12:03:33 -0800
Organization: http://groups.google.com
Lines: 25
Message-ID: <7f**************************@posting.google.com >
NNTP-Posting-Host: 65.26.193.244
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 8bit
X-Trace: posting.google.com 1072987413 5967 127.0.0.1 (1 Jan 2004 20:03:33 GMT)X-Complaints-To: gr**********@google.com
NNTP-Posting-Date: Thu, 1 Jan 2004 20:03:33 +0000 (UTC)
Path: cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTN GP08.phx.gbl!newsfeed00.su
l.t-online.de!t-online.de!newsfeed.icl.net!newsfeed.fjserv.net!new s.maxwell.
syr.edu!postnews1.google.com!not-for-mailXref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:199254
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

I have been having trouble the last few days opening any ASP.NET web
forms in the design view in the designer. Every time I clicked on an
aspx file I got a message box with the error "Unable to open in
designer. Illegal characters in path" and the file is instead opened
in HTML view. I don't know what application or situation may have
caused this error. I looked on the newsgroups and noticed that
numerous other people were having this problem.

The way I fixed it was to:
1> Go to another machine with same version of VS.NET and OS
2> run "regedit"
3> Select "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramewo rk" branch
from tree on the machine that does not have this issue.
4> Select File->Export from the menu of Registry Editor to export
branch to file.
5> Double-click on this file on the machine that is having the issue.

The error message should be gone and the aspx files should now be
viewed correctly in the designer. This is what worked for me.

I hope this helps other people who have struggled with the same issue.

------------

Steve Grahovac


Nov 18 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by Kostatus | last post: by
reply views Thread by dsh | last post: by
1 post views Thread by Jonas Auken | last post: by
3 posts views Thread by Kondapanaidu | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.