468,103 Members | 1,225 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,103 developers. It's quick & easy.

My Internet provider does not want to create a virtual directory

Hello,

I need to implement form based authentication in my WebForm application.
When I deployed it I have received the following the error:

=========
Configuration Error
Description: An error occurred during the processing of a configuration file
required to service this request. Please review the specific error details
below and modify your configuration file appropriately.
Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This error
can be caused by a virtual directory not being configured as an application
in IIS.
=========

The problem is that my Internet provider (Look Communication -
http://www.look.ca/e/index.html) is not able to create a virtual directory
for my application. I had requested it for the codebehind feature, but they
answered that they could not do this because of security reasons (?). I had
to copy and past all code from codebehind files to a <script> section of
each page manually!

Now it turned out I can't use Form authentication! It's too much! If they do
not support .NET why they claim they do!

Anyway is there any workaround to use Form authentication without a virtual
directory. I just need files from one folder to be authenticated.

Thanks for any help,

And remember - NEVER USE LOOK.CA for .NET development!

Leszek Taratuta
Nov 18 '05 #1
4 1231
May want to check out Brinkster.com. They are really good. Fantastic
customer support.

Harry Simpson
MCSD

"Leszek" <ta******@5thbusiness.com> wrote in message
news:uD**************@TK2MSFTNGP12.phx.gbl...
Hello,

I need to implement form based authentication in my WebForm application.
When I deployed it I have received the following the error:

=========
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details
below and modify your configuration file appropriately.
Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.
=========

The problem is that my Internet provider (Look Communication -
http://www.look.ca/e/index.html) is not able to create a virtual directory
for my application. I had requested it for the codebehind feature, but they answered that they could not do this because of security reasons (?). I had to copy and past all code from codebehind files to a <script> section of
each page manually!

Now it turned out I can't use Form authentication! It's too much! If they do not support .NET why they claim they do!

Anyway is there any workaround to use Form authentication without a virtual directory. I just need files from one folder to be authenticated.

Thanks for any help,

And remember - NEVER USE LOOK.CA for .NET development!

Leszek Taratuta

Nov 18 '05 #2
I wish to do this, but I am developing the application for a client who is
not willing to change their Internet provider :-(

Leszek

"Harry Simpson" <hs*******@nospamphgt.net> wrote in message
news:u0**************@TK2MSFTNGP10.phx.gbl...
May want to check out Brinkster.com. They are really good. Fantastic
customer support.

Harry Simpson
MCSD

"Leszek" <ta******@5thbusiness.com> wrote in message
news:uD**************@TK2MSFTNGP12.phx.gbl...
Hello,

I need to implement form based authentication in my WebForm application.
When I deployed it I have received the following the error:

=========
Configuration Error
Description: An error occurred during the processing of a configuration file
required to service this request. Please review the specific error details below and modify your configuration file appropriately.
Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This

error
can be caused by a virtual directory not being configured as an

application
in IIS.
=========

The problem is that my Internet provider (Look Communication -
http://www.look.ca/e/index.html) is not able to create a virtual directory for my application. I had requested it for the codebehind feature, but

they
answered that they could not do this because of security reasons (?). I

had
to copy and past all code from codebehind files to a <script> section of
each page manually!

Now it turned out I can't use Form authentication! It's too much! If

they do
not support .NET why they claim they do!

Anyway is there any workaround to use Form authentication without a

virtual
directory. I just need files from one folder to be authenticated.

Thanks for any help,

And remember - NEVER USE LOOK.CA for .NET development!

Leszek Taratuta


Nov 18 '05 #3
I think you might want to explain to your client that their ISP does not
know what they are doing, and for me this would be a very serious concern
indeed. In the meantime, ask them to elaborate on exactly what they mean by
"could not do this because of security reasons (?)."

--
Regards

John Timney (Microsoft ASP.NET MVP)
----------------------------------------------
<shameless_author_plug>
Professional .NET for Java Developers with C#
ISBN:1-861007-91-4
Professional Windows Forms
ISBN: 1861005547
Professional JSP 2nd Edition
ISBN: 1861004958
Professional JSP
ISBN: 1861003625
Beginning JSP Web Development
ISBN: 1861002092
</shameless_author_plug>
----------------------------------------------

"Leszek" <ta******@5thbusiness.com> wrote in message
news:OK**************@tk2msftngp13.phx.gbl...
I wish to do this, but I am developing the application for a client who is
not willing to change their Internet provider :-(

Leszek

"Harry Simpson" <hs*******@nospamphgt.net> wrote in message
news:u0**************@TK2MSFTNGP10.phx.gbl...
May want to check out Brinkster.com. They are really good. Fantastic
customer support.

Harry Simpson
MCSD

"Leszek" <ta******@5thbusiness.com> wrote in message
news:uD**************@TK2MSFTNGP12.phx.gbl...
Hello,

I need to implement form based authentication in my WebForm application. When I deployed it I have received the following the error:

=========
Configuration Error
Description: An error occurred during the processing of a configuration
file
required to service this request. Please review the specific error details below and modify your configuration file appropriately.
Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This

error
can be caused by a virtual directory not being configured as an

application
in IIS.
=========

The problem is that my Internet provider (Look Communication -
http://www.look.ca/e/index.html) is not able to create a virtual directory for my application. I had requested it for the codebehind feature, but

they
answered that they could not do this because of security reasons (?).
I had
to copy and past all code from codebehind files to a <script> section

of each page manually!

Now it turned out I can't use Form authentication! It's too much! If

they
do
not support .NET why they claim they do!

Anyway is there any workaround to use Form authentication without a

virtual
directory. I just need files from one folder to be authenticated.

Thanks for any help,

And remember - NEVER USE LOOK.CA for .NET development!

Leszek Taratuta



Nov 18 '05 #4
Hi Leszek,

Firstly I want to thank Harry and John for their great help in this issue.

Based on my research and experience, we need a virtual directory for this
issue. Thank you for your understanding. If the ISP cannot create a new
virtual directory for you, is it possible for your ISP to provide an
existed virtual directory?

I hope it helps.

Best regards,

Jacob Yang
Microsoft Online Partner Support
Get Secure! ®C www.microsoft.com/security
This posting is provided "as is" with no warranties and confers no rights.

Nov 18 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

5 posts views Thread by lanem | last post: by
reply views Thread by Atul Thombre | last post: by
1 post views Thread by Solo | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.