By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
448,562 Members | 1,223 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 448,562 IT Pros & Developers. It's quick & easy.

*HELP:Jmail Issue - unable to read unicode characters

P: 9
Hi there,

I'm using Jmail for sending email with some attachments. Basically, I will need to send out email with the contents in unicode characters such as Simplified Chinese, Japanese etc.

I have tried out and all characters are displayed well, if ONLY for me to send it to webmail such as Yahoo!/Gmail. However, I was unable to read the characters when sending to my own company email address, even on the company's webmail. All characters look weird in Microsoft Outlook/Company webmail, something like so:

Here is the Jmail code looks like:
Expand|Select|Wrap|Line Numbers
  1. ' This is my local SMTP server
  2.     JMail.ServerAddress = ""
  3.     JMail.Sender = email
  4.     JMail.SenderName = username
  5.         JMail.Charset = "936"
  6.     'Jmail.Encoding = "base64"
  7.         'JMail.ContentTransferEncoding = "base64"
  8.     JMail.Subject = subject
  10.     JMail.AddRecipient ""
  12.      JMail.HTMLBody = "<font face='Verdana' size='2'>" &_
  13.     body &_
  14.     "<br></font>"
  15.     JMail.AddAttachment Server.Mappath(Application("rootFolder")) & "\" & Upload("file1").FileName
For instance, I am using Charset 936 for Simplified Chinese and Charset 930 for Japanese. I am able to read in Yahoo!/Gmail. However, I am not allowed to read the text on the company webmail, and the outlook 2003 as well.

Appreciated if someone could give me some advice what would be the problems and what should I do?

Thanks so much!!
May 25 '09 #1
Share this Question
Share on Google+
2 Replies

Expert 2.5K+
P: 3,405
I keep scratching my head about this, and I find it hard to answer. It sounds to me like a flaw in Outlook. Have you tried opening it Outlook that has been set to a default language of Japanese or Chinese?

May 29 '09 #2

P: 9
Thanks for your advice Jared!

I have read on some forums and for those who had encountered this problem were advised to check on the Outlook's setting. However, it seems doesn't help much for solving this.

All this while, I am able to read the unicode characters such as Chinese characters in Outlook and also, I have tried to forward the copy from Yahoo!/Gmail to my company email address and try to open in Outlook, it's all displayed well.

Until now, I have no ideas at all what is actually going wrong with this.Sigh!
May 29 '09 #3

Post your reply

Sign in to post your reply or Sign up for a free account.